Nowe posty

xx Touchpad po pewnym losowym czasie przestaje reagować (7)
2019-04-24, 13:28:28
xx badblocks nie sprawdza dalej. (3)
2019-04-23, 20:44:36
xx Automat/scrypt do uruchamiania bootowalnego USB (0)
2019-04-22, 22:15:41
xx Zdalne polaczenie z posrednikiem pod Ubuntu bez GUI (2)
2019-04-22, 20:59:31
xx Uprawnienia (1)
2019-04-22, 14:10:38
xx bład krytyczny na dysku, dysk jest w LVM (2)
2019-04-19, 06:38:20
xx Przekierowanie na bezpieczną stronę z SSL (1)
2019-04-16, 19:52:43
xx bootloader (4)
2019-04-13, 18:31:03
xx Ubuntu i Bluetooth (1)
2019-04-12, 10:12:18
clip Opera - odtwarzanie niektórych filmów nie działa (1)
2019-04-12, 00:41:50

Autor Wątek: Nie ma dźwięku w systemie po instalacji sterownika realtek.  (Przeczytany 6271 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 38
    • Zobacz profil
Witam was serdecznie! Po instalacji sterownika Realtek z tej strony w wersji 3.0: http://www.realtek.com.tw/downloads/downloadsCheck.aspx?Langid=1&PNid=24&PFid=24&Level=4&Conn=3&DownTypeID=3&GetDown=false Nie mam dźwięku w systemie.. W pliku read me pisało jak mam to zainstalować, było coś takiego:

Cytuj
Manual install:
Step 1. unzip source code
        tar xfvj alsa-driver-1.0.xx.tar.bz2

Step 2. Complied source code
   a. cd alsa-driver-1.0.xx
   b. ./configure --with-cards=hda-intel
   c. make
   d. make install

gdy wpisalem ./configure, make oraz make install , to na końcu widziałem w terminalu jakieś errory, a po restarcie komputera, brak dźwięku.. Więc teraz by się to przydało odinstalować, alej jak? Będę wdzięczny za odpowiedź!

Po uruchomieniu alsamixera otwiera się po prostu puste okno:



Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2484
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • Linuxpedia.PL
Odp: Nie ma dźwięku w systemie po instalacji sterownika realtek.
« Odpowiedź #1 dnia: 2016-11-20, 17:52:37 »
 
Cytuj
widziałem w terminalu jakieś errory
:o Bardzo precyzyjny opis problemu...

Z ciekawości - po co w ogóle instalowałeś zewnętrzne sterowniki? Co jak co, ale audio w Linuksie jest dobrze obsługiwane "z pudełka" nawet na egzotycznych kartach - typu Xonary,, itp...

Trudno powiedzieć jak bardzo te sterowniki rozwaliły system, więc masz 3 drogi:
* przeinstalowć wszystkie składniki systemowe ALSA (w systemach bazujących na Debianie to będzie polecenie aptitude reinstall '~i~nalsa'  ). Powiedzmy 30% szansy na naprawienie.
* przeinstalować wszystkie pakiety (to będzie polecenie aptitude reinstall '~i'  ). Powiedzmy 70% szansy na naprawienie.
* zainstalować system od nowa. 100% szansy na naprawienie.
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 38
    • Zobacz profil
Odp: Nie ma dźwięku w systemie po instalacji sterownika realtek.
« Odpowiedź #2 dnia: 2016-11-20, 17:57:42 »
Ten sterownik instalowałem po to, ponieważ gdzieś tam czytałem, że po zainstalowaniu będzie mi działać karta dźwiękowa na USB.



Hmm.. (Posiadam system Linux Mint 64-bit XFCE)

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2484
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • Linuxpedia.PL
Odp: Nie ma dźwięku w systemie po instalacji sterownika realtek.
« Odpowiedź #3 dnia: 2016-11-21, 08:04:45 »
Co do błędów - musiałeś mieć uruchomiony jakiś inny program do zarządzania pakietami. Naraz może działać tylko jeden.

Co do karty dźwiękowej - prawdopodobnie działała od razu, tylko systemowi trzeba było powiedzieć, żeby z niej korzystał.
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy