Nowe posty

xx Przy uploadzie przerywane są wszystkie połączenia (1)
Wczoraj o 09:38:09
xx Apache2 i twarde https (3)
2020-05-25, 15:53:43
xx Czy istnieje emulator terminala który zapamieta komendy na jakiejś liście? (9)
2020-05-23, 17:04:57
xx RTLinux wybór dystrybucji (0)
2020-05-23, 15:42:54
xx Problem z instalacją Ubuntu na bootowalnym pendrajwie (9)
2020-05-22, 15:08:12
xx Ubuntudde 20.04 LTS nie działa Lightdm (8)
2020-05-22, 09:16:42
xx [Gra za darmo] GTA5 (1)
2020-05-20, 21:49:26
xx Marketing (1)
2020-05-13, 08:00:41
xx Polecenia Debian (1)
2020-05-10, 19:58:54
xx Uruchamianie pliku z każdego katlogu (2)
2020-05-10, 19:23:33

Autor Wątek: [xine] Menu z obciętymi wyrazami  (Przeczytany 4620 razy)

Offline Sebastian Chyba zartujecie

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 191
    • Zobacz profil
[xine] Menu z obciętymi wyrazami
« dnia: 2007-10-11, 13:38:41 »
Witam!

Mam Slackware 12. Bez żadnych rekompilacji i innych udziwnień.
LC_ALL="pl_PL"
LANG="pl_PL.ISO-8859-2"

Menu w XINE mi się pojawia w języku naszym ojczystym, jednak wszystkie pozycje menu są obcięte do miejsca gdzie występuje znaczek z ogonkiem (ęóąśłżźćń).

Poniżej zamieszczam zrzut z pulpitu jak to wygląda:


Pozdrawiam
DevilaN

Offline

  • Users
  • Guru
  • *****
  • Wiadomości: 825
    • Zobacz profil
[xine] Menu z obciętymi wyrazami
« Odpowiedź #1 dnia: 2007-10-11, 14:22:52 »
A jak ustawisz lang na: LANG=pl_PL.UTF-8

M.

Offline Sebastian Chyba zartujecie

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 191
    • Zobacz profil
[xine] Menu z obciętymi wyrazami
« Odpowiedź #2 dnia: 2007-10-11, 14:39:43 »
Dałem export LANG na podaną przez Ciebie wartość i odpaliłem xine - niestety dalej jest to samo.

Dla pewności jeszcze spróbowałem tak odpalić xine:
# LANG=pl_PL.UTF-8 xine

Niestety bez zmian.

Offline

  • Users
  • Guru
  • *****
  • Wiadomości: 825
    • Zobacz profil
[xine] Menu z obciętymi wyrazami
« Odpowiedź #3 dnia: 2007-10-11, 14:45:50 »
To jak tak uruchamiasz to daj LC_ALL a nie LANG.

M.

Offline Sebastian Chyba zartujecie

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 191
    • Zobacz profil
[xine] Menu z obciętymi wyrazami
« Odpowiedź #4 dnia: 2007-10-11, 14:56:31 »
ok, działa :)

Pytanie czy da radę zrobić to na ISO czy muszę za każdym razem ustawiać na UTF-8 przed uruchomieniem?

Bo z tego co widziałem w README do slacka, to nie jest zalecane używanie UTF-8 globalnie w systemie z powodu potencjalnych konfliktów ze zgodnością z UTF dla starszych aplikacji.

Offline

  • Users
  • Guru
  • *****
  • Wiadomości: 825
    • Zobacz profil
[xine] Menu z obciętymi wyrazami
« Odpowiedź #5 dnia: 2007-10-11, 14:58:31 »
Zmień xine na xine2 i utwórz skrypt o nazwie xine który w sobie będzie miał export UTF'a i który będzie uruchamiał xine2.
W openSUSE domyślnie jest UTF.

M.