Nowe posty

Autor Wątek: X nie widzi myszy (Debian).  (Przeczytany 6862 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 20
    • Zobacz profil
X nie widzi myszy (Debian).
« dnia: 2006-11-06, 17:54:49 »
Nic dziwnego, jest czarna, można jej nie zobaczyć.


A tak poważniej, problem nazywa się Logitech M-SBF96, i jest podłączony do portu ps/2. Niestety, używając ustawienia portu /dev/psaux nie jestem w stanie w ogóle uruchomić X-ów (na wyjściu pojawia się komunikat 'no such device' i potem 'no core pointer found').
De facto, X-y uruchamiają się wyłącznie gdy wybiorę opcję /dev/ttyS0, ale oczywiście mysz wtedy nie działa. Przy wszystkich innych opcjach z /dev/psaux i /dev/input/mice na czele pojawia się w/w komunikat.

Szczerze mówiąc, jestem na najlepszej drodze do załamania nerwowego :/
Mysz testowałem na postawionym obok Auroksie z antycznym jądrem, i działa bez problemu.

Moja dystrybucja do Debian, kernel 2.6.8-12-amd64.

Offline Damian Labuda

  • Global Moderator
  • Guru
  • *****
  • Wiadomości: 705
    • Zobacz profil
X nie widzi myszy (Debian).
« Odpowiedź #1 dnia: 2006-11-06, 18:05:55 »
> A tak poważniej, problem nazywa się Logitech M-SBF96, i jest podłączony do portu ps/2.
 > Niestety, używając ustawienia portu /dev/psaux nie jestem w stanie w ogóle uruchomić X-ów (na
 > wyjściu pojawia się komunikat 'no such device' i potem 'no core pointer found').
 > De facto, X-y uruchamiają się wyłącznie gdy wybiorę opcję /dev/ttyS0, ale oczywiście mysz wtedy
 > nie działa. Przy wszystkich innych opcjach z /dev/psaux i /dev/input/mice na czele pojawia się
 > w/w komunikat.
 >
 > Szczerze mówiąc, jestem na najlepszej drodze do załamania nerwowego :/
 > Mysz testowałem na postawionym obok Auroksie z antycznym jądrem, i działa bez problemu.
 >
 > Moja dystrybucja do Debian, kernel 2.6.8-12-amd64.

zobacz:

dpkg-reconfigure xserver-xfree86 lub xorg zależy co masz. Wybierz jeszcze raz wszystkie ustawienia może pomoże. Zobacz także w /etc/X11/XF86Config-4 lub xorg jak widzi twoją mysz, zobacz, pozmieniaj i takie tam. Przed wykonaniem którejkolwiek z wyżej wymieninych operacji zrób kopię zapasową pliku.


Pozdrawiam!

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 20
    • Zobacz profil
X nie widzi myszy (Debian).
« Odpowiedź #2 dnia: 2006-11-06, 21:53:19 »
2006-11-06 18:05:55 Kaka napisał:

 > zobacz:
 >
 > dpkg-reconfigure xserver-xfree86 lub xorg zależy co masz. Wybierz jeszcze raz wszystkie
 > ustawienia może pomoże. Zobacz także w /etc/X11/XF86Config-4 lub xorg jak widzi twoją mysz,
 > zobacz, pozmieniaj i takie tam. Przed wykonaniem którejkolwiek z wyżej wymieninych operacji
 > zrób kopię zapasową pliku.
 >
 >
 > Pozdrawiam!
 >
Oczywiście próbowałem uruchamiać dpkg-reconfigure xserver-xorg (mam xorg) i pojechałem przez wszystkie możliwości; bezskutecznie. Oglądałem logi w /var i zdaje się, że fizycznie widzi urządzenie.

Offline Damian Labuda

  • Global Moderator
  • Guru
  • *****
  • Wiadomości: 705
    • Zobacz profil
X nie widzi myszy (Debian).
« Odpowiedź #3 dnia: 2006-11-06, 22:24:30 »
> Oczywiście próbowałem uruchamiać dpkg-reconfigure xserver-xorg (mam xorg) i pojechałem przez
 > wszystkie możliwości; bezskutecznie. Oglądałem logi w /var i zdaje się, że fizycznie widzi
 > urządzenie.

Może myszka jest zła. Bo u mojego kolegi pod Debianem myszka nie chodziła ale pod XP tak. Zmiana myszki pomogła. Może też nie do końca określiłeś swój typ myszki bo trzeba wybrać czy masz z tym kółkiem i takie tam...może właśnie w tym miejscu popełniasz błąd?


Pokaż też wpis z /etc/X11/xorg

Mój wpis wygląda tak:

"Section "InputDevice"
        Identifier  "Configured Mouse"
        Driver      "mouse"
        Option      "CorePointer"
        Option      "Device" "/dev/psaux"
        Option      "Protocol" "ImPS/2"
        Option      "Emulate3Buttons" "true"
        Option      "ZAxisMapping" "4 5"
EndSection"

Ja mam xfree86 więc ten wpis może się różnić od tego z xorg ale sprawdź czy masz podobne ustawienia.


Pozdrawiam!


Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 20
    • Zobacz profil
X nie widzi myszy (Debian).
« Odpowiedź #4 dnia: 2006-11-07, 10:18:39 »
 > Może myszka jest zła. Bo u mojego kolegi pod Debianem myszka nie chodziła ale pod XP tak.
 > Zmiana myszki pomogła. Może też nie do końca określiłeś swój typ myszki bo trzeba wybrać czy
 > masz z tym kółkiem i takie tam...może właśnie w tym miejscu popełniasz błąd?
 >
Że niby gdzie trzeba wybrać, czy ma się mysz z kółkiem? dodając opcję ZAxisMapping? Dodając Emulate3Buttons? Wybierając protokówł ImPS/2?

Próbowałem wszystkiego.

Mysz oczywiśćie może być zła, jak wspomniałem jest czarna, a zatem jest dziełem szatana :) Jednakże próbowałem ją, jak mówię obok na Auroksie, i nic to nie dało. Co więcej, do mojego Debiana wpiąłem przed chwilą już też inną mysz dla sprawdzenia (bezfirmowa, 3button, z kółkiem) - bez żadnego efektu.

 >
 > Pokaż też wpis z /etc/X11/xorg
 >
 > Mój wpis wygląda tak:
 >
 > "Section "InputDevice"
 >         Identifier  "Configured Mouse"
 >         Driver      "mouse"
 >         Option      "CorePointer"
 >         Option      "Device" "/dev/psaux"
 >         Option      "Protocol" "ImPS/2"
 >         Option      "Emulate3Buttons" "true"
 >         Option      "ZAxisMapping" "4 5"
 > EndSection"
 >

Mój aktualny wpis wygląda następująco:

  "Section "InputDevice"
          Identifier  "Configured Mouse"
          Driver      "mouse"
          Option      "CorePointer"
          Option      "Device" "/dev/psaux"
          Option      "Protocol" "ImPS/2"
          Option      "ZAxisMapping" "4 5"
          Option      "Emulate3Buttons" "true"
         
  EndSection"
           
A zatem jest identyczny z Twoim. Ale nie działa!

cat /var/log/dmesg |grep PS/2

daje

input: ImPS/2 Logitech Wheel Mouse on isa0060/serio1

(gdy podłączona jest mysz Logitecha, ta czarna)

lub

input: ImExPS/2 Generic Explorer Mouse on isa0060/serio1

gdy podłączona jest ta druga mysz...


Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 20
    • Zobacz profil
X nie widzi myszy (Debian).
« Odpowiedź #5 dnia: 2006-11-08, 09:54:35 »
I co, nikt mi nie pomoże?

Lightweights...

Offline xis

  • Global Moderator
  • Guru
  • *****
  • Wiadomości: 1049
    • Zobacz profil
X nie widzi myszy (Debian).
« Odpowiedź #6 dnia: 2006-11-08, 10:19:58 »
2006-11-08 09:54:35 dve napisał:

> I co, nikt mi nie pomoże?
 >
 > Lightweights...

Wpisz
ls -l /dev/psaux

i pokaż nam tu wyjście tej komendy. Może nie masz takiego urządzenia albo linku?
U mnie /dev/psaux wskazuje na /dev/misc/psaux.

Everything should be made as simple as possible, but not simpler
-- Albert Einstein

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 20
    • Zobacz profil
X nie widzi myszy (Debian).
« Odpowiedź #7 dnia: 2006-11-08, 10:53:19 »
# ls -l /dev/psaux
crw-------- 1 root root 10, 1 2005-03-01 00:07 /dev/psaux


Offline xis

  • Global Moderator
  • Guru
  • *****
  • Wiadomości: 1049
    • Zobacz profil
X nie widzi myszy (Debian).
« Odpowiedź #8 dnia: 2006-11-08, 11:48:12 »
2006-11-08 10:53:19 dve napisał:

> # ls -l /dev/psaux
 > crw-------- 1 root root 10, 1 2005-03-01 00:07 /dev/psaux
 >
 >

Urządzenie - jak na moje oko - wygląda OK. Co mówi /var/log/Xorg.0.log?
Czy gpm (konsolowy demon myszki) Ci działa?

Everything should be made as simple as possible, but not simpler
-- Albert Einstein

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 20
    • Zobacz profil
X nie widzi myszy (Debian).
« Odpowiedź #9 dnia: 2006-11-08, 13:35:28 »
2006-11-08 11:48:12 xis napisał:

> 2006-11-08 10:53:19 dve napisał:
 >
 > > # ls -l /dev/psaux
 >  > crw-------- 1 root root 10, 1 2005-03-01 00:07 /dev/psaux
 >  >
 >  >
 >
 > Urządzenie - jak na moje oko - wygląda OK. Co mówi /var/log/Xorg.0.log?
 > Czy gpm (konsolowy demon myszki) Ci działa?
 >
 >

No to po kolei. Jeśli ustawiam w xorg.conf, że port jest 'dev/psaux' i protokół 'ImPS/2', to Xorg.0.log mówi, że nie istnieje urządzenie "/dev/psaux". (X się w tym momencie nie uruchamia, wyrzucając błąd "No core Pointer").

Z kolei jeśli ustawię np. "/dev/input/psaux" to Xorg.0.log nie zawiera żadnych błędów myszy, X się uruchamia, a mysz nie działa (kursor stoi w miejscu).

Próbowałem "/dev/input/psaux" ze wszystkimi możliwymi protokołami i nie pomogło.
Próbowałem także "/dev/input/mice", "/dev/input/mouse*" (gdzie *=0-3).

Jeśli chodzi o gpm. No cóż, wczoraj zainstalowałem gpm i z kolei wydaje mi się że to nic nie daje, bo w gpm-ie też musisz ustawić jaki port ma mysz, nic Ci to nie daje. W sensie, że oczywiśćie, w xorg.conf można wtedy właczyć port '/dev/gpmdata',  i X uruchamia się, nie podaje błędów, ale mysz się nie rusza.
oczywiście wcześniej (tj. przed wpisaniem '/dev/gpmdata' do xorg.conf) trzeba jeszcze skonfigurować gpm-a. No i tu jest pies pogrzebany, bo co bym mu nie podał, to są to te same porty które wtedy wpisywałem w xorg.conf, np. '/dev/psaux', '/dev/input/psaux', z których żaden nie powoduje żeby coś działało.
W ogóle jak mam rozumieć zwrot "gpm działa"? Bo nie wiem, nigdy wcześniej gpm nie używałem.

Jeszcze ciekawostka : Jak pożyczyłem od kolegi mysz starożytną, na porcie szeregowym (rs/2) i ustawiłem w xorg.conf opcję '/dev/ttys0' to zaczęła działać.
Może poszukałbym przejściówki z ps/2 na szeregowy... to jedyne co przychodzi mi do głowy narazie...

pozdrawiam





Offline xis

  • Global Moderator
  • Guru
  • *****
  • Wiadomości: 1049
    • Zobacz profil
X nie widzi myszy (Debian).
« Odpowiedź #10 dnia: 2006-11-08, 13:56:24 »
Pisząc 'gpm działa?' miałem na myśli to czy rusza Ci się tekstowy kursorek na ekranie konsoli tekstowej :) Ale - z tego co opisujesz - też nie działa.
Czy masz załadowany/wkompilowany moduł psmouse (modprobe psmouse)?
(Pytam, bo nie mam za bardzo pomysłu, ale może akurat trafimy na coś ;) )
Everything should be made as simple as possible, but not simpler
-- Albert Einstein

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 20
    • Zobacz profil
X nie widzi myszy (Debian).
« Odpowiedź #11 dnia: 2006-11-09, 11:03:28 »
2006-11-08 13:56:24 xis napisał:

> Pisząc 'gpm działa?' miałem na myśli to czy rusza Ci się tekstowy kursorek na ekranie konsoli
 > tekstowej :) Ale - z tego co opisujesz - też nie działa.
 > Czy masz załadowany/wkompilowany moduł psmouse (modprobe psmouse)?
 > (Pytam, bo nie mam za bardzo pomysłu, ale może akurat trafimy na coś ;) )
 >

No więc polecenie

modprobe psmouse

nie daje żadnego outputu, z kolei

modprobe -l psmouse

daje

/lib/modules/2.6.8-12-amd64-generic/kernel/drivers/input/mouse/psmouse.ko



Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 20
    • Zobacz profil
X nie widzi myszy (Debian).
« Odpowiedź #12 dnia: 2006-11-09, 11:06:56 »
Aha, a w jaki sposób mogę przejrzeć wiadomości pojawiające się w trakcie uruchamiania systemu (dokładnie te same)? Bo chyba syslog zawiera jednak nieco inne rzeczy, a ja byłbym bardzo tym zainteresowany. A to dlatego, że pisze tam coś o myszy, ale znika tak szybko, że nie daję rady odczytać.

Offline xis

  • Global Moderator
  • Guru
  • *****
  • Wiadomości: 1049
    • Zobacz profil
X nie widzi myszy (Debian).
« Odpowiedź #13 dnia: 2006-11-09, 11:35:53 »
Jeśli wykonanie modprobe nie owocuje żadnym komunikatem to znaczy, że komenda się powiodła - udało Ci się załadować moduł psmouse, to dobra wiadomość.
To co wkleiłeś świadczy o tym, że musisz ładować moduł psmouse odpowiedzialny za obsługę myszy na porcie PS/2.

Odnośnie informacji startowych, sprawdź komendę dmesg.
Wykonaj ją także po wykonaniu 'modprobe psmouse' i sprawdź co zwraca.

PS. Żeby wyświetlić listę załadowanych modułów użyj 'lsmod'.
Everything should be made as simple as possible, but not simpler
-- Albert Einstein

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 20
    • Zobacz profil
X nie widzi myszy (Debian).
« Odpowiedź #14 dnia: 2006-11-09, 11:56:52 »
2006-11-09 11:35:53 xis napisał:

> Jeśli wykonanie modprobe nie owocuje żadnym komunikatem to znaczy, że komenda się powiodła -
 > udało Ci się załadować moduł psmouse, to dobra wiadomość.
 > To co wkleiłeś świadczy o tym, że musisz ładować moduł psmouse odpowiedzialny za obsługę myszy
 > na porcie PS/2.
 >
 > Odnośnie informacji startowych, sprawdź komendę dmesg.
 > Wykonaj ją także po wykonaniu 'modprobe psmouse' i sprawdź co zwraca.
 >
 > PS. Żeby wyświetlić listę załadowanych modułów użyj 'lsmod'.
 >


Ls mod wypisuje że psmouse jest załadowany (po restarcie komputera), tj.

# lsmod |grep psmouse

psmouse 18572  0

Ale w takiej sytuacji ustawienie w xorg.conf opcji '/dev/psaux' dalej owocuje komunikatem "no such device" i X-y odmawiają uruchomienia się.

Obecnie zatem używam myszy na porcie szeregowym...
Hihi trochę śmiesznie się prezentuje obok dwurdzeniowego 64bitowego procesora :)