Nowe posty

Autor Wątek: Jak właczyć num locka przy starcie systemu debian 12?  (Przeczytany 1394 razy)

Offline marcin21

  • Stały bywalec
  • ***
  • Wiadomości: 116
    • Zobacz profil
Witam
W jaki sposób  można  włączyć num locka przy starcie Debiana 12 ? Próbowałem włączyć jego w ten sposób 
 sudo apt-get install numlockx
Edytuj plik /etc/lightdm/lightdm.conf:

 sudo nano /etc/lightdm/lightdm.conf
Dodaj następujący wiersz do pliku:

 greeter-setup-script=/usr/bin/numlockx on
Naciśnij Ctrl+ X, aby wyjść z Nano.
Ale nie za działo  .
Pozdrawiam

Offline kszyhu

  • Użytkownik
  • **
  • Wiadomości: 60
    • Zobacz profil
Odp: Jak właczyć num locka przy starcie systemu debian 12?
« Odpowiedź #1 dnia: 2024-03-31, 18:23:05 »
Nie wiem, akurat czy to zadziała, ale po dopisaniu w nano do lightdm.conf podanej frazy musisz jeszcze zapisać zmiany w pliku
najpierw Ctrl+O a potem dopiero wyjść z nano poprzez Ctrl+X

Offline marcin21

  • Stały bywalec
  • ***
  • Wiadomości: 116
    • Zobacz profil
Odp: Jak właczyć num locka przy starcie systemu debian 12?
« Odpowiedź #2 dnia: 2024-03-31, 18:37:15 »
A w którym  miejscu mam jego wpisać ? Na samym końcu pliku jako ostatnia linijka ?
A znasz jakiś dobry sposób na właczenie num locka przy starcie systemu ?
« Ostatnia zmiana: 2024-03-31, 18:53:30 wysłana przez marcin21 »

Offline kszyhu

  • Użytkownik
  • **
  • Wiadomości: 60
    • Zobacz profil
Odp: Jak właczyć num locka przy starcie systemu debian 12?
« Odpowiedź #3 dnia: 2024-04-01, 08:28:49 »
Możesz wyłączyć go w BIOS-ie lub UEFI.

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 3062
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
Odp: Jak właczyć num locka przy starcie systemu debian 12?
« Odpowiedź #4 dnia: 2024-04-01, 10:48:41 »
Jak napisał Kszyhu - jak sobie w BIOSie/UEFIu ustawisz jako domyślne, tak będziesz miał w systemie - bo on nie zmienia defaulta jeżeli mu tego nie każesz.

A jak podasz jakiego używasz środowiska (nie jest to KDE bo ono używa SDDM, ani Gnome bo to używa GDM) - to (pewnie) każde ma to w swoich konfiguracjach klawiatury. W KDE na pierwszym ekranie konfiguracji klawiatury masz wielkie pole NumLock z opcjami włączony/wyłączony/nie zmieniaj i domyślnie jest "nie zmieniaj". Nie chcę sobie świątecznego nastroju psuć instalując Gnome - ale tam pewnie jest podobnie. W XFCE jest opcja "Restore on startup". Bez niej nic nie zmienia (masz to co w BIOSie ustawisz), z nią zapamiętuje ustawienie przy wylogowaniu i przywraca przy zalogowaniu.

Paweł Kraszewski
~Arch/Void/Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline marcin21

  • Stały bywalec
  • ***
  • Wiadomości: 116
    • Zobacz profil
Odp: Jak właczyć num locka przy starcie systemu debian 12?
« Odpowiedź #5 dnia: 2024-04-01, 17:18:29 »
Używam Debiana 12 Xfce na laptopie dell inspirion 15 3552.
« Ostatnia zmiana: 2024-04-01, 17:51:47 wysłana przez marcin21 »

Offline robson75

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 430
    • Zobacz profil
Odp: Jak właczyć num locka przy starcie systemu debian 12?
« Odpowiedź #6 dnia: 2024-04-01, 18:14:59 »
Być może że wystarczy komenda
numlockx on
Arch Linux Xfce - 64Bit Linux User #621110

Offline marcin21

  • Stały bywalec
  • ***
  • Wiadomości: 116
    • Zobacz profil
Odp: Jak właczyć num locka przy starcie systemu debian 12?
« Odpowiedź #7 dnia: 2024-04-01, 18:27:48 »
Dalej nie działa num lock przy starcie systemu . Wciaż musze właczac jego przy starcie recznie

Offline robson75

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 430
    • Zobacz profil
Arch Linux Xfce - 64Bit Linux User #621110

Offline marcin'82

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 404
    • Zobacz profil
Odp: Jak właczyć num locka przy starcie systemu debian 12?
« Odpowiedź #9 dnia: 2024-04-01, 21:18:03 »
Pokaż zawartość pliku:
cat /etc/lightdm/lightdm.conf

LightDM to gówno jakich mało - tak na marginesie. Przetestuj SDDM, działa z Xfce bez problemu.

Po drugie:
1. Wyloguj się
2. Przełącz się na TTY (Ctrl+Alt+F3)
3. Zaloguj się na konto swojego użytkownika i usuń cache sesji:
rm -rf .cache/sessions/*
Uważaj z rm, można sobie zrobić kuku.

Po trzecie, po ponownym zalogowaniu włącz ręcznie NumLock i idź do ustawień klawiatury w Xfce i zanzacz pole Przywracanie stanu klawiatury numerycznej po uruchomieniu.

Wyloguj się, zaloguj się ponownie i sprawdź czy działa.

PS
Sprawdź ustawienia klawiatury numerycznej w BIOS - jak pisali koledzy wcześniej.
« Ostatnia zmiana: 2024-04-01, 21:20:38 wysłana przez marcin'82 »
marcin82

Offline marcin21

  • Stały bywalec
  • ***
  • Wiadomości: 116
    • Zobacz profil
Odp: Jak właczyć num locka przy starcie systemu debian 12?
« Odpowiedź #10 dnia: 2024-04-01, 21:30:00 »
#
[XDMCPServer]
#enabled=false
#port=177
#listen-address=
#key=
#hostname=

#
# VNC Server configuration
#
# enabled = True if VNC connections should be allowed
# command = Command to run Xvnc server with
# port = TCP/IP port to listen for connections on
# listen-address = Host/address to listen for VNC connections (use all addresses if not present)
# width = Width of display to use
# height = Height of display to use
# depth = Color depth of display to use
#
[VNCServer]
#enabled=false
#command=Xvnc
#port=5900
#listen-address=
#width=1024
#height=768
#depth=8

Offline marcin'82

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 404
    • Zobacz profil
Odp: Jak właczyć num locka przy starcie systemu debian 12?
« Odpowiedź #11 dnia: 2024-04-01, 21:43:02 »
To jest kawałek pliku czy - nieważne...

Podnieś uprawnienia:
sudo su -
Edytuj plik /etc/lightdm/lightdm.conf:
nano /etc/lightdm/lightdm.conf

Dopisz takie dwie linijki, chyba, że niezahaszowany nagłówek sekcji [Seat:*] jest gdzieś wyżej, to umieść linijkę z greeter-setup-script między nagłówkiem [Seat:*], a początkiem nastepnej sekcji:
[Seat:*]
greeter-setup-script=/usr/bin/numlockx on

ALBO


greeter-setup-script=/usr/bin/numlockx on

Zapisz zmiany skrótem Ctrl+s, wyjdź z nano Ctrl+x. Przeloguj się.

Poglądowo, w tej części zgodne:
https://wiki.archlinux.org/title/LightDM#NumLock_on_by_default .
« Ostatnia zmiana: 2024-04-01, 21:44:48 wysłana przez marcin'82 »
marcin82

Offline marcin21

  • Stały bywalec
  • ***
  • Wiadomości: 116
    • Zobacz profil
Odp: Jak właczyć num locka przy starcie systemu debian 12?
« Odpowiedź #12 dnia: 2024-04-02, 17:43:54 »
Dzięki za radę marcin'82 działa . Przy logowaniu działa juz num lock .