Nowe posty

xx Różnice w wydajności :) (0)
Wczoraj o 21:20:21
xx Problem z pulpitem w XFCE (1)
Wczoraj o 10:43:16
xx Problemy z instalacją ustawień jądra (1)
2024-02-26, 14:01:41
xx System 5.1 jak podłączyć i skonfigurować? (3)
2024-02-23, 22:32:16
xx Alternatywa dla Hamachi pod Raspberry Pi? (1)
2024-02-22, 13:51:32
xx Everspace (7)
2024-02-21, 21:33:19
xx [C] Uruchamianie zewnętrznych programów (14)
2024-02-11, 19:20:33
xx libfuse i wielowątkowość (5)
2024-02-11, 13:37:22
xx [libfuse3] Kolejkowanie tworzenia plików dla tego samego katalogu (0)
2024-02-11, 13:31:51

Autor Wątek: Problem z nmap'em  (Przeczytany 684 razy)

Offline grizliiirk

  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
Problem z nmap'em
« dnia: 2023-10-22, 23:58:41 »
Cześć

Byłem niedawno na szkoleniu CEH i jestem na etapie przygotowywania się do egzaminu. W związku z tym, że ichniejsze laby działają tylko przez pewien okres, postanowiłem, że utworzę takie same laby u siebie lokalnie na PC - dopóki mam jeszcze do nich dostęp.

Problemów miałem kilka i niestety dłużej schodzi mi się z ich debugowaniem niż z samą nauką. W tym przypadku mam problem z nmap'em. Poniżej wrzucam zrzut ekranu. Po lewej jest lab z EC, po prawo mój. Mógłby ktoś powiedzieć z czego wzięła się zaznaczona różnica i dlaczego to skanowanie u mnie nie działa?


Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 3041
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
Odp: Problem z nmap'em
« Odpowiedź #1 dnia: 2023-10-23, 05:57:42 »
To tylko pokazuje jak słaby jest CEH z merytorycznego punktu widzenia (sam cyklicznie zdawałem wewnętrzny egzamin na bazie CEH, więc znam mniej więcej zakres pytań).

Mój hint: Skupiasz się na nieistotnej różnicy (a CEH nie wyjaśnił, co ona znaczy, żebyś wiedział czy jest ważna w tym momencie) a nie zauważasz kluczowego błędu dwie linijki niżej (a to wiedza potrzebna przed myśleniem o przystąpieniu do CEH)...
« Ostatnia zmiana: 2023-10-23, 07:01:06 wysłana przez Paweł Kraszewski »
Paweł Kraszewski
~Arch/Void/Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline grizliiirk

  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
Odp: Problem z nmap'em
« Odpowiedź #2 dnia: 2023-10-23, 06:13:37 »
Mogłem sobie robić lab i bym w ogóle nie miał żadnych problemów 😏
Wolę jednak poszerzyć swoją wiedzę i byłbym wdzięczny jakbyś napisał jak rozwiązać problem.

Ja zdaję CEH, nie CIH. Wydaje mi się że na egzaminie nie będę musiał bawić się w debugowanie problemów z apkami, tylko tam już będą gotowe maszyny.
« Ostatnia zmiana: 2023-10-23, 06:16:46 wysłana przez grizliiirk »

Offline grizliiirk

  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
Odp: Problem z nmap'em
« Odpowiedź #3 dnia: 2023-10-23, 06:25:30 »
Zauważyłem jeszcze jedną chyba znaczącą w tym przypadku różnicę.

Po lewo, przy wykonywaniu skryptu jest adres maszynki, a po prawo adres bramy.

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 3041
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
Odp: Problem z nmap'em
« Odpowiedź #4 dnia: 2023-10-23, 07:01:55 »
Ja zdaję CEH, nie CIH. Wydaje mi się że na egzaminie nie będę musiał bawić się w debugowanie problemów z apkami, tylko tam już będą gotowe maszyny.
Pisałem CEH, ale je*a autokorekta zmieniła na CIH.

Zauważyłem jeszcze jedną chyba znaczącą w tym przypadku różnicę.

Po lewo, przy wykonywaniu skryptu jest adres maszynki, a po prawo adres bramy.
Czyli po prostu nie rozumiesz, co ten konkretny test sprawdza, jak działają grupy multikastowe, jaki wpływ na działanie programów typu NMAP ma konkretne srodowisko sieciowe, w którym działają...
« Ostatnia zmiana: 2023-10-23, 07:06:05 wysłana przez Paweł Kraszewski »
Paweł Kraszewski
~Arch/Void/Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline grizliiirk

  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
Odp: Problem z nmap'em
« Odpowiedź #5 dnia: 2023-10-23, 07:03:19 »
Ja zdaję CEH, nie CIH. Wydaje mi się że na egzaminie nie będę musiał bawić się w debugowanie problemów z apkami, tylko tam już będą gotowe maszyny.
Pisałem CEH, ale je*a autokorekta zmieniła na CIH.

Okej 😅 Classic mam tak samo :D

Offline grizliiirk

  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
Odp: Problem z nmap'em
« Odpowiedź #6 dnia: 2023-10-23, 07:25:29 »
Cytuj
Czyli po prostu nie rozumiesz, co ten konkretny test sprawdza, jak działają grupy multikastowe, jaki wpływ na działanie programów typu NMAP ma konkretne srodowisko sieciowe, w którym działają...

Oczywiście że wiem, że środowisko sieciowe ma wpływ na działanie tego typu programów. Ja w linuxach nie jestem jakiś biegły. Tyle co wiedziałem, to odwzorowałem u siebie na maszynie. Na pewno nie zrobiłem wszystkiego 1:1, bo nie wiem gdzie jeszcze szukać.




Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 3041
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
Odp: Problem z nmap'em
« Odpowiedź #7 dnia: 2023-10-23, 08:41:05 »
To teraz bardziej skup się, dlaczego nmap nie widzi adresu certifiedhacker.com... Adres istnieje i (w każdym razie u mnie) rozwiązuje się na IP taki sam, jak w lewym screenshocie.
Paweł Kraszewski
~Arch/Void/Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline grizliiirk

  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
Odp: Problem z nmap'em
« Odpowiedź #8 dnia: 2023-10-23, 08:53:33 »
IP to też u mnie rozwiązuje. Skanowanie konkretnych portów działa.. a ten skrypt już nie. Nie wiem.

To jest 4 miejsce na ktorym proszę o pomoc. Z innego forum ktoś polecił mi tutejsze foru, a póki co mam wrażenie że trochę przepychamy się w odpowiedziach.

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 3041
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
Odp: Problem z nmap'em
« Odpowiedź #9 dnia: 2023-10-23, 10:38:29 »
Matko. Skrypt działa, tylko u ciebie w sieci działają na multikaście inne serwisy niż u nich. To twoje to (prawdopodobnie) usługa strumieniowania gier (NVidia/Sunshine).

Cytuj
To jest 4 miejsce na ktorym proszę o pomoc. Z innego forum ktoś polecił mi tutejsze foru, a póki co mam wrażenie że trochę przepychamy się w odpowiedziach.

- To, co tobie wydaje się problemem wynika po prostu z różnic środowiska sieciowego i nie jest problemem.
- Problem, którego nie zauważyłeś to błąd "Failed to resolve", którego następstwem jest warning "0 hosts scanned" i związany z tym brak wyników skanowania.
Cytuj
IP to też u mnie rozwiązuje.
- Jeżeli po rekonfiguracji sieci coś inaczej/zaczęło/przestało działać - tego już nie wiemy, bo nie widzimy twojej konsoli. To co widzać na screenshotach to to, że się nie rozwiązuje.
« Ostatnia zmiana: 2023-10-23, 11:02:13 wysłana przez Paweł Kraszewski »
Paweł Kraszewski
~Arch/Void/Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline grizliiirk

  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
Odp: Problem z nmap'em
« Odpowiedź #10 dnia: 2023-10-23, 12:49:11 »
To nie jest pierwszy test nmapem z tej maszynki na tą domenę.
np.  nmap -T4 -p 53 --script dns-brute certifiedhacker.com działa bez problemu i tu potrafi rozwiązać adres.

Offline grizliiirk

  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
Odp: Problem z nmap'em
« Odpowiedź #11 dnia: 2023-10-23, 17:54:20 »
Dobra, jednak  nie do konca to działa. Niby rozwiązuje adres, ale np. na maszynce pokazuje ze port jest filtrowany, a na PC że otwarty

Zrzut ekranu z VMki


Zrzut z nmap na PC

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2747
  • 1709
    • Zobacz profil
Odp: Problem z nmap'em
« Odpowiedź #12 dnia: 2023-10-23, 20:17:10 »
Na pewno czytałeś dokumentacje nmap https://nmap.org/book/man.html
i wiesz co to znaczy filtered.
Czy to znaczy że twój problem został już rozwiązany?
PS: Brak polskiej czcionki, nie jest to brak lenistwa, a jej brak w systemie i brak czasu na reczne poprawki.

Offline grizliiirk

  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
Odp: Problem z nmap'em
« Odpowiedź #13 dnia: 2023-10-23, 20:30:07 »
Już sobie poradziłem.
Zmieniłem konfig sieci na VM na bridge i zaczęło działac.
Sieci NAT nie udało mi się ustawić na tym darmowym VMwarze tak aby to działało.