Nowe posty

xx Problem ze sterownikami. (5)
2024-04-13, 21:25:16
xx Instalacja xfce4 (2)
2024-04-13, 16:20:17
xx Serie kompilacji bez instalacji dla “emerge” w Gentoo (2)
2024-04-08, 18:40:04
xx Plasma 6 w Neonie ssie trochę mniej ... (17)
2024-04-05, 10:03:46
xx Problem z Linux Lite po instalacji (3)
2024-04-03, 14:23:40
xx Jak właczyć num locka przy starcie systemu debian 12? (12)
2024-04-02, 17:43:54
xx Brak dźwieku w systemie. (5)
2024-04-02, 16:13:41
xx Dystrybucja pod HP Omen (7)
2024-03-29, 11:33:05
xx [Poradnik] Wyszukiwanie Sterowników (2)
2024-03-27, 21:08:23
xx Ile pingwinów? (1)
2024-03-27, 08:59:24

Autor Wątek: x11 i ubuntu-desktop  (Przeczytany 894 razy)

Offline Panas

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 198
    • Zobacz profil
x11 i ubuntu-desktop
« dnia: 2023-02-21, 18:55:28 »
Przepraszam że na leniwca.
Komuś się obiło o uszy aby ostatni update po 18.02.23 krzaczył x11? Po aktualizacji typowe czarne a wayland laguje.
Ubuntu 22.04.
Po cofce do 18 dostępne pakiety.
fwupd-signed/jammy-updates 1.51~22.04.1+1.2-3ubuntu0.2 amd64 [aktualizowany z: 1.44+1.2-3]
gnome-initial-setup/jammy-updates 42.0.1-1ubuntu2.3 amd64 [aktualizowany z: 42.0.1-1ubuntu2.2]
gnome-remote-desktop/jammy-updates 42.7-0ubuntu1 amd64 [aktualizowany z: 42.4-0ubuntu1]
grub-efi-amd64-bin/jammy-updates 2.06-2ubuntu14.1 amd64 [aktualizowany z: 2.06-2ubuntu10]
grub-efi-amd64-signed/jammy-updates 1.187.3~22.04.1+2.06-2ubuntu14.1 amd64 [aktualizowany z: 1.182~22.04.1+2.06-2ubuntu10]
python3-distupgrade/jammy-updates,jammy-updates 1:22.04.16 all [aktualizowany z: 1:22.04.15]
python3-software-properties/jammy-updates,jammy-updates 0.99.22.5 all [aktualizowany z: 0.99.22.4]
shim-signed/jammy-updates 1.51.3+15.7-0ubuntu1 amd64 [aktualizowany z: 1.51+15.4-0ubuntu9]
software-properties-common/jammy-updates,jammy-updates 0.99.22.5 all [aktualizowany z: 0.99.22.4]
software-properties-gtk/jammy-updates,jammy-updates 0.99.22.5 all [aktualizowany z: 0.99.22.4]
ubuntu-advantage-desktop-daemon/jammy-updates 1.10~22.04.1 amd64 [aktualizowany z: 1.9~22.04.1]
ubuntu-release-upgrader-core/jammy-updates,jammy-updates 1:22.04.16 all [aktualizowany z: 1:22.04.15]
ubuntu-release-upgrader-gtk/jammy-updates,jammy-updates 1:22.04.16 all [aktualizowany z: 1:22.04.15]
update-notifier-common/jammy-updates,jammy-updates 3.192.54.5 all [aktualizowany z: 3.192.54]
update-notifier/jammy-updates 3.192.54.5 amd64 [aktualizowany z: 3.192.54]
« Ostatnia zmiana: 2023-02-21, 18:59:02 wysłana przez Panas »

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 3056
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
Odp: x11 i ubuntu-desktop
« Odpowiedź #1 dnia: 2023-02-21, 21:18:43 »
Jedyne co mi tu marginalnie pasuje to shimy do Secure Boota - np bianrna NVidia przestała się ładować i wskoczyło Nouvau albo w ogóle VESA?
Paweł Kraszewski
~Arch/Void/Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2765
  • 1709
    • Zobacz profil
Odp: x11 i ubuntu-desktop
« Odpowiedź #2 dnia: 2023-02-21, 21:28:18 »
Nie słyszałem.
Ale chciałem tylko nadmienić że z powodu piekła zależności czasami błędy się zdarzają,
Może to wynikać
- ze słabego wsparcia
- z powodu zainstalowanego pakietu którego prawie nikt nie używa, ale akurat dana osoba używa.
Przykładowo , przykład fikcja
 domyślnie są ikonki GTK3, ale ja używam GTK2 i to zmienia u mnie połowę zależności w systemie.
I teraz po aktualizacji może się okazać że pakiet "A" chce innej wersji pakietu "B", lub całkiem innego pakietu który dodatkowo może być w konflikcie z innym zainstalowanym "C".

Problem często także dotyczy osób które posiadają więcej niż jedno repozytorium.
Można sprawdzić ilość aktywnych repozytoriów komendą
inxi -Fxxrzc0
W sekcji Repos:

Naprawa polega na wyłączeniu repozytorium które sprawia problem
i zgłoszeniu problemu odpowiedniemu developerowi żeby naprawił.
https://linuxmint-troubleshooting-guide.readthedocs.io/en/latest/where.html

Nie pomoże wyłączenie repozytorium, jeśli problem tkwi w głównym repozytorium które musi być aktywne.

W przypadku Ubuntu jeszcze zauważyłem jedną rzecz.
Do aktualizacji głównie używam " update-manager "
Natomiast Synaptic menadżer pakietów w sekcji
Stan --> zainstalowane ( z mozliwością aktualizacji )
zgłasza mi dodatkowe pakiety wyszarzone które nie chciały się zaktualizować
np.
firmware-sof-signed 2.0-1ubuntu4
fwupd-signed  1.44+1.2-3
Ale ja to mam od dawna i ja to ignoruje, bo mi na tym nie zależy.
« Ostatnia zmiana: 2023-02-21, 21:33:22 wysłana przez 1709 »
PS: Brak polskiej czcionki, nie jest to brak lenistwa, a jej brak w systemie i brak czasu na reczne poprawki.

Offline Panas

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 198
    • Zobacz profil
Odp: x11 i ubuntu-desktop
« Odpowiedź #3 dnia: 2023-02-22, 16:36:34 »
Dzięki, w weekend pojedynczo podciągnę i zobaczy się gdzie jest problemi czy shimy 1.51.3+15.7 faktycznie krzaczy.
Lista... Gotowe
shim-signed/jammy-updates 1.51.3+15.7-0ubuntu1 amd64 [aktualizowany z: 1.51+15.4-0ubuntu9]
N: There is 1 additional version. Please use the '-a' switch to see it

Faktycznie shimy krzaczy, tylko on pozostał.
« Ostatnia zmiana: 2023-02-22, 16:55:46 wysłana przez Panas »

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 3056
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
Odp: x11 i ubuntu-desktop
« Odpowiedź #4 dnia: 2023-02-22, 18:59:55 »
Jeżeli to rzeczywiście shim, to w logach kernela powinny być komunikaty o błędzie ładowania modułu (coś w stylu "invalid signature" czy coś w ten deseń — równolegle mam FreeBSD, więc i tak nie mam aktywne nic z SecureBoota).
Jeżeli to shim nabruździł w modułach, a wcześniej działało — to może wystarczy przeinstalować DKMS-y, żeby na nowo popodpisywał moduły.


Ale co dokładnie się sypie jest zapisane w logach systemu i X-ów.
Paweł Kraszewski
~Arch/Void/Gentoo/FreeBSD/OpenBSD/Specjalizowane customy