Nowe posty

Autor Wątek: Touchpad po pewnym losowym czasie przestaje reagować  (Przeczytany 2672 razy)

Offline Kacper

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
Witam.
Od dłuższego czasu eksperymentuję z Linuxami na biedronkowym laptopie Kiano Slimnote 14.1. Aktualnie mam zainstalowanego najnowszego Lubuntu 19.04 z jądrem 5.0
Problem jest z touchpadem, gdyż ten się randomowo wyłącza. Czasem pochodzi krócej, czasem dłużej, touchpad wyłącza się, ale reaguje tylko na jedną funkcję multi dotyku tj. zmiana okien (3 palcowy odpowiednik Alt+Tab)
Zauważyłem także, że jak touchpad przestanie działać, to w większości nie działają także klawisze funkcyjne typu Vol+/-/Mute

xinput list:
 Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SINO WEALTH USB KEYBOARD Mouse            id=8    [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ SINO WEALTH USB KEYBOARD                  id=7    [slave  keyboard (3)]
    ↳ SINO WEALTH USB KEYBOARD System Control   id=9    [slave  keyboard (3)]
    ↳ SINO WEALTH USB KEYBOARD Wireless Radio Control   id=10   [slave  keyboard (3)]
    ↳ SINO WEALTH USB KEYBOARD Consumer Control id=11   [slave  keyboard (3)]
    ↳ USB 2.0 Web Camera: USB 2.0 Web           id=12   [slave  keyboard (3)]
    ↳ bytcr-rt5640 Headset                      id=13   [slave  keyboard (3)]
    ↳ axp20x-pek                                id=14   [slave  keyboard (3)]
    ↳ gpio-keys                                 id=15   [slave  keyboard (3)]
    ↳ gpio-keys                                 id=16   [slave  keyboard (3)]
Dodam jeszcze, że xinput disable 8 (SINO WEALTH USB KEYBOARD Mouse) i potem enable nie przynosi skutku.
Czy jest jakiś sposób uratowania budżetowca przed powrotem na Windows? Coś podejrzewam, że to może mieć związek z zarządzaniem energii w Linuxie, bo tak jak pisałem, z klawiatury wraz z "wyłączeniem" touchpada nie działają klawisze funkcyjne.

Offline mackeire

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 189
    • Zobacz profil
Odp: Touchpad po pewnym losowym czasie przestaje reagować
« Odpowiedź #1 dnia: 2019-04-22, 18:39:59 »
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=1"

Offline Kacper

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
Odp: Touchpad po pewnym losowym czasie przestaje reagować
« Odpowiedź #2 dnia: 2019-04-22, 20:59:48 »
Niestety, jednak bez zmian
« Ostatnia zmiana: 2019-04-22, 21:23:25 wysłana przez Kacper »

Offline mackeire

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 189
    • Zobacz profil
Odp: Touchpad po pewnym losowym czasie przestaje reagować
« Odpowiedź #3 dnia: 2019-04-22, 23:21:26 »
Wiem skądinąd ,że Fedora daje radę na sprzętach z baytrailem , więc gdyby się nie upierać przy ubu*podobnych  to może to być jakimś wyjściem.

Offline mackeire

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 189
    • Zobacz profil
Odp: Touchpad po pewnym losowym czasie przestaje reagować
« Odpowiedź #4 dnia: 2019-04-23, 12:23:40 »
Niestety, jednak bez zmian
No to możesz jeszcze spróbować ustawić na zero, wtedy procesor nie będzie w ogóle zasypiał w stanie bezczynności .
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=0"

później , oczywiście
sudo update-grub
« Ostatnia zmiana: 2019-04-24, 13:05:41 wysłana przez mackeire »

Offline Kacper

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
Odp: Touchpad po pewnym losowym czasie przestaje reagować
« Odpowiedź #5 dnia: 2019-04-24, 12:41:24 »
Tak, tak, intel_idle.max_cstate=0 miałem także na Lubuntu, ale bez zmian. Potestuje jeszcze, bo w Lubuntu też się pośpieszyłem z pisaniem postu po zmianie intel_idle.max_cstate.

Co ciekawe na Fedorze Beta 30 działa już kilka minut OK, Jakoś przeboleję brak klawiszy funkcyjnych, to załatwi się innym razem.

Wybrałem póki co Fedorę 30, bo w jądrze Linux 5.0 są wreszcie sterowniki dźwięku do tego chinola.

Tak do zrobienia zostało jeszcze:
1) Brak w trayu ikonki od poziomu głośności, da się jakoś załatwić bez ciągłego siedzenia w terminalu i w alsamixer?
2) Brak ikonki baterii.

//EDIT już mam poziomy głośności i baterii. Jednakże bateria na Linuxie schodzi trochę szybciej jak na Windowsie, na Windzie bateria potrafiła trzymać 8 godzin nawet, jakieś są sposoby na energooszczędność? Pewnie się będzie wiązało z tym intel_idle, ale...
« Ostatnia zmiana: 2019-04-24, 12:44:19 wysłana przez Kacper »

Offline Kacper

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
Odp: Touchpad po pewnym losowym czasie przestaje reagować
« Odpowiedź #6 dnia: 2019-04-24, 12:54:54 »
Po części znowu wycofuję się z stwierdzenia sukcesu. Touchpad przestaje reagować, ale zauważyłem pewną zależność.

Jak na czas bootu jest do laptopa podłączona mysz USB i po zalogowaniu się do pulpitu odłączę mysz, to daje się używać normalnie komputer. Poprzednio jak touchpad nie reaguje to także da się używać laptopa dzięki myszce, ale co to za rozwiązanie...

Offline mackeire

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 189
    • Zobacz profil
Odp: Touchpad po pewnym losowym czasie przestaje reagować
« Odpowiedź #7 dnia: 2019-04-24, 13:28:28 »
SINO WEALTH USB KEYBOARD Mouse to jest touchpad w tym sprzęcie ?

Jeżeli tak to zobacz jaki sterownik go przechwytuje, bo wiem ,że są co najmniej trzy do wyboru.

xinput list-props 8

btw, do ogarnięcia dźwięku na baytrailu z realtekiem trzeba wrzucić katalog bytcr-rt5640 https://github.com/plbossart/UCM do /usr/share/alsa/ucm i dla pewności skasować /var/lib/alsa/asound.state

Offline Kacper

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
Odp: Touchpad po pewnym losowym czasie przestaje reagować
« Odpowiedź #8 dnia: 2019-04-26, 22:21:20 »
Libinput odpowiada za touchpad:
Device 'SINO WEALTH USB KEYBOARD Mouse':
Device Enabled (147): 1
Coordinate Transformation Matrix (149): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
libinput Natural Scrolling Enabled (284): 0
libinput Natural Scrolling Enabled Default (285): 0
libinput Scroll Methods Available (286): 0, 0, 1
libinput Scroll Method Enabled (287): 0, 0, 0
libinput Scroll Method Enabled Default (288): 0, 0, 0
libinput Button Scrolling Button (289): 2
libinput Button Scrolling Button Default (290): 2
libinput Middle Emulation Enabled (291): 0
libinput Middle Emulation Enabled Default (292): 0
libinput Accel Speed (293): 0.000000
libinput Accel Speed Default (294): 0.000000
libinput Accel Profiles Available (295): 1, 1
libinput Accel Profile Enabled (296): 1, 0
libinput Accel Profile Enabled Default (297): 1, 0
libinput Left Handed Enabled (298): 0
libinput Left Handed Enabled Default (299): 0
libinput Send Events Modes Available (269): 1, 0
libinput Send Events Mode Enabled (270): 0, 0
libinput Send Events Mode Enabled Default (271): 0, 0
Device Node (272): "/dev/input/event2"
Device Product ID (273): 24704, 32864
libinput Drag Lock Buttons (300): <no items>
libinput Horizontal Scroll Enabled (301): 1

Offline mackeire

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 189
    • Zobacz profil
Odp: Touchpad po pewnym losowym czasie przestaje reagować
« Odpowiedź #9 dnia: 2019-04-27, 12:37:04 »
No to może warto by sprawdzić jak będzie się sprawował evdev albo synaptics. Patrzyłem do laptopa znajomej , też na baytrailu (lenovo 100s) no i u niej touchpada przechwytuje evdev . U mnie w 'normalnym' dellu synaptics.

Offline Kacper

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
Odp: Touchpad po pewnym losowym czasie przestaje reagować
« Odpowiedź #10 dnia: 2019-04-28, 23:04:45 »
Zainstalowałem pakiety xorg-x11-drv-synaptics i dalej mam problemy z wymuszeniem korzystania touchpada z synapticsa, bo dodanie w pliku konfiguracyjnym 40-libinput Option "Ignore" "true". Z evdev jakoś to działało, ale touchpad też przestawał działać. Zauważyłem też kolejną rzecz, że aby touchpad działał non stop to musi być cokolwiek wpięte w USB...

Offline mackeire

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 189
    • Zobacz profil
Odp: Touchpad po pewnym losowym czasie przestaje reagować
« Odpowiedź #11 dnia: 2019-04-28, 23:40:22 »
/usr/share/X11/xorg.conf.d/70-synaptics.conf

# Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
# Additional options may be added in the form of
#   Option "OptionName" "value"
#
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
      MatchDevicePath "/dev/input/event*"
EndSection

Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/mouse*"
        Option "Ignore" "on"
EndSection

# This option enables the bottom right corner to be a right button on clickpads
# and the right and middle top areas to be right / middle buttons on clickpads
# with a top button area.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Default clickpad buttons"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
        Option "SecondarySoftButtonAreas" "58% 0 0 15% 42% 58% 0 15%"
EndSection

# This option disables software buttons on Apple touchpads.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Disable clickpad buttons on Apple touchpads"
        MatchProduct "Apple|bcm5974"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"
EndSection

ale to chyba zły kierunek, czuję że to nie kwestia 'sterownika'
« Ostatnia zmiana: 2019-04-29, 00:00:45 wysłana przez mackeire »

Offline Kacper

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
Odp: Touchpad po pewnym losowym czasie przestaje reagować
« Odpowiedź #12 dnia: 2019-04-29, 11:23:23 »
Tak, niestety dalej touchpad przestaje reagować (tylko działa na 3 punkty, mając otwarte programy można przełączać okna). Tak jak pisałem wcześniej, z włożonym czymkolwiek do USB dobrze działa. Czyżby jednak teoria o usypianiu pewnych funkcjonalności sprzętu?

Offline mackeire

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 189
    • Zobacz profil
Odp: Touchpad po pewnym losowym czasie przestaje reagować
« Odpowiedź #13 dnia: 2019-04-29, 12:06:46 »
Pokaż co tam masz na szynie usb ?
lsusb

A próbowałeś całkowicie wyłączyć w kernelu usypianie usb ?
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1"
https://www.kernel.org/doc/Documentation/admin-guide/kernel-parameters.txt

Dla oszczędzenia prądu można powyłączać autosuspend tylko  w konkretnych urządzeniach, TLP ma takie opcje w konfiguracji
np. kawałek mojego konfigu :
# Set to 0 to disable, 1 to enable USB autosuspend feature.
USB_AUTOSUSPEND=1

# Exclude listed devices from USB autosuspend (separate with spaces).
# Use lsusb to get the ids.
# Note: input devices (usbhid) are excluded automatically
#USB_BLACKLIST="1111:2222 3333:4444"

# Bluetooth devices are excluded from USB autosuspend:
#   0=do not exclude, 1=exclude.
USB_BLACKLIST_BTUSB=1

# Phone devices are excluded from USB autosuspend:
#   0=do not exclude, 1=exclude (enable charging).
USB_BLACKLIST_PHONE=1

# Printers are excluded from USB autosuspend:
#   0=do not exclude, 1=exclude.
USB_BLACKLIST_PRINTER=1

# WWAN devices are excluded from USB autosuspend:
#   0=do not exclude, 1=exclude.
USB_BLACKLIST_WWAN=1

# Include listed devices into USB autosuspend even if already excluded
# by the blacklists above (separate with spaces).
# Use lsusb to get the ids.
#USB_WHITELIST="1111:2222 3333:4444"

# Set to 1 to disable autosuspend before shutdown, 0 to do nothing
# (workaround for USB devices that cause shutdown problems).
#USB_AUTOSUSPEND_DISABLE_ON_SHUTDOWN=1

Jest też inny sposób, tutaj jest fajnie opisane :
https://morfikov.github.io/post/autosuspend-i-zasilanie-portow-usb/
« Ostatnia zmiana: 2019-04-29, 13:36:54 wysłana przez mackeire »

Offline Kacper

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
Odp: Touchpad po pewnym losowym czasie przestaje reagować
« Odpowiedź #14 dnia: 2019-04-29, 23:22:47 »
lsusb:
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 058f:5608 Alcor Micro Corp.
Bus 001 Device 004: ID 6080:8060 
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Też nie pomaga.
Da się np. jakoś komendą zapisać wszystkie logi systemowe, może tam warto zajrzeć.