Nowe posty

xx Nie działa mi Team Speak 3 (13)
Wczoraj o 08:56:37
xx Mint czy Knoppix, który lepszy jako system z USB (1)
2020-10-28, 20:24:25
xx Framebuffer 640x5760 => 2560x1400. "pocięcie" pamięci framebuffer (2)
2020-10-26, 22:06:34
xx kontrola dostępu (1)
2020-10-26, 07:47:58
xx Użytkownicy należący do grupy (1)
2020-10-26, 07:44:46
xx Klawiatura nie działa po włączeniu Ubuntu (3)
2020-10-25, 19:23:34
xx Szkielet z getops (3)
2020-10-25, 15:06:20
xx 2 adresy na jednej sieciówce - brak pingu (1)
2020-10-22, 14:09:22
xx Knoppix z polską klawiaturą. Czy tak się da w ogóle? (5)
2020-10-20, 21:31:47
xx DNF autouzupełnianie (0)
2020-10-20, 18:18:23

Autor Wątek: Ciągłe rozłączanie wi fi  (Przeczytany 2793 razy)

Offline nowy mint linux ja

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
Ciągłe rozłączanie wi fi
« dnia: 2016-12-29, 14:28:56 »
Cześc,
jestem początkującym użytkownikiem (chyba szczęśliwym) linuxa – tak dokładniej Minta. Borykam się z problemem ciągłęgo rozłączania wi fi. Kiedy podłączam się do interneru kablem, wszyskto jest okej, przy wi fi sprawy nie mają się już tak kolorowo – ciąglę się rozłącza. Z różną częstotliwością – momentami co chwilę, a jak jest dobrze tak co 20 – 30 minut. Próbowałem różnych metod, nic nie pomogło. Zainstalowałem WICD, działa trochę sprawniej niż wgrany program, ale problem nie ustąpił.  Dodam, że wcześniej na Ubuntu też miałem taki problem.
Dzięki i pozdrawiam :)

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2634
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • keybase.io/pkraszewski
Odp: Ciągłe rozłączanie wi fi
« Odpowiedź #1 dnia: 2016-12-29, 14:50:27 »
Brak danych... Brak danych...

Jaki to dokładnie model karty Wifi?
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline nowy mint linux ja

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
Odp: Ciągłe rozłączanie wi fi
« Odpowiedź #2 dnia: 2016-12-29, 16:50:33 »
realtek RTL8723BE hp

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2402
  • 1709
    • Zobacz profil
Odp: Ciągłe rozłączanie wi fi
« Odpowiedź #3 dnia: 2016-12-29, 19:36:56 »
 - Zmiana kernela, ( tam jest domyślny sterownik, może więc aktualizacja kernela pomoże, to było by najprostrze )
 - lub ręczne ściągnięcie ze strony producenta,  kompilacja i instalacja sterownika może pomóc. ( może ... )
 - Warto tez sprawdzić czy prawidłowy sterownik jest załadowany
lsmod | grep ^r
pokaze jaki sterownik jest zaladowany aktualnie , chyba.

Przykład jak ja mam
$ lsmod | grep ^r
r8168                 483328  0

$ lspci | egrep -i --color 'network|ethernet'
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
Jeśli byłyby dwa lub niewłasciwy trzeba by zły dodać do "czarnej listy".
PS: Brak polskiej czcionki, nie jest to brak lenistwa, a jej brak w systemie i brak czasu na reczne poprawki.

Offline nowy mint linux ja

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
Odp: Ciągłe rozłączanie wi fi
« Odpowiedź #4 dnia: 2016-12-29, 20:15:49 »
zaaktualizowałem system, łacznie z wszystkimi aktualizacjami do poziomu 5
rfcomm                 69632  2
raid6_pq              102400  1 btrfs
radeon               1515520  1
r8169                  81920  0
takie cuś wyskoczyło..
sterownikow od strony producenta nie ma na linuxa.
w zarządzaniu sterownikami ustawiłem na zalecane sterowniki.

Offline Andrzej J

  • Users
  • Guru
  • *****
  • Wiadomości: 710
    • Zobacz profil
Odp: Ciągłe rozłączanie wi fi
« Odpowiedź #5 dnia: 2016-12-29, 21:27:22 »
Realtek z mojego doświadczenia ma sterowniki nadające się do pracy jak jest widoczny router i nie ma przeszkód.
1. Spróbuj korzystać z wifi blisko routera.
2. Sprawdź, który kanał w Twojej okolicy jest wolny(ma najmniej sieci) i ustaw w routerze na stałe.
Sprawdź spod nadużytkowninka roota u Ciebie pewnie sudo.
Cytuj
iwlist wlan0 scan
Jeżeli masz w systemie twór marki systemd to wlan0 może mieć inną nazwę
Cytuj
ifconfig
Poda Ci nazwę intefejsu wifi (wlan)
3. Tak jak podał użytkownik wyżej, spróbuj innego kernela (kiedyś pclinuxos tylko z jednym kernelem działał mi z kartą na atherosie).

Offline nowy mint linux ja

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
Odp: Ciągłe rozłączanie wi fi
« Odpowiedź #6 dnia: 2016-12-29, 21:44:13 »
Realtek z mojego doświadczenia ma sterowniki nadające się do pracy jak jest widoczny router i nie ma przeszkód.
1. Spróbuj korzystać z wifi blisko routera.
2. Sprawdź, który kanał w Twojej okolicy jest wolny(ma najmniej sieci) i ustaw w routerze na stałe.
Sprawdź spod nadużytkowninka roota u Ciebie pewnie sudo.
Cytuj
iwlist wlan0 scan
Jeżeli masz w systemie twór marki systemd to wlan0 może mieć inną nazwę
Cytuj
ifconfig
Poda Ci nazwę intefejsu wifi (wlan)
3. Tak jak podał użytkownik wyżej, spróbuj innego kernela (kiedyś pclinuxos tylko z jednym kernelem działał mi z kartą na atherosie).

nie ma w poblizu innych sieci wifi.
ifconfig
enp2s0    Link encap:Ethernet  HWaddr 30:8d:99:f4:c8:44 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:13139 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13139 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:1020631 (1.0 MB)  TX bytes:1020631 (1.0 MB)

wlp4s0    Link encap:Ethernet  HWaddr d8:5d:e2:95:2b:fb 
          inet addr:192.168.1.106  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:495510 errors:0 dropped:2035 overruns:0 frame:195967
          TX packets:275534 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:652781323 (652.7 MB)  TX bytes:30484297 (30.4 MB)
          Interrupt:16
Ten pierwszy kod nie wspiera skanowania, tak wyszło.
O co chodzi z tymi kernelami?

Offline Andrzej J

  • Users
  • Guru
  • *****
  • Wiadomości: 710
    • Zobacz profil
Odp: Ciągłe rozłączanie wi fi
« Odpowiedź #7 dnia: 2016-12-29, 23:42:38 »
Wg czego sugerujesz, że nie ma innych sieci?
Cytuj
iwlist wlp4s0 scan
Oczywiście jako root.
Co do kerneli.
Najprościej jako sudo otwórz synaptic
odświerz
wyszukaj kernel i zobacz jakie są proponowane kernele.
Poniżej
Cytuj
uname -a
albo powyżej wyświetlonego kernela.
I po prostu zainstaluj najpierw najnowszy proponowany przez system...jeżeli będzie źle ....poniżej wyświetlanego numeru przez komendę uname -a.

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2402
  • 1709
    • Zobacz profil
Odp: Ciągłe rozłączanie wi fi
« Odpowiedź #8 dnia: 2016-12-30, 07:32:12 »
Pozwolicie że się na chwilę tylko wtrącę.
1. Załatwcie najjpierw aktualizację kernela na spokojnie.
2.
Cytuj
sterownikow od strony producenta nie ma na linuxa.
Ale czasami są, tylko zazwyczaj ich się nie sciąga, bo odrazu masz w kernelu i zazwyczaj działają prawidłowo.
w przypadku Realteka także są ,  przykład:
http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false

3. Znalazłem cos takiego, może się przyda jeśli aktualizacja kernela nie pomoże
A)  https://sites.google.com/site/easylinuxtipsproject/reserve-7
Cytuj
Realtek RTL8723BE chipset
...
No need to install another driver then; in many cases, a rather simple hack of the settings of the current driver suffices.
...
Copy/paste the following line into the terminal:
sudo touch /etc/modprobe.d/rtl8723be.conf
...
Copy/paste the following line into that empty text file, which disables power management for the chipset:
options rtl8723be fwlps=0
d. Reboot your computer.

B) Podobne ustawienia są w tym poradniku
https://chirath02.wordpress.com/2016/05/12/installing-realtek-rtl8723be-driver-for-ubuntu-16-04/
echo "options rtl8723be ant_sel=2 fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf

4. Generalnie testować zawsze można, ale zawsze radziłbym zgłaszać problemy ze sterownikiem w odpowiednik miejscu,
aby naprawili i żeby przy następnej instalacji dystrybucji linuxa już wszystko działało.

- Sterownik kernela
https://bugzilla.kernel.org/

- Sterownik producenta Realtek
email lub dane  kontaktowe znajdziesz w plikach lub
http://www.realtek.com.tw/contact/contactView.aspx?Langid=1&PNid=1&PFid=1&Level=1&Conn=0

5. A co do numerków ... nie potrafie tutaj pomóc,  bo nie widzę sterownika o takim numerku
zgaduję że aktualny numer sterownika jest OK, ponieważ możliwe że najnowszy sterownik wspiera także starsze karty sieciowe,
 więc wszystko powinno działać.

6. Google translator do pomocy z językiem
https://translate.google.pl/


Edytytowane:
- usunełem link do kernela na githubie, bo tam nie można zgłaszać błędów dla tego projektu.
PS: Brak polskiej czcionki, nie jest to brak lenistwa, a jej brak w systemie i brak czasu na reczne poprawki.