Nowe posty

xx Touchpad po pewnym losowym czasie przestaje reagować (7)
Wczoraj o 13:28:28
xx badblocks nie sprawdza dalej. (3)
2019-04-23, 20:44:36
xx Automat/scrypt do uruchamiania bootowalnego USB (0)
2019-04-22, 22:15:41
xx Zdalne polaczenie z posrednikiem pod Ubuntu bez GUI (2)
2019-04-22, 20:59:31
xx Uprawnienia (1)
2019-04-22, 14:10:38
xx bład krytyczny na dysku, dysk jest w LVM (2)
2019-04-19, 06:38:20
xx Przekierowanie na bezpieczną stronę z SSL (1)
2019-04-16, 19:52:43
xx bootloader (4)
2019-04-13, 18:31:03
xx Ubuntu i Bluetooth (1)
2019-04-12, 10:12:18
clip Opera - odtwarzanie niektórych filmów nie działa (1)
2019-04-12, 00:41:50

Autor Wątek: postgresql --with-pdo-pgsql \\  (Przeczytany 6967 razy)

Offline

  • Users
  • Użytkownik
  • **
  • Wiadomości: 50
    • Zobacz profil
postgresql --with-pdo-pgsql \\
« dnia: 2012-04-04, 18:08:12 »
próbuje zakablować php 5.4 z --with-pdo-pgsql \\  samo mi wychodzi  tak     --with-pgsql \\ ale jak dodam  pierwszą  regułę  to wskakuje  mi  


checking for PDO includes... checking for PDO includes... /usr/local/directadmin/custombuild/php-5.4.0/ext
checking Oracle OCI support for PDO... no
checking for ODBC v3 support for PDO... no
checking for PostgreSQL support for PDO... yes
checking for pg_config... /usr/bin/pg_config
checking for openssl dependencies... no
checking for PQparameterStatus in -lpq... no
Unable to build the PDO PostgreSQL driver: libpq 7.4+ is required

*** There was an error while trying to configure php. Check the configure/ap2/configure.php5 file

jak wpisze tak to
# dpkg -S  /usr/bin/pg_config
libpq-dev: /usr/bin/pg_config





jeszcze to
d# dpkg --get-selections | grep postgresql*
libapq-postgresql1-dev            install
libapq-postgresql3.0            install
libghc6-haskelldb-hdbc-postgresql-dev      install
libghc6-hdbc-postgresql-dev         install
libghc6-hsql-postgresql-dev         install
libpostgresql-ocaml            install
libpostgresql-ocaml-dev            install
postgresql               install
postgresql-8.3               install
postgresql-8.3-slony1            install
postgresql-8.4               install
postgresql-8.4-slony1            install
postgresql-client            install
postgresql-client-8.3            install
postgresql-client-8.4            install
postgresql-client-common         install
postgresql-common            install
postgresql-contrib            install
postgresql-contrib-8.3            install
postgresql-contrib-8.4            install
postgresql-server-dev-8.3         install
postgresql-server-dev-8.4         install
postgresql-server-dev-all         install
serwer:/usr/local/directadmin/custombuild#

Offline Grzegorz Świtkowski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 516
    • Zobacz profil
postgresql --with-pdo-pgsql \\
« Odpowiedź #1 dnia: 2012-04-10, 11:38:34 »
Jak dla mnie to ewidentnie brak czegoś w stylu: libpq-devel w wymaganej wersji.
Zobacz co masz:
dpgk -l \\*libpq\\*

A jak nie masz to doinstaluj.