Nowe posty

xx W Grubie nie pokazuje ubuntu (0)
2020-09-18, 15:49:34
question Połączenie się z OEL 8 >> MS SQL (0)
2020-09-16, 12:05:25
xx PORADNIK ! [Poszukiwanie bledow] (2)
2020-09-15, 08:24:56
xx Po instalacji minta i tak startuje windows ... (8)
2020-09-13, 00:48:13
xx DHCP i Virtualbox (2)
2020-09-08, 20:56:37
xx Brak macierzy RAID w Ubuntu (3)
2020-09-08, 19:10:24
xx Edycja plików w lokalizacji /sys/class/net/eth0/statistics (1)
2020-09-04, 08:43:34
xx ikona uruchamiająca (chyba) skrypt w ubuntu 16 (4)
2020-09-02, 22:57:36
xx Postfix (2)
2020-09-01, 18:58:16
xx Nie mogę naprawić dzwięku w Ubuntu 18.04 LTS (15)
2020-08-31, 22:48:26

Autor Wątek: Apache tomcat5  (Przeczytany 5837 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 21
    • Zobacz profil
Apache tomcat5
« dnia: 2011-01-29, 15:42:36 »
Witam,


Aktualnie zainstalowałem sobie Apacha Tomcat 5 na systemie CentOS 5.
Wszystko było by dobrze gdyby nie fakt iż wewnątrz sieci lokalnej mogę się połączyć z 127.0.0.1:8080

Jednak wszystko się komplikuje gdy próbuję to zrobić z innego komputera znajdującego się poza moją siecią.
http://moj-adres.dyndns.org:8080

Ruter który obsługuje moją sieć i dostęp do internetu ma skonfigurowane przekierowywanie portów (Virtual serwer) na porcie 8080

Czy czy powieniennem coś jeszcze ustawić?
iptables sa wylączone.

Offline Tomasz Frydrych

  • Users
  • Guru
  • *****
  • Wiadomości: 529
    • Zobacz profil
Apache tomcat5
« Odpowiedź #1 dnia: 2011-01-29, 19:51:17 »
mam nadzieję że zdajesz sobie z tego sprawę że serwer powinien być ustawiony nie na localu (127.0.0.1) tylko na ip twojego komputera w sieci lokalnej.
Gdyby głupota była lżejsza od powietrza to unosilibyśmy się pod sufitem.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 21
    • Zobacz profil
Apache tomcat5
« Odpowiedź #2 dnia: 2011-01-30, 09:37:25 »
A jak to mogę ustawić?

Offline Tomasz Frydrych

  • Users
  • Guru
  • *****
  • Wiadomości: 529
    • Zobacz profil
Apache tomcat5
« Odpowiedź #3 dnia: 2011-01-30, 12:27:35 »
W sumie zawsze korzystałem z lighttpd (bo tam wszystko jest zrobione jak dla idioty i ma wszystkie potrzebne mi opcje), więc nie udzielę Ci pewnej odpowiedzi, co gdzie musisz skonfigurować. U mnie jak zainstalowałem Apache z czystej ciekawości, wszystko dobrze działało. Na początek sprawdź poleceniem ipconfig lub innym jakie jest ip twojego komputera w sieci lokalnej (chyba, że jest stałe i znasz je na pamięć ). Następnie uruchom przeglądarkę sprawdź czy po wpisaniu: http://ip_z_ifconfig:80 będzie działać. Jeśli tak to super. Jak nie to trzeba poczytać jak ustawić apache na konkretnym ip i porcie. Prawdopodobnie będzie się to ustawiało tam gdzie port(bo 8080 chyba nie ustalił się jako default i sam to zmieniłeś?). Tak jak mówiłem jeśli chodzi o apache to jestem laikiem. Prawdopodobnie musisz pozmieniać w: ports.conf lub httpd.conf, lub w katalogu sites-enabled.
Gdyby głupota była lżejsza od powietrza to unosilibyśmy się pod sufitem.

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2621
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • keybase.io/pkraszewski
Apache tomcat5
« Odpowiedź #4 dnia: 2011-01-30, 14:59:39 »
@Ksanderon: Apache Tomcat != Apache httpd

@blonek

1. Znajdź plik conf/server.xml
2. W pliku powinna być linijka zbliżona mniej-więcej do
minProcessors="5" maxProcessors="200" enableLookups="false"
redirectPort="8443" acceptCount="0" debug="0"
connectionTimeout="20000"
useURIValidationHack="false "disableUploadTimeout="true"
address="127.0.0.1" URIEncoding="utf-8" useBody
EncodingURI="false" />
3. Wywal z niej wpis address="cośtam"
4. Zapisz plik
5. Zresetuj TOMCATa
Po takiej konfiguracji Tomacat powinien słuchać na wszystkich adresach, nie tylko na localhost.
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 21
    • Zobacz profil
Apache tomcat5
« Odpowiedź #5 dnia: 2011-01-30, 21:58:09 »
W tym miejscu nie mam zadanego takiego  wpisu address.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 21
    • Zobacz profil
Apache tomcat5
« Odpowiedź #6 dnia: 2011-02-01, 11:26:24 »
Czy jest ktoś kto mógłby mi pomóc?

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 1
    • Zobacz profil
Apache tomcat5
« Odpowiedź #7 dnia: 2011-03-08, 18:51:06 »
W twoim przypadku nie bawiłbym się w żadne przekierowanie portów. Tutaj idealnie nadaje się reverse proxy, które rozwiąże od razu kilka rzeczy m.in. nie będziesz musiał wchodzić na stronę http://adres:port tylko http://adres pod drugie chyba lepiej jednak zostawić Tomcat-a w lokalnej sieci nie udostępniać go na wszystkich interfejsach. Jako reverse proxy polecam Ci nginx, który idealnie nadaje się do tego typu rozwiązań, tu masz przykładową konfigurację http://www.ulos.pl/linuxapp10.html
gdzie aplikacja też jest uruchomiona na 127.0.0.1:4200