Nowe posty

xx Problem ze sterownikami. (5)
Wczoraj o 21:25:16
xx Instalacja xfce4 (2)
Wczoraj o 16:20:17
xx Serie kompilacji bez instalacji dla “emerge” w Gentoo (2)
2024-04-08, 18:40:04
xx Plasma 6 w Neonie ssie trochę mniej ... (17)
2024-04-05, 10:03:46
xx Problem z Linux Lite po instalacji (3)
2024-04-03, 14:23:40
xx Jak właczyć num locka przy starcie systemu debian 12? (12)
2024-04-02, 17:43:54
xx Brak dźwieku w systemie. (5)
2024-04-02, 16:13:41
xx Dystrybucja pod HP Omen (7)
2024-03-29, 11:33:05
xx [Poradnik] Wyszukiwanie Sterowników (2)
2024-03-27, 21:08:23
xx Ile pingwinów? (1)
2024-03-27, 08:59:24

Autor Wątek: Czy Linux obsługuje tą kartę?  (Przeczytany 11622 razy)

khayyin

  • Gość
Czy Linux obsługuje tą kartę?
« dnia: 2010-08-18, 14:25:05 »
Chciałbym się dowiedzieć czy linux taki jak Backtrack i WIFIslax będzie współpracował z tą kartą: http://allegro.pl/show_item.php?item=1190497185 Jeżeli tak to w jakiej wersji Backtrack i WIFIslax będzie wszystko działało. A jeżeli te WIFI nie współpracuje z tymi linuxami to proszę polećcie mi jakąś tania kartę wifi na usb która będzie współpracowała z tymi Linuxami

Offline Robert

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2516
    • Zobacz profil
Zanim popełnisz grafomaństwo: 1 | 2 | 3
Baza RPM Jak szukać informacji

Offline Andrzej J

  • Users
  • Guru
  • *****
  • Wiadomości: 713
    • Zobacz profil
Czy Linux obsługuje tą kartę?
« Odpowiedź #2 dnia: 2010-08-18, 16:43:33 »
Z tego, co wiem to musisz mieć sterownik ar9271.fw i http://wireless.kernel.org/download/compat-wireless-2.6/compat-wireless-2010-08-17.tar.bz2 , a tu masz dokładnie opisane http://lost.one.pl/tag/driver/ .Warunkiem jest kernel 2.6.33.5 w pclinuxie nie działa zbyt dobrze-problemy z dźwiękiem i z sambą. W sidux-ie kernel 2.6.34.11 jest wszystko o.k. łącznie z sambą.Dobrze, w sidzie działał od kernela 2.6.34.1
- mam co prawda tp-link 722n, ale do tych kart jest wspólny sterownik. Pozdrawiam

flak

  • Gość
Czy Linux obsługuje tą kartę?
« Odpowiedź #3 dnia: 2010-08-18, 17:12:02 »
Cytat: Andrew_66
Z tego, co wiem to musisz mieć sterownik ar9271.fw
- mam co prawda tp-link 722n, ale do tych kart jest wspólny sterownik.
Nie jest to prawda.

Tę kartę obsługuje sterownik zd1211rw. http://www.linuxwireless.org/en/users/Drivers/zd1211rw i jest obecny w kernelu Linux od 2.6.18, po czym został przepisany od zera i włączony do kernela ponownie w 2.6.25.

Ta karta wymaga dodatkowego firmwaru, choć ten jest z reguły dostarczany przez samą dystrybucję.
Sprawdź czy w katalogu "/lib/firmware" jest katalog "zd1211" i czy nie jest pusty. Jeśli dostawca dystrybucji zaspał to firmware jest tu:

Brakujący firmware należy rzecz jasna rozpakować do katalogu "lib/firmware/zd1211" i tyle.

Offline Andrzej J

  • Users
  • Guru
  • *****
  • Wiadomości: 713
    • Zobacz profil
Czy Linux obsługuje tą kartę?
« Odpowiedź #4 dnia: 2010-08-18, 19:30:20 »
Tak jak wcześniej napisałem poradnik znalazłem do karty TP-Link WN422G pod w/w linkiem http://lost.one.pl/tag/driver/  Zresztą napisłem że mam inną i działa.

flak

  • Gość
Czy Linux obsługuje tą kartę?
« Odpowiedź #5 dnia: 2010-08-18, 20:58:23 »
Cytat: Andrew_66
Tak jak wcześniej napisałem poradnik znalazłem do karty TP-Link WN422G pod w/w linkiem http://lost.one.pl/tag/driver/  Zresztą napisłem że mam inną i działa.
Ale ja mówię o TP-Link WN422G v1 a Ty o TP-Link WN422G v2 :)

Porównaj:
http://www.linuxwireless.org/en/users/Drivers/zd1211rw/devices - v1
http://lost.one.pl/tag/driver/ - v2

Karty Atheros/Zydas mające tryb 802.11n draft są obsługiwane przez sterowniki otus/ar9170/carl9170 oraz ath9k_htc. Karty Atheros/Zydas bez obsługi 802.11n są obsługiwane przez sterownik zd1211rw/zd1211 (i stary zd1201). Ar5523 to trochę inna para kaloszy, nie jest powiązany z technologią Zydas.

TP-Link na aukcji jest produkcji Zydas, potwierdza to tekst podobnej aukcji:
http://allegro.pl/item1191598896_tp_link_tl_wn422g_karta_wifi_usb_ant_4dbi_wys24h.html
Karta działa tylko w trybie 802.11 b/g. To zd1211rw :)

http://www.linuxwireless.org/en/users/Drivers/Atheros

khayyin

  • Gość
Czy Linux obsługuje tą kartę?
« Odpowiedź #6 dnia: 2010-08-19, 08:17:31 »
Dziękuję wszystkim za odpowiedzi. Będę dzisiaj próbował licytować inną antenę opartą na chipsecie Ralink RT73 jak się nie uda to kupię to i myślę że dam radę coś z Wami wykombinować żeby działała ;)

Offline Andrzej J

  • Users
  • Guru
  • *****
  • Wiadomości: 713
    • Zobacz profil
Czy Linux obsługuje tą kartę?
« Odpowiedź #7 dnia: 2010-08-19, 12:47:11 »
Spokojnie możesz kupić tp-linka 422g, bo jak kolega Flak napisał do v1 nie będziesz miał problemów ze sterownikami zd1211rw/zd1211,a jakby okazało się,że karta ta to jednak v2 to będzie działać ze sterownikami ar9271 ze strony, którą wyżej podałem - warunek kernel.
Pozdrawiam

flak

  • Gość
Czy Linux obsługuje tą kartę?
« Odpowiedź #8 dnia: 2010-08-19, 14:18:20 »
UWAGA!!!

Właśnie sobie przypomniałem (skleroza nie boli), że parę miesięcy temu ktoś na forum narzekał, że zd1211rw nie działa packet-injection. Podobno trzeba nakładać łatki ale one nie specjalnie chcą działać. Powiem wprost nie wiem nie próbowałem. Nie wiem też czy to w ogóle prawda a jeśli tak to czy jeszcze aktualny problem. Jeśli chcesz się bawić aircrackiem to karta pod kontrolą zd1211rw może nie być najlepszym pomysłem.
 
Piszę nie żeby na koniec namieszać tylko żeby potem nie było "ups". Z drugiej strony jeśli nie masz ochoty na zabawę z aircrackiem to packet injection do niczego Ci się nie przyda.

Czy ktoś posiadający kartę na chipsecie Zydas na sterowniku zd1211rw mógłby sprawdzić czy działa wstrzykiwanie pakietów aireplay-ng? Byłbym bardzo wdzięczny Khayyin pewnie też.


[Edit:]
Tu jest powód moich wątpliwości:
http://forum.linux.pl/viewtopic.php?id=15761

pawtaj

  • Gość
Czy Linux obsługuje tą kartę?
« Odpowiedź #9 dnia: 2010-09-16, 21:32:23 »
karta wn422g dziala z >=2.6.35