Nowe posty

xx Touchpad po pewnym losowym czasie przestaje reagować (7)
Wczoraj o 13:28:28
xx badblocks nie sprawdza dalej. (3)
2019-04-23, 20:44:36
xx Automat/scrypt do uruchamiania bootowalnego USB (0)
2019-04-22, 22:15:41
xx Zdalne polaczenie z posrednikiem pod Ubuntu bez GUI (2)
2019-04-22, 20:59:31
xx Uprawnienia (1)
2019-04-22, 14:10:38
xx bład krytyczny na dysku, dysk jest w LVM (2)
2019-04-19, 06:38:20
xx Przekierowanie na bezpieczną stronę z SSL (1)
2019-04-16, 19:52:43
xx bootloader (4)
2019-04-13, 18:31:03
xx Ubuntu i Bluetooth (1)
2019-04-12, 10:12:18
clip Opera - odtwarzanie niektórych filmów nie działa (1)
2019-04-12, 00:41:50

Autor Wątek: nVidia 7174 + Kernel 2.6.11  (Przeczytany 4758 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
nVidia 7174 + Kernel 2.6.11
« dnia: 2005-05-27, 14:26:42 »
Zainstalowalem sterowniki bez najmnijeszych problemow, ale nie dziala Open GL.
Na przyklad gdy chce ruuchomic gre jakas to rozdzielczosc zmienia sie na 640x480 i psize \\'GLX failed\\'.
WIem, ze nalezy w pliki XF86Config zmienic \\'nv\\' na \\'nvidia\\', ale gdy to robie po kazdym restarcie systemu ponownie jest \\'nv\\' (oczywiscie zapisuje plik, jako root)
Nie pojawilo mi sie tez zadne logo nvidii.

Karta graficzna: GForce 2MX, os: mandrake 10.0, kernel: 2.6.8.1-12mdk.

Offline Tomcio Paluch

  • Users
  • Guru
  • *****
  • Wiadomości: 676
    • Zobacz profil
nVidia 7174 + Kernel 2.6.11
« Odpowiedź #1 dnia: 2005-05-27, 21:48:36 »
Sprawdz logi X\\'a, czy jako konfig faktycznie jest brany ten plik, w ktorym robisz zmiany. Od jakiegos juz czasu plikiem konfiguracyjnym X\\'ow jest plik xorg.conf, jezeli takowego nie ma brany jest ten, w ktorym ty robisz zmiany.

Najpierw sprawdz, ktory plik jest brany jako konfig.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
nVidia 7174 + Kernel 2.6.11
« Odpowiedź #2 dnia: 2005-05-27, 22:08:55 »
(==) Using config file: \\"/etc/X11/xorg.conf\\"

w tym pliku probowalem zrobic to, co powyzej - czyli zmienic \\'nv\\' na \\'nvidia\\'. Jak poprzednio, zmiany zostaja zapisane ale po ponownym uruchomieniu systemu, znika to co zedytowalem i powraca to \\'nv\\'.
Gdy robie to samo w failsafe i zrestartuje to jest ok, ale gdy uruchomie x\\'y to jest, tak jak pisze.

Offline Piotr Kiedrzyński

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 38
    • Zobacz profil
nVidia 7174 + Kernel 2.6.11
« Odpowiedź #3 dnia: 2005-05-28, 17:02:36 »
2005-05-27 14:26:42 Nargaroth napisał:

> Zainstalowalem sterowniki bez najmnijeszych problemow, ale nie dziala Open GL.
 > Na przyklad gdy chce ruuchomic gre jakas to rozdzielczosc zmienia sie na 640x480 i psize \\'GLX
 > failed\\'.
 > WIem, ze nalezy w pliki XF86Config zmienic \\'nv\\' na \\'nvidia\\', ale gdy to robie po kazdym
 > restarcie systemu ponownie jest \\'nv\\' (oczywiscie zapisuje plik, jako root)
 > Nie pojawilo mi sie tez zadne logo nvidii.
 >
 > Karta graficzna: GForce 2MX, os: mandrake 10.0, kernel: 2.6.8.1-12mdk.

W Mandrake\\'u oprócz modyfikacji /etc/X11/xorg.conf musisz jeszcze dopisać w /etc/modprobe.preload wpis nvidia; wtedy moduł nvidii będzie ładowany przy starcie systemu.
Pozdrawiam -
Piotr Kiedrzyński

Offline Michał K

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 18
    • Zobacz profil
nVidia 7174 + Kernel 2.6.11
« Odpowiedź #4 dnia: 2005-05-27, 13:31:30 »
Problem przedstawia się następująco:
Moduł kompiluje się i instaluje bez najmniejszych problemów. Również załadowanie odbywa się poprawnie, dmesg nie wypisuje niczego, co mogłoby wzbudzić jakiekolwiek podejrzenia.


Cały cyrk zaczyna się z momentem próby startu X-a.
Próba zainicjowania poprzez "startx" kończy się takowym przyjemnym komunikatem:

(EE) Screen(s) found, but none have a usable configuration.

I pod koniec dostaję podsumowanie że "no screen(s) found". Ok, no nic. Błędna konfiguracja X-a odpada, probowałem wielu możliwości. Próbowałem również z release 6.6 jak i 6.8.2.


Postanowiłem rozejrzeć się w /proc/driver/nvidia w poszukiwaniu przyczyn.
Bah, nie zawiodłem się, co sie okazało:

cat /proc/driver/nvidia/agp/status
Status:          Disabled

cat /proc/driver/nvidia/cards/0
Model:           GeForce4 MX 440
IRQ:             5
Video BIOS:      ??.??.??.??.??
Card Type:       AGP

Nie mam pytań odnośnie tego jest grane O_o. AGP jest wyłączone, a Video BIOS jest nieznany. Co ciekawsze, dmesg o niczym nie wspomina. AGPgart również siedzi cicho.


Sytuacja ma się podobnie z nieco wcześniejszą wersją 7167, natomiast 6629 (po zaaplikowaniu patcha dla serii 2.6) działa bez problemów.

Sporo się już naszukałem po necie czegoś na ten temat. Okazuje się, że albo komuś działa albo nie. Znalazłem kilka podobnych przypadków do mojego, ale żaden nie uzyskał odpowiedzi.

Gdyby ktoś mógł podzielić się jakimiś dobrymi grupami dyskusyjnymi byłby wdzięczny.

---
Posiadam: Slackware 9.0, Linux 2.6.11.10-ck, X relrease 6.7.0, Glibc 2.3.3

Offline Jacek

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
nVidia 7174 + Kernel 2.6.11
« Odpowiedź #5 dnia: 2005-06-15, 19:33:51 »
Mozesz odwiedzić forum nvidii http://www.nvnews.net/vbulletin/forumdisplay.php?s=d8dbbd762d58374bee85e67b1d89dd19&f=14

Ja obecnie mam zainstalowane 7174 karta riva tnt 2 i kernel 2.6.12-rc6-love1. Iksy ładnie chodzą, uptime po 10 godzin i ok.

Zródełka 2.6.11 kiedyś patchowałem nvidia_6111-6629_compat2.diff
i instalowałem spatchowany (nvidia_display_driver-1.0-6111.diff) driver nvidii 6111. I też działało ok.