Nowe posty

xx Przydatne Linki (4)
Dzisiaj o 14:13:00
xx Awstat (0)
Wczoraj o 14:55:15
xx SMB - Access denied z Windows (9)
2019-08-19, 11:27:24
xx Kali Linux - książka. (0)
2019-08-19, 00:20:25
xx Arch - startx dla uruchomienia GNOME powoduje wyłączenie komputera (6)
2019-08-18, 14:37:04
xx Nie moge urchmomic laptopa - grub rescue. (1)
2019-08-17, 18:24:00
xx Po aktualizacji zniknęły niektóre funkcje (45)
2019-08-14, 06:39:01
xx Operacje na bitach. (4)
2019-08-10, 21:44:36
xx Pblem z montowaniem dysku sieciowego (1)
2019-08-09, 23:36:45
xx [Promocja] Mój nowy kanał na YouTube o Linuksie po polsku. (0)
2019-08-07, 20:36:10

Autor Wątek: Dźwięk, ALSA i pewne problemy...  (Przeczytany 10331 razy)

Offline

  • Users
  • Użytkownik
  • **
  • Wiadomości: 57
    • Zobacz profil
Dźwięk, ALSA i pewne problemy...
« dnia: 2008-08-16, 21:45:23 »
Nie lubię zbędnego paplania także przedstawiam wam screeny:

1. Uruchamianie Gnome ALSA Mixer:
http://img299.imageshack.us/img299/6440/zrzutekranumd0.png

2. Próba odpalenia muzyki w odtwarzaczu:
http://img175.imageshack.us/img175/9429/zrzutekranu1fk5.png

-Dźwięk w grach został stwierdzony, aczkolwiek bardzo cichutki i z uchem przy glośniku ledwo słychać.

-Przed paroma dniami muzyka grała, a w Gnome ALSA Mixer widniały tylko dwa pierwsze "paski" (suwaki). Były to bodajże "master" i "CD". Nie wiem co się stało (lub co zrobiłem), że teraz nie gra.

-Dźwięk przy logowaniu użytkownika oraz wszystkie dźwięki systemowe także stwierdzono (ciche).

-Inne dystrybucje Linuxa nie miały z tym problemu, dlatego też założyłem topic właśnie w tym dziale.

Byłbym bardzo rad, gdyby ktoś poświęcił mi chwilę czasu i podpowiedział, co robić. Z góry dziękuję.

Offline arctgx

  • Users
  • Guru
  • *****
  • Wiadomości: 2753
    • Zobacz profil
Dźwięk, ALSA i pewne problemy...
« Odpowiedź #1 dnia: 2008-08-17, 00:21:06 »
Co pokazuje lsmod | grep snd?
Czy konsolowy alsamixer da się uruchomić (to tak na wszelki wypadek)?
Czy masz program aumix? To mikser dla OSS.

Czyżbyś czasem nie podmienił (o ile to możliwe) sterownika z Alsy na przestarzały z OSS? Wtedy alsamiksery i XMMS z ustawioną wtyczką Alsy nie chodziłyby, ale programy kierujące dźwięk do OSS (lub jego emulacji w Alsie) już tak. W szczególności, jeśli OSS teraz działa, to XMMS z wtyczką OSS pójdzie. Być może programy startowe też używają OSS.

Jeszcze jeden sposób: wklepać komunikaty w wyszukiwarkę i kopać w mnóstwie wątków na forach.

P.S. Informacji w okienkach jest (objętościowo) tak mało że uważam za zwykłe lenistwo, kiedy nie chce Ci się ich przepisać czy przekopiować, a my mamy ładować wielki obraz z małym napisem ;) Mało, nawet wykadrować w GIMPie czy czymkolwiek... Przeginka trochę moim zdaniem ;) Zawsze to jednak konkretny opis w odróżnieniu od samych ogólników i przynajmniej można o nim rozmawiać...
Użytkownik: Ib5sXfcCkvYR
Hasło: adam

Offline

  • Users
  • Użytkownik
  • **
  • Wiadomości: 57
    • Zobacz profil
Dźwięk, ALSA i pewne problemy...
« Odpowiedź #2 dnia: 2008-08-17, 23:51:02 »
1. Jestem mocno nieobyty i zdaję sobie sprawę jeśli narażam się na pośmiewisko, ale komendy "lsmod" i "grep snd" nie działają w konsoli (pierwsza: nie ma takiego polecenia, druga: żadnego komunikatu, nic się nie dzieję).

2. Konsolowy alsamixer się uruchamia, jest tylko wskaźnik "master" (ustawiony na max) i nic więcej.

3. Nie wiem co się stało, ale Gnome Alsa Mixer znów się uruchamia. Widnieją tam dwa suwaki: master i capture (nie CD, jak wcześniej pisałem). Ponadto, w polu "Card" jest napisane "PulseAudio", co mnie niepokoi bo wcześniej (na innych dystrybucjach) miałem normalnie podaną nazwę karty dźwiękowej. Nie wiem czy dobrze podejrzewam, że problem tkwi w sterownikach...

4. Ponadto, muzyka już gra jednak bardzo cichutko.

Także po tym wszystkim, moje pytanie teraz wygląda tak:
Jak zrobić, żeby w Gnome Alsa Mixer było więcej suwaków, dźwięk był głośniejszy oraz co z tym "PulseAudio"...?


PS: Co do tych screenów... Mój błąd, następnym razem będzie git. :)

Offline arctgx

  • Users
  • Guru
  • *****
  • Wiadomości: 2753
    • Zobacz profil
Dźwięk, ALSA i pewne problemy...
« Odpowiedź #3 dnia: 2008-08-18, 00:07:30 »
Cytat: viii
komendy "lsmod" i "grep snd" nie działają w konsoli (pierwsza: nie ma takiego polecenia, druga: żadnego komunikatu, nic się nie dzieję).
Być może uruchomiłeś ją jako zwykły użytkownik. To jedna komenda, choć będąca potokiem złożonym z dwóch - wyjście polecenia lsmod wpuszczasz do polecenia grep dla wyłapania linii zawierających łańcuch "snd", który jest kawałkiem nazw modułów Alsy. W niektórych dystrybucjach użycie lsmod jest ograniczane tylko dla specjalnych użytkowników jak choćby root.
Użytkownik: Ib5sXfcCkvYR
Hasło: adam

Offline

  • Users
  • Użytkownik
  • **
  • Wiadomości: 57
    • Zobacz profil
Dźwięk, ALSA i pewne problemy...
« Odpowiedź #4 dnia: 2008-08-18, 15:27:43 »
Na roocie to samo jest. :/

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 225
    • Zobacz profil
Dźwięk, ALSA i pewne problemy...
« Odpowiedź #5 dnia: 2008-08-18, 16:36:12 »
Po pierwsze - z
lsmod | grep snd
lub
dmesg | grep -E "snd|alsa"
(niech mnie tutaj ktoś poprawi bo mam przeczucie ( i to silne) że się mylę co do składni polecenia) - tutaj nie chodzi o to aby wykonywać to z KATALOGU "/root" (lub "/") tylko jako użytkownik /root (uzyskasz to logując się jako "root" na terminalu lub używając "su" na emulatorze terminala ("konsole" "xterm" albo coś z takich programików).

Po drugie o ile się nie mylę to u Ciebie pierwszy się odpala "PulseAudio" - to też serwer dźwięku tyle, że zajmuję sprzęt (kartę dźwiękową), a więc ALSA nie ma dostępu - tylko poprzez "PulseAudio", więc możliwości są ograniczone do tego co masz skonfigurowane w "PulseAudio" (skoro nie wiesz o jego istnieniu to podejżewam, że nie jest zbyt dobrze skonfigurowany - i tu leży problem, a nie w w tym że ALSA korzysta z karty dźwiękowej poprzez "PulseAudio").

Postaraj się zamieścić wynik polecenia
dmesg
lub
cat /var/log/dmesg
P.S. Jeżeli nie jesteś w ciemię bity, a przy okazji znam en (angielski) to może sam znajdziesz przyczynę, lub chociaż konkretne info poprzez
dmesg | more
A przy okazji - to nie ma żadnego związku z distro, oprócz tego, że akurat Fedora zawiera "PulseAudio" (debian też zawiera)

arctgx: parametr -E dla grepa dałem i wywaliłem spacje z szukanych łańcuchów

Offline arctgx

  • Users
  • Guru
  • *****
  • Wiadomości: 2753
    • Zobacz profil
Dźwięk, ALSA i pewne problemy...
« Odpowiedź #6 dnia: 2008-08-18, 17:15:21 »
Oki, poprawiłem: dla użycia alternatyw dajemy "grep -E" albo "egrep" jak kto woli. Orta zostawiłem. Zamiast "more" lepiej chyba przeglądarki "less" użyć - działa w obie strony.
Użytkownik: Ib5sXfcCkvYR
Hasło: adam