Nowe posty

Autor Wątek: lighttpd problem z przekazywaniem parametrów GET  (Przeczytany 6130 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 28
    • Zobacz profil
lighttpd problem z przekazywaniem parametrów GET
« dnia: 2008-04-21, 16:05:28 »
Witam wszystkich
Probuje ustawic sobie ten serwer www na moim domowym kompie i nie zabardzo wiem co jest nie tak. W konfiguracji wlaczylem mod_cgi,mod_status. Skrypty php dzialaja jednak Po wykonaniu polecenia echo $_GET['id']; nic nie otrzymuje.

Czy do przekazywania tych parametrów trzeba wlaczyc jeszcze jakis modul czy poprostu moj php zle dziala. Tak apropo moze ktos wie jak sprawdzic czy rzeczywiscie server przesyla te parametry. Za wszystkie do z gory dzieki

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 28
    • Zobacz profil
lighttpd problem z przekazywaniem parametrów GET
« Odpowiedź #1 dnia: 2008-04-21, 18:58:49 »
no kilku probach okazalo sie sie ze jednak php cos nie tak dziala poniewaz jak wysyalam do skryptu napisanego w perlu wszystko jest oki. Natomiast w php ma jakies klopoty heh tylko jakie :(

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 28
    • Zobacz profil
lighttpd problem z przekazywaniem parametrów GET
« Odpowiedź #2 dnia: 2008-04-21, 21:38:04 »
kurcze ja juz nie wiem co jest nie tak jak daje echo $_SERVER['QUERY_STRING'] wypisuje zmienne natomiast aby ja wyswietlic poprzez $_GET poprostu nic nie ma

Offline Norbert Kiszka

  • Users
  • Guru
  • *****
  • Wiadomości: 1846
    • Zobacz profil
lighttpd problem z przekazywaniem parametrów GET
« Odpowiedź #3 dnia: 2008-04-22, 02:22:11 »
Na twoim miejscu przyjrzałbym się plikowi php.ini (gdzie jest? phpinfo() prawdę Ci powie)

W PHP starszych niż 4.1 używało się $HTTP_GET_VARS (i m.in. $HTTP_POST_VARS) zamiast $_GET i z tego co pamiętam $_GET można "wyłączyć" w php.ini
"Ostrzeżenie menedżera okien: Okno 0x3e00019 (MPlayer) ustawia atrybut MWM, określający, że jego rozmiar okna jest niezmienny, lecz jednocześnie ustawia minimalny rozmiar na 1 x 1, a maksymalny rozmiar na 440 x 120. To nie ma żadnego sensu."

http://lottalinuxlinks.com/files/linux_mobile.jpg

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 28
    • Zobacz profil
lighttpd problem z przekazywaniem parametrów GET
« Odpowiedź #4 dnia: 2008-04-23, 09:20:13 »
no i doszedlem do rozwiazania - wlasnie phpinfo mi pomoglo. Okazalo ze mialem chyba zle skompilowane php tj. oryginalne z dystrybucji KateOS. Zwiasku z czym skompilowalem php i jako interpreter podalem php-cgi i teraz dziala prawidlowo.

Offline Norbert Kiszka

  • Users
  • Guru
  • *****
  • Wiadomości: 1846
    • Zobacz profil
lighttpd problem z przekazywaniem parametrów GET
« Odpowiedź #5 dnia: 2008-04-23, 11:37:24 »
sapi jest wydajniejsze...
"Ostrzeżenie menedżera okien: Okno 0x3e00019 (MPlayer) ustawia atrybut MWM, określający, że jego rozmiar okna jest niezmienny, lecz jednocześnie ustawia minimalny rozmiar na 1 x 1, a maksymalny rozmiar na 440 x 120. To nie ma żadnego sensu."

http://lottalinuxlinks.com/files/linux_mobile.jpg