Nowe posty

xx Migracja GRUB2 (0)
2019-08-24, 12:30:46
xx Przydatne Linki (4)
2019-08-23, 14:13:00
xx Awstat (0)
2019-08-22, 14:55:15
xx SMB - Access denied z Windows (9)
2019-08-19, 11:27:24
xx Kali Linux - książka. (0)
2019-08-19, 00:20:25
xx Arch - startx dla uruchomienia GNOME powoduje wyłączenie komputera (6)
2019-08-18, 14:37:04
xx Nie moge urchmomic laptopa - grub rescue. (1)
2019-08-17, 18:24:00
xx Po aktualizacji zniknęły niektóre funkcje (45)
2019-08-14, 06:39:01
xx Operacje na bitach. (4)
2019-08-10, 21:44:36
xx Pblem z montowaniem dysku sieciowego (1)
2019-08-09, 23:36:45

Autor Wątek: Valknut i problem z polaczeniem  (Przeczytany 3396 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 24
    • Zobacz profil
Valknut i problem z polaczeniem
« dnia: 2005-08-22, 11:27:53 »
Witam! Zgodnie z poprzednimi wskazówkami na forum zabrałem się za kompilację jądra. Postanowiłem skorzystać z poradnika znajdującego się na stronie PDDP. Pierwszy drobny problem pojawił się, kiedy przez apt-get nie potrafiłem zainstalować tk8.2, zamiast niego pobrałem libncurses5-dev. Wszystko ok. Jądro jest już w /usr/src, zrobiłem dowiązanie symbolicze do jądra (dowiązanie nazywa się linux, tak jak w poradniku). Więc w kosoli wpisuję make menuconfig (bedąc w /usr/src/linux)  i oto co pojawia się na konsoli:

HOSTCC  scripts/basic/fixdep
In file included from /usr/include/sys/socket.h:35,
                 from /usr/include/netinet/in.h:24,
                 from /usr/include/arpa/inet.h:23,
                 from scripts/basic/fixdep.c:115:
/usr/include/bits/socket.h:305:24: error: asm/socket.h: Nie ma takiego pliku ani katalogu
scripts/basic/fixdep.c: In function \\'parse_config_file\\':
scripts/basic/fixdep.c:245: warning: pointer targets in passing argument 1 of \\'use_config\\' differ in signedness
scripts/basic/fixdep.c: In function \\'parse_dep_file\\':
scripts/basic/fixdep.c:299: warning: pointer targets in passing argument 1 of \\'strchr\\' differ in signedness
scripts/basic/fixdep.c:299: warning: pointer targets in assignment differ in signedness
make[1]: *** [scripts/basic/fixdep] Błąd 1
make: *** [scripts_basic] Błąd 2
 W poradniku pisało, żeby w razie błędów jako zwykły użytkownik wpisać xhost +, ale dalej pojawia się ten sam komunikat. Świadomy tego, że nie pobrałem narzędzia tk8.2 (w poradniku autor pisze, że potrzebne jest tk8.2 lub ibncurses5-dev, ja mam to drugie), wpisałem make xconfig i te same komunikaty pojawiły się w konsoli...Z góry dziękuję za pomoc.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 11
    • Zobacz profil
Valknut i problem z polaczeniem
« Odpowiedź #1 dnia: 2005-08-22, 14:50:50 »
Witaj,
wez sprobuj uzyc tego poradnika
http://www.e-aiyama.com/~toshi/Computer/Linux/KernelCompile.html

i w punkcie 15 powina byc jeszcze ta linijka
np. mkinitrd -o /boot/initrd-2.6.8.1 /lib/modules/2.6.8.1
przynajmiej w debianie dla gruba to jest potrzebne nie wiem jak bedzie z Knoppixem

Offline Krzysztof Tulidowicz

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 446
    • Zobacz profil
Valknut i problem z polaczeniem
« Odpowiedź #2 dnia: 2005-08-22, 16:14:52 »
 > /usr/include/bits/socket.h:305:24: error: asm/socket.h: Nie ma takiego pliku ani katalogu

to jest kluczowa linijka - musisz znalezc paczkę która zawiera ten plik i ją zainstalować. najlepiej szukac paczek przez rpm.pbone.net - nawet jesli nie masz rpmowego distra, bo paczki zwykle sie nazywaja tak samo, a o nazwe paczki wszystko sie rozbija :P

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 12
    • Zobacz profil
Valknut i problem z polaczeniem
« Odpowiedź #3 dnia: 2005-08-22, 01:36:34 »
jest taki maly problem.. z dzialaniem valknuta... wbijam sie na hub`a i pobiera mi liste userow nastepnie wyrzuca msg :


!!

This hub is running version 0.7.14 of Open DC Hub.
[01:35:27] Error: 'Address already in use'
[01:35:27] Disconnected

!!

Mam wymagana liczbe slotow oraz share odpowiednio duzy.. i nie mam pojecia jak narazie co z tym zrobic ;] z gory dzieki za info

Offline Krzysztof Tulidowicz

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 446
    • Zobacz profil
Valknut i problem z polaczeniem
« Odpowiedź #4 dnia: 2005-08-22, 09:04:23 »
> [01:35:27] Error: 'Address already in use'
 > [01:35:27] Disconnected
 >
 > Mam wymagana liczbe slotow oraz share odpowiednio duzy.. i nie mam pojecia jak narazie co z tym
 > zrobic ;] z gory dzieki za info

zwroc uwage, ze on nie mowi o slotach, ani o share, tylko o adresie. czyli hub nie pozwala na wchodzenie kilku osob o tym samym adresie IP. pewnie masz internet przez LAN i ktos z tego LANa siedzi na tym hubie. mozesz sprowobac polaczyc sie przez jakies proxy, moze to cos da...

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 12
    • Zobacz profil
Valknut i problem z polaczeniem
« Odpowiedź #5 dnia: 2005-08-22, 09:44:34 »
2005-08-22 09:04:23 Stilgar napisał:

>
 >  > [01:35:27] Error: 'Address already in use'
 >  > [01:35:27] Disconnected
 >  >
 >  > Mam wymagana liczbe slotow oraz share odpowiednio duzy.. i nie mam pojecia jak narazie co
 > z tym
 >  > zrobic ;] z gory dzieki za info
 >
 > zwroc uwage, ze on nie mowi o slotach, ani o share, tylko o adresie. czyli hub nie pozwala na
 > wchodzenie kilku osob o tym samym adresie IP. pewnie masz internet przez LAN i ktos z tego LANa

no nieeestty alkazdy znasma zeewntrzne ip;] i wtymraczeej ni jest problem [-; a oslotach i sharezzaauwylem ;pprzez too nnnaatierzekam :)
 > siedzi na tym hubie. mozesz sprowobac polaczyc sie przez jakies proxy, moze to cos da...