Nowe posty

Autor Wątek: Nie działa HTTP poprawnie z DNS  (Przeczytany 325 razy)

Offline rafalkingpl

  • Nowy na forum
  • *
  • Wiadomości: 1
    • Zobacz profil
Nie działa HTTP poprawnie z DNS
« dnia: 2023-01-31, 20:26:41 »
Cześć,
mam taki problem:
Próbuje ustawić na opensusie 15.4 dns i http
wymyśliłem sobie domenę zakopane.local i teraz zrobiłem DNS dodałem strefę zakopane.local, nslookup dobrze mi ją rozwiązuje na adres serwera i teraz dziwna rzecz dodałem stronkę, która powinna się wczytywać na zakopane.local ale nie wczytuje się. Wczytuje się na adresie serwera po IP i co ciekawe wczytuje się na adresie w cname dałem przekierowanie z serwer.zakopane.local na zakopane.local i to działa. Więc nie kumam czemu nie działa na zakopane.local.

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2950
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
Odp: Nie działa HTTP poprawnie z DNS
« Odpowiedź #1 dnia: 2023-01-31, 22:25:37 »
Jak popatrzysz dokładnie na komunikat błędu, to przeglądarka próbuje wejść na www.zakopane.local.
Paweł Kraszewski
~Arch/Void/Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline marcin'82

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 399
    • Zobacz profil
Odp: Nie działa HTTP poprawnie z DNS
« Odpowiedź #2 dnia: 2023-02-01, 21:51:31 »
Prawdopodobnie jest konflikt <nazw> między protokołami i usługami DNS oraz mDNS. Domeny *.local są zarezerwowane dla protokołu mDNS dla sieci lokalnych.

W systemie prawdopodobnie działa albo NetworkManager albo systemd-resolved w trybie "resolver".

Do testów konfiguracji DNS wybierz inną nazwę domeny lokalnej.
marcin82