Nowe posty

xx Problem ze sterownikami. (2)
Wczoraj o 17:45:19
xx Serie kompilacji bez instalacji dla “emerge” w Gentoo (2)
2024-04-08, 18:40:04
xx Plasma 6 w Neonie ssie trochę mniej ... (17)
2024-04-05, 10:03:46
xx Problem z Linux Lite po instalacji (3)
2024-04-03, 14:23:40
xx Jak właczyć num locka przy starcie systemu debian 12? (12)
2024-04-02, 17:43:54
xx Brak dźwieku w systemie. (5)
2024-04-02, 16:13:41
xx Dystrybucja pod HP Omen (7)
2024-03-29, 11:33:05
xx [Poradnik] Wyszukiwanie Sterowników (2)
2024-03-27, 21:08:23
xx Ile pingwinów? (1)
2024-03-27, 08:59:24
xx problem z instalacja sterowników do karty sieciowej (3)
2024-03-18, 18:10:16

Autor Wątek: EPSON L3070 - Drukarka[OK] Skaner[?]  (Przeczytany 6194 razy)

Offline marcin'82

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 404
    • Zobacz profil
Odp: EPSON L3070 - Drukarka[OK] Skaner[?]
« Odpowiedź #15 dnia: 2020-03-20, 20:22:21 »
Robert
Cytuj
pojęcia nie mam,kiego grzyba szuka mi w systemie jakiegos uzyszkodnika o nazwie build.
A zwykłego rpm-u,jak nie było, tak nie ma.

Pliki wewnątrz pakietu źródłowego były utworzone z konta o nazwie build. Program rpmbuild ostrzega, że w obecnym systemie takiego użytkownika nie ma. Nie budujemy na koncie root.

Pewnie coś pominę, ale nie wnikam w całą politykę SUSE, itd. Minimalnie do budowania pakietów instalujemy:
zypper in rpm-build rpmdevtools

Tworzymy drzewo katalogów:
rpmdev-setuptree

Rozpakowujemy "instalujemy" pakiet źródłowy:
rpm -ivh /ścieżka/do/pakietu/nazwa.src.rpm

Budujemy pakiet (po przejściu do katalogu ~/rpmbuild/SPECS):
rpmbuild -ba --define "uversion 0.62.0" imagescan.spec

pavbaranov
Jak to jak? Tak samo - łopatą, ogniem i sedem :D
Dodać na końcu sekcji %prep:
%__sed -e 's|-Werror||g' -i %{_builddir}/%{upstream}-%{uversion}/configure.ac

Na początku sekcji %build - przed %configure dodać:
autoreconf -fiv

W sekcji %files w tym miejscu dodać %ghost:
%if "true" == "%{have_sane_dll_d}"
%ghost %{_sysconfdir}/sane.d/dll.d/%{name}
%endif

Zależność budowania jest zbyt ogólnie podana - trzeba kopać i zainstalować takie:
[root@suse ~]# rpm -qa \*boost*-devel --queryformat '%{name}\n'
libboost_headers-devel
libboost_chrono1_71_0-devel
libboost_thread-devel
libboost_headers1_71_0-devel
libboost_test1_71_0-devel
libboost_date_time1_71_0-devel
libboost_iostreams1_71_0-devel
libboost_program_options-devel
libboost_filesystem1_71_0-devel
libboost_test-devel
libboost_thread1_71_0-devel
libboost_system1_71_0-devel
boost-devel
libboost_program_options1_71_0-devel

Sprawdzone na OpenSUSE Tumbleweed 64bit przy użyciu najnowszej wersji pakietu, który podał Paweł Kraszewski:
http://support.epson.net/linux/src/scanner/imagescanv3/opensuse/imagescan-3.62.0-1epson4opensuse15.1.src.rpm .
« Ostatnia zmiana: 2020-03-20, 20:42:39 wysłana przez marcin'82 »
marcin82