Nowe posty

Autor Wątek: Arch - startx dla uruchomienia GNOME powoduje wyłączenie komputera  (Przeczytany 227 razy)

Offline wojo44

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 3
    • Zobacz profil
Cześć,

to jest moja pierwsza przygoda z Archiem, i być może problem jest trywialny, ale jest już 23:00, siedzę przy tym trzeci dzień i brakuje mi już siły.
Udało mi się zainstalować Archa, podzielić partycje, zainstalować i skonfigurować GRUBa, komputer łączy się z internetem przez wifi po zalogowaniu, ale wciąż mogę korzystać z systemu jedynie z poziomu wiersza poleceń.

zainstalowałem gnome
sudo pacman -S gnome gnome-extra
skonfigurowałem
~/.xinitrc
wpisując do pliku
exec gnome-session

no i przy uruchomieniu komendy
startx
system trochę pomyśli i się wyłącza. Jeśli użyję "systemctl enable gdm.service" to komputer będzie wyłączać się niedługo po uruchomieniu systemu.
Wiem, że to prawdopodobnie problem ze sterownikami, ale szukałem i szukałem i nie mogłem znaleźć rozwiązania...
Czy może ktoś wie jak rozwiązać problem, z którym się borykam?

Do instalacji sterowników użyłem
pacman -S xf86-video-intel intel-dri
Mój komputer:
MSI GP62 7RD Leopard
Intel Core i5-7300HQ
karta graficzna zintegrowana Intel + Nvidia Geforce GTX1050

Z góry dziękuję za pomoc
« Ostatnia zmiana: 2019-08-17, 23:17:41 wysłana przez wojo44 »

Offline Robert75

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 136
    • Zobacz profil
Odp: Arch - startx dla uruchomienia GNOME powoduje wyłączenie komputera
« Odpowiedź #1 dnia: 2019-08-18, 00:33:38 »
Jeżeli to Twój pierwszy kontakt z Arch-em, to może zacznij od jakiegoś graficznego instalatora, a nie od "czystego" Arch-a.
Osobiście polecam własnoręcznie sprawdzone Anarchy, ten instalator odwali za Ciebie czarną robotę.
https://anarchylinux.org/

Ps.
A czy wykonałeś komendę
systemctl start gdm.service
Co do Intel-a sam używam na Arch-u, zero problemów.
« Ostatnia zmiana: 2019-08-18, 00:54:59 wysłana przez Robert75 »
Arch Linux Xfce+compiz - 64Bit Linux User #621110https://www.anarchylinux.org/

Offline wojo44

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 3
    • Zobacz profil
Odp: Arch - startx dla uruchomienia GNOME powoduje wyłączenie komputera
« Odpowiedź #2 dnia: 2019-08-18, 00:59:25 »
Hej,
tak, użyłem systemctl start gdm.service, rezultat taki jak opisałem.
Szkoda jest mi zaczynać kolejny raz od nowa, bo wiem, że już sporo pracy za mną. Mam stabilne połączenie z internetem, skonfigurowanego gruba, dodanych użytkowników, tylko zainstalowane środowisko nie działa...

Offline pavbaranov

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 353
    • Zobacz profil
Odp: Arch - startx dla uruchomienia GNOME powoduje wyłączenie komputera
« Odpowiedź #3 dnia: 2019-08-18, 10:13:46 »
Zakładając, że wszystko wykonałeś prawidłowo - możesz pokazać dziennik z bootowania?

Offline wojo44

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 3
    • Zobacz profil
Odp: Arch - startx dla uruchomienia GNOME powoduje wyłączenie komputera
« Odpowiedź #4 dnia: 2019-08-18, 12:15:43 »
Raczej nie mam takiej możliwości :( z resztą świata komunikuję się poprzez MacBooka, Archa postawiłem na drugim laptopie i nie mogę na nim zrobić wiele więcej niż podłubać coś w konsoli...

Offline Robert75

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 136
    • Zobacz profil
Odp: Arch - startx dla uruchomienia GNOME powoduje wyłączenie komputera
« Odpowiedź #5 dnia: 2019-08-18, 13:00:27 »
Szkoda jest mi zaczynać kolejny raz od nowa, bo wiem, że już sporo pracy za mną. Mam stabilne połączenie z internetem, skonfigurowanego gruba, dodanych użytkowników, tylko zainstalowane środowisko nie działa...
Ale instalacja Arch-a przez Anarchy zajmuje góra 30 min.
A Ty już jak długo siedzisz nad skonfigurowaniem obecnie zainstalowanego?
Czyli wniosek jest prosty.
Arch Linux Xfce+compiz - 64Bit Linux User #621110https://www.anarchylinux.org/

Offline pavbaranov

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 353
    • Zobacz profil
Odp: Arch - startx dla uruchomienia GNOME powoduje wyłączenie komputera
« Odpowiedź #6 dnia: 2019-08-18, 14:37:04 »
@wujo44 - Znów - zakładając, że prawidłowo postawiłeś Archa, to masz na nim połęczenie z netem. Nawet w trybie "tekstowym". Zatem:
sudo pacman -Syu pastebinit
A potem już prosto:
journalctl -b -0 > log.txt && pastebinit log.txt
Potem podaj nam link.
Być może to jest też coś związane z błędami Xów, zatem również zawartość:
pastebinit /var/log/Xorg.0.log
i również link poprosimy. Niestety po samym opisie np.: "Jeśli użyję "systemctl enable gdm.service" to komputer będzie wyłączać się niedługo po uruchomieniu systemu." nic się nie dowiemy. To polecenie winno wyłącznie podlinkować gdm.service do usług systemd, które są uruchamiane weraz ze startem systemu. Nic więcej. Skąd zatem jakieś "wyłączanie się"?