Nowe posty

xx brak uprawnienia do zamontowanej partycji ntfs - elementaryOS 6,1 (5)
Dzisiaj o 06:36:07
xx Jak zainstalować sterowniki do karty sieciowej TP LINK WN350GD (1)
2022-08-04, 05:55:46
xx Poczta Linux.pl (8)
2022-08-02, 16:48:14
xx Ubuntu vs Fedora (1)
2022-07-26, 03:40:58
xx virtualization technology (1)
2022-07-25, 21:27:10
xx Migracja z centos 6 na centos 7 (3)
2022-07-25, 07:31:19
xx akonadi w KDE5 (10)
2022-07-22, 23:34:05
xx Alternatywa dla Delphi (7)
2022-07-22, 15:27:42
xx problem - znieksztłacenia dźwięku pod firefoxem na niektórych stronach www (2)
2022-07-19, 15:03:52
xx Jak podmienić sterownik sieciówki (7)
2022-07-18, 21:41:25

Autor Wątek: [solved]brak liblz4.so.1  (Przeczytany 1996 razy)

Offline Tomasz Rozalski

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 108
    • Zobacz profil
[solved]brak liblz4.so.1
« dnia: 2017-11-15, 20:47:44 »
Coś stukło, coś hukło i system padł. Odpaliłem z pendriva i naprawiłem fsck dysk systemowy. Pytał czy usuwać, dodawać do pliku lost i czy zmieniać liczbę powiązań i poprawiać. Tak, tak, tak, tak. System wstał ale nie działa np. synaptic bo brakuje liblz4.so.1. W ogóle to słabo bo:
Cytuj
vangoche@VanTv:~$ sudo synaptic
synaptic: error while loading shared libraries: liblz4.so.1: cannot open shared object file: No such file or directory
vangoche@VanTv:~$ sudo apt-get install aptitude
apt-get: error while loading shared libraries: liblz4.so.1: cannot open shared object file: No such file or directory
vangoche@VanTv:~$
Da się to załatać czy reinstall? Kopii nie mam.
« Ostatnia zmiana: 2017-11-19, 06:54:23 wysłana przez Tomasz Rozalski »

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2859
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
Odp: brak liblz4.so.1
« Odpowiedź #1 dnia: 2017-11-15, 22:56:48 »
Odpal jeszcze raz z pendrive'a, i skopiuj "na wydrę" to liblz4.so.1 .

Poprawność możesz sprawdzić robiąc chroot z pendrive'a do naprawianego systemu (wystarczy, że będziesz miał zamontowane /, /boot, /dev, /proc i /sys). Jak już poprawnie zainstalujesz aptitude'a, robisz z jego poziomu
aptitude reinstall '~i'
i powinien wszystko naprawić.
Paweł Kraszewski
~Arch/Void/Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline Tomasz Rozalski

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 108
    • Zobacz profil
Odp: [solved]brak liblz4.so.1
« Odpowiedź #2 dnia: 2017-11-19, 06:57:15 »
Po aptitude reinstall, które trwało jakieś ćwierć sekundy wywaliło komunikat, że nie może utworzyć list do pobrania czegoś tam. System jednak działa w pełni. Zamykamy.