Nowe posty

xx Debian 9 Stretch, linuxcnc i restart przy uruchamianiu (2)
2019-10-19, 21:54:36
xx Zakup sprzętu bez preinstalowanego windowsa (8)
2019-10-17, 16:50:51
xx Problem z pocztą Dovecot+Postfix+MySQL (3)
2019-10-16, 14:43:41
xx Instalacja Debian10 problem z instalacją GRUBa na RAID5 (5)
2019-10-15, 17:58:57
xx AMD Ryzen 5 3500U (11)
2019-10-14, 18:29:46
xx Konfiguracja directadmina (0)
2019-10-13, 03:18:36
xx Problem z instalacją sterowników TL-WN821N (4)
2019-10-11, 23:15:00
xx Sprzet z Linuxem (1)
2019-10-11, 10:06:24
xx nadpisanie partycji domowej (6)
2019-10-03, 03:27:28
xx Screen flickering Deepin (4)
2019-10-02, 20:32:56

Autor Wątek: Nie mogę zamontować mp3 player  (Przeczytany 2641 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 40
    • Zobacz profil
Nie mogę zamontować mp3 player
« dnia: 2015-02-19, 18:57:46 »
Witam wszystkich serdecznie.

Uzywam Debian Jessie.
Po włożeniu mp3 player system widzi go w nautilus ale nie monutje.
Chcę go zamontować aby posortować katalog za pomocą fatsort.

Po wykonaniu lsusb dostaję:
root@dell:/media# lsusb
Bus 002 Device 003: ID 0cf3:e004 Atheros Communications, Inc.
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 0c45:648b Microdia Integrated Webcam
Bus 001 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 003: ID 138a:0011 Validity Sensors, Inc. VFS5011 Fingerprint Reader
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 006: ID 054c:03d8 Sony Corp.
Bus 003 Device 002: ID 046d:c52f Logitech, Inc. Unifying Receiver
Bus 003 Device 005: ID 046d:c30e Logitech, Inc. UltraX Keyboard (Y-BL49)
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
A więc widzi mój mp3player sony :)

Z kolei polecenie mount zwraca:
root@dell:~# mount
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,relatime,size=10240k,nr_inodes=1006357,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,relatime,size=1613616k,mode=755)
/dev/sda1 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=22,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
mqueue on /dev/mqueue type mqueue (rw,relatime)
/dev/sda6 on /u1 type ext4 (rw,relatime,data=ordered)
/dev/sda7 on /u2 type ext4 (rw,relatime,data=ordered)
rpc_pipefs on /run/rpc_pipefs type rpc_pipefs (rw,relatime)
tmpfs on /run/user/117 type tmpfs (rw,nosuid,nodev,relatime,size=806808k,mode=700,uid=117,gid=124)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=806808k,mode=700,uid=1000,gid=1000)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
i tu nie ma.
Polecenie: ls /dev zwraca
root@dell:~# ls /dev
autofs       core fb1  hpet mapper    null    rtc0  shm    tty1   tty18  tty26  tty34 tty42  tty50  tty59  ttyS0    vboxdrv  vcs5 vcsa6      xconsole
block       cpu fd  hugepages mcelog    port    sda   snapshot  tty10  tty19  tty27  tty35 tty43  tty51  tty6   ttyS1    vboxdrvu  vcs6 vcsa7      zero
bsg       cpu_dma_latency freefall  initctl media0    ppp     sda1  snd    tty11  tty2   tty28  tty36 tty44  tty52  tty60  ttyS2    vboxnetctl  vcs7 vfio
btrfs-control  cuse full  input mei    psaux   sda2  sr0    tty12  tty20  tty29  tty37 tty45  tty53  tty61  ttyS3    vboxusb  vcsa vga_arbiter
bus       disk fuse  kmsg mem    ptmx    sda5  stderr    tty13  tty21  tty3 tty38 tty46  tty54  tty62  uhid     vcs  vcsa1  vhci
cdrom       dri hidraw0   kvm mqueue    pts     sda6  stdin     tty14  tty22  tty30  tty39 tty47  tty55  tty63  uinput   vcs1  vcsa2  vhost-net
cdrw       dvd hidraw1   libmtp-1-1 net    random  sda7  stdout    tty15  tty23  tty31  tty4 tty48  tty56  tty7   urandom  vcs2  vcsa3  video0
char       dvdrw hidraw2   log network_latency     rfkill  sg0   tty    tty16  tty24  tty32  tty40 tty49  tty57  tty8   usb      vcs3  vcsa4  watchdog
console        fb0 hidraw3   loop-control network_throughput  rtc     sg1   tty0    tty17  tty25  tty33  tty41 tty5   tty58  tty9   v4l      vcs4  vcsa5  watchdog0
Po wykonaniu polecenia dmesg dostaję (wkleiłem tylko końcówkę gdzie pojawia się mój mp3 player):
root@dell:~# dmesg
................
................
................
[   21.312660] wlan0: Limiting TX power to 20 (20 - 0) dBm as advertised by 00:1c:c5:d8:0b:6e
[  175.581164] usb 1-1: new high-speed USB device number 4 using xhci_hcd
[  175.709925] usb 1-1: New USB device found, idVendor=054c, idProduct=03d8
[  175.709928] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=8
[  175.709929] usb 1-1: Product: WALKMAN
[  175.709931] usb 1-1: Manufacturer: SONY
[  175.709932] usb 1-1: SerialNumber: 0E496931090005
[  175.801309] usbcore: registered new interface driver usb-storage
Tutaj też jest mój walkman sony mp3 player.
I jeszcze jedno. Nie wiem czy to może mieć jakiekolwiek znaczenie ale wykonanie polecenia wodim --devices daje:
root@dell:~# wodim --devices
wodim: No such file or directory.
Cannot open SCSI driver!
For possible targets try 'wodim --devices' or 'wodim -scanbus'.
For possible transport specifiers try 'wodim dev=help'.
For IDE/ATAPI devices configuration, see the file README.ATAPI.setup from
the wodim documentation.
Nie mam więcej pomysłu co zrobić.
Ciekawe jest to, że dawniej w debian stable Wheezy był montowany ten sam mp3player.

UPDATE:
własnie odkryłem, że próbuje system załadować go jako mtp (wcześniej jak miałem wheezy to nie ładował go jako mtp tylko normalnie w /media).
Po użyciu jmtpfs mogę go zamontować.
Ale wciąż pozostaje problem nie posortowanych plików, który wczesniej rozwiązywałem za pomocą programu fatsort.

Gdy użyję fatsort na zamontowanym katalogu z urzadzeniem mtp dostaję
robert@dell:~$ jmtpfs /home/robert/mtp
Unable to open ~/.mtpz-data for reading, MTPZ disabled.
Device 0 (VID=054c and PID=03d8) is a Sony NWZ-B142F.
robert@dell:~$ fatsort /home/robert/mtp/
FATSort Utility 0.9.15 by Boris Leidner

sort_fs: Jest katalogiem!
main: Failed to sort file system!
Ktoś ma jakiś pomysł jak posortować pliki w mp3playerze który system widzi jako mtp? Będę wdzięczny.

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2515
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • keybase.io/pkraszewski
Nie mogę zamontować mp3 player
« Odpowiedź #1 dnia: 2015-02-20, 10:04:32 »
Fatsort używasz na partycji/urządzeniu, nie na katalogu. Nie musisz jej nawet montować (wręcz nie możesz...)

Co do WODIM-a - kiedyś się nazywał CDRECORD i jak się domyśliłeś, ma niewiele wspólnego z odtwarzaczem MP3.
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 40
    • Zobacz profil
Nie mogę zamontować mp3 player
« Odpowiedź #2 dnia: 2015-02-20, 17:36:35 »
Cytat: pkraszewski
Fatsort używasz na partycji/urządzeniu, nie na katalogu. Nie musisz jej nawet montować (wręcz nie możesz...)
Dzięki za odpowedź.
Zgadza się.
Tylko tak jak wyżej dałem wynik polecenia "ls /dev" gdzie nie ma mojego mp3 playera jako urzadzenie. Wogóle ciekawe. Nie ma go jako urządzenie a mogę przez jmtpfs zamontować. Jak wtedy użyć fatsort?