Nowe posty

Autor Wątek: pytanko  (Przeczytany 7367 razy)

Offline Dominik Przyborowski

  • Users
  • Guru
  • *****
  • Wiadomości: 747
    • Zobacz profil
pytanko
« dnia: 2005-09-22, 12:26:11 »
Witam.

Zainstalowałem tą drukarke pod CUPS\\'em uzywając sterowników z www.linuxprinting.org, wszystko przebiegło ślicznie, ale nie wydrukowało strony testowej. Zainstalowałem ją następnie na sterownikach dostarczonych z pakietem Foomatic i znowu nic. Szukając dalej, zauważyłem że nie drukuje również pod LPR i Printtool\\'em, ale co najgorsze nie drukowała nawet po przekierowaniu tekstu na /dev/lp0 ani /dev/parport0. Dodam, że zarówno przy instalacji jak i przy starcie system ją wykrywa. Dodatkowo zauważyłem, iż przy instalacji za pomocą menadżera drukowania w KDE przy wyborze portu drukarki mam:

równoległy
      |-Równoległy -> Parralel port #1 -> Okidata Okipage 6w - adres: parport:/dev/lp0
(... usb i szeregowy są puste..)
Inni (dokładnie nie pamiętam jak to wygląda - pisze z innego kompa, ale podam jak wyglądają adresy)
  |-   adres: cannon:/dev/lp0
  |-   adres: epson:/dev/lp0

Czy możliwe jest, że to wykrywane nieznane cóś na \\"innych portach\\" może blokować przesył danych do drukarki? Jesli tak co może byc za to odpowiedzialne?
Po drugie. Nie odnalazłem pliku /etc/printcap i czy jest on zbędny lub niezbedny dla CUPS?

Dodam, iż sprawdziłem: kabel i port.
Systemem jest Debian Sarge.

Pozdrawiam
Dominik

Offline Szymek W

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 350
    • Zobacz profil
pytanko
« Odpowiedź #1 dnia: 2005-09-22, 12:33:26 »
2005-09-22 12:26:11 Lorenzo napisał:

> Witam.
 >
 > Zainstalowałem tą drukarke pod CUPS\\'em uzywając sterowników z www.linuxprinting.org, wszystko
 > przebiegło ślicznie, ale nie wydrukowało strony testowej. Zainstalowałem ją następnie na
 > sterownikach dostarczonych z pakietem Foomatic i znowu nic. Szukając dalej, zauważyłem że nie
 > drukuje również pod LPR i Printtool\\'em, ale co najgorsze nie drukowała nawet po przekierowaniu
 > tekstu na /dev/lp0 ani /dev/parport0. Dodam, że zarówno przy instalacji jak i przy starcie
 > system ją wykrywa. Dodatkowo zauważyłem, iż przy instalacji za pomocą menadżera drukowania w
 > KDE przy wyborze portu drukarki mam:
 >
 > równoległy
 >       |-Równoległy -> Parralel port #1 -> Okidata Okipage 6w - adres: parport:/dev/lp0
 > (... usb i szeregowy są puste..)
 > Inni (dokładnie nie pamiętam jak to wygląda - pisze z innego kompa, ale podam jak wyglądają
 > adresy)
 >   |-   adres: cannon:/dev/lp0
 >   |-   adres: epson:/dev/lp0
 >
 > Czy możliwe jest, że to wykrywane nieznane cóś na \\"innych portach\\" może blokować
 > przesył danych do drukarki? Jesli tak co może byc za to odpowiedzialne?
 > Po drugie. Nie odnalazłem pliku /etc/printcap i czy jest on zbędny lub niezbedny dla CUPS?
 >
 > Dodam, iż sprawdziłem: kabel i port.
 > Systemem jest Debian Sarge.
 >
 > Pozdrawiam
 > Dominik

Probowałeś drukować z konsoli
lpr plik.txt?

PZDR

Debian Users Gang

Offline Dominik Przyborowski

  • Users
  • Guru
  • *****
  • Wiadomości: 747
    • Zobacz profil
pytanko
« Odpowiedź #2 dnia: 2005-09-22, 12:39:35 »
2005-09-22 12:33:26 Zbooj napisał:

 > Probowałeś drukować z konsoli
 > lpr plik.txt?
 >
 > PZDR
 >
 > Debian Users Gang

W konsoli drukowałem poprzez potok, np:
cat plik.txt > /dev/lp0 (tak drukowałem kiedyś na starej seikoshy)
ale drukarka nie reagowała.



Offline Grzegorz L

  • Users
  • Guru
  • *****
  • Wiadomości: 594
    • Zobacz profil
pytanko
« Odpowiedź #3 dnia: 2005-09-22, 13:07:10 »
Witam,
ja mam tez drukarke OKI z tym ze nie 6W tylko 4W i po wielu \\"bojach\\" udalo mi sie ja zmusisc do pracy. Pierwsza czynnosc jaka nalezy robic to ustaw w biosie port LPT na SPP bo na ECP nie zabardzo chca te drukarki drukowac (tak jest z moja).
Jak bede w domu (czyli wieczorem) to podam ci moja konfiguracje.


Offline Dominik Przyborowski

  • Users
  • Guru
  • *****
  • Wiadomości: 747
    • Zobacz profil
pytanko
« Odpowiedź #4 dnia: 2005-09-22, 13:13:59 »
2005-09-22 13:07:10 greg000 napisał:

> Witam,
 > ja mam tez drukarke OKI z tym ze nie 6W tylko 4W i po wielu \\"bojach\\" udalo mi sie ja
 > zmusisc do pracy. Pierwsza czynnosc jaka nalezy robic to ustaw w biosie port LPT na SPP bo na
 > ECP nie zabardzo chca te drukarki drukowac (tak jest z moja).
 > Jak bede w domu (czyli wieczorem) to podam ci moja konfiguracje.
 >
Nie sprawdzałem na innym ustawieniu LPT\\'a niż ECP+EPP 1.9
Jak będe miał dostep do tego sprzęta (cały problem jest u kumpla ulice dalej) to sprawdze.

Dzieki za sugestie.

Pozdrawiam

Offline Grzegorz L

  • Users
  • Guru
  • *****
  • Wiadomości: 594
    • Zobacz profil
pytanko
« Odpowiedź #5 dnia: 2005-09-22, 16:34:13 »
Jezeli chodzi o konfiguracje drukarki to tak:

1. Port w bisoie na SPP (na EPP nie pamietam czy dziala)
2. Sterownik z linuxprinting.org
    \\"Okidata-Okipage_8w-oki4w (nie pomyl z oki4drv bo to cos innego)
link: http://www.linuxprinting.org/ppd-o-matic.cgi?driver=oki4w&printer=Okidata-Okipage_8w&show=0
3. Port LPT URI: parallel:/dev/lp0
4. System druku: CUPS (common unix printer system)

Jezeli uzywasz KDE to mozna to wszystko tam ustawic i zadnych plikow wiecej nie trzeba bylo u mnie edytowac, ale zaznaczam ze nie mam debiana :) Ustawialem to u siebuie na gentoo i wszytko smiga. Nie jest idealnie ale da sie przezyc szczegolnie ze to drukarka GDI.

Trzymam kciuki ;)

Offline Grzegorz L

  • Users
  • Guru
  • *****
  • Wiadomości: 594
    • Zobacz profil
pytanko
« Odpowiedź #6 dnia: 2005-09-22, 16:36:57 »

Offline Dominik Przyborowski

  • Users
  • Guru
  • *****
  • Wiadomości: 747
    • Zobacz profil
pytanko
« Odpowiedź #7 dnia: 2005-09-22, 20:31:39 »
2005-09-22 16:34:13 greg000 napisał:

> Jezeli chodzi o konfiguracje drukarki to tak:
 >
 > 1. Port w bisoie na SPP (na EPP nie pamietam czy dziala)
 
Właśnie to ją gryzło. Wielka dziekówka!

Pozdrawiam

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
pytanko
« Odpowiedź #8 dnia: 2005-09-21, 20:52:53 »
witam jestem barrrdzo poczatkujaca jezeli chodzzi o linux
niedawno zainstalowałam susła
i mam pytanie czy istnieje możliwość instalacji oprogramowania graficznego (tak zeby działało;) adobe macromedia itp czy tylko moge kozystac z linuxowego ?

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 165
    • Zobacz profil
pytanko
« Odpowiedź #9 dnia: 2005-09-21, 21:10:16 »
2005-09-21 20:52:53 amia00 napisał:

> witam jestem barrrdzo poczatkujaca jezeli chodzzi o linux
 > niedawno zainstalowałam susła
 > i mam pytanie czy istnieje możliwość instalacji oprogramowania graficznego (tak zeby działało;)
 > adobe macromedia itp czy tylko moge kozystac z linuxowego ?
 >

istnieje mozliwosc instalacji i używania programow windows'owych pod linuchem korzystajac na przyklad z Wine
http://www.winehq.com

Offline Szymek W

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 350
    • Zobacz profil
pytanko
« Odpowiedź #10 dnia: 2005-09-22, 08:17:50 »
2005-09-21 21:10:16 localghost napisał:

> 2005-09-21 20:52:53 amia00 napisał:
 >
 > > witam jestem barrrdzo poczatkujaca jezeli chodzzi o linux
 >  > niedawno zainstalowałam susła
 >  > i mam pytanie czy istnieje możliwość instalacji oprogramowania graficznego (tak zeby
 > działało;)
 >  > adobe macromedia itp czy tylko moge kozystac z linuxowego ?
 >  >
 >
 > istnieje mozliwosc instalacji i używania programow windows'owych pod linuchem korzystajac na
 > przyklad z Wine
 > http://www.winehq.com

Jest jeszcze kilka programów umożliwiających korzystanie z aplikacji winzgrozy. Ale wiekszość to komercyjne produkty. Warto równiez sprawdzić WineX