Nowe posty

xx Jak usunąć kilka dowiązań twardych jednym poleceniem. (3)
2019-06-14, 12:12:10
xx Skrypt sprawdzający miejsce na dysku (1)
2019-06-13, 13:55:00
xx Samba server (3)
2019-06-10, 17:01:44
xx Skrypt tworzący użytkownika (3)
2019-06-07, 17:11:55
xx Jaki serwis komp. we Wrocławiu (0)
2019-06-06, 12:39:23
xx serwer wydruku (1)
2019-06-04, 13:57:58
xx mod_security i roundcube (0)
2019-05-27, 14:27:03
xx Touchpad po pewnym losowym czasie przestaje reagować (33)
2019-05-27, 10:14:21
xx [ROZWIĄZANY] przygotowanie zeskanowanego pdf do OCR (6)
2019-05-24, 14:46:43
xx Przydatne Linki (1)
2019-05-23, 18:05:04

Pokaż wiadomości

Ta sekcja pozwala Ci zobaczyć wszystkie wiadomości wysłane przez tego użytkownika. Zwróć uwagę, że możesz widzieć tylko wiadomości wysłane w działach do których masz aktualnie dostęp.


Wiadomości - Jacek

Strony: [1] 2
1
Bash, skrypty powłoki / Cat pliki |grep i wskazanie pliku
« dnia: 2014-11-22, 20:16:22 »
Dziękuję.

2
Bash, skrypty powłoki / Cat pliki |grep i wskazanie pliku
« dnia: 2014-11-22, 17:28:42 »
Cześć

Przeszukuje sobie logi poleceniem:
cat 2014-10-* |grep "szukany tekst" |more

Ładnie pokazuje, jednak zależy mi żeby oprócz wyniku pokazywało gdzie poszukiwany fragment tekstu siedzi, tzn. niech wyświetli konkretną nazwą pliku np.:
2014-10-21

Jak to zrobić?

3
Konfiguracja / jak bezpiecznie odpalić kadu z konta roota?
« dnia: 2007-02-09, 14:22:29 »
2007-02-08 23:56:51 ^robert^ napisał:

> Cześć!
 >
 > Pytanie tak jak w temacie.
 >
 > pozdr.

Na forum kadu jak byk jest przyklejony temat o następującej treści: Dlaczego nie uruchamiać Kadu spod roota?

http://www.kadu.net/forum/viewtopic.php?t=5130

Dostęp do iksów możesz dać użytkownikowi poleceniem xhost

4
Konfiguracja / Ograniczenia Użytkownika
« dnia: 2007-02-09, 14:30:18 »
Uprawnienia możesz ustawić zarówno dla właściciela, grupy i wszystkich. Możesz wykorzystać grupy, usuwając z nich danego użytkownika któremu chcesz ograniczyć dostęp lub stworzyć nowe bez jego udziału. Sposobów jest wiele.

5
Konfiguracja / 2.4.34-lck1 problem z kompilacją
« dnia: 2007-02-04, 17:49:06 »
2007-02-02 13:39:57 andrewgatt napisał:

 > Hi,
 >
 > Sorry i realise this isn't an english forum, but your question is the only result from google.
 > I'm having the same error with i387.c when trying to compile 2.4.34 with the low-latency patch
 > could you repeat the solution in english for me?
 >
 > My apologies again.
 >
 > Andrew

Look at the 78 line in the file /usr/src/linux-2.4.34-lck1/arch/i386/kernel/i387.c
There is wrote: "/* AMD CPUs leak F?P. Clear it here */". So I cleared line 79 and next I compiled successful the kernel.

6
Konfiguracja / 2.4.34-lck1 problem z kompilacją
« dnia: 2007-01-28, 19:35:34 »
2007-01-28 19:29:55 Lorenzo napisał:

> Jeżeli kernel działa to prawidłowo. W źródłach można znaleźć różne kwiatki ;-)
 >
 > P.S. K6-2 rulez :D

:)

azirek@hermes$uname -a
Linux hermes 2.4.34-lck1 #3 nie sty 28 17:01:08 CET 2007 i586 k6-2 i386 GNU/Linux
azirek@hermes$cat /proc/sys/kernel/lowlatency
1

7
Konfiguracja / 2.4.34-lck1 problem z kompilacją
« dnia: 2007-01-28, 17:11:00 »
2007-01-28 16:59:33 Lorenzo napisał:

 > A bez patcha się kompiluje?
 > Jeszcze jedno pytanko - nie grzebałes w Makefile'u lub w zmiennych środowiskowych przy flagach
 > kompilatora?

Nie grzebałem w Makefile i nie zmieniałem flag. Nie próbowałem kompilować wyniliowego jaja. Nawet jeśli się da to zależy mi tylko żeby było z tym patchem.
Znalazłem coś ciekawego. W pliku i386.c w wierszu 78 jest napisane:
/* AMD CPUs leak F?P. Clear it here */

Posiadam procesor AMD K6-2 więc usunąłem cały następny 79 wiersz, który zawierał:
asm volatile("ffree %%st(7) ; fildl %0" ::asm volatile("ffree %%st(7) ; fildl %0" :: "m" (kstat.context_swtch)); "m" (kstat.context_swtch));

I dalsza kompilacja powiodła się. Zastanawiam się tylko czy to było prawidłowe z mojej strony.

8
Konfiguracja / 2.4.34-lck1 problem z kompilacją
« dnia: 2007-01-28, 16:42:43 »
Ściągnąłem sobie waniliowe jajko 2.4.34 i nałożyłem patcha 2.4.34-lck1.bz2. Użyłem podobnej konfiguracji z poprzedniej wersji (2.4.31-lck1), z którą nie miałem żadnych problemów. Wykonałem wszystko jak należy make dep i przy próbie kompilacji make bzImage zgłasza błąd:

make[1]: Entering directory `/usr/src/linux-2.4.34-lck1/arch/i386/kernel'
gcc -D__KERNEL__ -I/usr/src/linux-2.4.34-lck1/include -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fno-builtin-sprintf -fomit-frame-pointer  -pipe -mpreferred-stack-boundary=2 -march=k6 -fno-unit-at-a-time   -nostdinc -iwithprefix include -DKBUILD_BASENAME=i387  -c -o i387.o i387.c
i387.c: In function `__save_init_fpu':
i387.c:80: error: structure has no member named `context_swtch'
make[1]: *** [i387.o] Błąd 1
make[1]: Leaving directory `/usr/src/linux-2.4.34-lck1/arch/i386/kernel'
make: *** [_dir_arch/i386/kernel] Błąd 2

patch-2.4.34-lck1 zawiera wszystkie patche, z których można wyodrębnić np. 010-lckbase.diff.bz2 <-- właśnie ten patch ingeruje właśnie w plik /usr/src/linux-2.4.34-lck1/arch/i386/kernel/i387.c

Patch ten jest najistotniejszy, jego opis:
Base lck contains the batch O(1) scheduler, kernel preemption, low latency and CK interactivity:

Nie wiem jak sobie z tym poradzić, myślałem na początku, że "context_swtch" to literówka i powinno być "context_switch" ale niestety to nie to. Co można z tym fantem zrobić?

Moge gcc to wersja 3.4.5. System Slackware 10.2.

9
Multimedia / mplayer dvd napisy
« dnia: 2006-08-05, 18:48:00 »
Jeżeli film jest z wersją z napisami to spróbuj odpalić tak:
mplayer dvd:// -slang pl
slang to napisy, jak film ma lektora to wtedy -alang pl

10
Konfiguracja / Linux-2.6.12-rc1-love1 i riva tnt 2
« dnia: 2005-06-13, 21:46:19 »
Rozwiązałem problem kombinując z nowszą wersją 2.6.12-rc6-love1
Udało się zainstalować sterownik nvidii w wersji 7174 i tnt2 działa

11
Konfiguracja / Linux-2.6.12-rc1-love1 i riva tnt 2
« dnia: 2005-06-12, 21:23:49 »
Witam

Obecnie używam na swoim desktopie jądra 2.4.31. Mam kartę graficzną Riva TNT 2 m64 32 MB. Wersja zainstalowanych sterowników to Nvidia-Linux-x86-1.0-6111-pkg1.run (Wyższe wersje nie dają się zainstalować).
System Slackware-current. gcc w wersji 3.4.3.

Chcę skompilować sobie jądro 2.6.12-rc1-love1.
Czyli z nałożonym patchem http://heanet.dl.sourceforge.net/sourceforge/love-sources/2.6.12-rc1-love1.bz2

Próbowałem skompilować werje 2.6.12-rc3-love1 czyli patch nakładany na 2.6.12-rc3 ale wykładała się kompilacja modułów na drivers/scsi/ultrastor.o więc próbowałem z 2.6.12-rc1-love1 - ta wersja bez problemu się skompilowała i odpaliłem jądro. Niestety nie mogę zainstalować sterowników nvidii.

I poszukuję na razie bezskutecznie odpowiedniego patcha, dzięki któremu mógłbym zainstalować poprawnie sterowniki nvidii do mojej karty. Jeśli ktoś ma może tą kartę lub podobną i instalował wersje z patchem love to niech da znać i napiszę jaki patch nałożyć. Ewentualne rady np. zahaszowanie jakiś opcji w configu jądra typu riva_fb jak najbardziej będą pomocne. Dziękuje z góry.




12
X Serwer / nVidia 7174 + Kernel 2.6.11
« dnia: 2005-06-15, 19:33:51 »
Mozesz odwiedzić forum nvidii http://www.nvnews.net/vbulletin/forumdisplay.php?s=d8dbbd762d58374bee85e67b1d89dd19&f=14

Ja obecnie mam zainstalowane 7174 karta riva tnt 2 i kernel 2.6.12-rc6-love1. Iksy ładnie chodzą, uptime po 10 godzin i ok.

Zródełka 2.6.11 kiedyś patchowałem nvidia_6111-6629_compat2.diff
i instalowałem spatchowany (nvidia_display_driver-1.0-6111.diff) driver nvidii 6111. I też działało ok.

13
Urządzenia sieciowe / Jaki modem pod linuxa?
« dnia: 2006-08-05, 18:48:00 »
Jeżeli film jest z wersją z napisami to spróbuj odpalić tak:
mplayer dvd:// -slang pl
slang to napisy, jak film ma lektora to wtedy -alang pl

14
Slackware / problem z openbox'em
« dnia: 2005-06-13, 21:46:19 »
Rozwiązałem problem kombinując z nowszą wersją 2.6.12-rc6-love1
Udało się zainstalować sterownik nvidii w wersji 7174 i tnt2 działa

15
Slackware / problem z openbox'em
« dnia: 2005-06-12, 21:23:49 »
Witam

Obecnie używam na swoim desktopie jądra 2.4.31. Mam kartę graficzną Riva TNT 2 m64 32 MB. Wersja zainstalowanych sterowników to Nvidia-Linux-x86-1.0-6111-pkg1.run (Wyższe wersje nie dają się zainstalować).
System Slackware-current. gcc w wersji 3.4.3.

Chcę skompilować sobie jądro 2.6.12-rc1-love1.
Czyli z nałożonym patchem http://heanet.dl.sourceforge.net/sourceforge/love-sources/2.6.12-rc1-love1.bz2

Próbowałem skompilować werje 2.6.12-rc3-love1 czyli patch nakładany na 2.6.12-rc3 ale wykładała się kompilacja modułów na drivers/scsi/ultrastor.o więc próbowałem z 2.6.12-rc1-love1 - ta wersja bez problemu się skompilowała i odpaliłem jądro. Niestety nie mogę zainstalować sterowników nvidii.

I poszukuję na razie bezskutecznie odpowiedniego patcha, dzięki któremu mógłbym zainstalować poprawnie sterowniki nvidii do mojej karty. Jeśli ktoś ma może tą kartę lub podobną i instalował wersje z patchem love to niech da znać i napiszę jaki patch nałożyć. Ewentualne rady np. zahaszowanie jakiś opcji w configu jądra typu riva_fb jak najbardziej będą pomocne. Dziękuje z góry.




Strony: [1] 2