Forum Linux.pl

Dystrybucje Linuksa => *Ubuntu => Wątek zaczęty przez: mackeire w 2018-10-08, 14:43:06

Tytuł: Jak zmienić domyślny emulator terminala ?
Wiadomość wysłana przez: mackeire w 2018-10-08, 14:43:06
Ubu 18.10 Gnome 3.30

Zainstalowałem Tilix, usunąłem gnome-terminal i ikona Midnight Commander nic mi nie otwiera jak na nią klikam. To samo z ręcznie utworzonymi ikonkami dla programów terminalowych np wavemon.

Podejrzewam ,że gdzieś w systemie gnome-terminal jest ustawiony jako domyślny chociaż go nie ma. Sugerowany w internetach :
$ sudo update-alternatives --config x-terminal-emulator 
nie działa
Co robić ? Jak żyć ? I dlaczego im dłużej korzystam z Ubu tym bardziej przypomina mi on window$a ?


Z kolei dconf mówi : PRZESTARZAŁE, ten klucz jest przestarzały i ignorowany . Domyślny terminal jest obsługiwany przez bibliotekę GIO.




Tytuł: Odp: Jak zmienić domyślny emulator terminala ?
Wiadomość wysłana przez: marcin'82 w 2018-10-08, 17:17:30
Spróbuj:
# dpkg-reconfigure tilix

W źródłach pakietu w skrypcie postinstall jest instalacja tego emulatora jako alternatywy.

W ustawieniach środowiska graficznego masz gdzieś domyślne programy? To jest Gnome czy coś innego?
Tytuł: Odp: Jak zmienić domyślny emulator terminala ?
Wiadomość wysłana przez: mackeire w 2018-10-09, 00:37:53
reconfigure też nie pomaga

Jasne ,że to Gnome, w KDE bym to przestawił dwoma kliknięciami myszki ...
Tytuł: Odp: Jak zmienić domyślny emulator terminala ?
Wiadomość wysłana przez: 1709 w 2018-10-09, 11:28:02
Moge cos napisac o Ubuntu ?
Ubuntu nie jest stworzone by go konfigurowac, wrecz jest tworzone zebys nie mogl konfigurowac i nie popsuc systemu.
Ja bym proponowal wrocic do tego co bylo.
A jesli chcesz przetestowac to utworz kliknieciami skrot  gdzies gdzie bedziesz mogl podejrzec skrot
np.
$ ls 
uplos-drakconf.desktop*

$ cat uplos-drakconf.desktop*
#!/usr/bin/env xdg-open
[Desktop Entry]
Name=Configure Your Computer
...
Name[pl]=Konfiguracja komputera
Exec=/usr/bin/drakconf
Comment=Administration Center
...
Comment[pl]=Centrum sterowania UPLOS
Icon=drakconf.png
Terminal=false
Type=Application
StartupNotify=true
Categories=GTK;X-MandrivaLinux-System-Configuration;Settings;
I po tym widze ze  u mnie jest uzyta komenda "/usr/bin/drakconf " ,
u Ciebie moze byc uzyta dodatkowo nazwa terminala ktory usuneles i dlatego moze Ci nie dzialac.
Ale pewnosci nie mam.

Edytowane

Moze tez to wynikac ze przypisanej zmiennej srodowiskowej ktora moze wykorzystywac ikona
https://help.ubuntu.com/community/EnvironmentVariables
Np u mnie jak sprawdzam przykladowe zmienne
$ echo $TERM
xterm

Edytowane
Mozesz takze sprobowac utworzyc wlasny skrot i zobaczyc czy dziala.


Edytowane
Sprawdzilem zmienne systemowe 
set | less
i plik ~/.config/mc/ini
i widze tylko COLORTERM I TERM ktorych zmiana u mnie nic nie daje.
Chyba najlepiej spytac developera skad mc wie jakiego terminala uzyc, no chyba ze ktos wie i napisze.
Tytuł: Odp: Jak zmienić domyślny emulator terminala ?
Wiadomość wysłana przez: Miro57 w 2018-10-14, 20:51:52
Usunięty przez Ciebie terminal prawdopodobnie był uruchamiany poleceniem /usr/bin/gnome-terminal.
Możesz spróbować utworzyć dowiązanie do twojego nowego terminala o takiej nazwie jak odinstalowany terminal:
https://askubuntu.com/questions/749832/how-to-change-default-terminal-application-in-gnome-shell (https://askubuntu.com/questions/749832/how-to-change-default-terminal-application-in-gnome-shell)