Forum Linux.pl

System => X Serwer => Wątek zaczęty przez: Afghan w 2016-03-11, 20:46:48

Tytuł: System się wysypał
Wiadomość wysłana przez: Afghan w 2016-03-11, 20:46:48
Witam. Coś za dużo mam problemów z linuksem. Przed chwilą chciałem wejść na linuksa (linux mint 17,3. KDE) i system się nie uruchomił. Uruchamianie zatrzymało się na "Fixing recursive fault but reboot needed" Najdziwniejsze, że nic takiego nie robiłem. Może to wina aktualizacji? Ponieważ rano jakąś wgrywałem, a od tej aktualizacji jak komputer wyłączyłem, to dopiero włączyłem przed chwilą. Co dziwne pokazał mi się grub. Bootloader miałem windowsowy zrobiony w programie EasyBCD i jak wybrałem linuksa to grub mi się nie pokazywał, bo tak go skonfigurowałem. Wcześniej też w czasie uruchamiania systemu nie było widać żadnych poleceń, tylko chwilę był czarny ekran potem pokazały się tak jakby kropki postępu i za chwilę widziałem pulpit. Wiecie jak to naprawić? Nie chce mi się znowu instalować od nowa systemu, ponieważ już go sobie trochę skonfigurowałem i po instalowałem trochę ważnych dla mnie rzeczy.

EDIT: Chyba naprawiłem. :) Odpinałem wczoraj klawiaturę i możliwe, że wpiąłem w inny port USB. Przed chwilą zacząłem przekładać do innych portów i system się uruchomił. Czy możliwe, że to było powodem awarii?

Wątek do usunięcia
Tytuł: Odp: System się wysypał
Wiadomość wysłana przez: Paweł Kraszewski w 2016-03-12, 13:02:39
1. Linuksowi jest ryba co gdzie podepniesz. To nie Windows, gdzie przełożenie myszki do sąsiedniego portu powoduje ponowną instalację sterownika.
2. "recursive fault" jest dość paskudnym błędem na ogół mającym przyczynę gdzieś w sprzęcie, w szczególności w tym, że producent słyszał o czymś takim jak standardy, ale postanowił nic z nimi nie mieć wspólnego.
3. Zobacz, czy dodanie acpi=off do opcji bootowania pomoże. Jeżeli tak, to możesz sobie pogratulować wyboru sprzętu.
Tytuł: Odp: System się wysypał
Wiadomość wysłana przez: Afghan w 2016-03-12, 15:30:44
Jeśli problem się powtórzy to spróbuje z dodaniem acpi=off do opcji bootowania. Póki co wszystko działa OK także nie będę szukał dziury w całym  ;) bo jeszcze coś na mieszam  :D Ale dzięki za zainteresowanie.
Tytuł: Odp: System się wysypał
Wiadomość wysłana przez: Afghan w 2016-03-25, 05:59:27
1. Linuksowi jest ryba co gdzie podepniesz. To nie Windows, gdzie przełożenie myszki do sąsiedniego portu powoduje ponowną instalację sterownika.

Nie wiem czy tak jest. Wczoraj pojawił się ten sam problem. Dwa czy trzy razy uruchamiałem komputer i ten sam komunikat co wcześniej ale zaraz sobie przypomniałem, że odpiąłem tuner tv usb od komputera. Podłączyłem tuner i system po ponownym uruchomieniu wszedł  :o
Tytuł: Odp: System się wysypał
Wiadomość wysłana przez: wariat prawdziwy w 2016-03-25, 17:56:00
A u mnie wczoraj wieczorem padło wszystko. Najpierw pojawił się komunikat że CINNAMON ULEGŁ AWARII.  Po restarcie nie udało mi się zalogować na konto moje i konto roota. Nie pasowało hasło.  Hasło mam zawsze 5678 i nic więcej. Nie mogłem się pomylić. Nie wiem co się stało że system padł a padł podczas czytania linux.pl
Tytuł: Odp: System się wysypał
Wiadomość wysłana przez: ultr w 2016-03-25, 22:42:25
@Afghan
Zmień w GRUBie opcje bootowania kernela (klawisz e na pozycji w menu, taka zmiana jest tylko na jedno uruchomienie) i usuń opcje (jeśli są) 'quiet' i 'splash':
    linux   /boot/vmlinuz-X.Y.Z-... root=UUID=abcdabcd-abcd-abcd-abcd-abcdabcdabcd ro quiet
Zmienioną konfigurację uruchamiasz bez wychodzenia kombinacją Ctrl+x.
Wtedy przy starcie Linuksa pojawi się więcej komunikatów i może przed tym z błędem zobaczysz jakieś konkretne powody jego wystąpienia.
Możesz wrzucić fotkę ekranu na forum, bo pewnie inaczej tego nie przekopiujesz.
Tytuł: Odp: System się wysypał
Wiadomość wysłana przez: Piotr w 2016-03-26, 12:47:01
A u mnie wczoraj wieczorem padło wszystko. Najpierw pojawił się komunikat że CINNAMON ULEGŁ AWARII.  Po restarcie nie udało mi się zalogować na konto moje i konto roota. Nie pasowało hasło.  Hasło mam zawsze 5678 i nic więcej. Nie mogłem się pomylić. Nie wiem co się stało że system padł a padł podczas czytania linux.pl

Naciśnij kombinację klawiszy CTRL+LALT+F1, pojawi się tekstowa konsola. Spróbuj tam się zalogować na któreś z kont.
Tytuł: Odp: System się wysypał
Wiadomość wysłana przez: Afghan w 2016-03-26, 21:19:18
W pierwszym załączniku widać fotkę z "Fixing recursive fault but reboot needed"  Ekran z tym napisem jest z 15 sekund później przełącza się na ekran z załącznika 2 i tak już się zatrzymuje na stałe. Coraz bardziej się utwierdzam, że chodzi o urządzenia podłączone do usb. Może za dużo prądu potrzeba na urządzenia usb? Mam klawiaturę, kartę sieciową wifi i tuner tv. Dzisiaj znów odłączyłem tuner tv i kolejny raz pojawił się problem. Odłączyłem tuner tv i kartę sieciową i system się uruchomił. Co najlepsze jak uruchomił się już system, to podłączyłem tuner tv i już podłączałem kartę sieciową i gdzieś dotknąłem złączem od karty sieciowej, a raczej dotknąłem gniazda usb i system się w tym momencie zawiesił. W pierwszym załączniku widać, że coś o usb wyskoczyło.
Tytuł: Odp: System się wysypał
Wiadomość wysłana przez: Paweł Kraszewski w 2016-03-27, 12:22:21
Już pisałem, recursive fault (a teraz błąd z NMI jeszcze to utwierdza) to ewidentne objawy problemów sprzętowych. Problemem jest raczej nie urządzenie podpięte pod USB - wygląda to raczej na uszkodzenie samego kontrolera USB na płycie głównej. Albo na jakiś kontroler z piekła rodem, do którego nie ma stabilnych sterowników.
Tytuł: Odp: System się wysypał
Wiadomość wysłana przez: Afghan w 2016-03-28, 07:48:51
Jest prawdopodobne, że coś się dzieje z kontrolerem USB. W windowsie ostatnio mam problem z kartą sieciową, muszę ją czasem wypiąć i wpiąć ale też nie zawsze to pomaga. Poza tym też mam problem na linuksie z podłączaniem telefonu przez usb i z przodu i z tyłu obudowy. Telefon jest przez chwilę zamontowany, a tylko jak próbuję coś zrobić, powiedzmy skopiować zdjęcie to zaraz się odmontowuję.
Tytuł: Odp: System się wysypał
Wiadomość wysłana przez: Afghan w 2016-03-29, 20:56:05
Albo na jakiś kontroler z piekła rodem, do którego nie ma stabilnych sterowników
A jak się upewnić, że nie jest to wina sterowników?  Wbijając w konsolę polecenie lspci wyskakują takie informację o kontrolerze:

00:02.0 USB controller: NVIDIA Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:02.1 USB controller: NVIDIA Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:04.0 USB controller: NVIDIA Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:04.1 USB controller: NVIDIA Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)

Tytuł: Odp: System się wysypał
Wiadomość wysłana przez: Afghan w 2016-05-08, 07:57:44
Wygląda na to, że znalazłem rozwiązanie problemu. Wszystko wydaje mi się zaczęło jak podłączyłem kartę TV USB do komputera i do niej kabel antenowy. Wydaje mi się też, mniej więcej od tego momentu jak podłączyłem kartę TV zacząłem czuć przy dotknięciu obudowy lub z tyłu komputera lekkie kopnięcia prądem, na początku nie wiązałem tego z problemem który mnie nękał. I w końcu jakoś w połowie kwietnia sprawdziłem czy przedłużacz przez który jest podłączony komputer ma uziemienie. Okazało się, że nie ma i wymieniłem na przedłużacz z uziemieniem. Od tamtej pory komputer się nie zatrzymał w czasie ładowania systemu ani razu jak to się wcześniej działo.   :)