Nowe posty

xx Przy uploadzie przerywane są wszystkie połączenia (1)
Dzisiaj o 09:38:09
xx Apache2 i twarde https (3)
2020-05-25, 15:53:43
xx Czy istnieje emulator terminala który zapamieta komendy na jakiejś liście? (9)
2020-05-23, 17:04:57
xx RTLinux wybór dystrybucji (0)
2020-05-23, 15:42:54
xx Problem z instalacją Ubuntu na bootowalnym pendrajwie (9)
2020-05-22, 15:08:12
xx Ubuntudde 20.04 LTS nie działa Lightdm (8)
2020-05-22, 09:16:42
xx [Gra za darmo] GTA5 (1)
2020-05-20, 21:49:26
xx Marketing (1)
2020-05-13, 08:00:41
xx Polecenia Debian (1)
2020-05-10, 19:58:54
xx Uruchamianie pliku z każdego katlogu (2)
2020-05-10, 19:23:33

Pokaż wiadomości

Ta sekcja pozwala Ci zobaczyć wszystkie wiadomości wysłane przez tego użytkownika. Zwróć uwagę, że możesz widzieć tylko wiadomości wysłane w działach do których masz aktualnie dostęp.


Wiadomości - pavbaranov

Strony: [1] 2 3 ... 45
1
1. O spolszczeniu - na oficjalnym, polskim supporcie Puppy: http://www.puppylinux.pl/
2. Puppy korzysta z repozytoriów Ubuntu - instalacja Firefox jest możliwa.
W dalszym ciągu (i to na podstawie doświadczeń) twierdzę, że zdecydowanie lepiej pracuje się na linuksach na napędach podłączonych przez USB, które do takiej pracy są stworzone, niż w przypadku instalacji na takim (dowolnym) nośniku innego, dowolnego linuksa.

2
Inne / Odp: Ubuntudde 20.04 LTS nie działa Lightdm
« dnia: 2020-05-22, 09:16:42 »
Plik winien być w paczce lightdm-deepin-greeter (tzn. zwykle jest w tak nazywających się). Ja na Twoim miejscu raz jeszcze spróbowałbym zainstalować paczkę deepin-desktop, bo gdzieś są jakieś poważne kłopoty w skonfigurowaniu u Ciebie LightDM. Alternatywa - sam sprawdzisz np. na askubuntu.com lub nawet na wiki.ubuntu.com/lightdm, jak należy skonfigurować prawidłowo lightdm, albo ktoś, kto ma Ubuntu Ci podpowie.

3
Inne / Odp: Ubuntudde 20.04 LTS nie działa Lightdm
« dnia: 2020-05-21, 20:04:51 »
Nie o to mi chodzi. Gdzieś w systemie powinieneś mieć plik: lightdm.conf. To on jest podstawowym, który konfiguruje LightDM. Nie wiem jak działa ubuntudde - mogę się opierać obecnie wyłącznie na innych dystrybucjach - być może, jakaś aktualizacja dokonuje zainstalowania takiego pliku, ale dodaje do niego jakiś sufix. Np. w moim systemie, gdyby doszło do aktualizacji, to plik - tu akurat /etc/lightdm.conf - który wraz z tą aktualizacją zostałby zainstalowany nazywałby się lightdm.conf.pacnew i do mnie należałaby ocena na ile ten plik jest mi przydatny, na ile powinienem go "podmienić", a na ile zmienić dotychczasowy. Być może i u Ciebie jest podobna sytuacja. Tu musi się wypowiedzieć ktoś, kto jest bardziej obeznany w obecnych wersjach Ubuntu (ja ich nie używam od 7-8 lat). Fakt, że log pokazuje:
lightdm[16783]: Seat type 'xlocal' is deprecated, use 'type=local' instead
Jeśli nie masz pliku lightdm.conf, to być może to samo znajdziesz w 60-deepin.conf. Trzeba zmienić.
Niemniej jednak podstawowy problem, jaki napotyka lightdm, to autoryzacja. Log pokazuje:
AM unable to dlopen(pam_deepin_auth.so): /lib/security/pam_deepin_auth.so: nie można otworzyć pliku obiektu dzielonego: Nie ma takiego pliku ani katalogu
maj 21 15:00:22 jakub-mycomputer sudo[16760]: PAM adding faulty module: pam_deepin_auth.so
maj 21 15:00:22 jakub-mycomputer sudo[16760]:     root : TTY=tty1 ; PWD=/root ; USER=root ; COMMAND=/usr/bin/systemctl start lightdm
maj 21 15:00:22 jakub-mycomputer sudo[16760]: pam_unix(sudo:session): session opened for user root by (uid=0)
I dopóki tego się nie rozwiąże, to LightDM nie wystartuje i nie dopuści logowania. Niestety ja Ci tu nic nie podpowiem. Nie mam ubuntudde, nie mam ubuntu, nie mam deepin, nie mam lightdm...
Jedyna rada, tymczasowa, to szukać zamiennika. Jeśli nie odpowiada Ci SDDM, to powinieneś mieć jeszcze np. lxdm (niewielki "narzut"), a nawet xdm (chyba jeszcze mniejszy). To, że być może nie będzie taki ładny jak lightdm, tymczasowo przetrzymasz. Jeśli nie, to alternatywnie możesz zastosować takie rozwiązanie: https://wiki.archlinux.org/index.php/Deepin_Desktop_Environment#Via_xinit i po prostu będzie to startować bez lightdm. Możesz sprawdzić "unieruchamiając" usługę jakiegokolwiek DM i po przejściu - wówczas - do konsolowego logowania po prostu wpisać:
startdde
Jeśli Deepin startuje, zamyka się i wszystko inne pracuje dobrze, to być może jest to dla Ciebie - tymczasowo - dobre rozwiązanie, a problemy, o których piszesz - zgłoś tam, gdzie Paweł wskazał, zwłaszcza, że - jak się wydaje - są one bezpośrednio związane z Deepinem i obsługą przez niego Deepinowego PAM przez LightDM.

4
Inne / Odp: Ubuntudde 20.04 LTS nie działa Lightdm
« dnia: 2020-05-21, 15:46:08 »
Strasznie, to długie, ale... sugeruje, że należy wykonać aktualizację systemu, bo być może coś poprawione zostało, co zostało zmienione.
Z takich podstawowych rzeczy:
- wygląda na to, że LightDM domaga się biblioteki: /lib/security/pam_deepin_auth.so, której nie ma w Twoim systemie - sprawdź co to dostarcza i zainstaluj,
- plik konfigurujący LightDM jaki istnieje w Twoim systemie jest "za stary", sprawdź, czy nie masz jakiegoś innego pliku lightdm.conf.* i jeśli jest - sprawdź, czy nie jest nowszy, a jeśli tak to podmień, jeśli nie:
-- masz gdzieś w nim wpisane:
type=xlocal
winno być:
type=local
To są dwa, powtarzające się błędy, dotyczące LightDM. I powtórzę: wygląda na to, że masz przeprowadzoną jakąś częściową aktualizację systemu, która obecnie uniemożliwia otwarcie LightDM.

PS: SDDM działa bardzo poprawnie - używam od bodaj 7 lat. Jedyne obecnie jego problemy dotyczą sesji Wayland, ale nie są widoczne dla ZU.

5
Inne / Odp: Ubuntudde 20.04 LTS nie działa Lightdm
« dnia: 2020-05-21, 09:45:34 »
Z LightDM być może występuje u Ciebie ten błąd: https://wiki.archlinux.org/index.php/LightDM#LightDM_freezes_on_login_attempt
Prawdopodobnie lepszym zamiennikiem za LightDM w przypadku Deepin będzie SDDM, a nie GDM (ten jest jednak bardzo, bardzo mocno powiązany z GNOME 3 i w zasadzie wyłącznie z nim dogaduje się bez problemów).
Odnośnie diagnostyki LightDM, to jak mi się wydaje należałoby zrobić tak:
- instalacja i podniesienie usługi,
- start,
- gdy nie będzie się chciał pojawić ekran logowania, przejście na inną konsolę (ctrl+alt+Fx - który musisz sprawdzić, bo różne mogą być to klawisze, powiedzmy F4 lub F5 powinien bez problemu funkcjonować),
- sprawdzenie usługi przez systemctl oraz sprawdzenie dziennika (journalctl) pod kątem błędów danego logowania (powinien wystarczyć z opcją -xb).
Dopiero wówczas będzie przynajmniej cokolwiek wiadomo.
Przydałaby się pewnie również pełna aktualizacja systemu, bo skoro LightDM funkcjonował dobrze do czasu, a potem przestał, to prawdopodobnie może on być zależny od czegoś, co zostało w międzyczasie u Ciebie zaktualizowane lub odwrotnie - zaktualizowany LightDM, a jego zależność, na której został zbudowany - nie).

6
@1709 - Masz rację z DSL - sorry, nie sprawdziłem. Są natomiast jeszcze MX Linux (który ma bardzo fajnego orędownika na siostrzanym forum.linuxiarze.pl) oraz Knoppix (o nim kompletnie zapominam, bo ostatni raz, gdy go miałem, to była to dystrybucja do normalnej instalacji; o pendrive jeszcze chyba nikt nie myślał :). a jeśli to były one bardzo małe).

7
@mackeire - Ten zapis jest zależny od dystrybucji. Np. Puppy startuje z pendrive'a, wrzuca się w RAM, ale całe, niewykorzystane przez system (który jest malutki) miejsce pozostaje do dyspozycji i można spokojnie zapisywać.

8
1. Instalacja Ubuntu na pendrive jest mocno średnio sensowna, gdyż system będzie się ciąć na skutek słabego transferu przez interfejs USB i to nawet w wersji 3.x
2. Są dystrybucje - jak np. Puppy - które specjalnie są konstruowane w taki sposób, by być "instalowane" na pendrive. Raczej polecałbym coś takiego. Inne to jakiś Porteus, Slax, Damn Small Linux, Tiny Linux itp. Puppy myślę, że z tego towarzystwa najsensowniejszy.
3. Zamiast "instalacji" na pendrive można po prostu stworzyć bootowalny pendrive i dać mu tzw. persystencję, co umożliwia zapis na tym samym pendrive itp. Popularne narzędzie, które to umożliwia nazywa się unetbootin i dostępne jest także na Windows.
4. To co zrobiłeś, to stworzyłeś bootowalny pendrive (liveusb), a nie zainstalowałeś system na pendrive. Jeśli chcesz instalować, musisz mieć przygotowany jakikolwiek liveusb, z którego startujesz komputer, a następnie podczas instalacji wskazać, że system ma być zainstalowany na innym pendrive. Uwaga: nieuważne obchodzenie się może spowodować, że albo wykasujesz sobie przy okazji system na HDD, albo spowodujesz że system (ten na HDD) będzie się uruchamiać, ale wyłącznie przy włączonym pendrive, bo na niego przeniesiesz bootloader.

9
Tyle, że chyba nie o to chodziło.

10
https://opensource.com/article/17/6/set-path-linux oczywiście, o ile to plik wykonywalny, bo wówczas można mówić o jego "uruchamianiu".

11
C/C++ / Odp: parser plikow konfiguracyjnych w C
« dnia: 2020-05-06, 13:48:12 »
Czy Tobie chodzi o jakieś IDE/edytor tekstu z kolorowaniem składni? Jeśli tak, to wiele edytorów oferuje takie. Osobiście korzystam z dobrodziejstw Kate/Kwrite (w zasadzie to każdy, który korzysta z syntax-highlighting).

12
Instalacja / Odp: Problem z instalacją Linux lite
« dnia: 2020-05-02, 21:07:21 »
To sprawdź jeszcze sumy kontrolne. Obecnie jest takie obciążenie sieci, że być może Ci się ściąga wadliwe iso.

13
Jak najnowszy kernel, sterowniki raczej własnościowe NVidii i prawdopodobnie dobrze funkcjonujące wsparcie dla Optimusa. Jak powiedział Paweł - Debiana Stable (a ja twierdzę, że w ogóle, ale nie miejsce tu pewnie uzasadniać moje sądy) odpuścić sobie możesz.
Ubuntu? Jeśli, to 20.04, ale i tu dobrym rozwiązaniem byłoby sięgnięcie po jak najnowszy kernel (w Ubuntu jest 5.3, obecnie już 5.6, a ostatni LTS to 5.4) - Ubuntu oferuje swoje świeższe kernele, ale nie wiem, czy i jak z nimi przygotowane są do działania sterowniki NVidia w Ubuntu).
Z alternatyw - np. OpenSUSE Tumbleweed (nie Leap!).

14
Sieć / Odp: Netkit v2
« dnia: 2020-04-12, 19:01:45 »
Żadnych błędów nie wygenerują :) To są wyłącznie ostrzeżenia i kompilacja winna pójść mimo to.
Dlaczego na ext4 daje Ci takie ostrzeżenie - bladego pojęcia nie mam.

15
Sieć / Odp: Netkit v2
« dnia: 2020-04-10, 13:07:03 »
Co to jest "Lang=C"??? Jeśli chcesz "skasować" tymczasowo ustawienia lokalizacyjne, to winno być:
LC_LANG=C komenda
A oprócz "warningów", wobec których warto byłoby się co najmniej pochylić, to dokładnie jaki masz problem?

Strony: [1] 2 3 ... 45