Nowe posty

Pokaż wiadomości

Ta sekcja pozwala Ci zobaczyć wszystkie wiadomości wysłane przez tego użytkownika. Zwróć uwagę, że możesz widzieć tylko wiadomości wysłane w działach do których masz aktualnie dostęp.


Wiadomości -

Strony: [1] 2
1
C/C++ - KDE/Qt / Kdevelop debuger
« dnia: 2012-08-13, 21:41:05 »
Cytat: xaoc
Witam,
Jestem początkujący, mój ang nie jest za dobry. Nie potrafię sobie poradzić z konfiguracją debuggera w Kdevelopie(korzystałem z codebloksa). Wydaje mi się że powinienem to zrobić w >> Uruchom >> Konfiguracja uruchomienia >> Tylko co i jak mam wpisać,
 
Kolejny problem(można pominąć, mogę pracować w konsoli) chciałbym aby po zbudowaniu otwierał mi się automatycznie terminal.

Tak wiem że kdevelop nie jest dla początkujących ale co innego mogę wybrać w kde?
Mam podobny problem , nie wiem co tam wpisać w >> Uruchom >> Konfiguracja uruchomienia >> żeby skompilować program pod konsolą. W codeblocks, geany nie mam z tym problemu. Wpisywałem już poprawną scieżkę do g++ i nic polecenie buduj program jest nadal nieaktywne.
W qtcrator też mam dopisane niby poprawnie w opcjach budowanie i uruchamianie >> sciezka kompilatora /usr/bin/g++ >> debuger /usr/bin/gdb >> mkspec linux-g++. Lecz tu jest to samo , przyciski budowania programu są nadal nieaktywne. Mam zainstalowany g++, gcc, gdb. Może ktoś wyjaśni jak to poprawnie ustawić by działało kompilowanie konsolowych programów?

2
Gentoo / Jak poprawnie zainstalować niestabilne pakiety?
« dnia: 2012-08-08, 19:26:54 »
Całkowicie zapomniałem o tym że Opera mimo że jest darmowa to ma zamknięty kod źródłowy, to samo z Google-Chrome. Która to przecież czerpie z Chromium i potem zamyka swój projekt z jakimiś swoimi ulepszeniami(szpiegami:).

3
Gentoo / Jak poprawnie zainstalować niestabilne pakiety?
« dnia: 2012-08-08, 12:47:06 »
Może się nie znam , ale wydawało mi się że pakiety binarne w Gentoo mają końcówkę -bin. Jest druga wersja Firefox bez bin , czyli ta do kompilacji zajmująca 78MB do pobrania. Najwidoczniej Opera i Chrome to zwykłe binarki bez nazwy bin na końcu. Na pewno masz rację dlatego że Chromium jest na licencji BSD, więc dodany jest tam cały kod źródłowy.
To ostatnie moje pytanie , jeżeli Opera jest tylko do pobrania i zainstalowania w wersji binarnej, a ja chciałbym ją skompilować przez emerge to jak to wykonać?

4
Gentoo / Jak poprawnie zainstalować niestabilne pakiety?
« dnia: 2012-08-07, 22:40:14 »
A dlaczego żeby zainstalować Chromium potrzeba aż pobrać ponad 180MB? Gdzie taka Opera zajmuje 12MB, a nawet Google-Chrome czy firefox dużo mniej.  
emerge -s opera firefox
Searching...    
[ Results for search key : opera ]
[ Applications found : 2 ]

*  www-client/opera
      Latest version available: 12.01.1532
      Latest version installed: 12.01.1532
      Size of files: 12,554 kB
      Homepage:      http://www.opera.com/
      Description:   A fast and secure web browser and Internet suite
      License:       OPERA-11 LGPL-2 LGPL-3
*  www-client/firefox-bin
      Latest version available: 10.0.6
      Latest version installed: 10.0.6
      Size of files: 17,138 kB
      Homepage:      http://www.mozilla.com/firefox
      Description:   Firefox Web Browser
      License:       MPL-1.1 GPL-2 LGPL-2.1

*  www-client/google-chrome [ Masked ]
      Latest version available: 22.0.1221.1_alpha149058
      Latest version installed: [ Not Installed ]
      Size of files: 32,038 kB
      Homepage:      http://www.google.com/chrome
      Description:   The web browser from Google
      License:       google-chrome
*  www-client/chromium
      Latest version available: 21.0.1180.57
      Latest version installed: [ Not Installed ]
      Size of files: 187,907 kB
      Homepage:      http://chromium.org/
      Description:   Open-source version of Google Chrome web browser
      License:       BSD

5
Gentoo / Jak poprawnie zainstalować niestabilne pakiety?
« dnia: 2012-08-07, 18:21:04 »
Dzięki za tą informację. Co do tych repozytoriów które zwraca layman -S , to te przy których jest czerwony znaczek są jakieś niepewne ? A żółte i zielone są bardziej bezpieczne?

6
Gentoo / Jak poprawnie zainstalować niestabilne pakiety?
« dnia: 2012-08-07, 11:01:40 »
Tego właśnie szukałem, wiekie dzięki. Mam jeszcze takie pytanie , jeżeli dany pakiet nie znajduje się w Gentoo stable to lepiej go zamaskować i zainstalować przez emerge z wersji ~testowej? Czy po prostu przez laymana (mowa o tej samej wersji pakietu i która z tych opcji instalacji będzie lepsza)?

Znalazłem taką listę ebuildów(repozytoriów) i czy każde z nich można zainstalować przez laymana? Jeśli tak to wybór jest ogromny i niesamowity :)
http://gentoo-overlays.zugaina.org/index.html.en

7
Gentoo / Jak poprawnie zainstalować niestabilne pakiety?
« dnia: 2012-08-06, 21:16:33 »
Pewnie dobry procesor musi być i sporo ramu do tylu pakietów i ich kompilacji. W Gentoo jeszcze jednego nie mogę rozgryźć. Jak zainstalować pakiet do którego nie ma ebuilda w wersji stable czy nawet ~ testowej? Chciałbym zainstalować conky-lua i deadbeef , lecz emerge go nie znajduję. Czy trzeba w takim przypadku szukać obcych ebuildów po sieci i jakoś je instalować?

Wróć. Znalazłem tu jeden ebuild http://gpo.zugaina.org/media-sound/deadbeef. Lecz nie wiem jak go poprawnie zainstalować i czy w ogole emerge doda go do pozostałych pakietów, a następnie będzie go aktualizować wraz z jego zależnościami? Co do conky-lua to jeszcze szukam.

8
Gentoo / Jak poprawnie zainstalować niestabilne pakiety?
« dnia: 2012-08-05, 22:25:06 »
To trochę sporo tych pakietów jak na Gentoo. U mnie jeszcze nie jest tak przesadnie źle:
epm -gqa | wc -l
558

9
Gentoo / Jak poprawnie zainstalować niestabilne pakiety?
« dnia: 2012-08-04, 21:39:45 »
Bardzo dziękuję za dokładną odpowiedź. Też zaczynam korzystać z różnych przydatnych narzędzi w tym systemie (epm,  eread, euse, glsa-chec) i teraz eix sprawdzę. Co do tego pliku to ostatecznie dodałem bez znaku równosci  app-misc/screenfetch.
Czyli wygląda na to że korzysta Pan z wersji testowej Gentoo, sądząc po pakietach które się wyświetliły? A można wiedzieć do ilu pakietów rozrosło się u pana Gentoo? Ciekawi mnie jeszcze czy te pakiety które są w wersji testowej , za jaki czas dołączą do wersjii stabilnej ? Pytanie czy w ogóle tam przejdą, skoro nie ma jeszcze danego pakietu(żadnej jego wersji) w wersji stabilnej?

10
Gentoo / Jak poprawnie zainstalować niestabilne pakiety?
« dnia: 2012-08-04, 16:45:29 »
Nie wiem jak poprawnie zainstalować niestabilny pakiet w Gentoo stable. Chciałbym zainstalować ten pakiet app-misc/screenfetch , ale on jest dostępny tylko w niestabilnej wersji Gentoo. Więc dodałem go do   echo "app-misc/screenfetch ~x86" >>  /etc/portage/package.keywords
Teraz mogę go zainstalować, ale tu mam kilka pytań:
1. Czy podczas aktualizacji systemu przez  emerge -avuND world te niestabilne pakiety bedą aktualizowane i mogą wywołać jakieś problemy przy aktualizacjach?
2. Czy powinienem jeszcze ten pakiet dodać do package.unmask?

11
Gentoo / Brak net.eth0
« dnia: 2012-08-02, 09:45:24 »
Miałem identyczny problem , jednak u mnie załadowanie modułu nie pomagało. Trzeba było usunąć z jądra inne sterowniki atheros , dopiero wtedy eth0 się pojawił. Obecnie raz mi się uda uruchomić internet innym razem nie. Podczas uruchamiania systemu widzę jakiś ERROR i komunikat
ensure that you have loaded the correct kernel module for your hardware
Czasami przyzna dobry adres przez dhcpcd jeśli kombinuję z tymi poleceniami.
rmmod atl1c
modprobe atl1c
ifconfig eth0 up
dhcpcd - przy samym dhcpcd czasami udaje się wydzielić poprawny adres ip
dhcpcd eth0 - nawet nie chce ruszyć
A teraz dhcpcd przydziela jakieś błędne adresy ip i internet mi nie działa
dhcpcd[2128] eth0: checking for 169.254.53.167....
Nie wiem co jest nie tak z tym Gentoo. Na innych dystrybucjach przydziela dobry adres przez dhcpcd.

12
Gentoo / Update systemu
« dnia: 2012-08-01, 13:21:42 »
Ok dziękuję sprawdzę to. Co do Gentoo to zbierałem się do tego systemu już od kilku lat. Obecnie próbuje z nim sił jako drugi system. A z binarnymi systemami nie mam żadny problemów lub potrafię sobie z nimi poradzić. Jeśli nie dzisiaj mam wybrać i przetestować ten system Gentoo to kiedy? Za miesiąc, rok za 10 lat? Nikt się nie rodzi z wiedzą o Gentoo więc uważam że warto spróbować. Pewnie dużo osób która zaczynała z tym systemem i teraz można o nich powiedzieć specjaliści od Gentoo też miała różne problemy na samym początku. Jak dopiero mam styczność z tym systemem od 3 dni więc.

Rozwiązałem problem. Wystarczyło przekompilować jądro bez załadowanych modułów .

13
Gentoo / Update systemu
« dnia: 2012-07-31, 22:32:44 »
To już nie mam pomysłu jak to naprawić. Dla pewności dodałem wszystkie co widać. A przy ostatnim Atheros L1C pokazuje help mój moduł karty. Jednak nadal nie działa eth0.
[*]   Atheros devices                                                       │ │  
  │ │     <*>     Atheros L2 Fast Ethernet support                                    │ │  
  │ │     <*>     Atheros/Attansic L1 Gigabit Ethernet support                        │ │  
  │ │     <*>     Atheros L1E Gigabit Ethernet support (EXPERIMENTAL)                 │ │  
  │ │     <*>     Atheros L1C Gigabit Ethernet support (EXPERIMENTAL)                 │ │  
  │ │     [*]   Broadcom devices
Może jest jeszcze  inne ustawienie w menuconfig  od tego chipsetu Atheros? Lub mam niepoprawny make.conf i namieszane z flagami USE.

14
Gentoo / Update systemu
« dnia: 2012-07-31, 18:48:59 »
Próbowałem już tego wszystkiego co napisałeś. Ten moduł jest własciwy , ponieważ mi działa w innej dystrybucji. Natomiast polecenie ifconfig pokazuje jedynie lo i nieznaną mi nazwę sit0.  Przekompilowałem też jądro dodając Atheros L2 Fast (wydaje mi się że to jest ta karta)
 [*]   Atheros devices                                                       │ │  
  │ │     <*>     Atheros L2 Fast Ethernet support                                    │ │  
  │ │     < >     Atheros/Attansic L1 Gigabit Ethernet support                        │ │  
  │ │     < >     Atheros L1E Gigabit Ethernet support (EXPERIMENTAL)                 │ │  
  │ │     < >     Atheros L1C Gigabit Ethernet support (EXPERIMENTAL)
Ale nadal się eth0 nie pojawiło. Nie działa również polecenie lspci , lspci -v.
bash: lspci: nie znaleziono polecenia
Wyczytałem też że Gentoo może inaczej nazywać kartę i trzeba ten plik usunąć?
Usuń etc/udev/rules.d/70-persistent-net.rules i rebootuj, bedzie sie nazywac eth0 od tego momentu
Coś jest nie tak. Teraz zauważyłem że polecenie lsmod pod Gentoo nie pokazuje żadnego modułu.
Module                  Size  Used by
Pod chrootem widać wszystkie moduły.

15
Gentoo / Update systemu
« dnia: 2012-07-31, 17:17:50 »
Czytałem to, mimo to dzięki. Mam teraz inne zmartwienie. Mianowicie nie wykrywa mi eth0 i nie mogę użyc dhcpcd eth0. Pod chrotem jest eth0 i wszystko ładnie działa. Zrobiłem wszystko tak jak w handbooku http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=3.
Może teraz wraz z jądrem 3.5.0 wprowadzili jakieś zmiany w konfiguracji sieci, których nie zdążyli jeszcze dopisać do handbooka?
Moja karta sieciowa to
Atheros Communications Inc. AR8152 v2.0 Fast Ethernet
sterownik atl1c. Jak to rozwiązać?

Strony: [1] 2