Nowe posty

Pokaż wiadomości

Ta sekcja pozwala Ci zobaczyć wszystkie wiadomości wysłane przez tego użytkownika. Zwróć uwagę, że możesz widzieć tylko wiadomości wysłane w działach do których masz aktualnie dostęp.


Pokaż wątki - Panas

Strony: [1] 2
1
Nawiązując do tematu
https://forum.linux.pl/index.php/topic,25470.msg136857.html?PHPSESSID=9998bju9jct530rqooeod2mdm2#new

wyskakuje mi błąd przy instalacji via ppa (dlatego wcześniej po pobraniu ręcznie instalowałem jave)
Dodatkowo przeleciałem tym tematem i dalej ten sam błąd
https://github.com/bazelbuild/bazel/issues/2622

panas@Panas:~$ sudo add-apt-repository ppa:webupd8team/java
[sudo] hasło użytkownika panas:
 Oracle Java (JDK) Installer (automatically downloads and installs Oracle JDK8). There are no actual Java files in this PPA.

Important -> Why Oracle Java 7 And 6 Installers No Longer Work: http://www.webupd8.org/2017/06/why-oracle-java-7-and-6-installers-no.html

Update: Oracle Java 9 has reached end of life: http://www.oracle.com/technetwork/java/javase/downloads/jdk9-downloads-3848520.html

The PPA supports Ubuntu 18.10, 18.04, 16.04, 14.04 and 12.04.

More info (and Ubuntu installation instructions):
- http://www.webupd8.org/2012/09/install-oracle-java-8-in-ubuntu-via-ppa.html

Debian installation instructions:
- Oracle Java 8: http://www.webupd8.org/2014/03/how-to-install-oracle-java-8-in-debian.html

For Oracle Java 11, see a different PPA -> https://www.linuxuprising.com/2018/10/how-to-install-oracle-java-11-in-ubuntu.html
 Więcej informacj: https://launchpad.net/~webupd8team/+archive/ubuntu/java
Press [ENTER] to continue or Ctrl-c to cancel adding it.

Ign.:1 http://dl.google.com/linux/chrome/deb stable InRelease
Stary:2 http://ppa.launchpad.net/gezakovacs/ppa/ubuntu bionic InRelease                                                                             
Stary:3 http://packages.microsoft.com/repos/vscode stable InRelease                                                                                 
Ign.:4 http://download.opensuse.org/repositories/home:/strycore/xUbuntu_18.04 ./ InRelease                                                           
Stary:5 https://deb.opera.com/opera-stable stable InRelease                                                                                         
Stary:6 http://download.opensuse.org/repositories/home:/strycore/xUbuntu_18.04 ./ Release                                                           
Stary:7 http://apt.postgresql.org/pub/repos/apt bionic-pgdg InRelease                                                                               
Stary:8 http://dl.google.com/linux/chrome/deb stable Release                                                                                         
Stary:9 http://ppa.launchpad.net/morphis/anbox-support/ubuntu bionic InRelease                                                                       
Stary:10 http://ppa.launchpad.net/ricotz/docky/ubuntu bionic InRelease                                                                               
Stary:11 http://repo.steampowered.com/steam precise InRelease                                                                                       
Stary:13 http://ppa.launchpad.net/serge-rider/dbeaver-ce/ubuntu bionic InRelease                                                                 
Stary:14 https://dbeaver.io/debs/dbeaver-ce  InRelease                               
Stary:15 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease   
Czytanie list pakietów... Gotowe                                           
panas@Panas:~$ sudo apt-get update
Stary:1 http://repo.steampowered.com/steam precise InRelease
Ign.:2 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                       
Ign.:3 http://download.opensuse.org/repositories/home:/strycore/xUbuntu_18.04 ./ InRelease                                                           
Stary:4 http://packages.microsoft.com/repos/vscode stable InRelease                                                                                 
Stary:5 http://dl.google.com/linux/chrome/deb stable Release                                                                                         
Stary:6 http://apt.postgresql.org/pub/repos/apt bionic-pgdg InRelease                                                                               
Stary:7 http://ppa.launchpad.net/gezakovacs/ppa/ubuntu bionic InRelease                                                                             
Stary:8 http://download.opensuse.org/repositories/home:/strycore/xUbuntu_18.04 ./ Release                                                           
Stary:9 http://ppa.launchpad.net/morphis/anbox-support/ubuntu bionic InRelease                                                                       
Stary:10 https://deb.opera.com/opera-stable stable InRelease                                                                                     
Stary:12 http://ppa.launchpad.net/ricotz/docky/ubuntu bionic InRelease                                               
Stary:13 http://ppa.launchpad.net/serge-rider/dbeaver-ce/ubuntu bionic InRelease                                       
Stary:14 https://dbeaver.io/debs/dbeaver-ce  InRelease                             
Stary:16 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease
Czytanie list pakietów... Gotowe                         
panas@Panas:~$ sudo apt-get install oracle-java8-set-default
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 oracle-java8-set-default : Wymaga wstępnie: oracle-java8-installer ale nie zostanie zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.
panas@Panas:~$ sudo apt-get install oracle-java8-installer
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 oracle-java8-installer : Wymaga: java-common (>= 0.24) ale nie da się go zainstalować
                          Poleca: gsfonts-x11 ale nie da się go zainstalować
                          Poleca: oracle-java8-set-default ale nie zostanie zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.
panas@Panas:~$ sudo apt-get install oracle-java8-installer
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 oracle-java8-installer : Wymaga: java-common (>= 0.24) ale nie da się go zainstalować
                          Poleca: gsfonts-x11 ale nie da się go zainstalować
                          Poleca: oracle-java8-set-default ale nie zostanie zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.
panas@Panas:~$ sudo apt-get install java-common
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Pakiet java-common nie ma dostępnej wersji, ale odnosi się do niego inny pakiet.
Zazwyczaj oznacza to, że pakietu brakuje, został zastąpiony przez inny
pakiet lub nie jest dostępny przy pomocy obecnie ustawionych źródeł.

E: Pakiet java-common nie ma kandydata do instalacji

 apt search oracle-java
Sortowanie... Gotowe
Wyszukiwanie pełnotekstowe... Gotowe
oracle-java8-installer/bionic,bionic 8u201-1~webupd8~1 all
  Oracle Java(TM) Development Kit (JDK) 8

oracle-java8-set-default/bionic,bionic 8u201-1~webupd8~1 all
  Set Oracle JDK 8 as default Java

oracle-java8-unlimited-jce-policy/bionic,bionic 8u201-1~webupd8~1 all
  Unlimited JCE Policy for Oracle Java 8


panas@Panas:~$ sudo apt install java-common oracle-java8-installer oracle-java8-set-default
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Pakiet java-common nie ma dostępnej wersji, ale odnosi się do niego inny pakiet.
Zazwyczaj oznacza to, że pakietu brakuje, został zastąpiony przez inny
pakiet lub nie jest dostępny przy pomocy obecnie ustawionych źródeł.

2
Instalacja oprogramowania / dbeaver ubuntu 18.04
« dnia: 2019-01-17, 14:11:16 »
Nie potrafię zainstalować dbeaver
Poleciałem teraz najmniejszą linia oporu https://computingforgeeks.com/install-dbeaver-on-ubuntu-18-04-ubuntu-16-04-debian-9/

Przy komendzie sudo apt -y  install dbeaver-ce
wywala mi błąd

Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 dbeaver-ce : Wymaga: openjdk-8-jre-headless ale nie da się go zainstalować lub
                      java-runtime-headless ale nie da się go zainstalować
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.

java jest zainstalowana od dawna w wersji 1.8

java version "1.8.0_191"
Java(TM) SE Runtime Environment (build 1.8.0_191-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.191-b12, mixed mode)


Natomiast przy instalowaniu .deb wyskakuje błąd związany z linią
./dbeaver-ce_5.3.2_amd64.deb: linia 1: błąd składni przy nieoczekiwanym znaczniku `newline'
./dbeaver-ce_5.3.2_amd64.deb: linia 1: `!<arch>'

3
Narzędzia administracyjne / Bezpieczne usunięcie ubuntu 18.10
« dnia: 2018-10-21, 11:25:40 »
Wrzuciłem sobie dla testów 18.10 i zapomniałem o nie nadpisywaniu gruba.
Jak mogę teraz usunąć system i to co pozostawił w sobie w Grub? Na trywiala formatować partycję nie chcę ponieważ miałem problem z rozruchem ostatnim razem jak to zrobiłem.


Struktura
/hd
|- sda-  efi
|- sda1 - / 18.04
|- sda2 - /home (18.04)
|- sda3 - / + /home (18.10

4
Konfiguracja / Zmiana Nazwy użytkownika
« dnia: 2018-10-18, 16:42:32 »
Mam problem ze zmianą nazwy zmieniłem nazwę NAME2 ale nie wiem jak zmienić nazwę NAME1
Jak mogę ja zmienić?

NAME1@Name2:$

5
Inne / Dostęp zewnętrzny do sprzętu.
« dnia: 2018-10-18, 11:54:42 »
Jak sprawdzić czy ktoś nie ma dostępu do mojego sprzętu z zewnątrz?

Pojawił mi się plik na pulpicie no i wątpię abym lunatykował zwłaszcza dwie godziny temu.

"ls -l | grep 'Jak być śmiesznym? (i dlaczego ludzie się śmieją) | Polimaty #101Polimaty • 218 tys. wyświetleniaNa żywo27:32Playlista ()Składanka (50+).desktop' | awk '{print $6 , $7 , $8}'
paź 18 09:26 "

Aktualizacja, jednak będzie trzeba się gdzieś wybrać ponieważ plik jest skrótem do strony a ja tego nie robiłem.

[Desktop Entry]
Encoding=UTF-8
Name=Dowiązanie do Jak być śmiesznym? (i dlaczego ludzie się śmieją) | Polimaty$
Type=Link
URL=https://www.youtube.com/watch?v=VZOtPOsGJrg
Icon=text-html



 

6
Inne / Dzielenie sieci, nadawanie masek
« dnia: 2018-09-07, 19:37:26 »
Podpowie ktoś albo podrzuci materiał gdzie nauczę się nadawać maski na utworzone podsieci?
Mam na przykład adres do podziału 192.168.192.0 /20 i połączenia między routerami powinny mieć maskę /30 a pomiędzy hostami maskę /24 natomiast podsieci musi być 10.

7
Inne / JS w gulpie
« dnia: 2018-09-01, 21:02:49 »
Nieaktualne.

8
Emulacja / Savy, import wiedzmin1 i 2
« dnia: 2018-08-27, 01:21:10 »
Gdzie znajdę savy do wiedzmina 1 ( play steam ) i gdzie je wkleić aby 2 -ka je złapała?

The Witcher folder ma z 5 plików strasznie mało,pomimo jego kasacji gra dalej trzyma zapisy wiec muszą być gdzie indziej, jakkolwiek ten folder oraz pliki(na zmianę ) wklejałem do
~/.local/share/cdprojektred/witcher2/GameDocuments/

oraz

~/.steam/steam/userdata/60114480/20920/remote

No i nic ( ten drugi jest od chmury tak wiem )

Problem rozwiazany zapomniałem po katalogach wine przelecieć.

9
Karty graficzne / Problem z instalacją nvidia 396.54
« dnia: 2018-08-22, 03:45:28 »
Mam problem z instalacją sterwników do kary  gefore 740m, karta jest dalej wpierana.
instalacja przez ppa czy z pliku kończy się failem niestety i nie wiem jak  zainstalować najnowsze sterowniki.

https://www.nvidia.com/Download/driverResults.aspx/137211/en-us

sudo apt install nvidia-driver-396
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 nvidia-driver-396 : Wymaga: libnvidia-gl-396 (= 396.51-0ubuntu0~gpu18.04.1) ale nie zostanie zainstalowany
                     Wymaga: nvidia-dkms-396 (= 396.51-0ubuntu0~gpu18.04.1) ale nie zostanie zainstalowany
                     Wymaga: libnvidia-compute-396 (= 396.51-0ubuntu0~gpu18.04.1) ale nie zostanie zainstalowany
                     Wymaga: nvidia-compute-utils-396 (= 396.51-0ubuntu0~gpu18.04.1) ale nie zostanie zainstalowany
                     Wymaga: libnvidia-decode-396 (= 396.51-0ubuntu0~gpu18.04.1) ale nie zostanie zainstalowany
                     Wymaga: libnvidia-encode-396 (= 396.51-0ubuntu0~gpu18.04.1) ale nie zostanie zainstalowany
                     Wymaga: nvidia-utils-396 (= 396.51-0ubuntu0~gpu18.04.1) ale nie zostanie zainstalowany
                     Wymaga: libnvidia-ifr1-396 (= 396.51-0ubuntu0~gpu18.04.1) ale nie zostanie zainstalowany
                     Poleca: libnvidia-compute-396:i386 (= 396.51-0ubuntu0~gpu18.04.1)
                     Poleca: libnvidia-decode-396:i386 (= 396.51-0ubuntu0~gpu18.04.1)
                     Poleca: libnvidia-encode-396:i386 (= 396.51-0ubuntu0~gpu18.04.1)
                     Poleca: libnvidia-ifr1-396:i386 (= 396.51-0ubuntu0~gpu18.04.1)
                     Poleca: libnvidia-gl-396:i386 (= 396.51-0ubuntu0~gpu18.04.1)
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.

10
Konfiguracja / Dwujęzyczne nazwy folderów
« dnia: 2018-07-29, 01:20:15 »
Dopiero zauważyłem  że nazwy mi się dubluję.
System mam polskojęzyczny, menadżer plików normalnie wszystko widzi ale w terminalu aby dojść do plików muszę używać anielskich nazw, jeżeli coś przeniosę na "pulpit" to jest to niewidoczne dla "desktop".
Jak to naprawić?

11
Inne / Podstawowa aplikacja do wideo.
« dnia: 2018-05-12, 20:59:59 »
Podstawowa aplikacja do wideo nie reaguje na pliki, w ogóle się nie uruchamia.
Jak ją przywrócić do życia?

12
/dev/null / Grub
« dnia: 2018-04-28, 22:13:53 »
Nieaktualne

13
Sieć / NETKIT
« dnia: 2018-04-03, 19:24:17 »
Po wrzuceniu 3 komend exportu i dołożeniu ich do bashrc mam coś takiego przy sprawdzaniu pliku konfiguracyjnego.
Nie znajduje konsoli i jest problem z typem plików
https://imgur.com/a/Y5k5g

Ubuntu 17.10

14
Instalacja oprogramowania / Xampp i Mysql
« dnia: 2018-03-07, 23:27:17 »
Po instalacji xampp nie startuje MySql, ręcznie go powinienem doinstalować?
https://imgur.com/a/AYm4w
https://imgur.com/a/AfrFR
W opt/lampp Folder mysql posiada tylko readmi i folder scripts z plikiem.sh

W /etc/mysql$ ls
conf.d  my.cnf  my.cnf.fallback

Normalnie Xampp powinien przecież dołączyć mysql.

Ubuntu 17.10 / unity.


15
Programy graficzne / Video player
« dnia: 2018-02-28, 18:04:18 »
Po aktualizacji do 17.10 podstawowy odtwarzacz viedo po kilku sekundach się zacina, jak go reinstalować?

Strony: [1] 2