Nowe posty

Pokaż wiadomości

Ta sekcja pozwala Ci zobaczyć wszystkie wiadomości wysłane przez tego użytkownika. Zwróć uwagę, że możesz widzieć tylko wiadomości wysłane w działach do których masz aktualnie dostęp.


Pokaż wątki - Dominik Cebula

Strony: [1] 2
1
Urządzenia sieciowe / kernel 2.6.28+sagem fast 800 e4
« dnia: 2009-07-03, 22:42:28 »
witam

Przed wczoraj siadł mi na mieszkaniu komputer, który pełnił rolę routera.
Miałem na nim Arch Linux-a na kernelu 2.6.24, sterowniki ueagle-atm. Modem chodził bez problemu.

Teraz jestem zmuszony zainstalować modem na laptopie, mam tu kernel 2.6.28, więc sterowniki pod E4 są już w kernelu, więc używam ueagle-atm z kernela. Modem dłuuugo się synchronizuje, ale w końcu diody się stabilizują, jednak pppd wypisuje ciągle:
Plugin pppoatm.so loaded.
PPPoATM plugin_init
PPPoATM setdevname_pppoatm - SUCCESS:0.35
Using interface ppp0
Connect: ppp0 <--> 0.35
LCP: timeout sending Config-Requests
Connection terminated.
Modem hangup
W dmesg znajdują się takie dane:
http://wklej.org/id/115876/

Czy ktoś może powiedzieć co jest nie tak?
Firmware oczywiście wgrany :)

2
Sieć / xbox 360+iptables+mtu
« dnia: 2008-11-14, 07:36:45 »
witam

Oto mój skrypt firewalla:
http://phpfi.com/377753
xbox 360 jest na ip 192.168.0.3

Problem polega na tym, że kiedy odkomentuje trzy liniki z przekierowaniem portów na xbox-a 360, są problemy z połączeniem z xbox live, w teście sieci nie przechodzi testu MTU. Gdy porty nie są przekierowane wszystko chodzi ok, czy ktoś może mi pomóc?
Dodam, że za tym routerem stoi równiez 192.168.0.2 - mój laptop i nie ma problemów z MTU - wszystkie strony www chodzą OK - prawdopodobnie dzięki tej linice:
iptables -I FORWARD -p tcp --tcp-flags SYN,RST SYN -j TCPMSS --clamp-mss-to-pmtu
Moje łącze to neostrada.

EDIT: okazuje się, że dopisanie -i ppp0 do linijek w, których przekierowuje porty pomogło

3
Inne / midnight commander+długie ładowanie
« dnia: 2008-08-20, 13:30:57 »
witam

Mam problem z mc, strasznie długo się ładuje. Na strace widać, że probuje łączyć sie z DNS-em, tutaj cały plik strace: http://phpfi.com/345535

Szukałem trochę po google, problem polega chyba na tym, że mc probóje znaleźć nazwę mojego komputera na podstawie adresu ip. Niestety mam neostradę, a więc zmienne ip, MC czepia się interfejsu ppp0, sprawdza czy taki wpis ip jest w /etc/hosts, jako że go nie ma probuje połączyć się z DNS. Jeżeli do /etc/hosts wpisze linikę:

83.29.*.*      dominik      dominik

to wtedy mc ładuje sięnormalnie, niestety ponieważ moje ip jest zmienne musiałbym aktualizować plik /etc/hosts za każdym razem kiedy dostane nowe ip. Czy zna ktoś jakieś sensowne rozwiązanie problemu z MC?

4
witam


Dwa dni temu zainstalowalem sobie linuxa na swoim nowym laptopie, jesli chodzi o dystrybucje jest to Arch Linux, jadro 2.6.24.1, wersja alsy to 1.0.15. Mam problem z mikrofonem, ani wbudowany, ani podpiety do laptopa nie dziala. Na poczatku mialem problem z samymi glosnikami wbudowanymi, mimo podlaczenia glosnikow zewnetrznych glosniki wbudowane caly czas graly, okazalo sie ze rozwiazanie tego problemu to przekazanie odpowiedniego parametru do sterownika, a wiec do modprobe.conf dopisalem:
options snd-hda-intel model=toshiba
Problem z glosnikami zniknal, teraz kiedy wloze wtyczke od zewnetrznych glosnikow, wbudowane glosniki zostaja wyciszane i graja tylko glosniki zewnetrzne. Jednak po dopisaniu tej liniki do modprobe.conf mikrofon przestal dzialac. W momencie kiedy usune ta linike, mikrofon dziala, ale jest problem z glosnikami, jezeli ja zostawie, to wtedy dzialaja glosniki, a mikrofon nie, czy ktos moze mi pomoc?

5
Komunikatory / DotGadu - protokół Gadu-Gadu w .NET
« dnia: 2008-02-15, 19:00:22 »
witam

Od jakiegoś czasu w wolnych chwilach pisze sobie bibliotekę do obsługi Gadu-Gadu, dzisiaj wydałem pierwszą wersję, jeżeli ktoś jest zainteresowany to zapraszam na:
http://dotgadu.sourceforge.net/
biblioteka działa pod linux, windows, mac os x

6
Komunikatory / Gnu Gadu 2+audacious
« dnia: 2008-02-08, 11:29:45 »
witam

ostatnio w ramach "oderwania" sie od sesji napisalem sobie wtyczke do Gnu Gadu 2, ktora ustawia opis gg w zaleznosci od sluchanego utwory w audacious, Gnu Gadu 2 co prawda od jakiegos czasu jest juz nie rozwijane, ja jednak lubie ten komunikator, a poniewaz brakowalo mi wtyczki do audacious napisalem sobie swoja wlasna, udostepniam bo pomyslalem ze moze sie komus przydac.

mozna sciagnac tutaj:
http://audaciousstatus.sourceforge.net/

7
witam

Mam neo 1mbit/s i modem Sagem Fast 800 E4. Komputer z ktorego pisze i na ktorym zawsze ten modem chodzil bez problemu robil jako router na mieszkaniu. Nigdy nie bylo z nim zadnych problemow. Teraz musialem go przerobic na stacje robocza bo niestety moj laptop znajduje sie na serwisie. Jesli chodzi o sprzet to jest to AMD Duron 1GHz, 512 MB RAM DIMM 133, ogolnie sprzet nie jest pierwszej mlodosci ;-)
Jesli chodzi o dystrybucje to mam Arch Linux, kernel 2.6.23. Sterownik do sagema to ueagle-atm, probowalem roznych wersji ale na wszystkich to samo, aktualnie modul na zrodlach z svn.
Problem polega na tym ze, kiedy porzadnie obciaze komputer, odpale np. naraz: rtorrent, aMule, friefoxa, thunderdibrda, na firefox otworze pare zakladek i jeszcze cos z flashem polaczenie sie wiesza...
ale nie w taki "zwykly" sposob, typu utrata synchronizacji, potem modem odzyskuje synchronizacje i pppd juz laczy jescze raz, nic nie pomoga, tylko wylaczenie i wlaczenie modemu z usb lub przeladowanie modulu ueagle-atm. Co ciekawe jezeli zostawie np. komputer z wlaczonym tylko rtorrentem na np. jakies 18h, po 18h wszystko chodzi ok, co prawda neostrada moze sie rozlaczy ale potem sie sama podlaczy bez problemu...
Czy ktos z was spotkal sie z takim problemem?

8
witam

Post ten prosze potraktowac powaznie, bardzo prosze o KONSTRUKTYWNE komentarze, nie rzucanie tekstow typu win to shit itd.
Chcialbym poczytac wypowiedzi ludzi, ktorzy znaja chociaz czesciowa obie opisane tu technologie.

    Pisze ten post poniewaz musze podjac pewna decyzje, ktora moze miec dosc duzy wplyw na maja przyszla kariere zawodowa.
    Na poczatku powiem cos o sobie :), aktualnie jestem studentem 3 semestru informatyki, jaka specjalizacje zamierzam wybrac sobie Inzynierie Oprogramowania. Samym programowaniem zajmuje sie od 6 klasy szkoly podstawowej, od 3 klasy gimnazjum jestem uzytkownikiem linuxa i naprawde jestem zadowolny z tej decyzji o przesiadce windows->linux, ktora podjalem dawno temu.
    Jako ze moje studia trwaja 7 semestrow, chyba juz pora pomyslec powaznie o pracy, przyszlym zatrudnieniu, tutaj wlasnie pojawia sie moj problem.
    Od Jakiegos czasu przegladam rozne serwisy z ofertami pracy, nie trudno zauwazyc ze najwiecej ofert pracy dzisiaj jest w nowych technologiach, czyli .NET lub Java. Na dzisiejszy dzien programuje w .NET uzywajac jezyka C# oraz w Java, narazie jednak tworze tylko aplikacje okienkowe, a wiec WindowsForms dla .NET oraz Swing dla Javy. Zauwazylem rowniez ze znaczniej prosciej jest sie "wstrzelic" w rynek technik internetowych. W tym momencie zupelnie nie moge sie zdecydowac czy wybrac ASP .NET 2.0 czy moze jednak poswiecic swoj czas i poczuczyc sie pisania Servletow,JSP,JSF, sprobowac Springa, Hibernate, poczytac cos o EnterpriseJavaBeans.
    Platforma microsoftu z jednej strony pociaga mnie poniewaz wiem ze firma ta dostarcza IIS, baze danych ktora jest SQL Server, server smtp, pop3, wszystko to moze stac np. na Windows 2003 Server, do tego mam bardzo przyjemne srodowisko jakim jest VisualStudio. Wszystkie te produkty bardzo ladnie sie ze soba integruja, wiekszascia z tych produktow mozna rowniez "zarzadzac" piszac swoje programy w .NET (wiecie o co chodzi :)). Do tego swietna dokumentacja MSDN, support ze strony firmy, po prosty wydaje mi sie ze wybierajac wlasnie rozwiazania microsoftu mniej sie urobie niz wybierajac Java i roziwazania OpenSource. Z drugiej jednak strony wszystko to co do tej pory wymienilem to technologie ClosedSource, co niestety jest sprzeczne z moimi idealami :( Zawsze popieralem OpenSource cenilem sobie ta "wolnosc" jaka daje mi OpenSource, ciezko mi tak po prostu to porzucic. Z drugiej strony jest platforma mono, ktora jest OpenSource i umozliwia tworzenie aplikacji na windows, linux, mac os x, do tego jest mod_mono do apache, ktory daje nam XSP, czyli mozliwosc tworzenia aplikacji internetowych w OpenSource, pod wszystkie platformy.
    Java z kolei jest rowniez bardzo dobra platforma, ma duze mozliwosci, tak jak juz powiedzialem J2EE czyli JSP,JSF,Servlety,Spring,EJB daja mozliwosc tworzenia naprawde dobrych aplikacji internetowych i do tego jest OpenSource oraz kontenery J2EE czy to TomCat czy JBOSS stawia sie glownie na platformach unixowych, w tym linux. Niestety wada jest to ze nie jest tak zintegrowana z innymi rozwiazaniami jak platforma microsoftu. SUN tworzy sama maszyne wirtualna, server HTTP tworzy apache, kontener rowniez (tomcat), baze moge sobie wziasc np. MySQL, Oracle albo PostreSQL, a jezeli mamy jakis wiekszy projekt to trzeba sie wziasc za ant albo mavena (budowanie projektu). Jesli chodzi o srodowisko to SUN oficjalnie poleca NetBeans, ktoremu do idealu naprawde duzo brakuje, zwlaszcza jezeli porownamy go z VisualStudio. Z NetBeans mam zreszta bardzo ciekawe doswiadczenia, jest bardzo wkurzajacy podczaas tworzenia duzych formularzy (mowie tu o okienkach w swing). Sami widzicie, kazdy robi co innego :( Do tego musze powiedziec ze jesli chodzi o przenosnosc  aplikacji to naprawde nie jest tak ze jedna aplikacja tak samo chodzi na
windows,linux,mac os, ja zawsze zakladam ze chodzi tak samo w 90% :P, jezeli ktos nie wierzy to znaczy ze chyba za malo w Javie pisal :]  (albo ja sie myle :P). Wybierajac jednak ta opcje zachowam twarz i nie przejde nagle z OpenSource->ClosedSource.
    Wiec sami wydzicie, wybor .NET a Java jest dosc trudny i naprawde nie wiem co wybrac, w czym sie specjalizowsc, a wiec pomozcie bo spac po nocach nie moge ;-)

(jezeli cos napisalem niejasno, nielogicznie to przepraszam, jest juz dosc pozno i moja percepcja pisania klarownych tekstow moze nie byc doskonala)

9
Gry / quake4 pod linux i error
« dnia: 2005-10-30, 12:09:09 »
witam

mam problem z odpaleniem quake4 pod linux, wyskakuje mi taki blad:

ERROR: SDL_GL_LoadLibrary libGL.so.1 failed: Could not load OpenGL library
Sys_Error: SDL_GL_LoadLibrary libGL.so.1 failed: Could not load OpenGL library

Mam karte GeForce 2 Ti, zainstalowane sterowniki nvidia i lib SDL, doinstalowalem tez mesa3d najnowsze i dalej nie chodzi, czy ktos moze mi pomoc?? Mam slack 10.2

10
witam

dzisiaj podczas proby zwiekszenia rozmiaru partycji ext3 za pomoca Partition Magic 8.05 wyskoczyl mi jakis blad. Po tym znikla mi jedna partycja ext3 nad ktora program pracowal. Znajduje sie tam troche danych ktore chcialbym odzyskac, ale nie wiem dokladnie jakich narzedzi uzyc do tego. Prosze wiec o podanie nazw programow ktore potrafia w CALOSCI odzyskac partycje ext3, nie tylko pojedyncze pliki czy foldery, ale ktora po prostu przywroci mi ta partycje. Moga to byc aplikacje zarowno pod windowsa i linux, komercyjne jak i niekomercyjne. Zalezy mi na narzedziach sprawdzonych :)

aktualnie uzywam:
Kernel Recovery for EXT2 & EXT3 - Linux Data Recovery Software
pozawala on wyciagnac pliki z dysku i zapisac do innej lokalizacji, nie potrafi przywrocic partycji na dysku.

11
Instalacja oprogramowania / arch64, firefox i flash :]
« dnia: 2007-03-16, 14:05:42 »
witam

mam archa64, czy jest jakas mozliwosc zeby odpalic flasha?

firefoxa 32 bit nie zainstaluje bo pod arch64 nie mam zadnych libow pod 32bit, probowalem tez nspluginwrapper ale ze wzgledu na brak 32 bit libow tez nie dziala...

12
Konfiguracja / hp nx7400 i linux
« dnia: 2007-03-16, 14:03:47 »
witam

zainstalowalem sobie wlasnie arch64 na swoim laptopie hp nx7400
nie moge sobie poradzic ze zmuszeniem guzikow przyciszania i podglasniania dzwieku do dzialania
po odpaleniu acpid dziala jedynie guzik wyciszania

w /dev (nie pamietam dokladnej sciezki) sa dojscia do tych guzikow, ale kiedy probowalem naisac wlasny skrypt do acpid to w ogole nie dostaje eventow od tych buttonow

13
Napędy CD/DVD / problem z LITE-ON DVDRW SHM-165P6S
« dnia: 2006-12-18, 22:22:16 »
witam

Mam problem z nagrywarka LITE-ON DVDRW SHM-165P6S, nie wiem dlaczego ale nagrywarka wyciaga max speed 3x (nagrywarka moze nagrywac z max predokoscia 16x), nagrywam za pomoca k3b 0.12.17, inne rzeczy ktore wykorzystuje k3b:
cdrdao 1.2.2
cdrecord 2.1
dvd+rw-format 6.1
growisofs 6.1
mkisofs 2.1
normalize 0.7.6
readcd 2.1
sox 12.18.1
podczas nagrywania mam tez strasznie obciazony pc, load average dochodzi nawet do 2.17

pod Windows XP wszystko chodzi ok

jeszcze pare informacji:
kernel: 2.4.33.3
bash-3.1# hdparm -i /dev/hdc

/dev/hdc:

 Model=LITE-ON DVDRW SHM-165P6S, FwRev=MS0P, SerialNo=
 Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
 RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
 BuffType=unknown, BuffSize=0kB, MaxMultSect=0
 (maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
 IORDY=yes, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio3 pio4
 DMA modes:  sdma0 sdma1 sdma2 sdma? mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 *udma2
 AdvancedPM=no
 Drive conforms to: Unspecified:  ATA/ATAPI-4 ATA/ATAPI-5 ATA/ATAPI-6 ATA/ATAPI-7

 * signifies the current active mode

bash-3.1# hdparm -d /dev/hdc

/dev/hdc:
 using_dma    =  1 (on)

14
Konfiguracja / kernel z nieoficjalnej paczki
« dnia: 2006-05-09, 14:11:23 »
skonfigurowalem server pppoe, drugi komp laczy sie z serverem, wykrywa go i widzi bez problemu... ale jak sie polaczy z serverem to pisze ze sprawdza nazwe uzytkownika i haslo i tak stoi... stoi a potem sie rozlacza z kodem 619
w logu cos takiego jest:
http://www.phpfi.com/116908

na drugim kompie stoi winxp, probowalem sie laczyc uzywajac sterownikow PPPoE z winxp a takze raspppoe, ale w zadnym przypadku nie udalo sie zakonczyc pomyslnie polaczanie.

W pliku chap-secrets mam:
# Secrets for authentication using CHAP
# client        server  secret                  IP addresses
\\"czester21\\" * \\"czester21\\" 10.0.0.2

w pliku options:
mtu 1492
mru 1492
-pap
+chap
ms-dns 194.204.152.34
ms-dns 217.98.63.164

w pppoe-server-options:
# PPP options for the PPPoE server
# LIC: GPL
require-chap
lcp-echo-interval 20
lcp-echo-failure 10


server uruchamiam poleceniem:
pppoe-server -I wlan0 -N 1024 -C czester21 -L 10.0.0.1

wlan0 jest postawiony jako 0.0.0.0, czyli pusty interfejs :]

15
Urządzenia sieciowe / Położenie karty ralink.
« dnia: 2006-04-29, 09:48:40 »
witam

mam kernela 2.6.16.11, usiluje na niego zainstalowac drivery nvidi w ver. 7174, niestety mam problem:

tutaj jest log:
http://members.lycos.co.uk/czester21/nvidia-installer.log

glownie rozchodzi sie o ten blad:
structure has no member named `rlim\\'

najnowsze stery kompiluja mi sie pod tym jadrem bez problemu, ale najnowsze juz nie obsluguja mojej karty graficznej geforce 2 ti, 7174 to ostatnia ver. ktora ja obsluguje, a ich niestety nie moge skompilowac...

Strony: [1] 2