Nowe posty

xx Zlecę skrypt w bashu (0)
2020-02-19, 14:07:39
xx Nadawanie praw katalogom takich, jak nazwa usera (4)
2020-02-17, 14:15:18
xx Fedora na laptopie HP 15-bs152nw brak wifi (44)
2020-02-16, 12:17:18
xx Komputer do nauki linuxa (10)
2020-02-15, 07:03:28
xx Patronat serwisow internetowych. (1)
2020-02-13, 00:13:24
xx Xfce-terminal v 0.8.7.4 - jak ustawić wklejanie skopiowanego tekstu? (3)
2020-02-12, 18:59:24
xx HD ISO, jak odzyskać starsze pliki (6)
2020-02-12, 10:54:31
xx QEMU KVM gpu passthrough brak obrazu (4)
2020-02-11, 17:05:06
xx i7-9700 + Intel H370 (0)
2020-02-11, 12:36:55
xx Co to jest .xsession-errors.old ? (1)
2020-02-09, 22:55:09

Pokaż wiadomości

Ta sekcja pozwala Ci zobaczyć wszystkie wiadomości wysłane przez tego użytkownika. Zwróć uwagę, że możesz widzieć tylko wiadomości wysłane w działach do których masz aktualnie dostęp.


Pokaż wątki -

Strony: [1] 2 3 ... 6
1
PHP, *SQL / Wyszukiwanie zawartości tagu pre w HTML
« dnia: 2012-08-26, 13:04:39 »
Hej

Od kilku wieczorów staram się napisać prosty skrypt w PHP, który wyszuka mi tekst w tagach:
 ... 
Napisałem takie oto wyrażenie regularne i podpiąłem je do polecenia preg_replace_callback

||()|
Problem mój polega na tym, że wyrażenie to znajduje najdłuższe wystąpienie takiego oto wzorca, czyli wewnątrz może znaleźć się kilka innych fragmentów:
 
...
.
Jak zmusić wyrażenie regularne/PHP żeby szukał najkrótszych wystąpień takiego oto wzorca?

Dziękuję za pomoc :)

Pozdrawiam

2
Java / Jak połączyć razem GWT i JPA (Java)
« dnia: 2011-07-03, 21:21:36 »
Hej

Jako że najczęściej otrzymuję tutaj porady do moich problemów programistycznych postanowiłem zmajstrować jeszcze jeden post.

Otóż chciałbym skorzystać z JPA w moim projekcie GWT w wersji: 2.3.0.

Otóż już praktycznie wszędzie wsadziłem mój plik persistence.xml (włączając META-INF i  WEB-INF), a ciągle dostaję Exceptiona:

No Persistence provider for EntityManager named JPAandGWT
Chociaż w pliku persistence.xml jest JPAandGWT unit :/

W zasadzie już wypróbowałem ze 1000 różnych kombinacji i metod jak się dobrać do bazy danych, ale ciągle wywala ten sam exception.

Wydaje mi się że po prostu nie potrafi znaleźć tego pliku persistence.xml.

Czy ktoś może ma jakąś poradę?

Pozdrawiam :)

3
Hej

Mam 4 letniego laptopa marki Acer :P Odkąd go mam zawsze działał na nim Ubuntu i nigdy nie miałem problemu z jego instalacją aż do teraz.

Wkładam płytkę instalacyjną, rusza a potem "black screen":

http://imageshack.us/photo/my-images/808/foto0081n.jpg/

Nie mam pomysłu jak mógłbym zainstalować teraz na nim Ubuntu.

Nie wiem czy w tym tkwi przyczyna ale wymieniłem ostatnio kości ramu z 2 x 512 na 2 x 1gb.

Widać że nie może załadować chyba jakiś sterów czy coś....

Dzięki za pomoc :)

4
C/C++ / Wybór algorytmu szyfrowania - własna implementacja.
« dnia: 2011-05-04, 15:09:44 »
Hej

Na zajęcia muszę zaimplementować wybrany przeze mnie algorytm szyfrowania.

Nie mogę wybrać niestety RSA. Może to być to alg. symetryczny bądź asymetryczny.

Czy ktoś może mi doradzić w wyborze dość prostego w implementacji i "poważnego" algorytmu (Jakiś szyfr przesuwny odpada :P).

5
Java / Problem z Javą, a dokładnie z Javą 3D
« dnia: 2011-01-09, 10:02:14 »
Hej

Mam taki problem. Musiałem w przestrzeni 3D wyświetlić wykres danej funkcji f(x,y).
Nie było z tym problemów, wyznaczyłem sobie punkty, następnie połączyłem je odpowiednio tak że wyszła siatka. Napisałem to w Jave 3D.

Ale zacząłem kombinować i pomyślałem sobie że fajnie jakby punkty były połączone nie liniami, a były wierzchołkami poligonów tak że cały wykres jest płaszczyzną.

Obkminiłem jak to zrobić, narysował mi program płaszczyznę.

Tutaj pojawia się problem.

Nie wiem jak to wytłumaczyć ale po obróceniu mojego wykresu jest on niewidoczny.
Tzn tak jakby z jednej strony pojedynczy poligon jest widoczny a gdy zajrzy się na niego od drugiej strony (od tyłu, np po obrocie w osi X) jest niewidoczny.

Nie mam ustawionego żadnego oświetlenia, ponieważ jeszcze nad tym będę pracował.

Być może ktoś kto korzysta z OpenGL będzie wiedzieć co jest grane, o czym ja zapomniałem albo co ja głupio zrobiłem.

Oto kawałek kodu:



    private QuadArray drawQuadArray(ArrayList points)
    {
        QuadArray quadArray = new QuadArray (1000000, QuadArray.COORDINATES);
        Point3d[] pointsArray = points.get(0);
        int dimension = pointsArray.length; //Pobieram jaka jest długość wymiaru X

        int i=0;        
       
        for(int j=1 ; j        {
            for(int k=1 ; k            {
                Point3d a = points.get(k)[j];
                Point3d b = points.get(k-1)[j];
                Point3d c = points.get(k)[j-1];
                Point3d d = points.get(k-1)[j-1];
                quadArray.setCoordinate (i++, a);
                quadArray.setCoordinate (i++, b);
                quadArray.setCoordinate (i++, d);
                quadArray.setCoordinate (i++, c);
               
                //System.out.println(a + " " + b + " " + c + " " +d);
            }
        }
        return quadArray;
    }
Kod oczywiście jest poglądowy :P

W ArrayList points trzymam punkty które chcę połączyć.

Wdzięczny byłbym za każdą wskazówkę. Może jak dodam materiał z jakiego jest obiekt wykonany i oświetlenie to coś to zmieni ??

Pozdrawiam :)

6
X Serwer / Ubuntu 10.04, problem z GDM
« dnia: 2010-09-19, 22:38:13 »
Witam

Mam Ubunciaka w takiej wersji, kartę grafiki Nvidia GeForce GO 7300 (zainstalowane sterowniki).

Problem polega na tym, że jak od czasu do czasu włączam PC to ixy się włączają ale nie pojawia się okienko z możliwością zalogowania. Trochę jest to denerwujące. Próbowałem je reinstalować oraz zmienić gdm na kdm ale wtedy xy mi poleciały i przywróciłem znów gdm.

Czy może ktoś wie co jest nie tak?

Dzięki :)

7
Administracja / Problem z serwerem Thin, nagłe pady
« dnia: 2010-08-27, 14:06:29 »
Hej

Mam aplikację w Rails, działała ona przez pewien czas na serwerze Mongrel. Niestety oprogramowanie to było bardzo ślamazarne i często serwer się wyłączał bez jakieś przyczyny. Zmieniłem serwer na Thin. Przez kilka miesięcy nie było żadnego problemu. Teraz znów pojawił się syndrom padającego serwera. W ciągu kilku dni padł już drugi raz. Po prostu sam się wyłączył. W logach Rails nic szczególnego nie zauważyłem.

Serwer działa na Debianie. Czy ktoś może mi poradzić co zrobić?

Generalnie dobrym pomysłem by był jakiś program monitorujący czy Thin działa.

Dzięki za podpowiedzi jak poradzić sobie z Tym problemem.

8
PHP, *SQL / Netbeans, PHP oraz chmod
« dnia: 2010-08-23, 09:54:22 »
Hej

Od czasu do czasu zdarza mi się coś napisać w PHP. Używam w tym celu Netbeansa pod Linuxem. Czy ktoś wie jak zrobić aby domyślnie pliki zapisywały się na serwerze FTP z uprawnieniem 644 kiedy utworzę "PHP project form remote server"

Jakoś nie umiem tego znaleźć.

Dzięki za posty:)

9
Języki skryptowe / Proste wyrażenie regularne w PHP
« dnia: 2010-04-19, 13:52:46 »
Hej

Chciałbym zamienić kod html odpowiedzialny za wstawienie na stronę flasha na obrazek img.

W tym celu wygooglałem taką oto funkcję w PHP:

$tresc = preg_replace_callback(
                "/\\\\n\\\\r\\\\t]+<\\/object>/smi",
                "test",//'',
               $tresc) ;
Jak do tego wrzucić jeszcze to aby znalazł mi tylko flesha np z takiego adesu:

src="/flash/main.swf"

Dzięki za pomoc:)

10
Bash, skrypty powłoki / Automatyczny start procesu bo zwisie
« dnia: 2010-03-18, 10:29:53 »
Hej

Mam taki problem. W systemie działa mi proces, który w specyficznych warunkach wywala się :/. Jeszcze nie ustaliłem dlaczego, nic nie wypisuje do logów itp.

Chciałbym aby po jego "zwieszeniu" i jego zamknięciu następowało jego ponowne uruchomienie.

Myślałem o skrypcie podłączonym do Crona, który powiedzmy co 5 minut pobiera procesy działające w tle i sprawdza czy dany proces działa jeżeli nie to robi jego start.

Czy ktoś może mi powiedzieć czy idę w dobrą stronę?

Dodam że ten proces to serwer Mongrel.

11
Inne / Ruby On Rails
« dnia: 2010-02-17, 15:56:35 »
Witam

Zainstalowałem sobie gem install rails.

Jednak pod konsolą wydanie polecenia rails nie działa. Jak sobie z tym poradzić?

Pozdrawiam:)

12
Java / Problem z Eclipse pod Linuxem
« dnia: 2010-02-02, 12:06:36 »
Witam

Mam problem z wyśmienitym środowiskiem IDE - Eclipse pod Ubuntu 9.10.

Mianowicie buttony nie działają właściwie. Np. Klikam sobie w nowy projekt, wybieram typ projektu klikam w Next i nic się nie dzieje. Dziwna sprawa bo, gdy najadę kursorem myszy na button to zachowuje się on tak jak bym go kliknął :/ ale zawartość okna się nie zmienia. Tak samo miałem z RadRails. Czy ktoś może ma, lub miał taki problem i wie jak to rozwiązać.

Byłbym wdzięczny. Wiem że pod takim dziwnym systemem operacyjnym aczkolwiek dość popularnym Eclipse działa normalnie. THX

13
Inne / JQuery i click
« dnia: 2009-12-16, 12:48:38 »
Zdaję sobie sprawę, że jest to forum Linuksowe, ale od czasu do czasu lubię coś tu napisać odnośnie programowania aby stali bywalcy się nie znudzili:P

Więc:


Mam problem następujący. Mam linka Kod: [Zaznacz]




Temat:





Jak całość działa?

Formularz jest uzupełniany następnie user klika Wyślij, aktualizuje się mailto i wywoływane jest okienko programu pocztowego :)

Dzieki za posty

14
Inne / Dobry kilent FTP
« dnia: 2009-11-19, 09:42:13 »
Witam

Czy ktoś może mi polecić dobry klient FTP. Do tej pory używałem Gnome Commander. Jednak w pełni on mi nie odpowiada. Chciałbym aby miał on możliwość otwarcia pliku tekstowego (ściągnięcie go na dysk automatycznie), następnie była by możliwa jego edycja. Po zapisaniu zmian w edytorze i jego zamknięciu, wysyłałby plik automatycznie na serwer. Wiem że takie mechanizmy mają zaawansowane klienty ftp. A jeszcze czegoś takiego dla Linuksa nie znalazłem.

Może ktoś się podzieli swoimi doświadczeniami, jak jeszcze można jeszcze wygodnie korzystać z ftp pod Linuksem.

Dzięki;]

15
X Serwer / VirualBox + Debian + Xorg
« dnia: 2009-11-12, 20:35:54 »
Witam

Zainstalowalem sobie Debina na VirtualBox. Chcialem zrobic tak aby maksymalnie byl on okrojony i samemu wszystko doinstalowac. Na razie mam tylko xorg-a, jwm oraz Iceweasel. Nie mam tez jeszcze obslugi polskich znakow i klawiatury.

Problem mam taki ze rozdzielczosc w jakiej startuja ixy jest spora. Chcialbym aby byla 1024 x 768.

moj xorg.conf wyglada tak (po kilku modyfikacjach):

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "pl"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
        Identifier      "SM"
        UseModes        "tryb1"
        Option          "PreferredMode"         "1024x768_85.00"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "ATI Technologies, Inc. Radeon RV250 If [Radeon 9000]"
        Monitor         "SyncMaster"
        DefaultDepth    24
        SubSection "Display"
                Depth           24      
                Modes           "1024x768_85.00-setka" # "1280x1024_85.00"
        EndSubSection
EndSection
Probowalem rowniez z:

 dpkg-reconfigure xserver-xorg


Ale po odpaleniu skryptu nie mozna bylo wybrac rozdzielczosci obrazu :/

Hmm czy ktos wie jak zaradzic?

Dzieki

Strony: [1] 2 3 ... 6