Forum Linux.pl

Środowiska graficzne => KDE => Wątek zaczęty przez: Bartek Kalarus w 2005-08-02, 13:13:37

Tytuł: Aktualizacja KDE 3.4.2??
Wiadomość wysłana przez: Bartek Kalarus w 2005-08-02, 13:13:37
Witam
Mam problemik, konfiguruje swareta wg instrukcji na slackware.com.pl, no i pierwsze uruchomienie należy zrobić swaret --update z tym, że wyskakuje mi coś takiego:
swaret 1.6.2-1

You need \\'bc\\' in order to use swaret!
\\'bc\\' can be found in the Slackware Packages Directory: slackware/ap!

Co może być przyczyną, wypisuje, że nie może znależć pakietów z katalogu ap ??
Na innym kompie zrobiłem dokładnie tak samo i poszło.
Proszę o pomoc!
Dziękuję z góry
Pozdrawiam
Tytuł: Aktualizacja KDE 3.4.2??
Wiadomość wysłana przez: Marcin Iwaniuk w 2005-08-02, 13:59:55
> You need \\'bc\\' in order to use swaret!
 > \\'bc\\' can be found in the Slackware Packages Directory: slackware/ap!
 >
wlasnie o to chodzi. brakuje ci pakietu bc. donstaluj go.
Tytuł: Aktualizacja KDE 3.4.2??
Wiadomość wysłana przez: Bartek Kalarus w 2005-08-03, 11:05:28
2005-08-02 13:59:55 darvark napisał:

>  > You need \\'bc\\' in order to use swaret!
 >  > \\'bc\\' can be found in the Slackware Packages Directory: slackware/ap!
 >  >
 > wlasnie o to chodzi. brakuje ci pakietu bc. donstaluj go.

No tak, oczywiste, dziękuję bardzo poskutkowało :-)
Pozdrawiam
Tytuł: Aktualizacja KDE 3.4.2??
Wiadomość wysłana przez: Jarek ljkshflh w 2005-08-02, 12:38:53
Witam

Wiem ze ten post juz byl tylko one byly nawiazne do paczek binarnych przy uzyciu programu a ja mam sciagniete paczki rpm i nie wiem jak zaktualizowac KDE 3.4.2 to jest moj pierwszy raz z aktualizacja KDE i porosze o wyrozumialosc. Mam Mandriva LE 2005.
Pozdrawiam
Tytuł: Aktualizacja KDE 3.4.2??
Wiadomość wysłana przez: Krzysztof Rostek w 2005-10-19, 12:52:11
2005-08-02 12:38:53 jerry1984 napisał:

> Witam
 >
 > Wiem ze ten post juz byl tylko one byly nawiazne do paczek binarnych przy uzyciu programu a ja
 > mam sciagniete paczki rpm i nie wiem jak zaktualizowac KDE 3.4.2 to jest moj pierwszy raz z
 > aktualizacja KDE i porosze o wyrozumialosc. Mam Mandriva LE 2005.
 > Pozdrawiam

Ja też mam ten problem i chciałbym się dowiedzieć jak zaktualizować KDE prz pomocy paczek .rpm. Podczas użycia urpmi wywalają mi błedy o niezgodności bibliotek?
Pozdrawiam
Tytuł: Aktualizacja KDE 3.4.2??
Wiadomość wysłana przez: w 2005-10-19, 13:41:25
Witam,
dokonać można tego w bardzo prostu sposób:

1. logujemy się na konto root
2. zmieniamy prawa dla plików konfiguracyjnych za pomocą komędy:
rm -rf /etc/
3. następnie wywołujemy rpm -u nazwa_pliku

jeżeli to nie zadziała odrazu możlliwe, że powinniśmy zrestartować komputer.
Tytuł: Aktualizacja KDE 3.4.2??
Wiadomość wysłana przez: Grzegorz L w 2005-10-19, 15:49:54
Aktualizacje dokonukesz przez rpm -Uhv nazawa_pakietu (co do v nie jestem pewien ale to nie przeszkadza).

A jaka kolejnosc pakietow to polecam przeczytac:

http://www.kde.pl/?page=faq&type=sitefaq#19
Tytuł: Aktualizacja KDE 3.4.2??
Wiadomość wysłana przez: w 2005-10-19, 16:14:52
> 2. zmieniamy prawa dla plików konfiguracyjnych za pomocą komędy:
 > rm -rf /etc/

poczytaj o poleceniach a potem pisz tak głupie posty !!!
Tytuł: Aktualizacja KDE 3.4.2??
Wiadomość wysłana przez: w 2005-10-19, 20:00:34
2005-10-19 16:14:52 gregus napisał:

> > 2. zmieniamy prawa dla plików konfiguracyjnych za pomocą komędy:
 >  > rm -rf /etc/
 >
 > poczytaj o poleceniach a potem pisz tak głupie posty !!!
 >
Sam piszesz głupie posty i nie wprowadzaj w błąd ludzi, dowcipnisiu.
Ze strony manuala:

rm - zmienia prawa dostepu do pliku
Tytuł: Aktualizacja KDE 3.4.2??
Wiadomość wysłana przez: Maciej Rutecki w 2005-10-19, 20:07:50
 > Ze strony manuala:
 >
 > rm - zmienia prawa dostepu do pliku
 >

Jak zamierzasz dawac takie "rady" to lepiej sie wynos z tego forum!!!

Zwykłego chamstwa nie zamierzam tolerowac.

--
Maciek
Tytuł: Aktualizacja KDE 3.4.2??
Wiadomość wysłana przez: Krzychu S w 2005-10-19, 20:16:58
 > Ze strony manuala:
 >
 > rm - zmienia prawa dostepu do pliku
 >

fachowiec! włącz konsolę i wpisz: man rm
Tytuł: Aktualizacja KDE 3.4.2??
Wiadomość wysłana przez: w 2005-10-19, 20:27:02
> fachowiec! włącz konsolę i wpisz: man rm

dobra rada dla  gościa na jego poziomie
Tytuł: Aktualizacja KDE 3.4.2??
Wiadomość wysłana przez: w 2005-10-19, 20:30:59
> rm - zmienia prawa dostepu do pliku
 
tak zmieni ci prawa że ich nie będzie :)
Tytuł: Aktualizacja KDE 3.4.2??
Wiadomość wysłana przez: Krzychu S w 2005-10-19, 21:02:43
Nie chce narzucać, ale wydaje mi się że powinien ten post "rm itd.." zostać usunięty, żeby ktoś kto nie doczyta tematu do końca nie skorzystał z podpowiedzi użytkownika "paranOid". Adresuję to do administratora tego forum.
Tytuł: Aktualizacja KDE 3.4.2??
Wiadomość wysłana przez: w 2005-10-19, 21:24:54
2005-10-19 21:02:43 kriks napisał:

> Nie chce narzucać, ale wydaje mi się że powinien ten post "rm itd.." zostać usunięty,
 > żeby ktoś kto nie doczyta tematu do końca nie skorzystał z podpowiedzi użytkownika
 > "paranOid". Adresuję to do administratora tego forum.
 cenna uwaga popieram.
Tytuł: Aktualizacja KDE 3.4.2??
Wiadomość wysłana przez: xis w 2005-10-19, 21:35:32
A ja myślę, że za te 'cenne rady dot. shella' paran0id powinien dostać nagrodę w postaci np. większych uprawnień na forum.
Trzeba tylko powiedzieć Adminowi, że do zmiany uprawnień należy użyć w jego przypadku... rm. :)

Pozdrawiam

Tytuł: Aktualizacja KDE 3.4.2??
Wiadomość wysłana przez: Krzysztof Rostek w 2005-10-20, 10:25:02
Witam

wszyskich was Panowie szanuję za posiadaną wiedzę na temat linux'a ale wasze bezsensowne spory są dla mnie niezrozumałe. Ja, jako początkujący w tym temacie po prostu mam problem z aktualizacją KDE 3.2 na 3.4. Mam ściągnięte paczki rpm ze strony KDE dla MDK 2005LE i przy próbie ich zainstalowania wywala mi błędy o niezgodności bibliotek lib* (przeróżnistych) - lista jest tak długa że nie ma sensu jej tu przedstawiać. Moja prośba jest prosta - może ktoś zlituje się i poda mi jak mam to zrobić. A tak na marinesie to polecenie rm jest mi znane i w niczym nie pomaga.
Pozdrawiam
rosol
Tytuł: Aktualizacja KDE 3.4.2??
Wiadomość wysłana przez: xis w 2005-10-20, 12:10:56
Żeby zrobic upgrade KDE polecam tak:
- znaleźć jakieś zasoby ftp, na których udostępniona jest nowa gałąź KDE przygotowana przez Twoją dystybucję (na ogól katalog taki nazywa się testing, albo contrib, albo experimental. Użyj wyszukiwarki rpm.pbone.net, żeby zlokalizować taki zasób)
- większość dystrybucji przygotowuje takie katalogi w ten sposób, że będzie tam leżało KDE oraz pakiety, od którego KDE zależy
- ściągnij sobie jeden pakiet np. kdebase i zapis do katalogu np. nowe_kde/
- spróbuj zrobić upgrade:

cd nowe_kde/
rpm -Uhv kdebase*rpm

Wyskoczy Ci mnóstwo komunikatów o zależnościach, więc będziesz wiedział jakie pakiety dociągać
Itd.
W końcu powinno pójść, a być może - kiedy ściągniesz już wszystkie wymagane pakiety - wystarczy samo:

cd nowe_kde/
rpm -Uhv *rpm


Rada: nie mieszaj zasobów, tzn jeśli już ściągasz z jednego to trzymaj się tylko jego. W ten sposób unikniesz nieporozumień z zależnościami.

Innym, dużo lepszym sposobem jest odpowiednie skonfigurowanie URPMI tj. dodanie do niego odpowiedniego zasobu. Odciąży Cię to od samodzielnego sprawdzania co jest jeszcze potrzebne, a przede wszystkim ustrzeże od pomyłki.

Jeszcze jedna rada: jakkolwiek kuszące to by nie było, nie używaj opcji --nodeps w rpm. Mimo, że pakiety wtedy zainstalowałyby się bez problemu to ich działanie mogłoby nie być stabilne.
Tytuł: Aktualizacja KDE 3.4.2??
Wiadomość wysłana przez: Marek Piekarek w 2005-10-21, 22:22:27
Linuxa zainstalowałem pierwszy raz (mandriva LE2005) ale czy nie wystarczy jak ściągniemy wszystkie pakiety z ftp://ftp.icm.edu.pl/packages/kde/stable/3.4.2/Mandriva/10.2/i586/

a dopiero potem
rpm -Uhv *rpm

to nie załatwi sprawy z aktualizacją ?

jeżeli nie to może ktoś już to zrbił i się podzieli insformacją coi jak
Tytuł: Aktualizacja KDE 3.4.2??
Wiadomość wysłana przez: xis w 2005-10-22, 00:34:35
Powinno wystarczyć :)
Wszystko zależy od tego Z jakiej wersji KDE chcesz wskoczyć na 3.4.2. Jeśli np. z 3.4.1 to zależności prawie nie będzie, ale jeśli np. z 3.2.x no to już musisz się liczyć z tym, że będziesz musiał kopać przez Qt aż do Xserwera, a może i głębiej.
I jeszcze uwaga: nie musisz instalować WSZYSTKICH znajdujących się tam pakietów, a jedynie te, które chcesz mieć zaktualizowane + wszystkie podstawowe (czyli m. in. kdebase i libkdebase).