Forum Linux.pl

Sprzęt => Inne urządzenia => Wątek zaczęty przez: w 2006-06-15, 21:15:18

Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-15, 21:15:18
Witam.
Man Mandrake 10.1 Karta grafigi Nvidia GeForce2 MX400.Pentium 3.
Podjąłem próbę zainstalowania orginalnych sterowników ze strony Nvidii.
Pobrałem najnowszą wersję Nvidia-Linux-86-1.0-8762-pkg1.run
Następnie telinit 3 i instalacja sterowników. Niby przebiegła bez problemów.
W /etc/X11/xorg.conf instalator sam zmienił Driver z nv na nvidia i po wpisaniu telinit 5 zaczęło się uruchamianie niestety nie pojawiło się logo Nvidii tylko biały ekran który po chwili zmienił się na coś w rodzaju mozaiki z poprzeczncznych kresek i kompletne zawieszenie. Nie działało przełączanie na konsole ani inne znane mi kombinacje klawiszowe.
Co zrobiłem nie tak, a może sterowniki są zbyt świerze?
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-16, 17:12:42
2006-06-15 21:15:18 ozyr napisał:

> Witam.
 > Man Mandrake 10.1 Karta grafigi Nvidia GeForce2 MX400.Pentium 3.
 > Podjąłem próbę zainstalowania orginalnych sterowników ze strony Nvidii.
 > Pobrałem najnowszą wersję Nvidia-Linux-86-1.0-8762-pkg1.run
 > Następnie telinit 3 i instalacja sterowników. Niby przebiegła bez problemów.
 > W /etc/X11/xorg.conf instalator sam zmienił Driver z nv na nvidia i po wpisaniu telinit 5
 > zaczęło się uruchamianie niestety nie pojawiło się logo Nvidii tylko biały ekran który po
 > chwili zmienił się na coś w rodzaju mozaiki z poprzeczncznych kresek i kompletne zawieszenie.
 > Nie działało przełączanie na konsole ani inne znane mi kombinacje klawiszowe.
 > Co zrobiłem nie tak, a może sterowniki są zbyt świeze?
Tak się nieśmiało przypomnę bo nie wierzę że nikt nie potrafi i nie chce mi pomóc.
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-16, 17:27:28
 >  > Co zrobiłem nie tak, a może sterowniki są zbyt świeze?
 > Tak się nieśmiało przypomnę bo nie wierzę że nikt nie potrafi i nie chce mi pomóc.

Mam identyczny system i kartę GF 64 MB MX, te same sterowniki u mnie ruszyły bez problemu. Wątpię, zeby były zbyt świeże, bo przy poprzednich trzeba było doinstalowywać niektóre rzeczy do kernela, zeby zadziałało. tak jak piszesz instalator sam zmienia wpis w configu i nie powoduje to jakis problemów wiec pewnie nie w tym wina. Moze zależy to od srodowiska graficznego (mam KDE 3.2). Jeśli wcześniej przekompilowywałes jajko to mozliwe, ze czegoś nie doinstalowałeś...
Tytuł: winmodem
Wiadomość wysłana przez: Piotr Chmura w 2006-06-16, 18:17:42
w /var/log sa logi z uruchamiania X-ow - wartos sprawdzic - moze napisal, co mu sie nie podobalo...
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-16, 18:18:09
2006-06-16 17:27:28 sys napisał:

>
 >  >  > Co zrobiłem nie tak, a może sterowniki są zbyt świeze?
 >  > Tak się nieśmiało przypomnę bo nie wierzę że nikt nie potrafi i nie chce mi pomóc.
 >
 > Mam identyczny system i kartę GF 64 MB MX, te same sterowniki u mnie ruszyły bez problemu.
 > Wątpię, zeby były zbyt świeże, bo przy poprzednich trzeba było doinstalowywać niektóre rzeczy
 > do kernela, zeby zadziałało. tak jak piszesz instalator sam zmienia wpis w configu i nie
 > powoduje to jakis problemów wiec pewnie nie w tym wina. Moze zależy to od srodowiska
 > graficznego (mam KDE 3.2). Jeśli wcześniej przekompilowywałes jajko to mozliwe, ze czegoś nie
 > doinstalowałeś...
Ja mam też KDE3.2 a w jajku nic nie grzebałem jest orginalne takie jak z płyt instalacyjnych.
Tytuł: winmodem
Wiadomość wysłana przez: Dominik Przyborowski w 2006-06-16, 20:03:24
Proponuje przeczytać README do tych driverów. Z tego co sie orinetuje ostatnie obsługujące gf2 to 8178, które w przypadku kernela 2.6.16 nalezy paczować. Dodatkowo przy xorg 7.0 należy zmienić lokalizacje plików (przynajmniej w debilianie)
Tytuł: winmodem
Wiadomość wysłana przez: Krzysztof Plucinski w 2006-06-16, 20:26:37
2006-06-16 20:03:24 Lorenzo napisał:

> Proponuje przeczytać README do tych driverów. Z tego co sie orinetuje ostatnie obsługujące gf2
 > to 8178, które w przypadku kernela 2.6.16 nalezy paczować. Dodatkowo przy xorg 7.0 należy
 > zmienić lokalizacje plików (przynajmniej w debilianie)

False...
GF2 MX 400 64MB + kernel 2.6.16.20 + nvidia 8762 + Xorg 7.0.22
i wszystko dziala bez jakiegokolwiek patchowania...pod debianem zreszta...
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-16, 21:58:05
2006-06-16 20:26:37 kmp napisał:

> 2006-06-16 20:03:24 Lorenzo napisał:
 >
 > > Proponuje przeczytać README do tych driverów. Z tego co sie orinetuje ostatnie obsługujące
 > gf2
 >  > to 8178, które w przypadku kernela 2.6.16 nalezy paczować. Dodatkowo przy xorg 7.0
 > należy
 >  > zmienić lokalizacje plików (przynajmniej w debilianie)
 >
 > False...
 > GF2 MX 400 64MB + kernel 2.6.16.20 + nvidia 8762 + Xorg 7.0.22
 > i wszystko dziala bez jakiegokolwiek patchowania...pod debianem zreszta...
 >
Jak już wspomniałem wcześniej mam Mandrake na kernelu 2.6.8.1 i coś musi iść nie tak. W var/log/nvidia-installer.log  mam ostatni komunikat że konfiguracja przebiegła z sukcesem i jest kompletna a mimo to nie działa.
Nie wiem jak odinstalować steroniki aby ponowić  instalację.
Tytuł: winmodem
Wiadomość wysłana przez: Dominik Przyborowski w 2006-06-16, 23:11:56
kmp: ja miałem gf2 mx200 i niestety musiałem się zabawiać.
ozyr: sprawdź logi xów a nie instalatora nvidii - cat /var/log/Xorg.0.log | grep \\'(EE)\\'

Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-20, 12:30:43
2006-06-16 23:11:56 Lorenzo napisał:

> kmp: ja miałem gf2 mx200 i niestety musiałem się zabawiać.
 > ozyr: sprawdź logi xów a nie instalatora nvidii - cat /var/log/Xorg.0.log | grep \\'(EE)\\'
 >
 >
Odinstalowałem sterowniki i zainstalowałem ponownie i teraz to już zupełna katastrofa. Nie mogę przywrócic X-ów. Komp uruchamia się w trybie tekstowym. Prubuje odpalić X-y  - startx i pojawia się komunikat
using config file: \\"/etc/X11/Xorg.conf\\"
Using vt7
Fatal server error:
caught signal 11.Server aborting.

W var/log znalazłem coś takiego:
Loading extension GLX
Load Module:\\"glx\\"
Loading /usr/X11R6/lib/modules/extensions/libglx.so
Fatal server error.

Próba ratowania systemu z płyt instalacyjnych nie powiodła się. Przy konfiguracji grafiki i jej teście przychodziły błędy i nie dało się jej ustawić.
Nie mogę też odinstalować sterowników nvidii, pojawia się komunikat
Segmentation fault (core dumped)
Krótko mówiąc kompletny klops. Chyba muszę zainstalować system od początku bo moja wiedza już się skończyła.
Podpowiedzcie jak przenieść dane na płyty dvd przy użyciu komend w trybie tekstowym tylko proszę bez odnośników bo mam utrudniony dostęp do netu.
Tytuł: winmodem
Wiadomość wysłana przez: Piotr Chmura w 2006-06-20, 12:37:00
2006-06-20 12:30:43 ozyr napisał:

 > Nie mogę też odinstalować sterowników nvidii, pojawia się komunikat
 > Segmentation fault (core dumped)

nic nie musisz odinstalowywac.. wystarczy przywrocic /etc/X11/xorg.conf do stanu sprzed instalacji Xow
(zapewne do odpalenia Xow wystarczy zakomentowanie ladowania glx\\'a i zmiana drivera karty graficznej na nv badz tez vesa)
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-20, 12:55:43
2006-06-20 12:37:00 chmooreck napisał:

> 2006-06-20 12:30:43 ozyr napisał:
 >
 >  > Nie mogę też odinstalować sterowników nvidii, pojawia się komunikat
 >  > Segmentation fault (core dumped)
 >
 > nic nie musisz odinstalowywac.. wystarczy przywrocic /etc/X11/xorg.conf do stanu sprzed
 > instalacji Xow
 > (zapewne do odpalenia Xow wystarczy zakomentowanie ladowania glx\\'a i zmiana drivera karty
 > graficznej na nv badz tez vesa)
Właśnie to próbowałem robić. Po pierwszej nieudanej instalacji w xorg.conf    
nvidia zmieniłem na nv i wszystko wróciło do stanu poprzedniego. Odinstalowałem stery i zainstalowałem jeszcze raz i teraz mam ten problem. Nawet odinstalować sterownika nie mogę. W trybie ratunkowym z płyty instalacyinej też zmieniałem na nv i przychodziły błędy na teście. Z vesą nie próbowałme.
Tytuł: winmodem
Wiadomość wysłana przez: Piotr Chmura w 2006-06-20, 13:04:52
2006-06-20 12:55:43 ozyr napisał:

 > Z
 > vesą nie próbowałme.

to sprobuj... sterownikow nie musisz odinstalowywac...
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-20, 13:12:50
2006-06-20 13:04:52 chmooreck napisał:

> 2006-06-20 12:55:43 ozyr napisał:
 >
 >  > Z
 >  > vesą nie próbowałme.
 >
 > to sprobuj... sterownikow nie musisz odinstalowywac...
Podpowiedz jak zakomentować glx
Tytuł: winmodem
Wiadomość wysłana przez: Piotr Chmura w 2006-06-20, 13:48:38
2006-06-20 13:12:50 ozyr napisał:

 > Podpowiedz jak zakomentować glx

tak jak cala reszta komentarzy w tym pliku

#
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-20, 14:06:23
2006-06-20 13:48:38 chmooreck napisał:

> 2006-06-20 13:12:50 ozyr napisał:
 >
 >  > Podpowiedz jak zakomentować glx
 >
 > tak jak cala reszta komentarzy w tym pliku
 >
 > #
Dziękuję za podpowiedź \\"#\\". Powinienem pamiętać ale to pewnie przez to że w domu nie mam dojścia do netu bo jadę tylko na linuxie a konsoli nie opanowałem na tyle by czuć się w niej swobodnie. Teraz jestem w pracy i potrzebuje łopatologicznych podpowiedzi bo mam troche stresa że nie uda mi się przywrócić X-ów.
 Dla pewności glx powinien być w xorg.conf?
Tytuł: winmodem
Wiadomość wysłana przez: Piotr Chmura w 2006-06-20, 15:09:31
2006-06-20 14:06:23 ozyr napisał:

 >  Dla pewności glx powinien być w xorg.conf?

dla nv i vesa powinien byc zakomentowany

dla nvidia moze byc odkomentowany (odpowiada za akceleracje)
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-20, 16:13:45
2006-06-20 15:09:31 chmooreck napisał:

> 2006-06-20 14:06:23 ozyr napisał:
 >
 >  >  Dla pewności glx powinien być w xorg.conf?
 >
 > dla nv i vesa powinien byc zakomentowany
 >
 > dla nvidia moze byc odkomentowany (odpowiada za akceleracje)
Dziękuję Ci chmoreck za uratowanie. Teraz już siedzę na swoim kompie i X po zakomentowaniu glx pod nv działa. Nie zminia to faktu że nvidia za pierona nie chce ruszyć. Może masz na to jakiś lek.
Tytuł: winmodem
Wiadomość wysłana przez: Piotr Chmura w 2006-06-20, 21:48:09
jak dotychczas mandrive udawalo mi sie ominac szerokim lukiem ;-)
w slacku i gentoo nie natrafilem na zadne problemy...

moze to ci pomoze:
http://mandriva.org.pl/content/view/31/28/
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-20, 22:26:47
2006-06-20 21:48:09 chmooreck napisał:

> jak dotychczas mandrive udawalo mi sie ominac szerokim lukiem ;-)
 > w slacku i gentoo nie natrafilem na zadne problemy...
 >
 > moze to ci pomoze:
 > http://mandriva.org.pl/content/view/31/28/
Dzięki za adres. Nistety już go przerobiłem. Jak próbuję załadować nvidię to przychodzą komunikaty że coś nie tak z modułami w kernelu, a na tym to się jeszcze nie znam :-) i chyba coś faktycznie się namieszało w jądrze bo nie mogę odpalić nic z programów multimedialnch. Chyba pomyślę na poważnie o powrocie do auroxa bo z mandrivą mam sporo problemów - a to kompilacja nie zawsze wychodzi, a to aparatu za nic nie można zamontować a teraz jeszcze doszła grafika. Ale chociaż człowiek się czegoś nauczy :-) a to już jakaś pociecha.
Tytuł: winmodem
Wiadomość wysłana przez: Piotr Chmura w 2006-06-21, 00:25:13
2006-06-20 22:26:47 ozyr napisał:


 > Dzięki za adres. Nistety już go przerobiłem. Jak próbuję załadować nvidię to przychodzą
 > komunikaty że coś nie tak z modułami w kernelu, a na tym to się jeszcze nie znam :-)

to napisz o jakie moduly sie rzuca... bo faktycznie niektore sie gryza z modulem nvidia (chyba rivafb, ale nie jestem do konca pewny.... )

najprawdopodobniej wystarczy tych modulow nie ladowac na starcie, a zamiast nich zaladowac vesafb lub vesafb-tng czy jakos tak... a potem normalnie modul nvidia i start Xow...
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-21, 17:29:16
2006-06-21 00:25:13 chmooreck napisał:

> 2006-06-20 22:26:47 ozyr napisał:
 >
 >
 >  > Dzięki za adres. Nistety już go przerobiłem. Jak próbuję załadować nvidię to przychodzą
 >  > komunikaty że coś nie tak z modułami w kernelu, a na tym to się jeszcze nie znam :-)
 >
 > to napisz o jakie moduly sie rzuca... bo faktycznie niektore sie gryza z modulem nvidia (chyba
 > rivafb, ale nie jestem do konca pewny.... )
 >
 > najprawdopodobniej wystarczy tych modulow nie ladowac na starcie, a zamiast nich zaladowac
 > vesafb lub vesafb-tng czy jakos tak... a potem normalnie modul nvidia i start Xow...
To walczmy dalej!
Takie wpisy znalazłem:
(EE) NVIDIA (0): Failed go initialize the GLX module; please check in jour X
(EE)                        log file that the GLX module has been loaded in your X
(EE)                   server and that the module to encounter problems, PLEASE try reinstaling the NVIDIA driver.
FATAL: Error inserting nvidia (/lib/modules/2.6.8.1-12mdk/kernel/drivers/video/nvidia.ko): Invalid module format
(EE) Failed to load the NVIDIA kernel module!
(EE) *** Aborting ***
Scern found, but none have usable configuration.
Tak to wygląda w logach.
Mam monitor samtron ustawiony w X86Config jako:
Section \\"Monitor\\"
Identifier  \\"montor1\\"
VendorName   \\"Plug\\'n Play\\"
HorizSync      30.0 - 71.0
W Section  \\"Module\\"
Load \\"dbe\\" # Double-Buffering Extension
Load \\"v4l\\"  # Video for Linux
Load \\"extpod\\"
Load \\"freetype\\"
# Load \\"glx\\" # 3D layer
VertRefresh    50.0 - 160.0
Jakie sugestie?
Tytuł: winmodem
Wiadomość wysłana przez: Piotr Chmura w 2006-06-21, 18:53:42
2006-06-21 17:29:16 ozyr napisał:

> 2006-06-21 00:25:13 chmooreck napisał:
 >
 > > 2006-06-20 22:26:47 ozyr napisał:
 >  >
 >  >
 >  >  > Dzięki za adres. Nistety już go przerobiłem. Jak próbuję załadować nvidię to
 > przychodzą
 >  >  > komunikaty że coś nie tak z modułami w kernelu, a na tym to się jeszcze nie znam
 > :-)
 >  >
 >  > to napisz o jakie moduly sie rzuca... bo faktycznie niektore sie gryza z modulem nvidia
 > (chyba
 >  > rivafb, ale nie jestem do konca pewny.... )
 >  >
 >  > najprawdopodobniej wystarczy tych modulow nie ladowac na starcie, a zamiast nich
 > zaladowac
 >  > vesafb lub vesafb-tng czy jakos tak... a potem normalnie modul nvidia i start Xow...
 > To walczmy dalej!
 > Takie wpisy znalazłem:
 > (EE) NVIDIA (0): Failed go initialize the GLX module; please check in jour X
 > (EE)                        log file that the GLX module has been loaded in your X
 > (EE)                   server and that the module to encounter problems, PLEASE try reinstaling
 > the NVIDIA driver.
 > FATAL: Error inserting nvidia (/lib/modules/2.6.8.1-12mdk/kernel/drivers/video/nvidia.ko):
 > Invalid module format
 > (EE) Failed to load the NVIDIA kernel module!
 > (EE) *** Aborting ***
 > Scern found, but none have usable configuration.
 > Tak to wygląda w logach.
 > Mam monitor samtron ustawiony w X86Config jako:
 > Section \\"Monitor\\"
 > Identifier  \\"montor1\\"
 > VendorName   \\"Plug\\'n Play\\"
 > HorizSync      30.0 - 71.0
 > W Section  \\"Module\\"
 > Load \\"dbe\\" # Double-Buffering Extension
 > Load \\"v4l\\"  # Video for Linux
 > Load \\"extpod\\"
 > Load \\"freetype\\"
 > # Load \\"glx\\" # 3D layer
 > VertRefresh    50.0 - 160.0
 > Jakie sugestie?

jesli korzystasz ze sterownika nvidia ladowanie modulu glx powinno byc odkomentowane

po pierwsze sprawdz, czy zodla jadra jakie zainstalowales odpowiadaja DOKLADNIE wersji jadra, ktora chodzi ( $ uname -r )

po zainstalowaniu sterownika sprobuj recznie zaladowac modul nvidia (# modprobe nvidia )... i daj znac co sie stalo :-)
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-21, 19:05:43
> jesli korzystasz ze sterownika nvidia ladowanie modulu glx powinno byc odkomentowane
 >
 > po pierwsze sprawdz, czy zodla jadra jakie zainstalowales odpowiadaja DOKLADNIE wersji jadra,
 > ktora chodzi ( $ uname -r )
 >
 > po zainstalowaniu sterownika sprobuj recznie zaladowac modul nvidia (# modprobe nvidia )... i
 > daj znac co sie stalo :-)
wersja jądra jest porawna  a po modprobe przychodzi:
[root@localhost video]# modprobe nvidia
FATAL: Error inserting nvidia (/lib/modules/2.6.8.1-12mdk/kernel/drivers/video/nvidia.ko): Invalid module format
Coś się pochrzaniło w kernelu bo np. xine uruchamie się i zaraz wyłancza.
Tytuł: winmodem
Wiadomość wysłana przez: Piotr Chmura w 2006-06-21, 20:45:45
2006-06-21 19:05:43 ozyr napisał:

 > [root@localhost video]# modprobe nvidia
 > FATAL: Error inserting nvidia (/lib/modules/2.6.8.1-12mdk/kernel/drivers/video/nvidia.ko):
 > Invalid module format

u mnie modul do nvidii instaluje sie do /lib/modules/wersja_jadra/video.. ale to moze wynikac z tego, ze uzywam gentoo i instalacja sterownikow wyglada to troche inaczej...

sprobuj wyrzucic ten modul i skompilowac jeszcze raz...


 > Coś się pochrzaniło w kernelu bo np. xine uruchamie się i zaraz wyłancza.

sprobuj przeinstalowac paczke jadra... skoro cos sie pochrzanilo... ;-)
btw... kompilowales jadro samodzielnie, czy masz z paczki ?
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-21, 21:20:40
>  > [root@localhost video]# modprobe nvidia
 >  > FATAL: Error inserting nvidia
 > (/lib/modules/2.6.8.1-12mdk/kernel/drivers/video/nvidia.ko):
 >  > Invalid module format
 >
 > u mnie modul do nvidii instaluje sie do /lib/modules/wersja_jadra/video.. ale to moze wynikac z
 > tego, ze uzywam gentoo i instalacja sterownikow wyglada to troche inaczej...
 >
 > sprobuj wyrzucic ten modul i skompilowac jeszcze raz...
 >
 >
 >  > Coś się pochrzaniło w kernelu bo np. xine uruchamie się i zaraz wyłancza.
 >
 > sprobuj przeinstalowac paczke jadra... skoro cos sie pochrzanilo... ;-)
 > btw... kompilowales jadro samodzielnie, czy masz z paczki ?
Łatwo powiedzieć (napisać) :-). Nie kompilowałem jeszcze jądra i mam stracha że coś namieszam bo przeważnie zawsze coś wyskoczy niemiłego. Jądro mam z rpma z płyt instalacyjnych. Zanim się zabiorę za taką zabawę muszę zarchiwizowć dane. Szkoda by ich było. Zaskoczeniem dla mnie jest np. to że po pierwszej instalacji sterownikó nwidi co prawda nie startowały ale dały się odinstalować a teraz już nie dają się odinstalować. Przychodzi komunikat
Segmentation fault i nie wiem o co chodzi.
Z wyrzuceniem modułu i ponowną instalacją też nie bardzo wiem który modół wyrzucić i jak go ponownie zainstalować.
Tytuł: winmodem
Wiadomość wysłana przez: Piotr Chmura w 2006-06-21, 22:25:24
2006-06-21 21:20:40 ozyr napisał:

 > Łatwo powiedzieć (napisać) :-). Nie kompilowałem jeszcze jądra i mam stracha że coś namieszam
 > bo przeważnie zawsze coś wyskoczy niemiłego. Jądro mam z rpma z płyt instalacyjnych. Zanim się
 > zabiorę za taką zabawę muszę zarchiwizowć dane. Szkoda by ich było.

I bardzo dobrze.. tzn poki co nie bierz sie za kompilacje (z drugiej strony nie jest to nic niebezpiecznego i nie utrata danych nie grozi - chyba, ze sam je usuniesz ;-) )


 > Zaskoczeniem dla mnie jest
 > np. to że po pierwszej instalacji sterownikó nwidi co prawda nie startowały ale dały się
 > odinstalować a teraz już nie dają się odinstalować. Przychodzi komunikat

w jaki sposob probujesz je \\"odinstalowac\\" ?

chodzi o reczne usuniecie pliku modulu nvidia.ko (wskazanego wczesniej) i powtorne zainstalowanie sterownika nvidii (uruchomienie instalatora, itd)

mozesz podac nazwy paczki z jadrem i nazwe paczki ze zrodlami jadra jakie masz aktualnie zainstalowane ?

podaj co wyswietla
# lsmod

jaka jest zawartosc katalogu /usr/src ?
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-22, 16:25:43
2006-06-21 22:25:24 chmooreck napisał:

> 2006-06-21 21:20:40 ozyr napisał:
 >
 >  > Łatwo powiedzieć (napisać) :-). Nie kompilowałem jeszcze jądra i mam stracha że coś
   
 >  > Zaskoczeniem dla mnie jest
 >  > np. to że po pierwszej instalacji sterownikó nwidi co prawda nie startowały ale dały się
 >  > odinstalować a teraz już nie dają się odinstalować. Przychodzi komunikat
 >
 > w jaki sposob probujesz je \\"odinstalowac\\" ?
 wpisuję polecenie # nvidia-installer --uninstall
Segmentation fault
[root@localhost j]#

 > chodzi o reczne usuniecie pliku modulu nvidia.ko (wskazanego wczesniej) i powtorne
 > zainstalowanie sterownika nvidii (uruchomienie instalatora, itd)
 >
 > mozesz podac nazwy paczki z jadrem i nazwe paczki ze zrodlami jadra jakie masz aktualnie
 > zainstalowane ?
 #  rpm -qa | grep kernel
kernel-source-2.6-2.6.8.1-12mdk
kernel-2.6.8.1.12mdk-1-1mdk

 > podaj co wyswietla
 > # lsmod
 # lsmod
Module                  Size  Used by
md5                     3584  1
ipv6                  230916  10
rfcomm                 32348  0
l2cap                  19876  5 rfcomm
bluetooth              39076  4 rfcomm,l2cap
snd-pcm-oss            49480  0
snd-mixer-oss          17376  2 snd-pcm-oss
snd-cmipci             28228  3
snd-pcm                81800  2 snd-pcm-oss,snd-cmipci
snd-page-alloc          7400  1 snd-pcm
snd-opl3-lib            8448  1 snd-cmipci
snd-timer              20356  2 snd-pcm,snd-opl3-lib
snd-hwdep               6916  1 snd-opl3-lib
gameport                3328  1 snd-cmipci
snd-mpu401-uart         5856  1 snd-cmipci
snd-rawmidi            19300  1 snd-mpu401-uart
snd-seq-device          6344  2 snd-opl3-lib,snd-rawmidi
snd                    45988  14 snd-pcm-oss,snd-mixer-oss,snd-cmipci,snd-pcm,snd-opl3-lib,snd-timer,snd-hwdep,snd-mpu401-uart,snd-rawmidi,snd-seq-device
soundcore               7008  2 snd
ppp_async               8896  1
ppp_generic            24468  5 ppp_async
slhc                    6112  1 ppp_generic
crc-ccitt               1664  1 ppp_async
af_packet              16072  2
floppy                 55088  0
ide-cd                 37280  0
cdrom                  37724  1 ide-cd
loop                   12520  0
tsdev                   5824  0
joydev                  8032  0
usbmouse                4256  0
evdev                   7648  0
usbhid                 41088  0
eagle-usb             123520  0
ohci-hcd               18468  0
usbcore               103172  6 usbmouse,usbhid,eagle-usb,ohci-hcd
ext3                  120680  5
jbd                    49080  1 ext3

 > jaka jest zawartosc katalogu /usr/src ?
/RPM
~linux
/linux-2.6.15.2
/linux-2.6.8.1-12mdk
Tytuł: winmodem
Wiadomość wysłana przez: Piotr Chmura w 2006-06-22, 18:19:10
2006-06-22 16:25:43 ozyr napisał:

 >  > jaka jest zawartosc katalogu /usr/src ?
 > /RPM
 > ~linux
 > /linux-2.6.15.2
 > /linux-2.6.8.1-12mdk

skad sie wzial linux-2.6.15.2 ?
na co wskazuje ~linux ?
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-22, 18:36:34
2006-06-22 18:19:10 chmooreck napisał:

> 2006-06-22 16:25:43 ozyr napisał:
 >
 >  >  > jaka jest zawartosc katalogu /usr/src ?
 >  > /RPM
 >  > ~linux
 >  > /linux-2.6.15.2
 >  > /linux-2.6.8.1-12mdk
 >
 > skad sie wzial linux-2.6.15.2 ?
Tam są rozpakowane źródła które kiedyś pobrałem ale nic z tym jeszcze nie robiłem.
 > na co wskazuje ~linux ?
ten skrót idzie na /usr/src/linux-2.6.8.1-12mdk
Tytuł: winmodem
Wiadomość wysłana przez: Robert w 2006-06-22, 20:54:51
2006-06-22 18:36:34 ozyr napisał:

 > ten skrót idzie na /usr/src/linux-2.6.8.1-12mdk
 
Spróbuj Nvidii nieco starszej

np. takiej: NVIDIA-Linux-x86-1.0-8178-pkg1, ale przy tej wersji Nvidii musisz miec wyłączony modul nvidia fb, albo cos w tym stylu, na pewno z fb na końcu.
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-22, 21:00:14
 > Spróbuj Nvidii nieco starszej
 >
 > np. takiej: NVIDIA-Linux-x86-1.0-8178-pkg1, ale przy tej wersji Nvidii musisz miec wyłączony
 > modul nvidia fb, albo cos w tym stylu, na pewno z fb na końcu.
Pewnie bym poprubował tylko chyba powinienem odinstalować obecne sterowniki a te jakoś nie chcą się usunąć. Patrz poprzednie posty.
Tytuł: winmodem
Wiadomość wysłana przez: Robert w 2006-06-22, 22:03:23
2006-06-22 21:00:14 ozyr napisał:

Pewnie bym poprubował tylko chyba powinienem odinstalować obecne sterowniki a te jakoś nie chcą
 > się usunąć. Patrz poprzednie posty.

Jesli chodzi o mnie, o mi sie kiedys takie coś zdarzyło, że wydałem polecenie instalowania sterowników (ktore ci podalem) w jadrze, w którym już kiedys ten moduł instalowałem. Instalator poinformował mnie wtedy, że musi najpierw odinstalować poprzednią wersję, aby zainstalować nowszą (w rzeczywistości -tę samą) i nawet sie to udało.
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-22, 22:20:08
 > Pewnie bym poprubował tylko chyba powinienem odinstalować obecne sterowniki a te jakoś nie
 > chcą
 >  > się usunąć. Patrz poprzednie posty.
 >
 > Jesli chodzi o mnie, o mi sie kiedys takie coś zdarzyło, że wydałem polecenie instalowania
 > sterowników (ktore ci podalem) w jadrze, w którym już kiedys ten moduł instalowałem. Instalator
 > poinformował mnie wtedy, że musi najpierw odinstalować poprzednią wersję, aby zainstalować
 > nowszą (w rzeczywistości -tę samą) i nawet sie to udało.
No tak tylko w tym przypadku zamiana dotyczyła by zamiany nowszej na starszą.
Mogę poprubować ale to chyba nie przejdzie.
Tytuł: winmodem
Wiadomość wysłana przez: Piotr Chmura w 2006-06-23, 07:26:24
2006-06-22 22:20:08 ozyr napisał:

 > Mogę poprubować ale to chyba nie przejdzie.

powinno przejsc bez problemu...

P.S. swojadroga Twoje \\'Segmentation fault\\' jest problemem, ktory nalezaloby rozwiazac.. to niekoniecznie jest zwiazane z jadrem, byc moze masz uszkodzone jakies biblioteki...
Pamietasz po instalacji jakich paczek zaczely ci wylatywac te segfault\\'y ?
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-23, 17:32:09
 > P.S. swojadroga Twoje \\'Segmentation fault\\' jest problemem, ktory nalezaloby rozwiazac.. to
 > niekoniecznie jest zwiazane z jadrem, byc moze masz uszkodzone jakies biblioteki...
 > Pamietasz po instalacji jakich paczek zaczely ci wylatywac te segfault\\'y ?
Właśnie to chyba jest kluczowy problem bo ten błąd mi teraz często wyskakuje przy różnych programach,(głównie multimedialne) które się uruchamiają i zaraz znikają. Przeglądnąłem historię basha  i ostatnie programy jakie sobie kojarzę przed pojawieniem się tego komunikatu to odinstalowanie i zainstalowanie sterownika nvidi oraz
file:/home/j/xine/xine-plugins-1.1.1-0.1.101plf.i586.rpm
file:/home/j/xine/libtheora0-devel-1.0-0.alpha5.0.1.101plf.i586.rpm
file:/home/j/xine/libtheora0-1.0-0.alpha5.0.1.101plf.i586.rpm
file:/home/j/xine/xine-plugins-1.1.1-0.1.101plf.i586.rpm
file:/home/j/xine/libxine1-devel-1.1.1-0.1.101plf.i586.rpm
file:/home/j/xine/libxine1-1.1.2cvs-060514.i586.rpm
file:/home/j/xine/w32codec-0.52-1.i386.rpm
Nie pamiętam czy wszystkie się zainstalowały ze względu na niespełnine zależności.
Tak na marginesie to dziękuję Ci Chmooreck za cierpliwość, a może wygramy koszulki? :-)
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-23, 18:27:03
2006-06-23 17:32:09 ozyr napisał:

>  
 >  > P.S. swojadroga Twoje \\'Segmentation fault\\' jest problemem, ktory nalezaloby rozwiazac..
 > to
 >  > niekoniecznie jest zwiazane z jadrem, byc moze masz uszkodzone jakies biblioteki...
 >  > Pamietasz po instalacji jakich paczek zaczely ci wylatywac te segfault\\'y ?
 > Właśnie to chyba jest kluczowy problem bo ten błąd mi teraz często wyskakuje przy różnych
 > programach,(głównie multimedialne) które się uruchamiają i zaraz znikają.

Mi sie tak zrobilo po zainstalowaniu openspace.bin, który nadpisał mi libxml do wyzszej wersji.
Tytuł: winmodem
Wiadomość wysłana przez: Piotr Chmura w 2006-06-23, 20:26:10
moze sprobuj upgradnac caly system do najnowszych wersji ? ;-)
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-23, 20:27:08
2006-06-23 18:27:03 sys napisał:

> 2006-06-23 17:32:09 ozyr napisał:
 >
 > >  
 >  >  > P.S. swojadroga Twoje \\'Segmentation fault\\' jest problemem, ktory nalezaloby
 > rozwiazac..
 >  > to
 >  >  > niekoniecznie jest zwiazane z jadrem, byc moze masz uszkodzone jakies
 > biblioteki...
 >  >  > Pamietasz po instalacji jakich paczek zaczely ci wylatywac te segfault\\'y ?
 >  > Właśnie to chyba jest kluczowy problem bo ten błąd mi teraz często wyskakuje przy
 > różnych
 >  > programach,(głównie multimedialne) które się uruchamiają i zaraz znikają.
 >
 > Mi sie tak zrobilo po zainstalowaniu openspace.bin, który nadpisał mi libxml do wyzszej wersji.
Ale jak wymacać co mi przeszkadza w systemie?
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-23, 22:05:20
2006-06-23 20:26:10 chmooreck napisał:

> moze sprobuj upgradnac caly system do najnowszych wersji ? ;-)
Z tym byłbym ostrożny bo jak instalowałem nowsze wersje jąder na innych dystrybucjach to wieszał mi się komp tak skutecznie że tylko twardy reset pomagał. To być może była wina sterowników grafiki, ale nie próbowałem wtedy wgrywać nvidi, a teraz jest właśnie z tym problem. Obawiam się że na nowszej wersji to kompletnie ugrzęznę, a tu przynajmniej nic mi się nie zawiesza :-). Kiedyś miałem auroxa 10 i całkiem fajnie mi chodził i nawet wtedy nvidia mi hulała ale jak zdobyłem neostradę i zacząłem ją instalować to pojawiły się problemy (bo oczywiście tpsa nie daje dobrych sterowników pod modem ale skąd ja biedny miałem o tym wiedzieć? ) i przeskoczyłem na mandrake. I tak sobie na nim siedzę ale coś czuję że jego czas dobiega końca :-). Ciekawi mnie jednak przyczyna komunikatu \\"Segmentation fault\\" i chciałbym to jakoś rozgryźć i te stery nvidi też.
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-23, 22:34:38
mam ten sam system co Twoj, malo tego prawie że identyczną karte, a problem nieladowania programow pokaze Ci sie jak odpalisz dany program z konsoli...
Tytuł: winmodem
Wiadomość wysłana przez: w 2006-06-24, 13:01:53
2006-06-23 22:34:38 sys napisał:

> mam ten sam system co Twoj, malo tego prawie że identyczną karte, a problem nieladowania
 > programow pokaze Ci sie jak odpalisz dany program z konsoli...
 >
Jak odpalam program z konsoli to przychodzi nieodmiennie tylko ten jeden komunikat \\"Segmentation fault\\" a to mi nic a nic nie mówi.
Tytuł: winmodem
Wiadomość wysłana przez: Joanna w 2006-06-15, 20:25:02
Jak dystrybucja linuxa pozwoli na połaczenie z Intenetem przy użyciu pentagramu Navell? Joanna
Tytuł: winmodem
Wiadomość wysłana przez: Krzysztof Plucinski w 2006-06-15, 20:42:57
2006-06-15 20:25:02 Abakan napisał:

> Jak dystrybucja linuxa pozwoli na połaczenie z Intenetem przy użyciu pentagramu Navell? Joanna



http://www.heby.de/ltmodem

Tytuł: winmodem
Wiadomość wysłana przez: flak w 2006-06-15, 21:21:12
2006-06-15 20:25:02 Abakan napisał:

> Jak dystrybucja linuxa pozwoli na połaczenie z Intenetem przy użyciu pentagramu Navell? Joanna

Jeśli jest to chipset Conexant/Rockwell to www.linuxant.com
Tytuł: winmodem
Wiadomość wysłana przez: Krzysztof Plucinski w 2006-06-15, 21:30:19
2006-06-15 21:21:12 flak napisał:

 > Jeśli jest to chipset Conexant/Rockwell to www.linuxant.com


Nie. To chip Agere (Lucent).

http://pentagram.com.tw/main/products.php?section=products&inner_section=faxmodems,0&details=21