Forum Linux.pl

Środowiska graficzne => GNOME => Wątek zaczęty przez: łukasz Malecki w 2005-12-27, 15:16:56

Tytuł: Evolution a brak gnome
Wiadomość wysłana przez: łukasz Malecki w 2005-12-27, 15:16:56
Witam!
Mam taki mały problemik chcem skonfigurować linuxa jako serwer dostępu do internetu dla dwóch innych kompów znajdujących się u mnie w domciu,przeglądałem różne stronki i mam w głowie mętlik prosę by ktoś mnie pomógł to poukładać czyli co i jak,od cego zacząć czego mogę użyć itd
Oto co ja posiadam 1 kompa na którym zainstalowałem linuxa Auroxa 10 , 2X komputery na windowsie xp i przełąznik..Moje łącze to dsl 1M.Połączenie wygląda następująco z modemu dsl\\'a kabel jest poprowadzony do serwera -karty sieciowej z drógiej karty sieciowej zainstalowanej na serwerku do przełącznika i do niego są podłączone 2 inne komputery.Na windowsie znam się dobrze ale na linuxie moge tylko powiedzieć że umiem go obsługiwać.Proszę o pomoc!!
Tytuł: Evolution a brak gnome
Wiadomość wysłana przez: Marcin Iwaniuk w 2005-12-27, 15:34:29
poszukaj o NAT, jesli poradzisz sobie z skonfigurowaniem lacza i uruchomieniu go zeby na linuksie dzialalo to z NATem powinienes sobie poradzic. nie jest trudne, pare linijek w pliku konfiguracyjnym i dziala. mi kompletna instalacja debiana z konfiguracja + sharper zajela jakies 3 godziny, ale sam system troche sie instalowal
Tytuł: Evolution a brak gnome
Wiadomość wysłana przez: Dominik Przyborowski w 2005-12-27, 15:37:13
Witam.

Jeżeli dobrze rozumiem to chcesz postawić router.

Jak to zrobić masz na debian user gang, oto linki do artów:
http://dug.net.pl/texty/masq.php
http://dug.net.pl/texty/htb.php

Pozdrawiam
Tytuł: Evolution a brak gnome
Wiadomość wysłana przez: łukasz Malecki w 2005-12-27, 17:05:21
Dzi ęki Lorenzo za linki jednak póki co nie daje rady gdyz debian widocznie sie troszke rozni od auroxa i nie moge znaleźć plików podanych w artykule nie ma ich w tych lokalizacjach u mnie :-(
Tytuł: Evolution a brak gnome
Wiadomość wysłana przez: Dominik Przyborowski w 2005-12-27, 21:15:10
Aurox jest zdaje sie inną gałęzia RH więc masz linka do strony, na której jest instrukcja zrobienia maskarady na RH 6.2 (wiem archaiczny troche) może na podstawie tego cosik wykminisz.
http://zlobek.tcz.wroclaw.pl/dzial.php3?dzial=3

Pozdro
Tytuł: Evolution a brak gnome
Wiadomość wysłana przez: łukasz Malecki w 2005-12-28, 21:09:17
A więc tak
Tytuł: Evolution a brak gnome
Wiadomość wysłana przez: łukasz Malecki w 2005-12-28, 21:29:25
A Więc TAK,problem został rozwwiązany opisze w jaki sposób to zrobiłem mam nadzieję ze osoby o podobnym problemie z tego skorzystają.
Nie udało by mnie się  gdyby nie lorenzo wskazł mnie stronki na podstawie których to mogłem zrobić.
http://dug.net.pl/texty/masq.php
Konfiguracja kart cieciowych
aplikacje=>narzedzia systemowe=>konfiguracja urządzeń sieciowych
i eth0 wklepane parametry sieciowe które dostałem od dostawcy dsl\\'a czyli dialogu ip.maska,brama,i dns\\'y
eth1 wklepane parametry sieci tylko ip i maski czyli ip 192.168.1.2 maska 255.255.255.0
później zrobiłem pliczek jak na stronce polecono FIREWALL
Dostosowałem tem plik dla swoich potrzeb
tzrymając sie wskazówek co i jak w nim wypełniać autora textu
Wstawilem go tam gdzie wskazano mnie.
Dodałem linijke w pliku rc.local by automatycznie się ładowało /etc/init.d/firewall potem restarcik
i udało się.
W razie jakichkolwiek pytań prosze pytać na maila gyfyt@tlen.pl
Od razu zastrzegam ze jestem tylko \\'\\'userem\\'\\'linuxa
Tytuł: Evolution a brak gnome
Wiadomość wysłana przez: Aleksandra Brzezińska w 2005-12-27, 14:23:51
Cześć
W Slackware 10.2 usunięto w ogóle gnoma - osobiście nie używam, ale jestem bardzo przywiązana do evolution i kilku innych programów (taki sodipodi np). Więc zainstalowałam evolution z linuxpackages - zgodnie ze zdrową logiką nie działa. No to zabieram się za kompilację potrzebnych bibliotek. Gal wymaga gnome-libs, gnome-libs ORBita, orbit nie wymaga nic, kompiluje się i instaluje. Powracam do gnome-libs a tu:
checking for orbit-config... no
checking for orbit-idl... no
checking for working ORBit environment... no
configure: error: ORBit not installed or installation problem

Tak samo w przypadku samodzielnie kompilowanej paczki (--prefix=/usr) jak i paczki z płyty dla Slackware 10.1
$whereis orbit-2
orbit-2: /usr/lib/orbit-2.0 /usr/include/orbit-2.0

Orientuje się ktoś co mu się nie podoba?
A tak na marginesie... Od biblioteki do biblioteki i małymi kroczkami skompiluje całego gnoma zanim uruchomię evolution, czy jest szansa, ze nie :D ?

z góry dziękuję za wszelkie pomocne sugestie
olka
Tytuł: Evolution a brak gnome
Wiadomość wysłana przez: Piotr Chmura w 2005-12-27, 14:52:14
mozna i tak...

...ale i mozna inaczej - zainteresuj sie swaret'em - sciagniesz sobie evolution razem z zaleznsciami, chcociazby w wersji slackware-current ;-)

jak jeszcze siedzialem na slacku, to do aktualizacji paczek systemowych byl jak znalazl ;-)
Tytuł: Evolution a brak gnome
Wiadomość wysłana przez: Aleksandra Brzezińska w 2005-12-27, 15:37:28
2005-12-27 14:52:14 chmooreck napisał:

> mozna i tak...

I wolałabym przy tym pozostać :-)

 > ...ale i mozna inaczej - zainteresuj sie swaret'em - sciagniesz sobie evolution razem z
 > zaleznsciami, chcociazby w wersji slackware-current ;-)

Brzmi bardzo kusząco, ale pod Slackware 10.1 miałam swareta i jakoś nie potrafiliśmy się dogadać :D. Nigdy nic nie chciał znaleść, ewentualnie to, co miałam zainstalowane na komputerze... Jedyne co udawało mi się ściągnąć to pliki list pakietów (czy jakoś tak) pobierane przez swaret --update

dziękuję
olka
Tytuł: Evolution a brak gnome
Wiadomość wysłana przez: Aleksandra Brzezińska w 2005-12-27, 20:25:46
No dobra, wzięłam się na honor :D
Jak inni potrafią, to ja też się nauczę - zmusiłam swareta do znalezienia evolution, dla wersji 10.1, bo dla 10.2 nie ma paczki.
Faktycznie, zauważył, że mu brakuje bibliotek, zainstalował, DZIAŁA! (trzeba było dokompilować jeszcze dwie inne biblioteki, których sobie nie sciagnął)

Ogromne podziękowania dla kolegi Chmoorecka! Jak zawsze: krótko, zwięźle i na temat. A nade wszystko trafnie.
Potrafisz zdopingowac koleżanki do działania :-)
Co prawda pozbawiłeś mnie przyjemności kompilowania minimum 15 pakietów ;-), ale mam działający program szybko i niedużym nakładem straconych nerwów (chociaż coś jeszcze jest nie tak, bo przed chwilą przywiesił mi tak system, że myślałam, że bez zkillowania całych xów się nie obejdzie, ale utłukłam gada po kawałku z konsoli i po 5 minutach było już normalnie: kde odżyło)

jeszcze raz ogromne podziękowania!
olka
Tytuł: Evolution a brak gnome
Wiadomość wysłana przez: Piotr Chmura w 2005-12-28, 00:18:57
dzieki

polecam sie na przyszlosc ;-)
Tytuł: Evolution a brak gnome
Wiadomość wysłana przez: Piotr Chmura w 2005-12-28, 00:21:57
jeszcze jedno - co do problemu z brakiem widocznosci skompilowanych bibliotek - wywolals ldconfig'a po ich instalacji ?
Tytuł: Evolution a brak gnome
Wiadomość wysłana przez: Aleksandra Brzezińska w 2005-12-28, 15:22:49
2005-12-28 00:21:57 chmooreck napisał:

> jeszcze jedno - co do problemu z brakiem widocznosci skompilowanych bibliotek - wywolals
 > ldconfig'a po ich instalacji ?

Tego :D... Właśnie się dowiedziałam, że istnieje taka komenda...
Tytułem nędznego usprawiedliwienia zauważę, że pół roku żyłam bez niej a odkąd kompiluję biblioteki z prefixem /usr nie miałam takich problemów.

Dziękuję za cenną wskazówkę
olka