Forum Linux.pl

Dystrybucje Linuksa => *Ubuntu => Wątek zaczęty przez: Darek Mr w 2016-02-27, 09:46:14

Tytuł: Brak polskich liter
Wiadomość wysłana przez: Darek Mr w 2016-02-27, 09:46:14
Mam problem z pobieranymi napisami do filmów, nie wyświetlają mi sie polskie znaki. Mam ubuntu 14.04 w wersji polskiej. W systemie mogę isać polskie znaki jednak jak ściągam plik .txt z napisami to ich nie pokazuje ich.

Tak jak w linku poniżej poprawiłem wpis i dalej to samo.

https://dug.net.pl/tekst/227/polskie_znaki_w_gedit_3_x___kodowanie_windows_1250/
Tytuł: Odp: Brak polskich liter
Wiadomość wysłana przez: 1709 w 2016-02-27, 10:33:15
Cytuj
jak ściągam plik .txt z napisami to ich nie pokazuje ich.
- Może tak kijowo przetłumaczono ?
- Po otwarciu pliku w edytorze nie widzisz polskich znaków ?
  A jak ty zapiszesz plik z polskimi znakami to widzisz znaki w edytorze ?
Tytuł: Odp: Brak polskich liter
Wiadomość wysłana przez: Darek Mr w 2016-02-27, 12:35:40
W każdym pliku z napisami tak mam  a używam QNAPI i SUBDOWNLOADER a zamiast polskich znaków mam tak jak w załączonym screenie

To co mam lokalnie w gedit otwiera mi się prawidłowo z polskimi znakami.
Tytuł: Odp: Brak polskich liter
Wiadomość wysłana przez: Lord Darius w 2016-02-27, 12:53:18
Mam ubuntu 14.04 w wersji polskiej.

A ja mam Debiana.
Halo! proszę napisać w jakim odtwarzaczu występują opisane problemy.
Tytuł: Odp: Brak polskich liter
Wiadomość wysłana przez: marcin'82 w 2016-02-27, 12:57:04
Darek Mr

Chyba na początku przyjąłeś złe założenia.

To co chcesz zrobić to uzyskać (włączyć lub dodać) w linuksie obsługę innego kodowania oprócz UTF-8 (domyślnego dla nowoczesnego systemu operacyjnego nie licząc GIGANTA Z REDMOND :D).

Szukaj w kierunku jak przekonwertować stronę kodową pliku z cp1250 na utf-8, na przykład:
https://dug.net.pl/tekst/124/%C5%82atwa_konwersja_z_iso_do_utf8___i_nie_tylko/ .

EDYCJA:
Cytuj
Mam problem z pobieranymi napisami do filmów
Odtwarzacz MOŻE mieć opcje wybrania kodowania, jakiego używają akurat te konkretne napisy => poszukaj w opcjach. Patrz post Lord Darius.
Tytuł: Odp: Brak polskich liter
Wiadomość wysłana przez: Darek Mr w 2016-02-27, 13:36:01
Hmm w gedit zmieniłem kofdowanie z UTF8( myślałem ze to ma być ustawione ) na ISO-8859-2 i w gedit polskie litery wyświetla już, teraz tylko jak w odtwarzaczu "filmy" ładuje ten sam plik to tych liter nie wyświetla. Nie wiem gdzieś ten odtwarzacz ma ustawienia by zmienić je na kodowanie ISO-8859-2...
Tytuł: Odp: Brak polskich liter
Wiadomość wysłana przez: Lord Darius w 2016-02-27, 16:07:52
. Nie wiem gdzieś ten odtwarzacz ma ustawienia

Gdzieś i "jakiś" z pewnością...
Tytuł: Odp: Brak polskich liter
Wiadomość wysłana przez: Darek Mr w 2016-02-27, 16:26:45
domyślny player do odtwarzania filmów totem 3.10.1-1ubuntu4
Tytuł: Odp: Brak polskich liter
Wiadomość wysłana przez: marcin'82 w 2016-02-27, 17:25:23
Dalej nic? (https://help.gnome.org/users/totem/stable/totem-prefs.html.en)

Tytuł: Odp: Brak polskich liter
Wiadomość wysłana przez: Darek Mr w 2016-02-27, 18:03:52
Nie znalazłem rozwiązania, zainstalowałem VLC ale znowu ten nie wyświetla wszystkich wierszy z pliku tekstowego nie wiem czemu.
Tytuł: Odp: Brak polskich liter
Wiadomość wysłana przez: Miro57 w 2016-02-27, 18:40:58
Sprawdź co Masz ustawione w VLC
Narzędzia > Preferencje
 wybierz w Pokaż ustawienia *pełne,
rozwiń Wejście/Kodeki > Kodeki napisów > Napisy
 tu powinno być ustawione w Kodowanie tekstu napisów
Windows-1250
i być może wyłączone wykrywanie napisów UTF-8
Tytuł: Odp: Brak polskich liter
Wiadomość wysłana przez: Darek Mr w 2016-02-27, 19:10:52
Super! Teraz działa, dziękuje :)