Forum Linux.pl

System => Konfiguracja => Wątek zaczęty przez: w 2011-09-24, 15:22:42

Tytuł: brak biblioteki libGL.so.1 po instalacji sterowników
Wiadomość wysłana przez: w 2011-09-24, 15:22:42
witam, instalowałem dzisiaj sterowniki do mojej karty graficznej (geforce4 mx 440). Sterowniki to
NVIDIA-Linux-x86-96.43.19-pkg1
mój system to ubuntu 11.04. instalacja przebiegała pomyślnie lecz po instalacji nie wstawały X'y wyskakiwał błąd
no screens found
więc pierwsze co zrobiłem to wykonałem polecenie
nvidia-xconfig
niestety bez rezultatów. przeszukałem google, także bez rezultatów więc dałem sobie spokój i odinstalowałem te sterowniki i przywróciłem stary plik xorg.conf.
 następnie z folderu /etc/modprobe.d usunąłem plik "nvidia-noveau-blocking" czy jakoś tak w każdym razie plik dodawał stary sterownik do blacklist. następnie zrestartowałem system i wszystko zdawało się być jak wcześniej niestety przy próbie odpalenia jakiejkolwiek gry dostaje komunikat
error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory
poszperałem i dowiedziałem się, że jest to część mesa'y, ale jestem kompletnym laikiem i nie mam pojęcia co powinienem usunąć i co zainstalować. dodam tylko, że w folderze /usr/lib/mesa znajdują się pliki
ld.so.conf  libGL.so  libGL.so.1  libGL.so.1.2
plik libGL.so.1 i libGL.so są dowiązaniami do (chyba) nieistniejących plików.
z góry dzięki za jakąkolwiek pomoc.
Tytuł: brak biblioteki libGL.so.1 po instalacji sterowników
Wiadomość wysłana przez: w 2011-09-24, 15:31:54
Cytat: llaik
mój system to ubuntu 11.04. instalacja przebiegała pomyślnie lecz po instalacji nie wstawały X'y wyskakiwał błąd
Po instalacji sterowników zrestartuj komputer i wygeneruj nowy plik xorg.conf
Najpiew kopia starego:
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.oldie
Następnie tworzymy nowy plik:
X -configure
i umieszczamy go na swoim miejscu:
sudo mv /root/xorg.conf.new /etc/X11/xorg.conf
Plik xorg.conf generujemy z poziomu runlevel 3 (konsola bez X), czyli ... podczas uruchamiania komputera wciśnij Shift aby zatrzymać odliczanie Gruba, potem wciśnij "e", przejdź na koniec linii z wyrażeniem /boot/vmlinuz i dopisz na końcu:
single
Aby uruchomić jądro ze zmodyfikowanymi opcjami wciśnij:
Ctrl+X
Bluescreen'a na pewno nie zobaczysz :P
Tytuł: brak biblioteki libGL.so.1 po instalacji sterowników
Wiadomość wysłana przez: w 2011-09-24, 15:39:22
Ale X'y i te Nvidiowskie sterowniki już nie są problemem. Po wywaleniu sterowników nvidii po prostu usunąłem plik /etc/X11/xorg.conf i zrestartowałem komputer (doszukałem się żeby tak zrobić na jakiejś stronie) i system działa jak działał przed mieszaniem z tymi sterownikami.
 teraz problemem jest brak możliwości odpalenia jakiejkolwiek gry. 3/4 mojego poprzedniego posta można olać opisałem tylko jak to wszystko popsułem na razie i tak nie będę już instalował tych sterowników nvidii, bo nie mam sprawnej nagrywarki, a boję się, że coś znowu popsuję.

@edit tak spojrzałem na mój pierwszy post i bardzo chaotycznie napisałem z czym w ogóle mam problem. w każdym razie nie mogę odpalić żadnej gry, bo nie można znaleźć biblioteki współdzielonej libGL.so.1
Tytuł: brak biblioteki libGL.so.1 po instalacji sterowników
Wiadomość wysłana przez: Piotr Chmura w 2011-09-24, 20:58:31
o ile się nie mylę powinna pomóc ponowna instalacja biblioteki mesa
Tytuł: brak biblioteki libGL.so.1 po instalacji sterowników
Wiadomość wysłana przez: w 2011-09-25, 12:06:33
też tak pomyślałem, ale mesa ciągnie za sobą dużo innych rzeczy
(http://i.imgur.com/hgGol.png)
jak bym to wszystko usunął to by to się dobrze dla systemu nie skończyło.
Tytuł: brak biblioteki libGL.so.1 po instalacji sterowników
Wiadomość wysłana przez: Piotr Chmura w 2011-09-26, 07:35:03
ale nie masz usuwać, tylko zainstalować
Tytuł: brak biblioteki libGL.so.1 po instalacji sterowników
Wiadomość wysłana przez: w 2011-09-26, 18:38:40
myślałem, że masz na myśli odinstalowanie i ponowne zainstalowanie wszystkich składników mesa'y. doinstalowałem libglw1-mesa i wszystko śmiga, dzięki za pomoc :)