Nowe posty

xx Strona o testach penetracyjnych, hackingu (23)
2022-01-22, 22:28:27
xx Ocena odpowiedzi - włączenie funkcji forum (1)
2022-01-18, 17:00:43
xx Instalacja Linux pop!os na laptopie bez systemu (10)
2022-01-13, 19:00:51
xx Stary Asus x71sl , nie startuje żaden linux (8)
2022-01-11, 19:00:52
xx HDMI - problem w poprawnym działaniu (0)
2022-01-11, 13:09:19
xx Search redirecting (4)
2022-01-08, 12:12:02
xx Jak to wersja (24)
2022-01-07, 00:22:09
xx Zadanie (1)
2022-01-06, 09:34:34
xx Skrypt usuwający zawartość folderu przy wyłączaniu komputera (8)
2022-01-06, 05:32:29
xx Jak w Manjaro uniemożliwić montowanie innych dysków? (5)
2022-01-06, 05:25:25

Pokaż wiadomości

Ta sekcja pozwala Ci zobaczyć wszystkie wiadomości wysłane przez tego użytkownika. Zwróć uwagę, że możesz widzieć tylko wiadomości wysłane w działach do których masz aktualnie dostęp.


Pokaż wątki - pld

Strony: [1] 2 3
1
Witam,
mam skonfigurowany router na linuxie (reguły iptables, systemowy firewall i apparmor wyłączony) z openvpn, za tym routerem mam komputer z Windowsem, wszystko działa poprawnie, ale gdy na tym komputerze z Windowsem próbuje załadować plik na jakąkolwiek stronę gdzie można uploadować, wszystkie połaczenia są przerywane ,
-przerwanie uploadu
-przerwanie połączenia openvpn
-przerwanie sesji ssh z routerem (łączenie poza openvpn)
Po chwili openvpn połączy się ponownie i po RDP dostane się do tego komputera z Windowsem to upload jest przerwany na 1%
Jaka może być przyczyna?

#/bin/bash
#Czyszczenie dotychczasowych regul
iptables -F
iptables -Z
iptables -X
iptables --flush
iptables --table nat --flush
iptables --delete-chain
iptables --table nat --delete-chain

#Przypisanie interfejsow do zmiennych
INTERNET="eth3"
LAN="eth2"
DMZ="eth1"
VPN="tun0"
LANNETWORK="10.0.0.0/16"
DMZNETWORK="192.168.0.0/24"
VPNNETWORK="192.168.99.0/24"
VPNPORT="1194"
VPNPROTOKOL="tcp"

echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o $INTERNET -j MASQUERADE


iptables -P INPUT DROP
iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A INPUT -s $LANNETWORK -j ACCEPT
iptables -A INPUT -s $VPNNETWORK -j ACCEPT
iptables -A INPUT -p $VPNPROTOKOL --dport $VPNPORT -j ACCEPT
iptables -A INPUT -i $INTERNET -p tcp -m multiport --dport 22000 -j ACCEPT

iptables -P OUTPUT ACCEPT

iptables -P FORWARD DROP
iptables -A FORWARD -i $INTERNET -o $DMZ -j ACCEPT
iptables -A FORWARD -i $DMZ -o $INTERNET -j ACCEPT
iptables -A FORWARD -i $INTERNET -o $LAN -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A FORWARD -i $LAN -o $INTERNET -j ACCEPT
iptables -A FORWARD -i $DMZ -o $LAN -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A FORWARD -i $LAN -o $DMZ -j ACCEPT
iptables -A FORWARD -i $INTERNET -o $VPN -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A FORWARD -i $VPN -o $INTERNET -j ACCEPT
iptables -A FORWARD -i $VPN -o $LAN -j ACCEPT
iptables -A FORWARD -i $LAN -o $VPN -j ACCEPT
iptables -A FORWARD -i $DMZ -o $VPN -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A FORWARD -i $VPN -o $DMZ -j ACCEPT


2
Konfiguracja / Przekierowanie portów RDP pytanko
« dnia: 2020-04-03, 16:16:45 »
Jeśli komputer 10.0.10.112 na który chcę przekierować pulpit zdalny z routera nie ma ustawione GATEWAY na adres mojego routera to przekierowanie nie działa, można to jakoś pominąć, aby przekierowanie działało, nawet jeśli komputer 10.0.10.112 ma ustawiony inny gateway niż mój router?

iptables -A INPUT -i $INTERNET -p tcp -m multiport --dport 3389 -j ACCEPT
iptables -t nat -A PREROUTING -p tcp -d $IPZEW --dport 3389 -j DNAT --to 10.0.10.112:3389
iptables -A FORWARD -i $INTERNET -o $LAN -p tcp -d 10.0.10.112 --dport 3389 -j ACCEPT

3
Instalacja / Libvirtd VM restartuje się przy Loading Linux
« dnia: 2020-03-31, 06:45:36 »
Po uruchomieniu wirtualnej maszyny
virsh start sle15 --console

Uruchamia się grub, lecz nie działa klawiatura (?) Przy instalacji klawiatura działała poprawnie

Jak minie to 10sekund, i następuje uruchamianie, VM restartuje się przy Loading Linux i przechodzi spowrotem do ekranu gruba

Proszę o pomoc

Dystrybucja: Opensuse 15.1 Leap

4
Urządzenia sieciowe / Jakie patchcordy do serwerowni?
« dnia: 2020-03-03, 13:11:53 »
Witam,
wymieniam okablowanie ethernet w serwerowni, jakie patchcordy warto zastosować?

Cat 6 ?
Warto kupować patchcordy ekranowane FTP ? Czy w serwerownii nie będzie miało to znaczenia?

Dziękuję za odpowiedzi

5
Witam,
w jaki sposób można przekierować port USB z hosta kvm do maszyny wirtualnej? (nie poprzez virt-viewer spice)


virsh edit vwin7

<domain type='kvm'>
  <name>vwin7</name>
  <uuid>9448e471-c96d-4211-8965-3384769ca2eb</uuid>
  <metadata>
    <libosinfo:libosinfo xmlns:libosinfo="http://libosinfo.org/xmlns/libvirt/domain/1.0">
      <libosinfo:os id="http://microsoft.com/win/7"/>
    </libosinfo:libosinfo>
  </metadata>
  <memory unit='KiB'>4194304</memory>
  <currentMemory unit='KiB'>4194304</currentMemory>
  <vcpu placement='static'>4</vcpu>
  <os>
    <type arch='x86_64' machine='pc-q35-3.1'>hvm</type>
    <boot dev='hd'/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <hyperv>
      <relaxed state='on'/>
      <vapic state='on'/>
      <spinlocks state='on' retries='8191'/>
    </hyperv>
    <vmport state='off'/>
  </features>
  <cpu mode='host-model' check='partial'>
    <model fallback='allow'/>
  </cpu>
  <clock offset='localtime'>
    <timer name='rtc' tickpolicy='catchup'/>
    <timer name='pit' tickpolicy='delay'/>
    <timer name='hpet' present='no'/>
    <timer name='hypervclock' present='yes'/>
  </clock>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>destroy</on_crash>
  <pm>
    <suspend-to-mem enabled='no'/>
    <suspend-to-disk enabled='no'/>
  </pm>
  <devices>
    <emulator>/usr/bin/qemu-system-x86_64</emulator>
    <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2'/>
      <source file='/services/kvm/images/vwin7.img'/>
      <target dev='sda' bus='sata'/>
      <address type='drive' controller='0' bus='0' target='0' unit='0'/>
    </disk>
    <disk type='file' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <source file='/services/kvm/win7.iso'/>
      <target dev='sdb' bus='sata'/>
      <readonly/>
      <address type='drive' controller='0' bus='0' target='0' unit='1'/>
    </disk>
    <controller type='usb' index='0' model='ich9-ehci1'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x1d' function='0x7'/>
    </controller>
    <controller type='usb' index='0' model='ich9-uhci1'>
      <master startport='0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x1d' function='0x0' multifunction='on'/>
    </controller>
    <controller type='usb' index='0' model='ich9-uhci2'>
      <master startport='2'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x1d' function='0x1'/>
    </controller>
    <controller type='usb' index='0' model='ich9-uhci3'>
      <master startport='4'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x1d' function='0x2'/>
    </controller>
    <controller type='sata' index='0'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x1f' function='0x2'/>
    </controller>
    <controller type='pci' index='0' model='pcie-root'/>
    <controller type='pci' index='1' model='pcie-root-port'>
      <model name='pcie-root-port'/>
      <target chassis='1' port='0x10'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0' multifunction='on'/>
    </controller>
    <controller type='pci' index='2' model='pcie-root-port'>
      <model name='pcie-root-port'/>
      <target chassis='2' port='0x11'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x1'/>
    </controller>
    <controller type='pci' index='3' model='pcie-root-port'>
      <model name='pcie-root-port'/>
      <target chassis='3' port='0x12'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x2'/>
    </controller>
    <interface type='bridge'>
      <mac address='52:54:00:d0:29:f6'/>
      <source bridge='br0'/>
      <model type='e1000e'/>
      <address type='pci' domain='0x0000' bus='0x01' slot='0x00' function='0x0'/>
    </interface>
    <serial type='pty'>
      <target type='isa-serial' port='0'>
        <model name='isa-serial'/>
      </target>
    </serial>
    <console type='pty'>
      <target type='serial' port='0'/>
    </console>
    <input type='tablet' bus='usb'>
      <address type='usb' bus='0' port='1'/>
    </input>
    <input type='mouse' bus='ps2'/>
    <input type='keyboard' bus='ps2'/>
    <graphics type='spice' autoport='yes' listen='0.0.0.0' passwd='xxx'>
      <listen type='address' address='0.0.0.0'/>
      <image compression='off'/>
    </graphics>
    <sound model='ich9'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x1b' function='0x0'/>
    </sound>
    <video>
      <model type='qxl' ram='65536' vram='65536' vgamem='16384' heads='1' primary='yes'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x0'/>
    </video>
    <redirdev bus='usb' type='spicevmc'>
      <address type='usb' bus='0' port='5'/>
    </redirdev>
    <redirdev bus='usb' type='spicevmc'>
      <address type='usb' bus='0' port='6'/>
    </redirdev>
    <redirdev bus='usb' type='spicevmc'>
      <address type='usb' bus='0' port='4.1'/>
    </redirdev>
    <redirdev bus='usb' type='spicevmc'>
      <address type='usb' bus='0' port='4.2'/>
    </redirdev>
    <redirdev bus='usb' type='spicevmc'>
      <address type='usb' bus='0' port='2'/>
    </redirdev>
    <redirdev bus='usb' type='spicevmc'>
      <address type='usb' bus='0' port='3'/>
    </redirdev>
    <hub type='usb'>
      <address type='usb' bus='0' port='4'/>
    </hub>
    <memballoon model='virtio'>
      <address type='pci' domain='0x0000' bus='0x02' slot='0x00' function='0x0'/>
    </memballoon>
  </devices>
</domain>

6
Sieć / Iptables podział łącza
« dnia: 2019-11-22, 10:42:54 »
Witam,
ostatnio internet zaczął wolniej działać i mam problem
załóżmy że mam serwer(linux) z dwoma kartami sieciowymi który pełni rolę dhcp,dns,firewall
eth0 - internet
eth1 - lan
W jaki sposób z pomocą reguł iptables można podzielić łącze na użytkowników sieci LAN, tak żeby pojedynczy uzytkownik nie zablokowal calego łącza (mam na mysli dostep do internetu)

7
Witam,

posiadam serwer pełniący rolę DHCP, DNS, GATEWAY, FIREWALL. Do eth0 podpięte łącze internetowe, eth1(dhcp interface) sieć LAN - switch sieciowy.

Jak można zabezpieczyć się przed podłączeniem obcego serwera DHCP do switch'a i nadawaniu błędnych adresów przez niego urządzeniom?
Przez iptables nie da się tego zrobić, bo jak rozumiem komunikacja między urządzeniami w sieci LAN odbywa się na warstwie switcha sieciowego i nie przechodzi przez mój serwer ?

8
Konfiguracja / Munin nie wysyla mail
« dnia: 2018-06-30, 15:28:06 »
Witam,
munin powiadamia o błędach critical i warning jednak nie wysyła powiadomień mailowych

Polecenie wykonane z poziomu root'a wysyła mail'a:
echo "MUNINs" | mail -s "MUNIN - ${var:group} :: ${var:host}" xxx@gmail.com

cat /etc/munin/munin.conf
# Example configuration file for Munin, generated by 'make build'

# The next three variables specifies where the location of the RRD
# databases, the HTML output, logs and the lock/pid files.  They all
# must be writable by the user running munin-cron.  They are all
# defaulted to the values you see here.
#
#dbdir  /var/lib/munin
#htmldir /var/cache/munin/www
#logdir /var/log/munin
#rundir  /var/run/munin

# Where to look for the HTML templates
#
#tmpldir        /etc/munin/templates

# Where to look for the static www files
#
#staticdir /etc/munin/static

# temporary cgi files are here. note that it has to be writable by
# the cgi user (usually nobody or httpd).
#
# cgitmpdir /var/lib/munin/cgi-tmp

# (Exactly one) directory to include all files from.
includedir /etc/munin/munin-conf.d

# You can choose the time reference for "DERIVE" like graphs, and show
# "per minute", "per hour" values instead of the default "per second"
#
#graph_period second

# Graphics files are generated either via cron or by a CGI process.
# See http://munin-monitoring.org/wiki/CgiHowto2 for more
# documentation.
# Since 2.0, munin-graph has been rewritten to use the cgi code.
# It is single threaded *by design* now.
#
#graph_strategy cron

# munin-cgi-graph is invoked by the web server up to very many times at the
# same time.  This is not optimal since it results in high CPU and memory
# consumption to the degree that the system can thrash.  Again the default is
# 6.  Most likely the optimal number for max_cgi_graph_jobs is the same as
# max_graph_jobs.
#
#munin_cgi_graph_jobs 6

# If the automatic CGI url is wrong for your system override it here:
#
#cgiurl_graph /munin-cgi/munin-cgi-graph

# max_size_x and max_size_y are the max size of images in pixel.
# Default is 4000. Do not make it too large otherwise RRD might use all
# RAM to generate the images.
#
#max_size_x 4000
#max_size_y 4000

# HTML files are normally generated by munin-html, no matter if the
# files are used or not. You can change this to on-demand generation
# by following the instructions in http://munin-monitoring.org/wiki/CgiHowto2
#
# Notes:
# - moving to CGI for HTML means you cannot have graph generated by cron.
# - cgi html has some bugs, mostly you still have to launch munin-html by hand
#
#html_strategy cron

# munin-update runs in parallel.
#
# The default max number of processes is 16, and is probably ok for you.
#
# If set too high, it might hit some process/ram/filedesc limits.
# If set too low, munin-update might take more than 5 min.
#
# If you want munin-update to not be parallel set it to 0.
#
#max_processes 16

# RRD updates are per default, performed directly on the rrd files.
# To reduce IO and enable the use of the rrdcached, uncomment it and set it to
# the location of the socket that rrdcached uses.
#
#rrdcached_socket /var/run/rrdcached.sock

# Drop somejuser@fnord.comm and anotheruser@blibb.comm an email everytime
# something changes (OK -> WARNING, CRITICAL -> OK, etc)
#contact.someuser.command mail -s "Munin notification" somejuser@fnord.comm
#contact.anotheruser.command mail -s "Munin notification" anotheruser@blibb.comm
#
# For those with Nagios, the following might come in handy. In addition,
# the services must be defined in the Nagios server as well.
#contact.nagios.command /usr/bin/send_nsca nagios.host.comm -c /etc/nsca.conf

# a simple host tree
[localhost.localdomain]
    address 127.0.0.1
    use_node_name yes
    cpu.user.warning :1
    cpu.user.critical :2
    contacts myalert
[lamb16]
        address 192.168.100.105
        use_node_name yes
        contacts myalert
    cpu.user.warning :1
    cpu.user.critical :2
    df._dev_mapper_ubuntu__vg_root.warning :1
    df._dev_mapper_ubuntu__vg_root.critical :2
#
# A more complex example of a host tree
#
## First our "normal" host.
# [fii.foo.com]
#       address foo
#
## Then our other host...
# [fay.foo.com]
#       address fay
#
## IPv6 host. note that the ip adress has to be in brackets
# [ip6.foo.com]
#       address [2001::1234:1]
#
## Then we want totals...
# [foo.com;Totals] #Force it into the "foo.com"-domain...
#       update no   # Turn off data-fetching for this "host".
#
#   # The graph "load1". We want to see the loads of both machines...
#   # "fii=fii.foo.com:load.load" means "label=machine:graph.field"
#       load1.graph_title Loads side by side
#       load1.graph_order fii=fii.foo.com:load.load fay=fay.foo.com:load.load
#
#   # The graph "load2". Now we want them stacked on top of each other.
#       load2.graph_title Loads on top of each other
#       load2.dummy_field.stack fii=fii.foo.com:load.load fay=fay.foo.com:load.load
#       load2.dummy_field.draw AREA # We want area instead the default LINE2.
#       load2.dummy_field.label dummy # This is needed. Silly, really.
#
#   # The graph "load3". Now we want them summarised into one field
#       load3.graph_title Loads summarised
#       load3.combined_loads.sum fii.foo.com:load.load fay.foo.com:load.load
#       load3.combined_loads.label Combined loads # Must be set, as this is
#                                                 # not a dummy field!
#
## ...and on a side note, I want them listen in another order (default is
## alphabetically)
#
# # Since [foo.com] would be interpreted as a host in the domain "com", we
# # specify that this is a domain by adding a semicolon.
# [foo.com;]
#       node_order Totals fii.foo.com fay.foo.com

contact.log.command tee -a /var/log/munin/alert.log
contact.myalert.command echo "MUNINs" | mail -s "MUNIN - ${var:group} :: ${var:host}" xxx@gmail.com
contact.myalert.always_send warning critical

Proszę o pomoc

9
Konfiguracja / Bash backup NAS
« dnia: 2018-04-27, 18:07:23 »
Witam, mam utworzone wydzieloną macierz na serwerze na kopię plików z NAS /dev/md5
Na tej macierzy przechowywane będą kopie NAS z każdego dnia
Chciałbym dopisać do skryptu backup'owego linijkę, aby
1. sprawdzał ile miejsca zajmuje katalog /mnt    (podmontowany NAS)
2. wyliczył X= 3400GB / (wyliczona wartość w 1 punkcie)
3. i podstawił do komendy find /services/bkpnas/ -ctime $X -delete

Wiadomym jest, plików na serwerze coraz więcej, dlatego chce zeby wyliczał z ilu dni musi usunąć najstarsze kopie, żeby zmieściła się najnowsza
Proszę o pomoc

10
Administracja / HA linux
« dnia: 2018-03-17, 17:38:04 »
Witam serdecznie,
poszukuje usługi w Linux'ie która zapewnia (HA)
-taką samą zawartość obu serwerów
-podczas awarii jednego automatycznie przełączenie

Która usługa jest odpowiednia, której usługi konfiguracji warto się uczyć?

11
Instalacja / Instalacja na raid1
« dnia: 2018-02-28, 17:33:39 »
Witam,
posiadam dwa dyski WD 4TB, tworzę macierz raid1 za pomocą instalatora linux (próbowałem na Opensuse i Ubuntu), dzielę dyski tak
md0: 8GB swap
md1: 8GB /
md2: ~4TB /services
Na końcu instalacji występuje błąd z instalacją grub'a
Proszę o pomoc

12
Witam serdecznie,
montowanie partycji ręcznie działa
mount /dev/sda3 /smb
mount -t ecryptfs /smb /smb

nie działa montowanie partycji /dev/sda3  /smb, odkąd została zaszyfrowana ecryptfs, chciałbym aby była obsługiwana na niej także quota

vi /etc/fstab
UUID=30b1d099-587d-4b53-9414-4497b42ef0d1 swap                 swap       defaults              0 0
UUID=46466790-b48f-470a-8585-4ae1d5c61184 /                    ext4       acl,user_xattr        1 1
UUID=48aa855f-dd87-4b8b-ace8-97f0bddaae66 /smb                 ext3       defaults        1 2

bez zakomentowania ostatniej linii system nie uruchamia się

13
Konfiguracja / Munin dynazoom
« dnia: 2018-01-26, 19:03:07 »
Witam,  munin generuje ładne wykresy, wszystko chodzi pięknie, jednak nie działa powiększanie wykresów wyznaczanie np. aby munin pokazał wykres od godziny do godziny, nie generuje się wykres nad parametrami
Proszę o pomoc

14
Konfiguracja / Vim Debian a Suse
« dnia: 2017-11-24, 17:27:46 »
Witam,
gdzie znajduja sie ustawienia Vim'a ?
Na czystym systemie w OpenSuse operuje się dużo przyjemniej w VIM niż w Debianie, chciałbym przeniesc ustawienia

15
Konfiguracja / Rescuecd a macierz jak odczytac dane z dysku
« dnia: 2017-11-16, 14:20:24 »
Witam
uruchamiam serwer z Rescuecd, jak mozna odczytac dane zapisane na jednym z dwóch dysków (działały w trybie Raid1). Obecnie przy próbie montowania pokazuje błąd linux raid member

Strony: [1] 2 3