Nowe posty

xx Linux na baaardzo leciwy laptop (4)
Dzisiaj o 13:22:04
xx Plasma 6 ssie (4)
Wczoraj o 08:52:34
xx instalacja asystenta google - problem (1)
Wczoraj o 06:20:59
xx Różnice w wydajności :) (1)
2024-02-29, 20:20:39
xx Problem z pulpitem w XFCE (2)
2024-02-29, 17:30:42
xx Problemy z instalacją ustawień jądra (1)
2024-02-26, 14:01:41
xx System 5.1 jak podłączyć i skonfigurować? (3)
2024-02-23, 22:32:16
xx Alternatywa dla Hamachi pod Raspberry Pi? (1)
2024-02-22, 13:51:32
xx Everspace (7)
2024-02-21, 21:33:19
xx [C] Uruchamianie zewnętrznych programów (14)
2024-02-11, 19:20:33

Pokaż wiadomości

Ta sekcja pozwala Ci zobaczyć wszystkie wiadomości wysłane przez tego użytkownika. Zwróć uwagę, że możesz widzieć tylko wiadomości wysłane w działach do których masz aktualnie dostęp.


Wiadomości - m72

Strony: [1]
1
To raczej będzie problem po stronie konfiguracji dns u usługodawcy bo jak zapodaje z wiersza komend spod windowsa  funkcje "tracert domena.pl" to idzie ale "tracert www.domena.pl" odpowiada "Unable to resolve target system name www.domena.pl." 
Więc chyba trzeba jakiś wpis dodać.
Są takie do wyboru:

2
Dodam jeszcze że np w cyberfolksach wygląda to tak że dodatkowo jest "zakres przekierowania" (jak na obrazku) i tam się to jakoś samo poustawiało że www też działa. Drugi wpis typu A (z www) chyba się sam dodał.
Reasumując, wystarczy że w Netmarku dodam kolejny wpis typu "A" tylko z www i powinno zadziałać?

3
I to pewnie jest dobry trop ale jakbyś mi mógł wytłumaczyć o co chodzi w tych CNAME, MX,  A, AAAA bo kompletnie tego nie ogarniam.
Myślałem że wystarczy przekierować tylko główną nazwę np domena.pl (bez www) na jakieś IP a reszta się dzieje po stronie serwera.
Faktycznie, mam tylko jeden wpis typu A przekierowujący na IP mojego pożal się boże "serwera".
Pozostałe wyglądają tak jak na obrazku.

ps. nazwy domen powycinałem bo wstyd :D

4
Konfiguracja / Apache2 nie działa domena z przedrostkiem www
« dnia: 2024-01-06, 11:15:27 »
Nie wiem gdzie jest problem. Nie działa mi domena z przedrostkiem www ale bez przedrostka działa normalnie tzn gdy na początku adresu jest http:// 
Przesyłam pliki konfiguracyjen apacza i vhosta. Jakby ktoś mógł rzucić na to okiem.

5
OK znalazłem błąd, może komuś się przyda.

Trzeba zmienić w confie apacza

<Directory /var/www/html>
    AllowOverride None
</Directory>


na

<Directory /var/www/html>
    AllowOverride All
</Directory>

6
Przesyłam jeszcze pliki konfiguracyjne apacza i vhosta

7
Konfiguracja / Ubuntu Server 22 jak ustawić przyjaze adresy
« dnia: 2023-12-13, 23:22:58 »
Jest problem z CMS-ami. Po świeżej instalacji nie działa ani drupal ani typo3, wordpress działa ale chyba tylko dla tego bo nie uzywa tzw przyjaznych adresów.
Po instalacji CMS-y nie znajdują własnych stron- jak na obrazkach.
Mod_Rewrite jest włączony jak widać. Czy ktoś wie w czym problem ?

8
Wtrące jeszcze jedno pewnie głupie  pytanie. Mam jakieś domeny w hostingowni i tam przekierowuje je na własny serwer i to działa. Na serwerze mam apacza z vhostami rodzielającymi ruch wg nazw domen i to działa. Jak mam wejść na własne stronki używając adresu IP a nie nazwy domeny ?
Bo takie coś nie działa.
---> 1.2.3.4/mojastrona.pl
---> 1.2.3.4/../mojastrona.pl
---> 1.2.3.4/public_html/mojastrona.pl
????jak to odpalić???
Strony mam w
/var/www/strona1/public_html
/var/www/strona2/public_html

domyślna strona apacza po wpisaniu samego IP też działa i jest w katalogu
/var/www/html

 

9
Wielkie dzięki kolego, zrobiłem jak napisałeś i już większość rzeczy działa. Ale nie kumam co ma dawać ten sgid. Próbowałem go dodawać i nic to nie daje.
Jak tworzę pliki lub katalogi (przez ftp-a bo tak bedzie przecież pracował user ze swoimi stronkami) to powstają "normalnie" czyli user=user:grupa=user a nie jak chyba powinno być czyli user:www-data bo rozumiem że wszystko co wchodzi w zawartość stronki powinno mieć takich właścicieli/grupy. 

W przykładzie są to nowe - katalog zzz i plik  --.php

10
Panowie, tak edukacyjnie sobie stawiam serwerek i mam problem jak powinny być ustawione właściwości i właściciele systemu plików pod strony www.
Są sobie dwa vhosty i dwóch userów. Ogólnie serwer działa ..... ale nie działa bo nie wiem jak poustawiać w.w. właściwości. Męczę się już 2 dzień.

Chcę tak to ustawić żeby każdy user po wrzuceniu przez ftp-a plików na serwer miał do nich pełne prawa, ale nie mógł wyleźć wyżej swojego katalogu domowego (domowego w /var/www/'strona_usera') No i oczywiście żeby stronki działały.
Podobno właścicielem wszystkiego w www powinien być user "www-data" tak mi się o oko obiło w necie.
Panowie, jak ktoś potrafi to niech zmodyfikuje mi poniższe drzewko tak żeby było poprawne. Będę próbował sam to zmodyfikować/poustawiać. Jak nie dźwignę to się tu upomnę o poradę.
 
user_1@atari:/var/www$ sudo tree -pug

[drw-r----- user_1     user_1]  .
├── [drw-r----- user_1     www-data]  strona1
│   └── [drw-r----- user_1     www-data]  public_html
│       ├── [-rw-r----- user_1     user_1]      index1.html
│       └── [-rw-r----- user_1     user_1]      style.css
└── [drw-r----- user_2     www-data]  strona2
    └── [drw-r----- user_2     www-data]  public_html
        ├── [-rw-r----- user_2     user_2]       index2.html
        └── [-rw-r----- user_2     user_2]       style.css


11
Administracja / Odp: Jak przenieść obraz dysku na inny dysk
« dnia: 2022-06-24, 15:47:32 »
Tak mi jeszcze przyszło do głowy.
A może by tak przenieść tylko same partycje np: sudo dd if=/dev/sdb2 of=/dev/sdc2 status=progress
Pierwsze / a później /home.
Bo inaczej to będzie chyba klonował cały dysk łącznie z pustym miejscem nawet jeśli nie ma tam żadnych partycji a tak to się nie da skopiować 500Gb na 250Gb.
 sudo dd if=/dev/sdb of=/dev/sdc status=progress

Tak ?

12
Administracja / Jak przenieść obraz dysku na inny dysk
« dnia: 2022-06-24, 12:35:55 »
Nie jestem pewien czy w dobrym dziale piszę.
Panowie, czy da się przenieść w miarę bezproblemowo cały dysk łącznie z partycjami na inny dysk za pomocą programu dd ?
Teraz komputer chodzi na dysku talerzowym 500GB a docelowo ma to trafić na SSD250GB.
Powiedzmy że uporządkuję dysk 500GB tak żeby dalej poza 200GB w górę nic nie było, nawet żadnej partycji i czy wtedy da się zrobić takiego klona  na 250GB SSD ?
Nie chce mi się siedzieć 2 dni i jeszcze raz wszystkiego konfigurować.
System Ubuntu server 20.


Strony: [1]