Nowe posty

xx Ocena odpowiedzi - włączenie funkcji forum (1)
2022-01-18, 17:00:43
xx Instalacja Linux pop!os na laptopie bez systemu (10)
2022-01-13, 19:00:51
xx Stary Asus x71sl , nie startuje żaden linux (8)
2022-01-11, 19:00:52
xx HDMI - problem w poprawnym działaniu (0)
2022-01-11, 13:09:19
xx Search redirecting (4)
2022-01-08, 12:12:02
xx Jak to wersja (24)
2022-01-07, 00:22:09
xx Zadanie (1)
2022-01-06, 09:34:34
xx Skrypt usuwający zawartość folderu przy wyłączaniu komputera (8)
2022-01-06, 05:32:29
xx Jak w Manjaro uniemożliwić montowanie innych dysków? (5)
2022-01-06, 05:25:25
xx Problem z prawami dostępu (2)
2022-01-04, 14:40:03

Pokaż wiadomości

Ta sekcja pozwala Ci zobaczyć wszystkie wiadomości wysłane przez tego użytkownika. Zwróć uwagę, że możesz widzieć tylko wiadomości wysłane w działach do których masz aktualnie dostęp.


Wiadomości - Panas

Strony: [1] 2 3 ... 13
1
Inne / Odp: symlinki do sbin
« dnia: 2021-10-17, 11:52:55 »
Ta dokumentacja nie ma nic do mojego problemu.
Temat proszę usunąć bo tylko wstyd sobie robię =D

2
Inne / symlinki do sbin
« dnia: 2021-10-17, 01:25:10 »
Mam starszego debiana na virtualce i część komend podstawowych jak "shutdown –h now"  oraz starszych po instalacji net-tools nie działa poprawnie, również na roocie.
ifconfig,ifup etc i kij go wi co jeszcze.
Wyrażenie muszę wyciągać z /sbin/[wyrażenie]

Takie uroki debiana 10.X? Czy może da się wyciągnąć polecenia do terminala za jednym zamachem bez grzebania się z każdym poleceniem?

3
Karty graficzne / Odp: Geforce 740M a ubuntu 20.04.2
« dnia: 2021-04-27, 18:21:17 »
Już poprawione, Nouveau ma artefakty więc pozostanę na intelowskiej grafice.

4
Karty graficzne / Odp: Geforce 740M a ubuntu 20.04.2
« dnia: 2021-04-27, 17:25:28 »
Z tym jest zabawnie ponieważ zrobiłem reinstalkę i nie łapie mi już żadnych sterowników do nvidii
Graphics:  Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915 v: kernel 
           Device-2: NVIDIA GK208M [GeForce GT 740M] driver: nvidia v: 460.73.01
           Display: x11 server: X.Org 1.20.9 driver: modesetting,nouveau unloaded: fbdev,vesa resolution: 2560x1440~60Hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2) v: 4.5 Mesa 20.2.6

Cytuj
ubuntu-drivers devices
WARNING:root:_pkg_get_support nvidia-driver-390: package has invalid Support Legacyheader, cannot determine support level
== /sys/devices/pci0000:00/0000:00:01.1/0000:07:00.0 ==
modalias : pci:v000010DEd00001292sv000017AAsd0000380Abc03sc02i00
vendor   : NVIDIA Corporation
model    : GK208M [GeForce GT 740M]
manual_install: True
driver   : nvidia-driver-460-server - distro non-free
driver   : nvidia-340 - distro non-free
driver   : nvidia-driver-460 - distro non-free recommended
driver   : nvidia-driver-390 - distro non-free
driver   : nvidia-driver-450-server - distro non-free
driver   : nvidia-driver-450 - distro non-free
driver   : nvidia-driver-418-server - distro non-free
driver   : xserver-xorg-video-nouveau - distro free builtin

panas@panas:~$ sudo apt install xserver-xorg-video-nouveau
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
xserver-xorg-video-nouveau is already the newest version (1:1.0.16-1).
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.



5
Karty graficzne / Odp: Geforce 740M a ubuntu 20.04.2
« dnia: 2021-04-26, 21:36:38 »
418 też coś nie działa, sterownik ze strony miał problem z kernelem, Pozostaje 20.04.1 albo pozostanę z intelowską grafiką.

6
Karty graficzne / Geforce 740M a ubuntu 20.04.2
« dnia: 2021-04-25, 23:45:06 »
Mam kilka problemów z kratą jak niżej widać, w tej sytuacji poza zbiciem kernela do 5.4 jeszcze coś jest możliwe?
System rekomenduje mi sterownik do innej karty, 390 wykrywa ale w sieci znalazłem że 390 jest do Ubuntu 20.04.1, na stronie invidia że sterownik działa z kernelem 5.4 a ten domyślnie jest na Ubuntu 20.04.2.
To samo z 418 który znajduje przez apt search.
Jak nic nie ruszy to downgrade do 20.04.1 ;/

Ubuntu: 20.04.2
Kernel: 5.8.0-50-generic
Grafika: Geforce 740M
Sterownik: 390.143

panas@panas:~$ vainfo
libva info: VA-API version 1.7.0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/nvidia_drv_video.so
libva info: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit

ubuntu-drivers devices
WARNING:root:_pkg_get_support nvidia-driver-390: package has invalid Support Legacyheader, cannot determine support level
== /sys/devices/pci0000:00/0000:00:01.1/0000:07:00.0 ==
modalias : pci:v000010DEd00001292sv000017AAsd0000380Abc03sc02i00
vendor   : NVIDIA Corporation
model    : GK208M [GeForce GT 740M]
driver   : nvidia-driver-460 - distro non-free recommended
driver   : nvidia-driver-450-server - distro non-free
driver   : nvidia-340 - distro non-free
driver   : nvidia-driver-450 - distro non-free
driver   : nvidia-driver-418-server - distro non-free
driver   : nvidia-driver-390 - distro non-free
driver   : nvidia-driver-460-server - distro non-free
driver   : xserver-xorg-video-nouveau - distro free builtin

panas@panas:~$ nvidia-smi
Sun Apr 25 23:05:15 2021       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 390.143                Driver Version: 390.143                   |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GT 740M     Off  | 00000000:07:00.0 N/A |                  N/A |
| N/A   51C    P0    N/A /  N/A |    233MiB /  2004MiB |     N/A      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0                    Not Supported                                       |
+-----------------------------------------------------------------------------+


7
Usługi / Odp: Nginx dostęp
« dnia: 2020-11-29, 20:09:05 »
No i temat zamknięty
sudo chmod og+x /home/...

Ostatnio chwilę po napisaniu odpowiedzi same wpadają mi do głowy.

8
Usługi / Nginx dostęp
« dnia: 2020-11-29, 20:04:03 »
Zakręciłem się na prawach dostępowych.
Na serwerze mam folder www (root, użytkownik) mają dostęp i stąd nginx czyta stronę.
Kolejny użytkownik to użytkownik testowy jednak jego plików nginx nie chce czytać.
Jecheli chownem zmienię użytkownika oryginalnego na nginx:nginx to strona testowa lata idealnie ale nie ma wtedy dostępu do konta użytkownika co jest nieakceptowalne.
usermod -G test nginx  nie rozwiazuje problemu
usera w nginx nie chce zmieniać na root

Jakieś rozwiazanie?

9
Administracja / Odp: kontrola dostępu
« dnia: 2020-11-08, 12:26:31 »
search nie wymaga, z rozpędu napisałem.
W skryptach jestem jeszcze zerowy.
Temat rozwiązany poniekąd

10
Administracja / kontrola dostępu
« dnia: 2020-10-25, 15:37:30 »
Argumenty na dnf muszę wydzielić, chcę aby użytkownik mógł tylko instalować program i restartować podobnie ale przy  /usr/bin/dnf  [arg1] [arg2] wywala mi błąd w zapisie.
przy dnf chciałbym aby użytkownik mógł tylko instalować , szukać i aktualizować, jak to podzielić?
Cytuj
www ALL = NOPASSWD : /usr/bin/dnf , /usr/bin/systemctl, /bin/nice, /bin/kill, /usr/bin/kill, /usr/bin/killall, !/bin/su

 

11
Bash, skrypty powłoki / Odp: Szkielet z getops
« dnia: 2020-10-25, 15:06:20 »
Dzięki panowie, jak się da to mogę drążyć temat.

12
Bash, skrypty powłoki / Szkielet z getops
« dnia: 2020-10-24, 01:13:31 »
Chcę zrobić coś takiego że przy odpaleniu skrypu muszę podać dwie opcje np -c -a
Pierwszy  argument (c||a) odpowiednie narzędzie i dla nich (a || b || c || d ) czyli co ma się wykonać  np a odczytuje, b zapisuje, d robi backup d przywraca backup.
Pierwsza cześć kodu się wykona (przy za komentowaniu drugiej cześci) ale przy a) wywala błąd.
getopts nie można zagnieżdżać? jak powinien wyglądać taki szkielet poprawnie?



while getopts ":ca" opt
do
case "${opt}" in
c)
            while getopts ":abcd" opt2
            do
                case "${opt2}" in
                    e)
                    echo "ok -a"
                    ;;
                    d)
                    echo "ok -b"
                    ;;
                    k)
                    echo "ok -c"
                    ;;
                    j)
                    echo  "ok -d"
                    ;;
                    *)
                    echo "Invalid option: -$OPTARG" >&2
                    exit 1
                    ;;
                esac
            done   


        a)
            while getopts ":abcd" opt2
            do
                case "${opt2}" in
                    e)
                    echo "ok -a"
                    ;;
                    d)
                    echo "ok -b"
                    ;;
                    k)
                    echo "ok -c"
                    ;;
                    j)
                    echo  "ok -d"
                    ;;
                    *)
                    echo "Invalid option: -$OPTARG" >&2
                    exit 1
                    ;;
                esac
            done 
       

       
     
esac
done

13
Inne / DNF autouzupełnianie
« dnia: 2020-10-20, 18:18:23 »
Mam centos8 na vps (ovh) i jeden mały lecz denerwujący błąd
nie działa autouzupełnianie dnf in[tab] i nie dokańcza, wszystko musze robić manualnie, etc czy hasła jak history uzupełn ale nazw pakietów i haseł od dnf nie tyka.
Shell basha wersja 4.4.19(1)-release (x86_64-redhat-linux-gnu)


bash-completion zainstalowane
bash-completion-extras - tego nie znajduje.

/var/cache/dnf wyczyszczone, ale nic to nie pomogło.

Podpowiedzi jakie znalazłem zawiodły.

// Problem występował tylko na quake terminal , po resecie ruszyło normalnie.

14
Administracja / Logi: USB brak komunikacji.
« dnia: 2020-10-18, 20:30:10 »
Pomożecie z odczytaniem syslogów od USB nie wiem czy hardware siada czy tylko system coś odwalił.
syslog
https://pastebin.com/yFNGSx76

dmesg | grep -iE "err|warn|fail"
https://pastebin.com/xypKDanu

Do laptopa mam podpięty kabel upstrem od monitora (do niego mysz i klawiatura)
Wyskoczyłem do sklepu , po powrocie nic nie reaguje, restart latopa i zero reakcji, druga myszka to samo, pendrive nie czytany ale dioda w nim sygnalizuje podłączenie.
Odpaliłem Live CD  wszystko działa, ponowny reset i wszystko wróciło do normy.
Kabel podpięty pod USB 3.0

15
Instalacja / Odp: System nie widzi Linuxa
« dnia: 2020-10-06, 21:53:30 »
Który boot manager używasz? (Mi windowsowy dalej automatycznie startuje z windowsem)
Przy starcie pod f10 lub f12 możesz ustawić.

Na koniec możesz gruba przeinstalować i na nowo wszystko poustawia.
https://forum.linux.pl/index.php/topic,25952.msg139898.html#new


Strony: [1] 2 3 ... 13