Forum Linux.pl

Środowiska graficzne => KDE => Wątek zaczęty przez: adas007 w 2009-02-03, 18:16:48

Tytuł: Usunięcie KDE 3.5 - pozostawienie KDE 4.2
Wiadomość wysłana przez: adas007 w 2009-02-03, 18:16:48
Jestem początkującym użytkownikiem openSUSE 11.1. Początkowo miałem zainstalowane KDE 3.5. Doinstalowałem KDE 4.2,chodzi ok. Chciałbym usunąć pakiety poprzedniej wersji KDE, jednak obawiam się, że będą problemy... Czy jeżeli używam KDE 4.2 to programy w moim systemie korzystają tylko z tej nowej biblioteki czy potrzebują też bibliotek z poprzedniej wersji KDE ?
Tytuł: Usunięcie KDE 3.5 - pozostawienie KDE 4.2
Wiadomość wysłana przez: arctgx w 2009-02-03, 18:38:38
  arctgx # ldd /usr/bin/k3b | grep kdecore
libkdecore.so.4 => /usr/lib/libkdecore.so.4 (0xb73d3000)
  arctgx # ldd /usr/bin/ktorrent | grep kdecore
libkdecore.so.5 => /usr/lib/libkdecore.so.5 (0xb7720000)
Mówi to tyle, że mój K3B zależy od KDE 3.*, zaś KTorrent - od KDE 4. Być może u Ciebie warto sprawdzić, co zostanie odinstalowane wraz z bibliotekami KDE3. Biblioteki, a środowisko potrzebne do uruchomienia pulpitu itp. to dwie różne rzeczy. Zobacz w swoim menedżerze pakietów na nazwy i opisy paczek.
Tytuł: Usunięcie KDE 3.5 - pozostawienie KDE 4.2
Wiadomość wysłana przez: adas007 w 2009-02-03, 19:01:13
Są powiązania np. kdelibs3  potrzebne jest do programu amarok.
Czyli rozumiem, że biblioteki związane z KDE3 są mi potrzebne. To w takim razie na czym polega i jak wykonać usunięcie środowiska 3.5 ?
Tytuł: Usunięcie KDE 3.5 - pozostawienie KDE 4.2
Wiadomość wysłana przez: Bees w 2009-02-03, 21:13:16
Radzę nie śpiesz się tak z usuwaniem 3.5, to jeszcze może ci się przydać. Jak KDE4 dorośnie i wszystkie programy będą już dopracowane to wtedy usuniesz.