Nowe posty

xx Jak poprawić polecenie wyszukujące największe pliki? (3)
2021-06-13, 20:00:52
xx CUPS - Wyłączenie hostname w nazwie udostępnionej drukarki (6)
2021-06-12, 02:45:06
xx Tłumaczenie prostych programów napisanych w csh na sh (0)
2021-06-11, 16:07:52
xx Do regulaminu (0)
2021-06-07, 02:16:34
xx kompletny restore systemu (5)
2021-06-03, 11:47:08
xx Połączenie wifi, nie skanuje w poszukiwaniu sieci. (1)
2021-06-02, 22:04:54
xx problemy z instalacją (1)
2021-06-02, 14:23:26
xx Pomoc w napisaniu skryptu (11)
2021-05-31, 13:34:19
xx Instalacja php5.4 na Debian10 (2)
2021-05-31, 09:13:54
xx Wielkie firmy wymuszają dane (7)
2021-05-30, 20:25:21

Pokaż wiadomości

Ta sekcja pozwala Ci zobaczyć wszystkie wiadomości wysłane przez tego użytkownika. Zwróć uwagę, że możesz widzieć tylko wiadomości wysłane w działach do których masz aktualnie dostęp.


Pokaż wątki -

Strony: [1] 2 3 4
1
Inne / Problem z usunięciem katalogu
« dnia: 2021-03-14, 08:23:50 »
Witam. Problem dotyczy dystrybucji OpenATV 6.5 - stosowanej do sterowania tunerami satelitarnymi. W tej dystrybucji, próbuję usunąć katalog który miał być używany do montowania zasobu sieciowego i nie mogę tego zrobić
Połączyłem się przez telnet  laptopem do tunera satelitarnego i próbuję usunąć katalog /media/autofs/Multimedia i nic mi nie wychodzi. Nie mogę też wejść do tego katalogu

Welcome to openATV for vusolo4k
openatv 6.5 vusolo4k

vusolo4k login: root
Password:
Last login: Sun Mar 14 08:11:14 CET 2021 on pts/0
root@vusolo4k:~# cd /
root@vusolo4k:/# cd /media/autofs
root@vusolo4k:/media/autofs# ls
Multimedia
root@vusolo4k:/media/autofs# rmdir Multimedia
rmdir: 'Multimedia': Permission denied
root@vusolo4k:/media/autofs# cd /media/autofs/Multimedia
-bash: cd: /media/autofs/Multimedia: No such file or directory
root@vusolo4k:/media/autofs#

Jak mogę sprawdzić co blokuje usunięcie tego katalogu i co blokuje wejście do tego katalogu?

2
Programy graficzne / digiKam - problem z uruchomianiem
« dnia: 2020-02-06, 08:29:56 »
Witam
Coś namieszałem w ustawieniach i program digikam do zarządzania zdjęciami nie chce mi startować. Startuje natomiast bez problemu będą zalogowanym jako inny użytkownik. Aby rozwiązać problem z uruchomianiem dgikam chciałbym wykasować plik z ustawieniami programu. W którym miejscu w katalogu domowym użytkownika, program digikam przechowuje swoje ustawienia?

3
*Suse / Pblem z montowaniem dysku sieciowego
« dnia: 2019-08-09, 21:41:22 »
Mój system operacyjny to:

cat /etc/*-release
NAME="openSUSE Leap"
VERSION="15.1 "
ID="opensuse-leap"
ID_LIKE="suse opensuse"
VERSION_ID="15.1"
PRETTY_NAME="openSUSE Leap 15.1"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:leap:15.1"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"

Po aktualizacji systemu operacyjnego z OpenSuse 42.3 do OpenSuse 15.1, pojawił się problem z montowaniem dysków sieciowych poprzez CIFS.
W pliku /etc/fstab mam następujący wpis do montowania dysku sieciowego

//10.0.0.4/Multimedia /home/gienek/Multimedia cifs username=admin,password=**********,user,file_mode=0777,dir_mode=0777 0 0
//10.0.0.4/archiwum /home/gienek/Archiwum cifs username=admin,password=*****,user,file_mode=0777,dir_mode=0777 0 0
//10.0.0.4/Praca /home/gienek/Praca cifs username=admin,password=*****,user,file_mode=0777,dir_mode=0777 0 0

Zdziwiłem się, gdy kliknąłem w menagerze plików na katalog /home/gienek/Multimedia a tam pusto. Spróbowałem zamontować katalog Multimedia i otrzymałem dziwną odpowiedź

linux-nx5d:~ # mount /home/gienek/Multimedia
mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)

linux-nx5d:~ # rpm -qa | grep cifs
pcp-pmda-cifs-4.3.1-lp151.1.3.x86_64
cifs-utils-6.8-lp151.3.1.x86_64
cifs-utils-devel-6.8-lp151.3.1.x86_64

linux-nx5d:~ # rpm -qa | grep mount
libmount1-2.33.1-lp151.2.23.x86_64
linux-nx5d:~ #

Nie wiem w czym jest problem. Przed aktualizacją systemu, nie było żadnego problemu, przy takim wpisie w pliku fstab z montowaniem dysków sieciowych. Czy ktoś może mi pomóc w montowaniu dysków sieciowych?


4
Instalacja oprogramowania / Problem z kompilacją Qnapi
« dnia: 2015-08-09, 08:58:09 »
Witam.

Mój system operacyjny to Opensuse 13.2 64bit

Pobrałem sobie źródła programu do napisów Qmake http://qnapi.github.io/

Mam zainstalowane następujące pakiety
gienek@linux-ygzy:~/Pulpit/qnapi-0.1.8> rpm -qa | grep icecream-clang
icecream-clang-wrappers-1.0.1-5.1.2.x86_64
gienek@linux-ygzy:~/Pulpit/qnapi-0.1.8> rpm -qa | grep libconfig++
libconfig++9-1.4.9-6.1.2.x86_64
libconfig++-devel-1.4.9-6.1.2.x86_64
Potem wydałem polecenie
git clone --recursive https://github.com/QNapi/qnapi.git`
Oraz
qmake
i

gienek@linux-ygzy:~/Pulpit/qnapi-0.1.8> qmake
gienek@linux-ygzy:~/Pulpit/qnapi-0.1.8> make
uic ui/frmprogress.ui
uic ui/frmlistsubtitles.ui
uic ui/frmsummary.ui
uic ui/frmscan.ui
uic ui/frmoptions.ui
uic ui/frmabout.ui
uic ui/napiprojekt/frmnapiprojektconfig.ui
uic ui/frmupload.ui
uic ui/frmcorrect.ui
uic ui/frmreport.ui
uic ui/opensubtitles/frmopensubtitlesconfig.ui
compiling src/main.cpp
In file included from src/qnapi.h:25:0,
                 from src/forms/frmprogress.h:30,
                 from src/qnapiapp.h:29,
                 from src/main.cpp:25:
src/qnapisy24engine.h:7:21: fatal error: QUrlQuery: Nie ma takiego pliku ani katalogu
 #include
                     ^
compilation terminated.
Makefile:581: polecenia dla obiektu 'tmp/main.o' nie powiodły się
make: *** [tmp/main.o] Błąd 1
gienek@linux-ygzy:~/Pulpit/qnapi-0.1.8> qmake
gienek@linux-ygzy:~/Pulpit/qnapi-0.1.8> make
compiling src/main.cpp
In file included from src/qnapi.h:25:0,
                 from src/forms/frmprogress.h:30,
                 from src/qnapiapp.h:29,
                 from src/main.cpp:25:
src/qnapisy24engine.h:7:21: fatal error: QUrlQuery: Nie ma takiego pliku ani katalogu
 #include
                     ^
compilation terminated.
Makefile:581: polecenia dla obiektu 'tmp/main.o' nie powiodły się
make: *** [tmp/main.o] Błąd 1
gienek@linux-ygzy:~/Pulpit/qnapi-0.1.8>
Wywaliło mi błąd tak jak powyżej.

Czego nie mam w systemie lub co źle robię?

5
Inne urządzenia / Problem z drukarką Canon Pixma MG7550
« dnia: 2014-11-11, 13:28:49 »
OS - OpenSuse 13.2 64bit
Drukarka - Canon Pixma MG7550 podłączona poprzez gniazdo ethernet do domowej sieci LAN

Nie dawno kupiłem nową drukarkę. Na początku miałem OpenSuse 13.1 i na tym systemie jak i na Windows 8.1 drukarka działała jak należy.

Teraz mam OpenSuse 13.2 i niestety nie mogę uruchomić mojej drukarki. Skaner w tym urządzeniu działa prawidłowo.

Robiłem tak:

1. Pobrałem sterowniki ze strony producenta drukarki
2. Rozpakowałem archiwum a następnie uruchomiłem zawarty tam instalator install.sh który to mi zainstalował pakiet cnijfilter2-5.00-1.x86_64.rpm i zapytał się czy ma wyszukać drukarkę.
3. Wybrałem aby instalator wyszukał drukarkę i wybrałem, że drukarka jest podłączona poprzez LAN
4. Z niewiadomych przyczyn, instalator nie znalazł drukarki pomimo kilkukrotnego odświeżania.
5. Dałem sobie spokój z wyszukiwaniem drukarki przez instalator i wszedłem w Yast-> Sprzęt-> Drukarka
6. Tam wybrałem rodzaj połączenia LPD, nazwę ścieżki LPT1 i podałem adres IP drukarki.
7. Test połączenia z drukarką przeszedł pomyślnie.
8. Potem tylko wybrałem producenta drukarki i sterownik canonmg7500.ppd i na końcu zatwierdziłem.
9. Zrestartowałem system operacyjny jak i drukarkę i spróbowałem wydrukować stronę testową. Na drukarce na wyświetlaczu pojawił się napis "przetwarzanie" potem drukarka piknęła i nic nie wydrukowało
10.Wpisałem kilka literek w libreoffice i kliknąłem drukuj. Drukarka bardzo szybko zaczęła pobierać kartki i na każedj drukować to samo - te literki które wpisałem i kilka dziwnych linijek. Drukarka zdążyła w ten sposób zmarnować z 10 kartek zanim zdążyłem wcisnąć przycisk stop na urządzeniu.

W pliku /var/log/cups/error.log pojawił się wpis

!
E [11/Nov/2014:12:22:45 +0100] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
Czy może ktoś wie co może być nie tak bo skończyły mi się już pomysły.


EDIT 13.11.2014

Spróbowałem powalczyć z drukarką jeszcze trochę.

1. Usunąłem drukarkę zainstalowaną poprzednio.
2. Odinstalowałem zainstalowany pakiet cnijfilter2-5.00-1.x86_64.rpm
3.Zrestartowałem komputer
4. Wyłączyłem firewall
5. Uruchomiłem ponownie instalator install.sh
6. Instalator zainstalował ponownie pakiet cnijfilter2-5.00-1.x86_64.rpm oraz zapytał w jaki sposób mam podłączoną drukarkę. Okazało się, że poprzednio nie znajdował drukarki ponieważ blokował go firewall.
7. Wybrałem LAN i wcisnąłem ENTER. Instalator odnalazł drukarkę i ją zainstalował w systemie.
 Niestety przy próbie drukowania jest dokładnie taki sam efekt jak poprzednio i dokładnie ten sam błąd w logu.

Co nadal robię nie tak?

PS do jakich grup powinien należeć użytkownik oby nie było problemów z drukowaniem?

EDIT 15.11.2014

Powalczyłem jeszcze trochę
Sformatowałem dysk, zainstalowałem OpenSuse 13.1 64 bit
Zainstalowałem drukarkę. Drukarka zaczęła działać prawidłowo. Potem zaktualizowałem OpenSuse 13.1 do OpenSuse 13.2. Po sprawdzeniu okazało się że drukarka nadal działa prawidłowo.

Czemu drukarka nie chciała prawidłowo zainstalować się pod systemem operacyjnym OpenSuse 13.2 tego to nie wiem. Co prawda trochę na około ale udało mi się rozwiązać problem.

6
Inne / Brak widoku satelitarnego w Google Earth
« dnia: 2013-12-31, 16:57:45 »
Witam.

Zainstalowałem Google Earth i na moim komputerze wygląda to tak



Całkowity barak jest widoku z satelity. Widać tylko kontury i nazwy miejscowości. Może jakieś podpowiedzi co należy zrobić aby uzyskać normalny widok satelitarny.

7
Multimedia / VLC nie odtwarza filmów
« dnia: 2013-12-22, 22:54:07 »
Gdy próbuję odtworzyć film za pomocą VLC to mi wywala

No suitable decoder module:
VLC does not support the audio or video format "h264". Unfortunately there is no way for you to fix this.
Przewiduję, że nie zainstalowałem jakichś kodeków.
Mam takie pakiety które zawierają VLC w nazwie.

Cytuj
gienek@stacjonarny:~> rpm -qa | grep vlc
vlc-qt-2.1.2-186.10.x86_64
vlc-codecs-2.1.2-186.10.x86_64
libvlccore7-2.1.2-186.10.x86_64
vlc-2.1.2-186.10.x86_64
vlc-codecs-debuginfo-2.1.2-186.10.x86_64
vlc-noX-2.1.2-186.10.x86_64
libvlc5-2.1.2-186.10.x86_64
gienek@stacjonarny:~>
Czy coś jeszcze powinienem doinstalować aby móc odtwarzać filmy na VLC?

OS OpenSuse 13.1 64bit

8
Sieć / Montowanie - prawa do zapisu dla zwykłego użytkownika
« dnia: 2013-12-15, 17:04:50 »
Witam.

Pacjent to OpenSuse 13.1

Mam sobie sieciowy dysk twardy a w nim zasoby
Archiwum, Multimedia, Praca, Public

Na dysku lokalnym komputera utworzyłem katalogi do których chcę podmontować te zdalne zasoby. Do pliku /etc/fstab dopisałem i teraz mam

/dev/disk/by-id/ata-Maxtor_6B200M0_B404GFFH-part6 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-Maxtor_6B200M0_B404GFFH-part1 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-Maxtor_6B200M0_B404GFFH-part7 /archiwum            ext4       defaults              1 2
/dev/disk/by-id/ata-Maxtor_6B200M0_B404GFFH-part5 /home                ext4       acl,user_xattr        1 2
/dev/disk/by-id/ata-STM31000528AS_5VP0DEDE-part1 /multimedia          ext4       defaults              1 2
//10.0.0.4/archiwum /Archiwum cifs username=admin,password=xxx,user,rw 0 0
//10.0.0.4/Multimedia /Multimedia cifs username=admin,password=xxx,user,rw 0 0
//10.0.0.4/Praca /Praca cifs username=admin,password=xxx,user,rw 0 0
//10.0.0.4/Public /Publiczny cifs username=admin,password=xxx,user,rw 0 0
Cztery ostatnie linijki to zdalne katalogi które chcę zamontować.

Po restarcie systemu katalogi ładnie się zamontowały ale niestety nie ma możliwości zapisu do nich jako zwykły użytkownik. Jako root mogę zapisywać bez problemu

Próbowałem zmienić uprawnienia poleceniem

linux-qz5p:/ # chmod -R 777 /Archiwum
ale to nic nie pomogło.

Co robię nie tak?

9
Sieć / Montowanie dysku sieciowego
« dnia: 2013-04-19, 21:00:10 »
Posiadam dysk sieciowy który ma przypisany numer ip

10.0.0.4
W tym dysku sieciowym mam udział Mulitimedia do którego pełne prawa ma użytkownik o nazwie admin i haśle (powiedzmy) xxx

Chciałbym powyższy zasób zamontować do katalogu /Multimedia na moim komputerze.

W pliku /etc/fstab zrobiłem następujący wpis (ten na samym dole)

Cytuj
/dev/disk/by-id/ata-Maxtor_6B200M0_B404GFFH-part6 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-Maxtor_6B200M0_B404GFFH-part1 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-Maxtor_6B200M0_B404GFFH-part7 /archiwum            ext4       defaults              1 2
/dev/disk/by-id/ata-Maxtor_6B200M0_B404GFFH-part5 /home                ext4       acl,user_xattr        1 2
/dev/disk/by-id/ata-STM31000528AS_5VP0DEDE-part1 /multimedia          ext4       defaults              1 2
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
#
//10.0.0.4/Multimedia /Multimedia cifs users,username=admin,password=xxx 0 0
Po restarcie komputera widzę pliki z dysku sieciowego w katalogu /Multimedia. Niestety nie mogę nic utworzyć jako zwykły użytkownik. Jak zmodyfikować powyższy wpis w pliku /etc/fstab aby zwykli użytkownicy mieli prawo do zapisu?

PS
OS - OpenSuse 12.3 64bit

10
OS - OpenSuse 12.2 64bit
KDE 4.9
Nie chcę korzystać z pakietu rpm - dlaczego? Odpowiedź jest prosta - linux daje wolny wybór a ja wybrałem to, że nie chcę korzystać z rpma thunderbirda ;)

Od wielu lat korzystam z thunderbirda pobieranego ze strony mozilli Na początku korzystałem z niego w mandrivie, potem w OpenSuse 12.1 a teraz chciałem skorzystać z thunderbirda w OpenSuse 12.2. Zawsze były to systemy 64bit. Pobrałem spakowany program, rozpakowałem program do katalogu

/usr/share/thunderbird
wszedłem do tego katalogu i wydałem polecenie:

./thunderbird
Odpowiedź w konsoli była taka

gienek@linux-28ri:/usr/share/thunderbird> ./thunderbird
XPCOMGlueLoad error for file /usr/share/thunderbird/libxpcom.so:
libxul.so: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

gienek@linux-28ri:/usr/share/thunderbird>
Szczerze powiedziawszy to nigdy nie spotkałem się z czymś takim. W czym może być problem?

11
Multimedia / Amarok i Cyrylica
« dnia: 2012-08-11, 16:25:19 »
Niedawno kupiłem sobie płytę z muzyką w postaci MP3 wykonawcy z Rosji no i w Amaroku zamiast liter widzę tylko krzaki.



Czy da się jakoś zmusić Amaroka aby poprawnie wyświetlał TAGI w których występuje Cyrylica?

System operacyjny OpenSuse 12.1 64bit

12
Multimedia / Jak ooglądać filmy na Blu-Ray na OpenSuSE?
« dnia: 2012-01-15, 14:35:25 »
Czy jest jakaś metoda aby odtworzyć oryginalny film Blu-Ray na OpenSuSE wraz z menu z płyty?

Dziś zauważyłem podczas aktualizacji systemu, że YaST aktualizuje bibliotekę libbluray. Kiedyś sporo interesowałem się problemem odtwarzania oryginalnych krążków Blu-Ray z filmami na linuxie i dowiedziałem się, że zespół VideoLAN pracuje nad tą biblioteką.libbluray. Wtedy jeszcze to był dość początkujący projekt i do niczego się nie nadawał, ale obecnie skoro znajduje się już w dystrybucji to być może już coś na tym można obejrzeć?


Dotychczas radziłem sobie z oglądaniem filmów na oryginalnych płytach blu-ray za pomocą programu MakeMKV. Proces instalacji opisałem kiedyś na tej stronie Niestety odkodowywanie filmów za pomocą MakeMKV jest bardzo niewygodne a na dodatek nie ma obsługi menu krążka dlatego szukam innego rozwiązania


Ale wróćmy do libbluray

Na stronie ArchLinux znajduje się opis jak sobie poradzić z tym pakietem. Mój angielski jest dość problematyczny więc z tego co zrozumiałem to robiłem tak:

Zainstalowałem pakiety z repozytorów

gienek@stacjonarny:~> rpm -qa | grep libbluray
libbluray1-0.2.1-5.1.x86_64
gienek@stacjonarny:~>
Grzebiąc się po stronie VideoLan i niezdarnie rozszyfrowując angielski wydaje mi się aby odtwarzać oryginalne płyty Blu-Ray to trzeba zainstalować również drugi pakiet o nazwie libaacs

Ten pakiet również był w repozytorium do zainstalowania

gienek@stacjonarny:~> rpm -qa | grep libaacs
libaacs0-debuginfo-0.3.0-2.1.x86_64
libaacs0-0.3.0-2.1.x86_64
libaacs-devel-0.3.0-2.1.x86_64
gienek@stacjonarny:~>
1.Zgodnie z opisem wszedłem do

/home/gienek/.config/
i utworzyłem katalog  aacs.

2. Następnie pobrałem klucze z tego adresu i rozpakowałem do katalogu aacs

gienek@stacjonarny:~> ls /home/gienek/.config/aacs
KEYDB.cfg
gienek@stacjonarny:~>
3. Następnie wszedłem do katalogu /home/gienek/.config/aacs i wydałem polecenie

gienek@stacjonarny:~/.config/aacs> sed -i 's/\\([[:xdigit:]]\\)\\{5,\\}/0x&/g' /home/gienek/.config/aacs/KEYDB.cfg
gienek@stacjonarny:~/.config/aacs>
4. Zalogowałem się jako root i utworzyłem katalog /media/blurays

gienek@stacjonarny:~> su
Hasło:
stacjonarny:/home/gienek # mkdir /media/blurays
stacjonarny:/home/gienek #
5. Jako root zamontowałem płytę blu-ray z filmem do utworzonego poprzednio katalogu

stacjonarny:/home/gienek # mount /dev/sr0 /media/blurays
mount: urządzenie blokowe /dev/sr0 jest zabezpieczone przed zapisem, montowanie tylko do odczytu
stacjonarny:/home/gienek #
6. Sprawdzam już jako zwykły użytkownik czy napęd się zamontował

gienek@stacjonarny:~> ls /media/blurays
AACS  BDMV  CERTIFICATE
gienek@stacjonarny:~>
Widać katalogi z płyty blu-ray więc oznacza to, że napęd zamontował się poprawnie.

7. Zgodnie z opisem

Now the bluray has to be added to the key database so that libaacs can decrypt it. To do this, cd into /usr/share/aacskeys and run:
próbuję wejść do katalogu wskazanego w opisie

gienek@stacjonarny:/usr/share> cd /usr/share/aacskeys
bash: cd: /usr/share/aacskeys: Nie ma takiego pliku ani katalogu
gienek@stacjonarny:/usr/share>
I okazuje się, że nie ma takiego katalogu.

Co robię nie tak?

13
Sieć / Problem z hp-toolbox +
« dnia: 2011-12-24, 22:52:30 »
Posiadam drukarkę HP 5652 podłączoną do serwera wydruku Edimax PS-1206U który umożliwia korzystanie z drukarki w sieci.

Niestety program do administracji drukarek HP

hp-toolbox
nie widzi drukarki podłączonej do serwera wydruku. Za każdym razem gdy uruchomię ten program to pojawia mi się okienko widoczne poniżej



Gdy klikam Device Setup to niestety nie znajduje mi drukarki.

Postanowiłem dodać drukarkę w inny sposób i kliknąłem na przycisk CUPS web Interface i w okienku które otworzyło się w przeglądarce dodałem drukarkę.

Adres IP serwera wydruku to 10.0.0.3 więc jako adres drukarki wpisałem

socket://10.0.0.3:9100
Drukarka drukuje, lecz niestety narzędzie do zarządzania drukarkami hp-toolbox nie widzi dalej mojej drukarki.

Jako root w konsoli wpisałem hp-check -r

Konsola wypluła takie coś klik

HP5652
------
Type: Unknown
Device URI: socket://10.0.0.3:9100
PPD: /etc/cups/ppd/HP5652.ppd
PPD Description: HP Deskjet 5652 hpijs, 3.11.10
Printer status: printer HP5652 is idle.  enabled since sob, 24 gru 2011, 22:08:55
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend to function in HPLIP.
Nie bardzo rozumiem o co mu chodzi. Da się w jakiś sposób zmusić aby hp-toolbox zobaczyło moją drukarkę sieciową?

14
Inne / Problem z kompilowaniem Gnapi
« dnia: 2011-12-17, 23:10:37 »
Próbuję skompilować program gnapi do pobrania tutaj

Mój system operacyjny to OpenSuSE 12.1 64bit

W instrukcji instalacji tego programu czytamy:

Dependencies

Gnapi needs following *development* packages:
- gtk2.0,
- libnotify,
- libsoup2.4,
- libxml2,
- glib2.0,
- gconf2.0,
- gmodule2.0,
- libnautilus-extension,
- gnome-vfs,
- libavcodec, libavutil, libavformat (or ffmpeg or libav).

You need also:
- C compiler (gcc or clang),
- ld,
- strip,
- make,
- install,
- pkg-config.
These programs should be part of binutils and/or build-essentials packages.



 *** Compilation/Installation under Linux

Make sure you've installed all packages mentioned above!

After that type:

make
sudo make install

Compile with Clang (or other compiler):

make CC=clang

Install to other dir:

sudo make install DESTDIR=/home/me/programs/gnapi
Ja mam takie pakiety

gtk2.0
gienek@stacjonarny:~> rpm -qa | grep gtk2-devel
gtk2-devel-2.24.7-2.5.1.x86_64
gienek@stacjonarny:~>
libnotify
gienek@stacjonarny:~> rpm -qa |grep libnotify-devel
libnotify-devel-0.7.4-3.1.2.x86_64
gienek@stacjonarny:~>
libsoup2.4
gienek@stacjonarny:~> rpm -qa | grep libsoup-devel 
libsoup-devel-2.36.1-2.1.3.x86_64
gienek@stacjonarny:~>
libxml2
gienek@stacjonarny:~> rpm -qa | grep libxml2-devel
libxml2-devel-2.7.8+git20110708-3.1.2.x86_64
gienek@stacjonarny:~>
glib2.0
gienek@stacjonarny:~> rpm -qa | grep glib2-devel
glib2-devel-2.30.1-2.1.2.x86_64
glib2-devel-static-2.30.1-2.1.2.x86_64
gienek@stacjonarny:~>
gconf2.0
gienek@stacjonarny:~> rpm -qa | grep gconf2-devel
gconf2-devel-3.2.0-2.2.2.x86_64
gienek@stacjonarny:~>
gmodule2.0
gienek@stacjonarny:~> rpm -qa | grep gmodule
libgmodule-2_0-0-32bit-2.30.1-2.1.2.x86_64
libgmodule-2_0-0-2.30.1-2.1.2.x86_64
gienek@stacjonarny:~>
niestety nie mogę znaleźć pakietu gmodule-devel ale czy to nie jest to samo co glib2-devel?


libnautilus-extension
gienek@stacjonarny:~> rpm -qa | grep nautilus-devel
nautilus-devel-3.2.1-2.1.2.x86_64
gienek@stacjonarny:~>
gnome-vfs
gienek@stacjonarny:~> rpm -qa | grep gnome-vfs2-devel
gnome-vfs2-devel-2.24.4-7.1.2.x86_64
gienek@stacjonarny:~>
libavcodec, libavutil, libavformat (or ffmpeg or libav)
gienek@stacjonarny:~> rpm -qa | grep libffmpeg-devel
libffmpeg-devel-0.9-1.1.x86_64
gienek@stacjonarny:~>
libavcodec, libavutil, libavformat (or ffmpeg or libav)
gienek@stacjonarny:~> rpm -qa | grep libavahi-devel
libavahi-devel-0.6.30-10.1.3.x86_64
gienek@stacjonarny:~>
gcc
gienek@stacjonarny:~> rpm -qa | grep gcc
gcc46-fortran-4.6.2_20111026-1.1.4.x86_64
gcc46-4.6.2_20111026-1.1.4.x86_64
libgcc46-32bit-4.6.2_20111026-1.1.4.x86_64
gcc-objc-4.6-15.1.3.x86_64
gcc33-fortran-3.3.3-30.25.2.x86_64
gcc46-c++-4.6.2_20111026-1.1.4.x86_64
gcc-gij-4.6-15.1.3.x86_64
gcc-4.6-15.1.3.x86_64
gcc-obj-c++-4.6-15.1.3.x86_64
gcc46-objc-4.6.2_20111026-1.1.4.x86_64
gcc-fortran-4.6-15.1.3.x86_64
gcc-c++-4.6-15.1.3.x86_64
gcc46-obj-c++-4.6.2_20111026-1.1.4.x86_64
gcc33-3.3.3-30.25.2.x86_64
libgcc46-4.6.2_20111026-1.1.4.x86_64
gcc46-gij-4.6.2_20111026-1.1.2.x86_64
gcc33-c++-3.3.3-30.25.2.x86_64
gienek@stacjonarny:~>
clang
gienek@stacjonarny:~> rpm -qa | grep clang
llvm-clang-devel-3.0-1.5.1.x86_64
llvm-clang-3.0-1.5.1.x86_64
gienek@stacjonarny:~>
ld
nie mam pojęcia o co chodzi z tym ld. Jakieś sugestie?

strip
gienek@stacjonarny:~> rpm -qa | grep Strip
perl-HTML-Strip-1.06-4.5.x86_64
gienek@stacjonarny:~>
make
gienek@stacjonarny:~> rpm -qa | grep make
make-3.82-147.1.2.x86_64
gienek@stacjonarny:~>
install
gienek@stacjonarny:~> rpm -qa | grep install
install-initrd-branding-openSUSE-13.20-1.4.1.x86_64
checkinstall-1.6.2-14.1.2.x86_64
autoyast2-installation-2.21.4-2.1.2.noarch
libksuseinstall1-4.7.2-5.2.2.x86_64
yast2-installation-2.21.28-125.1.noarch
install-initrd-13.20-1.4.1.x86_64
gienek@stacjonarny:~>
pkg-config
gienek@stacjonarny:~> rpm -qa | grep pkg-config
pkg-config-0.25-7.1.5.x86_64
gienek@stacjonarny:~>
To wszystko co mam z tego co jest zapisane w pliku INSTALL. Jeśli powinienem coś doinstalować to proszę o podpowiedź.


Gdy wydaję polecenie make to pojawia mi się błąd

gienek@stacjonarny:~/Pulpit/gnapi-0.2.2> make -j5
cc -c ./src/gengine.c -o ./src/gengine.o -g -Wall -O2 -Wformat-security `pkg-config --cflags gtk+-2.0 gconf-2.0 gnome-vfs-2.0 libsoup-2.4 gmodule-2.0 libnautilus-extension`
cc -c ./src/plugins/napiprojekt/napi.c -o ./src/plugins/napiprojekt/napi.o -g -Wall -O2 -Wformat-security `pkg-config --cflags gtk+-2.0 gconf-2.0 gnome-vfs-2.0 libsoup-2.4 gmodule-2.0 libnautilus-extension` -fPIC
cc -c ./src/plugins/opensubtitles/os.c -o ./src/plugins/opensubtitles/os.o -g -Wall -O2 -Wformat-security `pkg-config --cflags gtk+-2.0 gconf-2.0 gnome-vfs-2.0 libsoup-2.4 gmodule-2.0 libnautilus-extension` -fPIC
cc -c ./src/plugins/nautilus/gnapi_nautilus.c -o ./src/plugins/nautilus/gnapi_nautilus.o -g -Wall -O2 -Wformat-security `pkg-config --cflags gtk+-2.0 gconf-2.0 gnome-vfs-2.0 libsoup-2.4 gmodule-2.0 libnautilus-extension` -fPIC
./src/plugins/nautilus/gnapi_nautilus.c: In function ‘get_file_items’:
./src/plugins/nautilus/gnapi_nautilus.c:51:17: warning: variable ‘gnapi’ set but not used [-Wunused-but-set-variable]
./src/gengine.c: In function ‘get_movie_info’:
./src/gengine.c:84:2: warning: ‘av_open_input_file’ is deprecated (declared at /usr/include/libavformat/avformat.h:1430) [-Wdeprecated-declarations]
./src/gengine.c:86:2: warning: ‘av_find_stream_info’ is deprecated (declared at /usr/include/libavformat/avformat.h:1476) [-Wdeprecated-declarations]
./src/gengine.c:96:2: warning: ‘avcodec_open’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:4073) [-Wdeprecated-declarations]
./src/gengine.c:75:8: warning: variable ‘streams’ set but not used [-Wunused-but-set-variable]
cc ./src/plugins/nautilus/gnapi_nautilus.o -shared -Wl,-export-dynamic,-soname,libnautilus-gnapi.so.1 -o libnautilus-gnapi.so -g -Wall -O2 -Wformat-security `pkg-config --cflags gtk+-2.0 gconf-2.0 gnome-vfs-2.0 libsoup-2.4 gmodule-2.0 libnautilus-extension` -fPIC `pkg-config --libs libnautilus-extension gtk+-2.0` -fPIC
cc -c ./src/plugins/napiprojekt/repbad.c -o ./src/plugins/napiprojekt/repbad.o -g -Wall -O2 -Wformat-security `pkg-config --cflags gtk+-2.0 gconf-2.0 gnome-vfs-2.0 libsoup-2.4 gmodule-2.0 libnautilus-extension` -fPIC
cc -c ./src/plugins/opensubtitles/os_config.c -o ./src/plugins/opensubtitles/os_config.o -g -Wall -O2 -Wformat-security `pkg-config --cflags gtk+-2.0 gconf-2.0 gnome-vfs-2.0 libsoup-2.4 gmodule-2.0 libnautilus-extension` -fPIC
cc -c ./src/gplugins.c -o ./src/gplugins.o -g -Wall -O2 -Wformat-security `pkg-config --cflags gtk+-2.0 gconf-2.0 gnome-vfs-2.0 libsoup-2.4 gmodule-2.0 libnautilus-extension`
./src/gplugins.c: In function ‘upload_once_plugin’:
./src/gplugins.c:167:10: warning: variable ‘status’ set but not used [-Wunused-but-set-variable]
./src/gplugins.c: In function ‘upload_once’:
./src/gplugins.c:192:10: warning: variable ‘status’ set but not used [-Wunused-but-set-variable]
./src/gplugins.c: In function ‘report_bad’:
./src/gplugins.c:217:10: warning: variable ‘status’ set but not used [-Wunused-but-set-variable]
cc ./src/plugins/opensubtitles/os.o ./src/plugins/opensubtitles/os_config.o -shared -Wl,-soname,libopensub.so.1 -o libopensub.so -g -Wall -O2 -Wformat-security `pkg-config --cflags gtk+-2.0 gconf-2.0 gnome-vfs-2.0 libsoup-2.4 gmodule-2.0 libnautilus-extension` -fPIC `pkg-config --libs gtk+-2.0 libsoup-2.4` -fPIC
cc -c ./src/plugins/napiprojekt/sendsubs.c -o ./src/plugins/napiprojekt/sendsubs.o -g -Wall -O2 -Wformat-security `pkg-config --cflags gtk+-2.0 gconf-2.0 gnome-vfs-2.0 libsoup-2.4 gmodule-2.0 libnautilus-extension` -fPIC
cc -c ./src/interface.c -o ./src/interface.o -g -Wall -O2 -Wformat-security `pkg-config --cflags gtk+-2.0 gconf-2.0 gnome-vfs-2.0 libsoup-2.4 gmodule-2.0 libnautilus-extension`
cc -c ./src/plugins/napiprojekt/napi_config.c -o ./src/plugins/napiprojekt/napi_config.o -g -Wall -O2 -Wformat-security `pkg-config --cflags gtk+-2.0 gconf-2.0 gnome-vfs-2.0 libsoup-2.4 gmodule-2.0 libnautilus-extension` -fPIC
cc -c ./src/scan.c -o ./src/scan.o -g -Wall -O2 -Wformat-security `pkg-config --cflags gtk+-2.0 gconf-2.0 gnome-vfs-2.0 libsoup-2.4 gmodule-2.0 libnautilus-extension`
cc -c ./src/plugins/napiprojekt/napi_common.c -o ./src/plugins/napiprojekt/napi_common.o -g -Wall -O2 -Wformat-security `pkg-config --cflags gtk+-2.0 gconf-2.0 gnome-vfs-2.0 libsoup-2.4 gmodule-2.0 libnautilus-extension` -fPIC
cc -c ./src/gnapi.c -o ./src/gnapi.o -g -Wall -O2 -Wformat-security `pkg-config --cflags gtk+-2.0 gconf-2.0 gnome-vfs-2.0 libsoup-2.4 gmodule-2.0 libnautilus-extension`
cc ./src/plugins/napiprojekt/napi.o ./src/plugins/napiprojekt/repbad.o ./src/plugins/napiprojekt/sendsubs.o ./src/plugins/napiprojekt/napi_config.o \\
        ./src/plugins/napiprojekt/napi_common.o -shared -Wl,-soname,libnapi.so.1 -o libnapi.so -g -Wall -O2 -Wformat-security `pkg-config --cflags gtk+-2.0 gconf-2.0 gnome-vfs-2.0 libsoup-2.4 gmodule-2.0 libnautilus-extension` -fPIC `pkg-config --libs gtk+-2.0 gconf-2.0 libsoup-2.4`
cc -c ./src/http_post.c -o ./src/http_post.o -g -Wall -O2 -Wformat-security `pkg-config --cflags gtk+-2.0 gconf-2.0 gnome-vfs-2.0 libsoup-2.4 gmodule-2.0 libnautilus-extension`
cc ./src/gnapi.o ./src/gengine.o ./src/gplugins.o ./src/interface.o ./src/scan.o ./src/http_post.o -o gnapi -g -Wall -O2 -Wformat-security `pkg-config --cflags gtk+-2.0 gconf-2.0 gnome-vfs-2.0 libsoup-2.4 gmodule-2.0 libnautilus-extension` `pkg-config --libs gtk+-2.0 gconf-2.0 gnome-vfs-2.0 libsoup-2.4 gmodule-2.0` -lnotify -lavformat -Wl,-export-dynamic
/usr/lib64/gcc/x86_64-suse-linux/4.6/../../../../x86_64-suse-linux/bin/ld: ./src/gplugins.o: undefined reference to symbol 'dlsym@@GLIBC_2.2.5'
/usr/lib64/gcc/x86_64-suse-linux/4.6/../../../../x86_64-suse-linux/bin/ld: note: 'dlsym@@GLIBC_2.2.5' is defined in DSO /lib64/libdl.so.2 so try adding it to the linker command line
/lib64/libdl.so.2: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make: *** [gnapi] Błąd 1
gienek@stacjonarny:~/Pulpit/gnapi-0.2.2>
Nie bardzo wiem o co chodzi. Z góry dziękuję pomoc.

EDIT -18.12.2011 - ROZWIĄZANIE

W końcu udało mi się rozwiązać problem.

gnapi 0.2.2 jest wersją ciut przestarzałą jak na OpenSuSE 12.1 i zawiera dość stare zależności. Aby zainstalować Gnapi należy pobrać najnowsze źródła za pomocą svn. Aby to zrobić tworzymy jakiś katalog, wchodzimy do niego i wydajemy polecenie:

svn co https://gnapi.svn.sourceforge.net/svnroot/gnapi gnapi
i czekamy aż pobierze nam źródła.

Następnie wchodzimy do katalogu ze źródłami i wydajemy polecenie

./configure
Jeśli konfigurator zasygnalizuje nam, że czegoś brakuje to należy to doinstalować. Gdy konfiguracja zakończy się pomyślnie to wydajemy polecenie

make -jx
zamiast literki x wstawiamy (aby nie przesadzić) cyfrę o jeden większą niż ilość rdzeni w naszym procesorze. Na przykład jeśli posiadamy procesor czterordzeniowy to wydajemy polecenie make -j5. Skutecznie przyśpiesza to proces kompilacji.

Po prawidłowy skompilowaniu programu tworzymy pakiet rpm. W tym celu logujemy się jako root

su
hasło
Następnie będąc zalogowanym jako root wydajemy polecenie które tworzy pakiet rpm czyli

checkinstall
Podajemy wszystkie dane aby nasz pakiet rpm miał jakiś ludzką nazwę i opis. Podczas tworzenia pakietu program checkinstall wywali prawdopodobnie kilka błędów odnośnie braku katalogów. Musimy je utworzyć w systemie i cały proces tworzenia pakietu zacząć od nowa. Czyli od momentu wydania polecenia checkinstall.

Gdy już utworzymymy pakiet rpm to instalujemy go za pomocą polecenia rpm -i nazwa_pakietu. I to w zasadzie wszystko. Po uruchomieniu programu musimy go skonfigurować ale to już inna bajka. U mnie wygląda to tak

gienek@stacjonarny:~> rpm -qa | grep gnapi
gnapi-0.3.0-1.x86_64
gienek@stacjonarny:~>
gienek@stacjonarny:~> rpm  -ql gnapi-0.3.0-1.x86_64
/usr
/usr/doc
/usr/doc/gnapi
/usr/doc/gnapi/ABOUT-NLS
/usr/doc/gnapi/AUTHORS
/usr/doc/gnapi/COPYING
/usr/doc/gnapi/ChangeLog
/usr/doc/gnapi/INSTALL
/usr/doc/gnapi/NEWS
/usr/doc/gnapi/README
/usr/doc/gnapi/TODO
/usr/doc/gnapi/docs
/usr/doc/gnapi/docs/.svn
/usr/doc/gnapi/docs/.svn/all-wcprops
/usr/doc/gnapi/docs/.svn/entries
/usr/doc/gnapi/docs/.svn/prop-base
/usr/doc/gnapi/docs/.svn/prop-base/copyright.svn-base
/usr/doc/gnapi/docs/.svn/props
/usr/doc/gnapi/docs/.svn/text-base
/usr/doc/gnapi/docs/.svn/text-base/Makefile.am.svn-base
/usr/doc/gnapi/docs/.svn/text-base/Makefile.in.svn-base
/usr/doc/gnapi/docs/.svn/text-base/copyright.svn-base
/usr/doc/gnapi/docs/.svn/text-base/gnapi.1.svn-base
/usr/doc/gnapi/docs/.svn/tmp
/usr/doc/gnapi/docs/.svn/tmp/prop-base
/usr/doc/gnapi/docs/.svn/tmp/props
/usr/doc/gnapi/docs/.svn/tmp/text-base
/usr/doc/gnapi/docs/Makefile
/usr/doc/gnapi/docs/Makefile.am
/usr/doc/gnapi/docs/Makefile.in
/usr/doc/gnapi/docs/copyright
/usr/doc/gnapi/docs/gnapi.1
/usr/lib64
/usr/lib64/nautilus
/usr/lib64/nautilus/extensions-3.0
/usr/lib64/nautilus/extensions-3.0/libnautilus-gnapi.so
/usr/local
/usr/local/bin
/usr/local/bin/gnapi
/usr/local/lib64
/usr/local/lib64/gnapi
/usr/local/lib64/gnapi/plugins
/usr/local/lib64/gnapi/plugins/libnapi.so
/usr/local/lib64/gnapi/plugins/libnapisyinfo.so
/usr/local/lib64/gnapi/plugins/libopensub.so
/usr/local/share
/usr/local/share/Thunar
/usr/local/share/Thunar/sendto
/usr/local/share/Thunar/sendto/gnapi-kde.desktop
/usr/local/share/applications
/usr/local/share/applications/gnapi.desktop
/usr/local/share/apps
/usr/local/share/apps/dolphin
/usr/local/share/apps/dolphin/servicemenus
/usr/local/share/apps/dolphin/servicemenus/gnapi-kde.desktop
/usr/local/share/apps/konqueror
/usr/local/share/apps/konqueror/servicemenus
/usr/local/share/apps/konqueror/servicemenus/gnapi-kde.desktop
/usr/local/share/gnapi
/usr/local/share/gnapi.png
/usr/local/share/gnapi/info.glade
/usr/local/share/gnapi/napi_config.glade
/usr/local/share/gnapi/niwindow.glade
/usr/local/share/gnapi/os.png
/usr/local/share/gnapi/os_config.glade
/usr/local/share/gnapi/plugins.glade
/usr/local/share/gnapi/scan.glade
/usr/local/share/kde4
/usr/local/share/kde4/services
/usr/local/share/kde4/services/ServiceMenus
/usr/local/share/kde4/services/ServiceMenus/gnapi-kde4.desktop
/usr/local/share/man
/usr/local/share/man/man1
/usr/local/share/man/man1/gnapi.1.gz
/usr/local/share/pixmaps
/usr/local/share/pixmaps/gnapi
/usr/local/share/pixmaps/gnapi/downloading.png
/usr/local/share/pixmaps/gnapi/gnapi.png
/usr/local/share/pixmaps/gnapi/os.png
/usr/local/share/pixmaps/gnapi/v-15.png
/usr/local/share/pixmaps/gnapi/v-18.png
/usr/local/share/pixmaps/gnapi/v-bo.png
/usr/local/share/pixmaps/gnapi/v-warn.png
gienek@stacjonarny:~>
gienek@stacjonarny:~> rpm  -qi gnapi-0.3.0-1.x86_64
Name        : gnapi
Version     : 0.3.0
Release     : 1
Architecture: x86_64
Install Date: nie, 18 gru 2011, 12:20:56
Group       : Applications/System
Size        : 457438
License     : GPL
Signature   : (none)
Source RPM  : gnapi-0.3.0-1.src.rpm
Build Date  : nie, 18 gru 2011, 12:20:36
Build Host  : stacjonarny
Relocations : (not relocatable)
Packager    : checkinstall-1.6.2
Summary     : Pobieranie napisów z: NapiProjekt, OpenSubtitles.org, Napisy.info
Description :
Package created with checkinstall 1.6.2
Distribution: (none)
gienek@stacjonarny:~>
Konfiguracja



http://gnapi.sourceforge.net/news.html

I to już wszystko. Jak to działa tego nie wiem bo jeszcze nie przetestowałem ale program wygląda równie ciekawie a nawet bardziej ciekawie jak qnapi.

15
Inne / Jak prawidłowo skonfigurować sambę
« dnia: 2011-11-30, 11:30:41 »
Mam problem z sambą. Dystrybucja to kubuntu.

Na początku założenia są takie (oczywiście potem będą rozbudowane)

1.Nazwa komputera widziana w sieci Stacjonarny
2. Grupa robocza Dom
3. Opis komputera kubuntu
4. Katalog udostępniony dla wszystkich na full /multimedia/udostepniony
5. Nazwa zasobu udostępnionego Udostepniony
6. Komentarz Katalog do wymiany plików


Napisałem taki prosty plik /etc/samba/smb.conf
[global]
netbios name = Stacjonarny
server string = kubuntu
workgroup = Dom
security = share

[Udostepniony]
comment = Katalog do wymiany danych
path = /multimedia/udostepniony
create mask = 0777
directory mask = 0777
browsable = yes
writable = yes
guest ok = yes
I teraz kilka problemów jakie napotkałem i nie wiem jak rozwiązać. Komputer klient to laptop z win7 i pracuje on również w grupie domowej Dom.
Niestety w Sieci w win7 nie widzę komputera sieciowego o nazwie Stacjonarny. Gdy wpiszę polecenie \\\\Stacjonarny to Win7 informuje mnie, że "System Windows nie może uzyskać dostępu do \\\\Stacjonarny". Lecz gdy zamiast nazwy podam adres IP komputera \\\\10.0.0.3 to otwiera się okienko w którym widzę katalog o nazwie Udostepniony lecz nie widzę żadnego komentarza do niego.

W związku z tym problemem mam pytanie co robię nie tak? Jak należy zmodyfikować plik smb.conf aby uzyskać dostęp po podaniu nazwy komputera.

Strony: [1] 2 3 4