Nowe posty

xx Pomoc w wyborze środowiska graficznego (11)
Wczoraj o 22:41:56
xx Usunąłem przez przypadek /bin co zrobić? (2)
Wczoraj o 21:36:24
xx Obrócony obraz lubuntu, xubuntu na lenovo Miix 320 (6)
Wczoraj o 11:56:25
xx Pierwsze kroki w Arch (9)
2022-05-22, 23:39:51
xx DBus (0)
2022-05-22, 12:47:35
xx Przedni panel (1)
2022-05-20, 01:34:35
xx Modem Medion S4222 jak zainstalować aplikację do jego obsługi? (52)
2022-05-18, 10:14:49
xx Strona o testach penetracyjnych, hackingu (33)
2022-05-18, 08:09:16
xx Nadawanie uprawnień przy kopiowaniu themes do katalogu (15)
2022-05-17, 21:18:16
xx Pobieraniu pliku zdalnie poprzez VPN (2)
2022-05-16, 20:49:59

Pokaż wiadomości

Ta sekcja pozwala Ci zobaczyć wszystkie wiadomości wysłane przez tego użytkownika. Zwróć uwagę, że możesz widzieć tylko wiadomości wysłane w działach do których masz aktualnie dostęp.


Wiadomości - utf-8

Strony: [1] 2 3 4
1
*Ubuntu / Odp: Brak macierzy RAID w Ubuntu
« dnia: 2020-09-08, 16:55:31 »
Ok czyli rozumiem że sprzętowy RAID to dopiero w płytach głównych za 2000zł. Cóż człowiek naiwny jest że za 500zł coś sensownego dostanie hehe

Co do problemu, to się wyjaśniło. Chipset B450 nie ma sterowników do RAID dla Linuxa. Czyli lipa, i ogólnie RAID przy Ryzen to niełatwo ogarnąć na Linux. Trzeba na starym B350, tylko go już za bardzo nie sprzedają. W takim razie wątek do zamknięcia. Będę się w innym dowiadywał czy da się ogarnąć RAID linuxem, co i tak nie jest pocieszające bo muszę dołożyć trzeci dysk.

2
*Ubuntu / Brak macierzy RAID w Ubuntu
« dnia: 2020-09-05, 13:50:28 »
Kiedyś instalowałem Ubuntu na RAID i było bez problemów
Natomiast teraz mam taki problem że nie wykrywa mi ustawionej macierzy w programie disks ani Gparted. Nie wiem o co chodzi, kwestie sprzętowe już właściwie odrzuciłem. Wątpię aby w sprzęcie tej klasy był jakiś pseudo RAID jak to czasami się zdarza.

Czy istnieją jakieś komendy co pozwolą mi wykryć tą macierz RAID? Zupełnie nie rozumiem dlaczego tak się dzieje, używam Ubuntu mate 20.04, czyli najnowszej stabilnej wersji.

3
Usługi / Odp: Apache2 i twarde https
« dnia: 2020-05-24, 23:11:25 »
Rewrite mam w htaccess, więc chyba nie potrzeba?

Ok, czyli ktoś kto to ustawiał, spowodował problemy umieszczając vhost w osobnych plikach. No i one się wczytują nie w tej kolejności co trzeba.

4
Usługi / Apache2 i twarde https
« dnia: 2020-05-19, 22:01:15 »
Panowie administratorzy. Może podpowiecie jak prawidłowo skonfigurować Apache2 z SSL. Tak aby na dwóch VirtualHost były różne certyfikaty i był tylko https, bez http.
Oczywiście skonfigurowałem te certyfikaty, tylko problem  jest z dzikimi przekierowaniami. Czy kombinuję jak koń pod górę i próbuję wymusić https przez apache a powinienem to robić .htaccess

Otóż zastosowałem taki bajer do przekierowania na VirtualHost nasłuchujący na porcie 443:
<VirtualHost serwera_ip:80>
        ServerAdmin webmaster@localhost
       
        ServerName sub.domena.pl
        ServerAlias www.sub.domena.pl
        DocumentRoot /var/www/vhost1
        Redirect permanent / https://sub.domena.pl
</VirtualHost>

Mam też VirtualHost na porcie 443 dla domena.pl i tam dałem identyczne przekierowanie:

No i teraz jak wchodzę na tą https://sub.domena.pl to tam ładnie wszystko działa z SSL. Z http://sub.domena.pl wyrzuca prawidłowo na https. Jak wchodzę na https://domena.pl to też działa SSL.
No ale jak wpiszę http://domena.pl to mnie wywala na https ale https://sub.domena.pl ! O co tutaj chodzi że dział nie to przekierowanie co powinno? Jest jakaś kolejka? Bo myślałem że określenie domeny i subdomeny określa co ma gdzie kierować, a tu jednak nie...

5
Sieć / Odp: Problem z kluczem w SSH
« dnia: 2020-03-28, 10:43:07 »
Bardziej mi chodzi o to czy jak jedna osoba korzysta z danego klucza to czy drugiej jest to blokowane.

I jak teraz dodać drugi klucz w Debian żeby nie tykać tego pierwszego. I aby nie odciąć sobie całkowicie dostępu? Ponieważ z tego co czytałem to wszystkie klucze są zdefiniowane w jednym pliku. I jego uszkodzenie spowoduje niemożliwość zalogowania się przez SSH? Czy tak?

6
Sieć / Problem z kluczem w SSH
« dnia: 2020-03-27, 16:23:38 »
Czy ktoś mógłby mi podpowiedzieć jak działają klucze w SSH?
Otóż korzystałem sobie z mojego klucza (automatycznie zainstalowanego) przez długi czas. Dawałem go nawet innemu użytkownikowi serwera i nie było problemu. Jednak po udostępnieniu klucza kolejnemu użytkownikowi, mi ten klucz przestał działać. Tzn przy próbie otworzenia SSH nic się nie dzieje. I to na dwóch komputerach i IP.
Czy to oznacza że zostałem zbanowany przez serwer?

Domyślam się że zainstalowanie drugiego klucza rozwiąże problem. Tylko trochę się boję odciąć dostęp całkowicie poprzez błąd w konfiguracji. A z tego co czytałem to trzeba pogrzebać w tym samym pliku który definiuje ten podstawowy klucz...

7
Konfiguracja / Swap w serwerach http
« dnia: 2019-11-21, 16:04:59 »
Mam problem z pewnym serwerem. Otóż z powodu że działa na nim dość popularna strona zrobiona w tragiczny sposób. Co jakiś czas potrafi się zawiesić mysql z powodu braku RAM.
I tak sobie myślę jak temu zaradzić, ponieważ na razie nic z technologią strony nie zdążę zrobić. Więc mam pytanie czy na takich serwerach w serwerowniach ustawia się SWAP jako rezerwę RAM? Trochę nie mam miejsca na tym serwerze bodajże 40GB (skalowalna Public claud w ovh), no ale z 5-10GB wyrwę w razie potrzeby. Tylko czy to ma sens?

8
Inne / Odp: Zmiana części pliku tekstowego (sed?)
« dnia: 2019-11-17, 14:48:52 »
Tyle to wiem, ale kopi zapasowych nie było. Więc muszę sprzątać kod ręcznie. To już inne techniki wykorzystuję do namierzania tych wstawek. Na szczęście zrobił to ktoś kto uważa że jest zajebisty. Wstawki są identyczne, więc bez problemu się to usuwa. Zabranie hasła mysql z domyślnego pliku też odcięło nadpisywanie bazy. Teraz w logach będę szukał gdzie to siedzi co nadpisuje cyklicznie.

Natomiast wracając do mojego problemu. Denerwuje mnie fakt że nie można zrobić find and replace stringa w pliku, jeśli ten zawiera znaki nowej linii.

9
Inne / Odp: Zmiana części pliku tekstowego (sed?)
« dnia: 2019-11-17, 12:56:10 »
Plików są setki jak nie tysiące. Ale fragment tekstu jest w każdym identyczny. Więc to chodzi tylko o to żeby wpisać frazę na te 5 linii. Problemem są linie:
} else {
}
 

Ponieważ one występują masowo i stąd muszę złapać wszystkie 5 linii.

Robiłem to za pomocą PHP Storm na okienkach. Ale ilość pomieszanych plików do skopiowania jest tak duża, że zajęłoby mi to cały dzień. A w konsoli zrobię to w kilkadziesiąt minut.

10
Inne / Zmiana części pliku tekstowego (sed?)
« dnia: 2019-11-17, 00:24:05 »
Potrzebuję wyciąć kawałek kodu z wszystkich plików w danym katalogu (pozostałość po ataku). Sęk w tym że jest on tak niewygodny, że muszę złapać kilka linii aby nie wywalić czegoś istotnego.

To jest mniej więcej taki format tekstu
if (blablabla) {
blabla.bla(bla);
} else {
blablablabla;
}

Natłukłem się tych poleceń w konsoli. Ale poprzednie problemy rozwiązywałem zdaje się:
find . -type f -name "*.js" -print0 | xargs -0 sed...
No ale z tymi kilkoma liniami to zupełnie mi nie wychodzi w sed. Patrzyłem ale nie mam komendy pearl na tym serwerze. Czy ktoś mógłby podpowiedzieć jak to ogarnąć?

11
Inne / Odp: Konto root i crontab backupu
« dnia: 2019-11-13, 22:51:23 »
Chodziło mi głównie o to czy taki zrzut wielkiej bazy, nie zabiera mocy obliczeniowej. No ale chyba pytanie z d..., ponieważ to proces jednowątkowy a rdzeni kilka...

12
Inne / Konto root i crontab backupu
« dnia: 2019-11-13, 17:45:42 »
Mam takie pytanie, konfiguruję dość konkretny serwer w chmurze pod HTTP. No i w sumie wprowadzam tylko drobne poprawki do domyślnej konfiguracji ovh.pl. No ale zastanawia mnie, czy jak dodaję do crontab skrypt tworzący backup np bazy danych. To mogę to robić na użytkowniku root czy muszę na jakimś innym np debian?
Na pewno nie chcę robić tego na użytkowniku www-data. Ponieważ miałem ostatnio taki przypadek że po uprawnieniach z poziomu PHP backdoor przeorał wszystkie pliki użytkownika tego użytkownika. Więc od razu czerwona lampka dla backupu na tym samym użytkowniku co działa serwer apache2

13
Płytę główną wymieniłem na identyczny model. Ustawiłem macierz RAID 1 w BIOS. No i system wystartował, chyba była jakaś naprawa na początku, ale to normalne podczas awarii w trakcie uruchomionego systemu.

Jak mogę sprawdzić te logi na Ubuntu? Administrator ze mnie kiepski dlatego pytam żeby nie pomylić co mam przejrzeć.

14
Niedawno padła mi płyta główna podczas pracy. Wymieniłem, ustawiłem ponownie RAID 1 i podłączyłem dyski. Linux chyba coś tam pokrzyczał przy starcie ale ogólnie uruchomił się i wydawało się że wszystko będzie git.
No ale niestety, teraz po uruchamianiu dostaję taki komunikat jak w załączniku, wcześniej jeszcze ekran ładowania dość długo "myśli". Co ciekawe po zamknięciu systemu z poziomu konsoli i uruchomieniu ponownie, nie występuje ten problem. Nie wiem też czy występuje on za każdym razem, z tego co pamiętam to ostatnie dwa uruchomienia tak, a przedostatnie nie.

Co może być problemem? Czy mam coś sprawdzić dla lepszego zobrazowania sytuacji?

15
Multimedia / Odp: Radio internetowe z buforem ładowania
« dnia: 2017-12-21, 19:25:45 »
Potestowałem, popróbowałem i udało mi się transmitować pliki FLAC bez kompresji.
Jednak jest jeden haczyk, działa to tylko gdy od razu podłączę się pod transmisję. Jak chcę dołaczyc jak zwykły słuchacz to niestety transmisja się przycina i co chwilę buforuje.
Co może być tego powodem? Eksperymentowałem z wielokrotnym zwiększaniem parametrów Icecast2 ale cały czas jest to samo. Zwiększenie buforowania w VLC też nie dało rozwiązania problemu. Będę wdzięczny za jakieś podpowiedzi gdzie szukać problemu

Strony: [1] 2 3 4