Forum Linux.pl

System => X Serwer => Wątek zaczęty przez: w 2007-04-14, 17:59:28

Tytuł: Problem z kompilacją xinelib
Wiadomość wysłana przez: w 2007-04-14, 17:59:28
Jak w temacie, przy make wyrzuca mi takie błędy(nie wiem czy to na pewno coś związne z X Serverem, jeśli nie to proszę o przniesienie):


creating xineplug_vo_out_xshm.la
(cd .libs && rm -f xineplug_vo_out_xshm.la && ln -s ../
xineplug_vo_out_xshm.la xineplug_vo_out_xshm.la)
 gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../.. -I../../include -I../../
include -I../../src -I../../src/xine-engine -I../../src/xine-engine -
I../../src/xine-utils -I../../src/input -I../../src/input -I../../lib -
I../../lib -DXINE_COMPILE -I/usr/X11R6/include -DNDEBUG -D_REENTRANT -
D_FILE_OFFSET_BITS=64 -DXINE_COMPILE -Wformat=2 -Wno-format-zero-
length -Wmissing-format-attribute -Werror-implicit-function-
declaration -Wstrict-aliasing -mcpu=pentiumpro -O3 -pipe -fomit-frame-
pointer -falign-functions=4 -falign-loops=4 -falign-jumps=4 -
fexpensive-optimizations -fschedule-insns2 -ffast-math -fno-inline-
functions -Wall -Wpointer-arith -Wnested-externs -Wcast-align -Wchar-
subscripts -Wmissing-declarations -Wmissing-prototypes -g -O2 -MT
xineplug_vo_out_xvmc_la-deinterlace.lo -MD -MP -MF .deps/
xineplug_vo_out_xvmc_la-deinterlace.Tpo -c deinterlace.c  -fPIC -DPIC -
o .libs/xineplug_vo_out_xvmc_la-deinterlace.o
deinterlace.h:44: warning: `deinterlace_methods' defined but not used
 gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../.. -I../../include -I../../
include -I../../src -I../../src/xine-engine -I../../src/xine-engine -
I../../src/xine-utils -I../../src/input -I../../src/input -I../../lib -
I../../lib -DXINE_COMPILE -I/usr/X11R6/include -DNDEBUG -D_REENTRANT -
D_FILE_OFFSET_BITS=64 -DXINE_COMPILE -Wformat=2 -Wno-format-zero-
length -Wmissing-format-attribute -Werror-implicit-function-
declaration -Wstrict-aliasing -mcpu=pentiumpro -O3 -pipe -fomit-frame-
pointer -falign-functions=4 -falign-loops=4 -falign-jumps=4 -
fexpensive-optimizations -fschedule-insns2 -ffast-math -fno-inline-
functions -Wall -Wpointer-arith -Wnested-externs -Wcast-align -Wchar-
subscripts -Wmissing-declarations -Wmissing-prototypes -g -O2 -MT
xineplug_vo_out_xvmc_la-video_out_xvmc.lo -MD -MP -MF .deps/
xineplug_vo_out_xvmc_la-video_out_xvmc.Tpo -c video_out_xvmc.c  -fPIC -
DPIC -o .libs/xineplug_vo_out_xvmc_la-video_out_xvmc.o
video_out_xvmc.c: In function `open_plugin':
video_out_xvmc.c:1551: warning: passing arg 4 of pointer to function
from incompatible pointer type
video_out_xvmc.c: At top level:
video_out_xvmc.c:706: warning: `create_ximage' defined but not used
video_out_xvmc.c:755: warning: `dispose_ximage' defined but not used
gcc -shared  .libs/xineplug_vo_out_xvmc_la-deinterlace.o .libs/
xineplug_vo_out_xvmc_la-video_out_xvmc.o  -Wl,--rpath -Wl,/root/Dane/
pakiety/multimedia/xine-lib-1.1.5/src/xine-engine/.libs -L/usr/X11R6/
lib -lXvMCW -lSM -lICE -lX11 -lXext -lXinerama ../../src/xine-
engine/.libs/libxine.so  -mcpu=pentiumpro -Wl,-z -Wl,defs -pthread -
Wl,-soname -Wl,xineplug_vo_out_xvmc.so -o .libs/
xineplug_vo_out_xvmc.so
.libs/xineplug_vo_out_xvmc_la-video_out_xvmc.o(.text+0xbfb): In
function `create_ximage':
/root/Dane/pakiety/multimedia/xine-lib-1.1.5/src/video_out/
video_out_xvmc.c:745: undefined reference to `XvCreateImage'
.libs/xineplug_vo_out_xvmc_la-video_out_xvmc.o(.text+0x1244): In
function `xvmc_property_callback':
/root/Dane/pakiety/multimedia/xine-lib-1.1.5/src/video_out/
video_out_xvmc.c:1019: undefined reference to `XvSetPortAttribute'
.libs/xineplug_vo_out_xvmc_la-video_out_xvmc.o(.text+0x12e2): In
function `xvmc_set_property':
/root/Dane/pakiety/multimedia/xine-lib-1.1.5/src/video_out/
video_out_xvmc.c:1036: undefined reference to `XvSetPortAttribute'
.libs/xineplug_vo_out_xvmc_la-video_out_xvmc.o(.text+0x1308):/root/
Dane/pakiety/multimedia/xine-lib-1.1.5/src/video_out/video_out_xvmc.c:
1038: undefined reference to `XvGetPortAttribute'
.libs/xineplug_vo_out_xvmc_la-video_out_xvmc.o(.text+0x17c2): In
function `xvmc_dispose':
/root/Dane/pakiety/multimedia/xine-lib-1.1.5/src/video_out/
video_out_xvmc.c:1219: undefined reference to `XvUngrabPort'
.libs/xineplug_vo_out_xvmc_la-video_out_xvmc.o(.text+0x191a): In
function `xvmc_check_capability':
/root/Dane/pakiety/multimedia/xine-lib-1.1.5/src/video_out/
video_out_xvmc.c:1256: undefined reference to `XvGetPortAttribute'
.libs/xineplug_vo_out_xvmc_la-video_out_xvmc.o(.text+0x1b39): In
function `xvmc_update_XV_DOUBLE_BUFFER':
/root/Dane/pakiety/multimedia/xine-lib-1.1.5/src/video_out/
video_out_xvmc.c:1309: undefined reference to `XvSetPortAttribute'
.libs/xineplug_vo_out_xvmc_la-video_out_xvmc.o(.text+0x1e2b): In
function `open_plugin':
/root/Dane/pakiety/multimedia/xine-lib-1.1.5/src/video_out/
video_out_xvmc.c:1416: undefined reference to `XvQueryPortAttributes'
.libs/xineplug_vo_out_xvmc_la-video_out_xvmc.o(.text+0x1ebd):/root/
Dane/pakiety/multimedia/xine-lib-1.1.5/src/video_out/video_out_xvmc.c:
1480: undefined reference to `XvListImageFormats'
.libs/xineplug_vo_out_xvmc_la-video_out_xvmc.o(.text+0x2520): In
function `dispose_class':
/root/Dane/pakiety/multimedia/xine-lib-1.1.5/src/video_out/
video_out_xvmc.c:1600: undefined reference to `XvFreeAdaptorInfo'
.libs/xineplug_vo_out_xvmc_la-video_out_xvmc.o(.text+0x25bf): In
function `init_class':
/root/Dane/pakiety/multimedia/xine-lib-1.1.5/src/video_out/
video_out_xvmc.c:1632: undefined reference to `XvQueryExtension'
.libs/xineplug_vo_out_xvmc_la-video_out_xvmc.o(.text+0x261b):/root/
Dane/pakiety/multimedia/xine-lib-1.1.5/src/video_out/video_out_xvmc.c:
1648: undefined reference to `XvQueryAdaptors'
.libs/xineplug_vo_out_xvmc_la-video_out_xvmc.o(.text+0x2bb7):/root/
Dane/pakiety/multimedia/xine-lib-1.1.5/src/video_out/video_out_xvmc.c:
1698: undefined reference to `XvGrabPort'
.libs/xineplug_vo_out_xvmc_la-video_out_xvmc.o(.text+0x2c9b):/root/
Dane/pakiety/multimedia/xine-lib-1.1.5/src/video_out/video_out_xvmc.c:
1672: undefined reference to `XvGrabPort'
collect2: ld returned 1 exit status
make[4]: *** [xineplug_vo_out_xvmc.la] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2



Nic mi to nie mówi... Brakuje czegoś w systemie?
Slackware 10.2
2.6.15.6