Nowe posty

Autor Wątek: Nie moge wpisywac polskich liter!!  (Przeczytany 11862 razy)

Offline Andrzej

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
Nie moge wpisywac polskich liter!!
« dnia: 2007-08-15, 14:35:06 »
Witam mam straszny problem :(
Mam Linux  Xubuntu  i nie moge wpisywac  polskich liter :(
wciskajac np. alt + a zaznacza mi tekst ktory napisalem nie moge napisac zadnego zdania z ogonkami :(   wszystko musze pisac tak jak wlasnie na forum :(
Prosze o pomoc.

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 452
    • Zobacz profil
Nie moge wpisywac polskich liter!!
« Odpowiedź #1 dnia: 2007-08-15, 14:38:52 »
1. Jak masz ustawione opcje językowe?
2.Problem występuje we wszystkich aplikacjach czy tylko w przeglądarce internetowej?
Ściemniać to my, ale nie nam :P

Offline Andrzej

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
Nie moge wpisywac polskich liter!!
« Odpowiedź #2 dnia: 2007-08-15, 14:42:30 »
Wszedzie ustawilem Polish
i ten problem wystepuje we wszystkich aplikacjach nie tylko w przegladarce :(

Offline arctgx

  • Users
  • Guru
  • *****
  • Wiadomości: 2753
    • Zobacz profil
Nie moge wpisywac polskich liter!!
« Odpowiedź #3 dnia: 2007-08-15, 15:38:55 »
Hmm, zazwyczaj tylko lewy Alt+A zaznaczają wszystko.

Jako zwykły użytkownik możesz w konsoli wpisać

setxkbmap -rules xorg -model pc105 -layout "pl"

i od razu sprawdzić czy takie "ą" się pojawi (lub "robak" w przypadku źle ustawionych czcionek). Sprawdź zarówno w konsoli, w której wpisałeś to polecenie, jak i w przeglądarce, w razie złej czcionki konsolowej.

Jeśli tak, to czas zerknąć do /etc/X11/xorg.conf i dopisać w odpowiednim miejscu (Section "InputDevice") te reguły:

        Option          "XkbRules"      "xfree86"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "pl"

Reguły X-ów mogą być nadpisane przez ustawienia Gnome lub KDE, jeśli używasz któregoś z tych menedżerów okien. Wtedy poszukaj czegoś w rodzaju okienkowego "centrum sterowania" czy polecenia w rodzaju gnome-keyboard-* - w tym już się zbyt dobrze nie orientuję - i wybierz, czy reguły menedżera mają dominować nad regułami Xorg.

Może Ubuntu ma jeszcze coś własnego, ale nie znam tej dystrybucji.
Użytkownik: Ib5sXfcCkvYR
Hasło: adam

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 452
    • Zobacz profil
Nie moge wpisywac polskich liter!!
« Odpowiedź #4 dnia: 2007-08-15, 16:04:43 »
Xubuntu jako środowisko graficzne ma Xfce, może tam należy szukać przyczyny.

Sprawdź jeszcze ten temat, szczególnie ostatnie kilka postów. Oczywiście wszystko masz na własną odpowiedzialność :)
http://forum.arch-linux.pl/viewtopic.php?pid=647
Ściemniać to my, ale nie nam :P

Offline Andrzej

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
Nie moge wpisywac polskich liter!!
« Odpowiedź #5 dnia: 2007-08-15, 18:30:54 »
Już rozwiązałem mój problem wchodząc w perfidne ustawienia klawiatury :D

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 452
    • Zobacz profil
Nie moge wpisywac polskich liter!!
« Odpowiedź #6 dnia: 2007-08-15, 23:17:25 »
Więc słoneczko wlep jak to zrobiłeś ku pamięci potomnym!
Ściemniać to my, ale nie nam :P

Offline Andrzej

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
Nie moge wpisywac polskich liter!!
« Odpowiedź #7 dnia: 2007-08-16, 13:34:04 »
Wchodzimy w menu u góry :D
Applications -> Ustawienia -> Ustawienia Klawiatury
W okienku wchodzimy w zakładkę Layouts  następnie odznaczamy Use X configuration
Niżej mamy:
Keyboard model i Keyboard Layouts
obok Keyboard layouts wciskamy Add (jest tam plusik w kółeczku) następnie na liście
trzeba odnaleść Poland i OK i następnie uruchamiamy ponownie komputer znowu wchodzimy w te ustawienia i w części keyboard layouts mamy us i pl więc zaznaczamy us i klikamy delete i od tej pory cieszymy się polskimi literkami i ich pięknymi ogonkami ;)