Nowe posty

Autor Wątek: debian + nvidia  (Przeczytany 5804 razy)

Offline Paweł Nowak

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
debian + nvidia
« dnia: 2005-08-13, 10:11:49 »
Mam problem z LILO. Podczas instalacji Mandrake\\'a 10.1 instalator nie pyta się gdzie ma umieścić boot loadera, a ja nie chcę go mieć na dysku tylko na dyskietce. Pomóżcie! Co mam zrobić żeby było dobrze?

Offline Remigiusz Witkowski

  • Users
  • Guru
  • *****
  • Wiadomości: 594
    • Zobacz profil
debian + nvidia
« Odpowiedź #1 dnia: 2005-08-13, 10:23:15 »
2005-08-13 10:11:49 sokol121 napisał:

> Mam problem z LILO. Podczas instalacji Mandrake\\'a 10.1 instalator nie pyta się gdzie ma umieścić
 > boot loadera, a ja nie chcę go mieć na dysku tylko na dyskietce. Pomóżcie! Co mam zrobić żeby
 > było dobrze?

 Pyta , na pewno pyta tylko Ty tego nie widzisz !
 Nie podam Ci szczegółów bo nie pamiętam ( to nie winda , że reinstalka co miesiąc...) , powtórzę jeszcze raz : PYTA ...

Offline kwazar uran

  • Users
  • Użytkownik
  • **
  • Wiadomości: 99
    • Zobacz profil
debian + nvidia
« Odpowiedź #2 dnia: 2005-08-13, 19:57:41 »
edytuj plik /etc/lilo.conf jako root

przykład:

# File generated by DrakX/drakboot
# WARNING: do not forget to run lilo after modifying this file

default=\\"LinnexOS\\"
boot=/dev/hdc2
map=/boot/map
keytable=/boot/livecd.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz-2.6.10-oci7
        label=\\"LinnexOS\\"
        root=/dev/hdc2
        initrd=/boot/initrd-2.6.10-oci7.img
        append=\\"devfs=nomount nomce splash=silent\\"
        vga=788
        read-only
---------------------------------------------
w linijce boot= wpisz gdzie chcesz umieścić lilo w cytowanym przykładzie to jest mbr pierwszego dysku / hda /

potem uaktualnij lilo poprzez wydanie komendy lilo -v

i gotowe...

Offline kwazar uran

  • Users
  • Użytkownik
  • **
  • Wiadomości: 99
    • Zobacz profil
debian + nvidia
« Odpowiedź #3 dnia: 2005-08-13, 19:59:52 »
boot=/dev/hdc2 - to mbr drugiego dysku....

Offline Remigiusz Witkowski

  • Users
  • Guru
  • *****
  • Wiadomości: 594
    • Zobacz profil
debian + nvidia
« Odpowiedź #4 dnia: 2005-08-13, 20:21:58 »
2005-08-13 19:57:41 kwazar napisał:

> edytuj plik /etc/lilo.conf jako root
 >
 > przykład:
 >
 > # File generated by DrakX/drakboot
 > # WARNING: do not forget to run lilo after modifying this file
 >
 > default=\\"LinnexOS\\"
 > boot=/dev/hdc2
 > map=/boot/map
 > keytable=/boot/livecd.klt
 > prompt
 > nowarn
 > timeout=100
 > message=/boot/message
 > menu-scheme=wb:bw:wb:bw
 > image=/boot/vmlinuz-2.6.10-oci7
 >         label=\\"LinnexOS\\"
 >         root=/dev/hdc2
 >         initrd=/boot/initrd-2.6.10-oci7.img
 >         append=\\"devfs=nomount nomce splash=silent\\"
 >         vga=788
 >         read-only
 > ---------------------------------------------
 > w linijce boot= wpisz gdzie chcesz umieścić lilo w cytowanym przykładzie to jest mbr pierwszego
 > dysku / hda /
 >
 > potem uaktualnij lilo poprzez wydanie komendy lilo -v
 >
 > i gotowe...

 Zdaje sie , ze gość pisze o instalacji a nie już zainstalowanym systemie ... :)

Offline kwazar uran

  • Users
  • Użytkownik
  • **
  • Wiadomości: 99
    • Zobacz profil
debian + nvidia
« Odpowiedź #5 dnia: 2005-08-13, 22:00:44 »
rany !.. przeciez podczas instalacji lilo niech sie instaluje gdzie chce byle tylko system sie uruchamial, po uruchomieniu mozna lilo zianstalowac gdzie sie chce  nawet na dyskietce, potem wywalic lilo z mbr i gotowe - a faktycznie instalator pyta gdzie zainstaloeać lilo -  podczas koncowej fazy instalacji...

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 8
    • Zobacz profil
debian + nvidia
« Odpowiedź #6 dnia: 2005-08-14, 12:58:13 »
2005-08-13 10:11:49 sokol121 napisał:

> Mam problem z LILO. Podczas instalacji Mandrake\\'a 10.1 instalator nie pyta się gdzie ma umieścić
 > boot loadera, a ja nie chcę go mieć na dysku tylko na dyskietce. Pomóżcie! Co mam zrobić żeby
 > było dobrze?

w /etc/lilo.conf musi byc linijka:
boot=/dev/fd0 #zero na koncu
po czym instalujesz lilo komenda lilo -v i tyle - zainstaluje Ci sie ladnie na dyskietce... pozdrawiam...

Offline Smoke Crack

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 14
    • Zobacz profil
debian + nvidia
« Odpowiedź #7 dnia: 2005-08-12, 23:34:22 »
nie moge zainstalowac mojego geforca 2 mx na debianie 3.1 sarge z jajkiem2.6.8, probowalem roznych sposobow, ale jakos nic to nie dalo, probowalem instalowac stary z paczek i te z oficjalnej strony nv, jednak zawsze podczas odpalania x-ow cos jest nie tak, dzialaja tylko ustawienia defultowe debiana

wie ktos jak sobie z tym poradzic, albo zna jakis sensowny opis?

z gory dzieki za pomoc

Offline Jacek Łuczak

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 437
    • Zobacz profil
debian + nvidia
« Odpowiedź #8 dnia: 2005-08-13, 00:59:43 »
2005-08-12 23:34:22 smoke-crack napisał:

> nie moge zainstalowac mojego geforca 2 mx na debianie 3.1 sarge z jajkiem2.6.8, probowalem
 > roznych sposobow, ale jakos nic to nie dalo, probowalem instalowac stary z paczek i te z
 > oficjalnej strony nv, jednak zawsze podczas odpalania x-ow cos jest nie tak, dzialaja tylko
 > ustawienia defultowe debiana
 >
 > wie ktos jak sobie z tym poradzic, albo zna jakis sensowny opis?
 >
 > z gory dzieki za pomoc

Nie orientuje sie w tej materii za dobrze, ale o ile pamietam, to w jadrze z tej serii trzeba bylo zastosowac jakies magiczne tance co by stery z nvidii dobrze dzialaly. Proponuje zmiane jadra na jakas aktualniejasza wersje - powiedzmy 2.6.12.4. Wszystko powinno byc OK:)

POZDRAWIAM

Offline Smoke Crack

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 14
    • Zobacz profil
debian + nvidia
« Odpowiedź #9 dnia: 2005-08-13, 08:22:24 »
a jest jakis sposob bez zmiany kernela?
czyzby wszyscy posiadacze sarga i kart nvidii musieli zmieniac jajka?

Offline Smoke Crack

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 14
    • Zobacz profil
debian + nvidia
« Odpowiedź #10 dnia: 2005-08-13, 09:41:10 »
zdaje sie, ze trzeba jakiegos patcha na stery nvidii nalozyc i wtedy pojda
wie ktos skad go sciagnac??

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 372
    • Zobacz profil
debian + nvidia
« Odpowiedź #11 dnia: 2005-08-13, 11:02:42 »
2005-08-12 23:34:22 smoke-crack napisał:

> nie moge zainstalowac mojego geforca 2 mx na debianie 3.1 sarge z jajkiem2.6.8, probowalem
 > roznych sposobow, ale jakos nic to nie dalo, probowalem instalowac stary z paczek i te z
 > oficjalnej strony nv, jednak zawsze podczas odpalania x-ow cos jest nie tak, dzialaja tylko
 > ustawienia defultowe debiana
 >
 > wie ktos jak sobie z tym poradzic, albo zna jakis sensowny opis?
 >
 > z gory dzieki za pomoc

Doinstaluj sobie pliki nagłówkowe jądra .

Offline Smoke Crack

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 14
    • Zobacz profil
debian + nvidia
« Odpowiedź #12 dnia: 2005-08-13, 11:21:18 »
nie trzeba instalowac, bo juz je mam

jak probuje odpalic x-y z nowym modulem to nie wiem czemu nie chce zainicjowac glx:
(EE) Failed to initialize GLX extension (NVIDIA X driver not found)