Nowe posty

Autor Wątek: GLib  (Przeczytany 5789 razy)

Offline tomek maciag

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 45
    • Zobacz profil
GLib
« dnia: 2005-05-23, 00:11:22 »
Wiem ze to nieslychanie lamerskie zapytanie ale.... a co tam.Nie bede sie tlumaczyl moze i jestem Lamer ;)
Obecnie korzystam z DCTC z nakladka graficzna GUI-QT.Jest to niesamowita kiszka, praktycznie nie moge niczego na tym wyszukac. Czy mozecie cos innego polecic?

Offline Robert S

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 6
    • Zobacz profil
GLib
« Odpowiedź #1 dnia: 2005-05-23, 07:40:49 »
Apollon(odpowiednik programu kazaa),badz aMule

Offline Krzysztof Kwiatkowski

  • Users
  • Użytkownik
  • **
  • Wiadomości: 59
    • Zobacz profil
GLib
« Odpowiedź #2 dnia: 2005-05-23, 07:57:16 »
2005-05-23 00:11:22 Rabarbar napisał:

> Wiem ze to nieslychanie lamerskie zapytanie ale.... a co tam.Nie bede sie tlumaczyl moze i
 > jestem Lamer ;)
 > Obecnie korzystam z DCTC z nakladka graficzna GUI-QT.Jest to niesamowita kiszka, praktycznie
 > nie moge niczego na tym wyszukac. Czy mozecie cos innego polecic?

Polecam Lime Wire oraz Edonkey (ed2k_gui).

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 337
    • Zobacz profil
GLib
« Odpowiedź #3 dnia: 2005-06-09, 02:38:33 »
aMule i GTK-Gnutella

Offline Jan Kowalski

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 22
    • Zobacz profil
GLib
« Odpowiedź #4 dnia: 2005-06-09, 21:09:07 »
Valknut

Offline Michal Rzymski

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 28
    • Zobacz profil
GLib
« Odpowiedź #5 dnia: 2005-05-22, 23:43:31 »
mam Mandriva LE 2005, kiedy chce zainstalować Xmms,wyskakuje błąd: error: *** GLIB >= 1.2.2 not installed - please install first ***.czyli trzeba zainstalować GLIB w wersji 1.2.2 lub nowszy.Ja zainstalowałem wersje 2.6.4 (w tej chwili najnowsza),ale to nie pomogło,nadal wypisuje error: *** GLIB >= 1.2.2 not installed - please install first ***.Wie ktoś dlaczego tak jest? Przecież 2.6.4 jest nowsze od 1.2.2.Moze chodzi o to ze jest "za nowe".Może ktoś mi doradzić? Dziekuję.

Offline marek zaradzki

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 11
    • Zobacz profil
GLib
« Odpowiedź #6 dnia: 2005-05-23, 01:21:51 »
2005-05-22 23:43:31 MichaUeQ napisał:

> mam Mandriva LE 2005, kiedy chce zainstalować Xmms,wyskakuje błąd: error: *** GLIB >= 1.2.2
 > not installed - please install first ***.czyli trzeba zainstalować GLIB w wersji 1.2.2 lub
 > nowszy.Ja zainstalowałem wersje 2.6.4 (w tej chwili najnowsza),ale to nie pomogło,nadal
 > wypisuje error: *** GLIB >= 1.2.2 not installed - please install first ***.Wie ktoś dlaczego
 > tak jest? Przecież 2.6.4 jest nowsze od 1.2.2.Moze chodzi o to ze jest "za nowe".Może
 > ktoś mi doradzić? Dziekuję.

Witam
xmms uzywa gtk w wersji 1 czyli musisz zainstalowac wersje 1.... glib gtk
spobuj moze BMP czyli beep-media-player oparty jest na gtk 2  
pozdrawiam

Offline Michal Rzymski

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 28
    • Zobacz profil
GLib
« Odpowiedź #7 dnia: 2005-05-23, 23:36:06 »
2005-05-23 01:21:51 mandylion napisał:

> 2005-05-22 23:43:31 MichaUeQ napisał:
 >
 > > mam Mandriva LE 2005, kiedy chce zainstalować Xmms,wyskakuje błąd: error: *** GLIB >=
 > 1.2.2
 >  > not installed - please install first ***.czyli trzeba zainstalować GLIB w wersji 1.2.2
 > lub
 >  > nowszy.Ja zainstalowałem wersje 2.6.4 (w tej chwili najnowsza),ale to nie pomogło,nadal
 >  > wypisuje error: *** GLIB >= 1.2.2 not installed - please install first ***.Wie ktoś
 > dlaczego
 >  > tak jest? Przecież 2.6.4 jest nowsze od 1.2.2.Moze chodzi o to ze jest "za
 > nowe".Może
 >  > ktoś mi doradzić? Dziekuję.
 >
 > Witam
 > xmms uzywa gtk w wersji 1 czyli musisz zainstalowac wersje 1.... glib gtk
 > spobuj moze BMP czyli beep-media-player oparty jest na gtk 2  
 > pozdrawiam

ale w błędzie nic nie pisze o GTK,tylko jest wspomniane o GLIB. GTK tez trzeba będzie zainstalować?

Offline xis

  • Global Moderator
  • Guru
  • *****
  • Wiadomości: 1049
    • Zobacz profil
GLib
« Odpowiedź #8 dnia: 2005-05-23, 23:56:23 »
Nie mylisz przypadkiem Glib i GlibC?
To są zupełnie różne pakiety.

Co do gliba, to nie jestem pewny, ale z gtk jest tak, że gtk i gtk2 to zupełnie inne linie pakietów.
Everything should be made as simple as possible, but not simpler
-- Albert Einstein

Offline Michal Rzymski

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 28
    • Zobacz profil
GLib
« Odpowiedź #9 dnia: 2005-05-24, 00:07:15 »
2005-05-23 23:56:23 xis napisał:

> Nie mylisz przypadkiem Glib i GlibC?
 > To są zupełnie różne pakiety.
 >
 > Co do gliba, to nie jestem pewny, ale z gtk jest tak, że gtk i gtk2 to zupełnie inne linie
 > pakietów.
 >

CHyba nie myle,raczej chodzi o GLIB.A co do GTK to nic nie bylo mowy o tym ze rowniez musi byc zainstalowany aby Xmms dzialal.

Offline xis

  • Global Moderator
  • Guru
  • *****
  • Wiadomości: 1049
    • Zobacz profil
GLib
« Odpowiedź #10 dnia: 2005-05-24, 10:52:43 »
Mam dla Ciebie doskonałą radę:
Przeszukaj to forum (albo dział Artykuły i FAQ) pod kątem słowa 'urpmi'. Skonfiguruj urpmi i zainstaluj po prostu xmms. Ten program sam zadba o zależności i nic Cię nie będzie obchodziło :)
Everything should be made as simple as possible, but not simpler
-- Albert Einstein

Offline andrzej nieznane

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 6
    • Zobacz profil
GLib
« Odpowiedź #11 dnia: 2005-05-28, 13:23:34 »
2005-05-24 10:52:43 xis napisał:

> Mam dla Ciebie doskonałą radę:
 > Przeszukaj to forum (albo dział Artykuły i FAQ) pod kątem słowa 'urpmi'. Skonfiguruj urpmi i
 > zainstaluj po prostu xmms. Ten program sam zadba o zależności i nic Cię nie będzie obchodziło
 > :)
 >
czy moze ten blad byc spowodowany tym ze wlasnie baza danych URPMI jest zablokowana?:>??

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
GLib
« Odpowiedź #12 dnia: 2005-08-01, 01:38:30 »
2005-05-22 23:43:31 MichaUeQ napisał:

> mam Mandriva LE 2005, kiedy chce zainstalować Xmms,wyskakuje błąd: error: *** GLIB >= 1.2.2
 > not installed - please install first ***.czyli trzeba zainstalować GLIB w wersji 1.2.2 lub
 > nowszy.Ja zainstalowałem wersje 2.6.4 (w tej chwili najnowsza),ale to nie pomogło,nadal
 > wypisuje error: *** GLIB >= 1.2.2 not installed - please install first ***.Wie ktoś dlaczego
 > tak jest? Przecież 2.6.4 jest nowsze od 1.2.2.Moze chodzi o to ze jest "za nowe".Może
 > ktoś mi doradzić? Dziekuję.


Witam. Ja też mam problem z Glib przy instalowaniu Xmms (pod Mandrake 10.0) - wypisuje coś takiego:

checking for glib-config... /usr/local/bin/glib-config
checking for GLIB - version >= 1.2.2...
*** 'glib-config --version' returned 1.2.2, but GLIB (1.2.10)
*** was found! If glib-config was correct, then it is best
*** to remove the old version of GLIB. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If glib-config was wrong, set the environment variable GLIB_CONFIG
*** to point to the correct copy of glib-config, and remove the file config.cache
*** before re-running configure
no
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***

Mam zainstalowane GLIB-1.2.2, natomiast żadnej wersji 1.2.10 nie instalowałam. Próbowałam już ustawiać wartość zmiennej GLIB_CONFIG na /usr/local/bin/glib-config (chyba o to chodziło w tym "set the environment variable GLIB_CONFIG
*** to point to the correct copy of glib-config"?) ale bez efektów, nadal to samo. Nie bardzo wiem co dalej z tym zrobić. Czy ktoś może mi pomóc? Z góry dziękuję.