Nowe posty

Autor Wątek: debian 3.1 i dzwięk w grach  (Przeczytany 4307 razy)

gbudny

  • Gość
debian 3.1 i dzwięk w grach
« dnia: 2005-05-21, 02:53:46 »
witam
mam debian 3.1 i problem z grami (rtcw, sof, sin itd)
W niektórych grach (mohaa, glest) mam dzwięk w wyżej wspomnianych mam brak dzwięku. To nie jest jądro 2.6 tylko.
2.4 a alsa nie jest włączona. Gdzie może leżec przyczyna moich problemów czy to wina braku jakiegoś pakietu.

                                                                 Pozdrawiam

Bakus

  • Gość
debian 3.1 i dzwięk w grach
« Odpowiedź #1 dnia: 2005-06-06, 16:34:21 »
2005-05-21 02:53:46 gbudny napisał:

> witam
 > mam debian 3.1 i problem z grami (rtcw, sof, sin itd)
 > W niektórych grach (mohaa, glest) mam dzwięk w wyżej wspomnianych mam brak dzwięku. To nie jest
 > jądro 2.6 tylko.
 > 2.4 a alsa nie jest włączona. Gdzie może leżec przyczyna moich problemów czy to wina braku
 > jakiegoś pakietu.
 >
 >                                                                  Pozdrawiam

Może sprubój OSS'a...

braqoon

  • Gość
debian 3.1 i dzwięk w grach
« Odpowiedź #2 dnia: 2005-06-06, 21:47:24 »
>  > 2.4 a alsa nie jest włączona. Gdzie może leżec przyczyna moich


Problem jest taki jak ze slackiem uzytkownik nie ma praw dostepu do /dev/dsp , co latwo rozwiazac komenda 'chmod 777 /dev/dsp' na root.

Kolega ktory odpowiedzial

>> Może sprubój OSS'a...

chyba nie doczytal dokladnie posta, bo ALSA nie jest wlaczona wiec OSS dziala, nie ma co probowac. Jesli inne gry dzialaja to na pewno wina lezy po stronie /dev/dsp (program pezposrednio dowoluje sie do sterownika dzwieku nie do systemu). wiekszosc gier ze stajni ID Software robi tak.

pozdro

gbudny

  • Gość
debian 3.1 i dzwięk w grach
« Odpowiedź #3 dnia: 2005-06-08, 00:34:03 »
2005-06-06 21:47:24 braqoon napisał:

>  >  > 2.4 a alsa nie jest włączona. Gdzie może leżec przyczyna moich
 >
 >
 > Problem jest taki jak ze slackiem uzytkownik nie ma praw dostepu do /dev/dsp , co latwo
 > rozwiazac komenda 'chmod 777 /dev/dsp' na root.
 >
 > Kolega ktory odpowiedzial
 >
 > >> Może sprubój OSS'a...
 >
 > chyba nie doczytal dokladnie posta, bo ALSA nie jest wlaczona wiec OSS dziala, nie ma co
 > probowac. Jesli inne gry dzialaja to na pewno wina lezy po stronie /dev/dsp (program
 > pezposrednio dowoluje sie do sterownika dzwieku nie do systemu). wiekszosc gier ze stajni ID
 > Software robi tak.
 >
 > pozdro
 >

Wpisałem polecenie z konta użytkownika root ale nadal brak dźwięku w grach.

braqoon

  • Gość
debian 3.1 i dzwięk w grach
« Odpowiedź #4 dnia: 2005-06-08, 09:47:46 »
> Wpisałem polecenie z konta użytkownika root ale nadal brak dźwięku w grach.

To odpal gre w konsoli i zobacz gdzie wyskakuje error, RCTW czy Q3 czy ET wyswietla gdzie jest blad. Mozesz wkleic to tu a my sie postaram y cos wymyslec

Pozdro

gbudny

  • Gość
debian 3.1 i dzwięk w grach
« Odpowiedź #5 dnia: 2005-06-08, 22:56:49 »
2005-06-08 09:47:46 braqoon napisał:

>  > Wpisałem polecenie z konta użytkownika root ale nadal brak dźwięku w grach.
 >
 > To odpal gre w konsoli i zobacz gdzie wyskakuje error, RCTW czy Q3 czy ET wyswietla gdzie jest
 > blad. Mozesz wkleic to tu a my sie postaram y cos wymyslec
 >
 > Pozdro

Dobra podaję na przykładzie rtcw demomat@debian:~$ wolfspdemo
Wolf 1.1b linux-i386 Jan 17 2002
----- FS_Startup -----
Current search path:
/home/mat/.wolf-spdemo/main
/usr/local/games/wolfenstein-spdemo/main
./wolfsp.x86/main

----------------------
0 files in pk3 files

Running in restricted demo mode.

----- FS_Startup -----
Current search path:
/home/mat/.wolf-spdemo/demomain
/usr/local/games/wolfenstein-spdemo/demomain/pak0.pk3 (2474 files)
/usr/local/games/wolfenstein-spdemo/demomain
./wolfsp.x86/demomain

----------------------
2474 files in pk3 files
execing default.cfg
couldn't exec language.cfg
execing wolfconfig.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
Bypassing CD checks
----- Client Initialization -----
Cmd_AddCommand: map_restart already defined
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so: Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 640x480
Using 4/4/4 Color bits, 24 depth, 0 stencil display.
GL_RENDERER: GeForce4 MX 440/AGP/SSE/3DNOW!
Initializing OpenGL extensions
...using GL_S3_s3tc
...ignoring GL_EXT_texture_env_add
...using GL_ARB_multitexture
...using GL_EXT_compiled_vertex_array
XF86 Gamma extension initialized

GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce4 MX 440/AGP/SSE/3DNOW!
GL_VERSION: 1.5.3 NVIDIA 76.64
GL_EXTENSIONS: GL_ARB_imaging GL_ARB_multitexture GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_paletted_texture GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shared_texture_palette GL_EXT_stencil_wrap GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_vertex_array GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_square GL_NV_fence GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_packed_depth_stencil GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_register_combiners GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex_program GL_NV_vertex_program1_1 GL_SGIS_generate_mipmap GL_SGIS_multitexture GL_SGIS_texture_lod GL_SUN_slice_accum
GL_MAX_TEXTURE_SIZE: 2048
GL_MAX_ACTIVE_TEXTURES_ARB: 2

PIXELFORMAT: color(32-bits) Z(24-bit) stencil(0-bits)
MODE: 3, 640 x 480 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
CPU:
rendering primitives: single glDrawElements
texturemode: GL_LINEAR_MIPMAP_NEAREST
picmip: 1
picmip2: 2
texture bits: 32
multitexture: enabled
compiled vertex arrays: enabled
texenv add: disabled
compressed textures: enabled
ATI truform: disabled
NV distance fog: disabled
Initializing Shaders
...loading 'scripts/ai.shader'
...loading 'scripts/alpha.shader'
...loading 'scripts/blacksmokeanim.shader'
...loading 'scripts/blacksmokeanimb.shader'
...loading 'scripts/characters.shader'
...loading 'scripts/clipboard.shader'
...loading 'scripts/common.shader'
...loading 'scripts/cursorhints.shader'
...loading 'scripts/decals.shader'
...loading 'scripts/eerie.shader'
...loading 'scripts/expblue.shader'
...loading 'scripts/explode1.shader'
...loading 'scripts/fijets.shader'
...loading 'scripts/firest.shader'
...loading 'scripts/flamethrower.shader'
...loading 'scripts/funnel.shader'
...loading 'scripts/gfx.shader'
...loading 'scripts/heat.shader'
...loading 'scripts/lights.shader'
...loading 'scripts/liquid.shader'
...loading 'scripts/maxx.shader'
...loading 'scripts/menu.shader'
...loading 'scripts/metal.shader'
...loading 'scripts/models.shader'
...loading 'scripts/netest.shader'
...loading 'scripts/oldwolf.shader'
...loading 'scripts/organics.shader'
...loading 'scripts/particle.shader'
...loading 'scripts/q3view.shader'
...loading 'scripts/sfx.shader'
...loading 'scripts/signs.shader'
...loading 'scripts/skin.shader'
...loading 'scripts/sky.shader'
...loading 'scripts/solo.shader'
...loading 'scripts/surfaces.shader'
...loading 'scripts/terrain.shader'
...loading 'scripts/test.shader'
...loading 'scripts/twiltb.shader'
...loading 'scripts/twiltb2.shader'
...loading 'scripts/ui.shader'
...loading 'scripts/ui_hud.shader'
...loading 'scripts/ui_notebook.shader'
...loading 'scripts/ui_wolf.shader'
...loading 'scripts/viewflames.shader'
...loading 'scripts/walls.shader'
...loading 'scripts/z_light.shader'
----- finished R_Init -----

------- sound initialization -------
------------------------------------
----- Sound Info -----
sound system is muted
    1 stereo
32768 samples
   16 samplebits
    1 submission_chunk
48000 speed
0x466d7000 dma buffer
No background file.
----------------------
Sound memory manager started
Sys_LoadDll(/usr/local/games/wolfenstein-spdemo/demomain/uii386.so)...
Sys_LoadDll(ui) found **vmMain** at  0x47f30778
Sys_LoadDll(ui) succeeded!
Parsing menu file:ui/main.menu
r_rmse of 0.000000 has saved 12kb
Parsing menu file:ui/setup.menu
Parsing menu file:ui/controls.menu
Parsing menu file:ui/cdkey.menu
Parsing menu file:ui/system.menu
Parsing menu file:ui/options.menu
Parsing menu file:ui/credit.menu
r_rmse of 0.000000 has saved 204kb
r_rmse of 0.000000 has saved 252kb
r_rmse of 0.000000 has saved 264kb
Parsing menu file:ui/connect.menu
Parsing menu file:ui/quit.menu
Parsing menu file:ui/vid_restart.menu
Parsing menu file:ui/snd_restart.menu
Parsing menu file:ui/rec_restart.menu
Parsing menu file:ui/default.menu
Parsing menu file:ui/error.menu
Parsing menu file:ui/serverinfo.menu
Parsing menu file:ui/quitcredit.menu
Parsing menu file:ui/resetscore.menu
Parsing menu file:ui/buy_pop.menu
Parsing menu file:ui/multiplayer_pop.menu
Parsing menu file:ui/play.menu
Parsing menu file:ui/load.menu
Parsing menu file:ui/briefing.menu
UI menu load time = 926 milli seconds
Parsing menu file:ui/ingame.menu
Parsing menu file:ui/ingame_controls.menu
Parsing menu file:ui/ingame_options.menu
Parsing menu file:ui/ingame_system.menu
Parsing menu file:ui/ingame_leave.menu
Parsing menu file:ui/ingame_player.menu
Parsing menu file:ui/ingame_load.menu
Parsing menu file:ui/ingame_save.menu
Parsing menu file:ui/in_vid_restart.menu
Parsing menu file:ui/in_snd_restart.menu
Parsing menu file:ui/in_rec_restart.menu
Parsing menu file:ui/notebook.menu
Parsing menu file:ui/clipboard.menu
Parsing menu file:ui/bookz.menu
Parsing menu file:ui/bookv.menu
Parsing menu file:ui/bookp.menu
Parsing menu file:ui/pregame.menu
Parsing menu file:ui/test.menu
Parsing menu file:ui/ingame_help.menu
UI menu load time = 427 milli seconds
--- Common Initialization Complete ---
Opening IP socket: localhost:27960
Hostname: localhost.localdomain
Alias: localhost
Alias: debian
IP: 127.0.0.1
Started tty console (use +set ttycon 0 to disable)
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Shutdown tty console
mat@debian:~$

                                               Pozdrawiam

braqoon

  • Gość
debian 3.1 i dzwięk w grach
« Odpowiedź #6 dnia: 2005-06-09, 00:29:26 »
------- sound initialization -------
------------------------------------
----- Sound Info -----
sound system is muted
1 stereo
32768 samples
16 samplebits
1 submission_chunk
48000 speed
0x466d7000 dma buffer
No background file.
----------------------

no i sprawa raczej rozwiazana, gra twierdzi ze dziwek jest wyciszony, a karta dziala dobrze. sprawdz w sowich ustawieniach dzwieku, np programem 'aumix' (obojetne czy root czy user) suwak PCM bodajrze.

pozdro
Braqoon

gbudny

  • Gość
debian 3.1 i dzwięk w grach
« Odpowiedź #7 dnia: 2005-06-11, 19:00:31 »
2005-06-09 00:29:26 braqoon napisał:

> ------- sound initialization -------
 > ------------------------------------
 > ----- Sound Info -----
 > sound system is muted
 > 1 stereo
 > 32768 samples
 > 16 samplebits
 > 1 submission_chunk
 > 48000 speed
 > 0x466d7000 dma buffer
 > No background file.
 > ----------------------
 >
 > no i sprawa raczej rozwiazana, gra twierdzi ze dziwek jest wyciszony, a karta dziala dobrze.
 > sprawdz w sowich ustawieniach dzwieku, np programem 'aumix' (obojetne czy root czy user) suwak
 > PCM bodajrze.
 >
 > pozdro
 > Braqoon
 >

Niestety to nie takie proste pcm jest odkręcone a dźwięku nie ma.
Dodatkowo nzauważyłem coś takiego gdy doinstalowałem kernel 2.6 po kilku minutach grania:

loaded maps/cutscene1_b1.aas
-------------------------------------
AAS initialized.
AAS initialized.
-----------------------------------
RE_Shutdown( 0 )
----- R_Init -----

GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce4 MX 440/AGP/SSE/3DNOW!
GL_VERSION: 1.5.3 NVIDIA 76.64
GL_EXTENSIONS: GL_ARB_imaging GL_ARB_multitexture GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_paletted_texture GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shared_texture_palette GL_EXT_stencil_wrap GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_vertex_array GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_square GL_NV_fence GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_packed_depth_stencil GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_register_combiners GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex_program GL_NV_vertex_program1_1 GL_SGIS_generate_mipmap GL_SGIS_multitexture GL_SGIS_texture_lod GL_SUN_slice_accum
GL_MAX_TEXTURE_SIZE: 2048
GL_MAX_ACTIVE_TEXTURES_ARB: 2

PIXELFORMAT: color(32-bits) Z(24-bit) stencil(0-bits)
MODE: 3, 640 x 480 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
CPU:
rendering primitives: single glDrawElements
texturemode: GL_LINEAR_MIPMAP_NEAREST
picmip: 1
picmip2: 2
texture bits: 32
multitexture: enabled
compiled vertex arrays: enabled
texenv add: disabled
compressed textures: enabled
ATI truform: disabled
NV distance fog: disabled
Initializing Shaders
...loading 'scripts/ai.shader'
...loading 'scripts/alpha.shader'
...loading 'scripts/blacksmokeanim.shader'
...loading 'scripts/blacksmokeanimb.shader'
...loading 'scripts/characters.shader'
...loading 'scripts/clipboard.shader'
...loading 'scripts/common.shader'
...loading 'scripts/cursorhints.shader'
...loading 'scripts/decals.shader'
...loading 'scripts/eerie.shader'
...loading 'scripts/expblue.shader'
...loading 'scripts/explode1.shader'
...loading 'scripts/fijets.shader'
...loading 'scripts/firest.shader'
...loading 'scripts/flamethrower.shader'
...loading 'scripts/funnel.shader'
...loading 'scripts/gfx.shader'
...loading 'scripts/heat.shader'
...loading 'scripts/lights.shader'
...loading 'scripts/liquid.shader'
...loading 'scripts/maxx.shader'
...loading 'scripts/menu.shader'
...loading 'scripts/metal.shader'
...loading 'scripts/models.shader'
...loading 'scripts/netest.shader'
...loading 'scripts/oldwolf.shader'
...loading 'scripts/organics.shader'
...loading 'scripts/particle.shader'
...loading 'scripts/q3view.shader'
...loading 'scripts/sfx.shader'
...loading 'scripts/signs.shader'
...loading 'scripts/skin.shader'
...loading 'scripts/sky.shader'
...loading 'scripts/solo.shader'
...loading 'scripts/surfaces.shader'
...loading 'scripts/terrain.shader'
...loading 'scripts/test.shader'
...loading 'scripts/twiltb.shader'
...loading 'scripts/twiltb2.shader'
...loading 'scripts/ui.shader'
...loading 'scripts/ui_hud.shader'
...loading 'scripts/ui_notebook.shader'
...loading 'scripts/ui_wolf.shader'
...loading 'scripts/viewflames.shader'
...loading 'scripts/walls.shader'
...loading 'scripts/z_light.shader'
----- finished R_Init -----
Sys_LoadDll(/usr/local/games/wolfenstein-spdemo/demomain/uii386.so)...
Sys_LoadDll(ui) found **vmMain** at  0x49fee778
Sys_LoadDll(ui) succeeded!
Parsing menu file:ui/main.menu
r_rmse of 0.000000 has saved 276kb
Parsing menu file:ui/setup.menu
Parsing menu file:ui/controls.menu
Parsing menu file:ui/cdkey.menu
Parsing menu file:ui/system.menu
Parsing menu file:ui/options.menu
Parsing menu file:ui/credit.menu
r_rmse of 0.000000 has saved 468kb
r_rmse of 0.000000 has saved 516kb
r_rmse of 0.000000 has saved 528kb
Parsing menu file:ui/connect.menu
Parsing menu file:ui/quit.menu
Parsing menu file:ui/vid_restart.menu
Parsing menu file:ui/snd_restart.menu
Parsing menu file:ui/rec_restart.menu
Parsing menu file:ui/default.menu
Parsing menu file:ui/error.menu
Parsing menu file:ui/serverinfo.menu
Parsing menu file:ui/quitcredit.menu
Parsing menu file:ui/resetscore.menu
Parsing menu file:ui/buy_pop.menu
Parsing menu file:ui/multiplayer_pop.menu
Parsing menu file:ui/play.menu
Parsing menu file:ui/load.menu
Parsing menu file:ui/briefing.menu
UI menu load time = 1342 milli seconds
Parsing menu file:ui/ingame.menu
Parsing menu file:ui/ingame_controls.menu
Parsing menu file:ui/ingame_options.menu
Parsing menu file:ui/ingame_system.menu
Parsing menu file:ui/ingame_leave.menu
Parsing menu file:ui/ingame_player.menu
Parsing menu file:ui/ingame_load.menu
Parsing menu file:ui/ingame_save.menu
Parsing menu file:ui/in_vid_restart.menu
Parsing menu file:ui/in_snd_restart.menu
Parsing menu file:ui/in_rec_restart.menu
Parsing menu file:ui/notebook.menu
Parsing menu file:ui/clipboard.menu
Parsing menu file:ui/bookz.menu
Parsing menu file:ui/bookv.menu
Parsing menu file:ui/bookp.menu
Parsing menu file:ui/pregame.menu
Parsing menu file:ui/test.menu
Parsing menu file:ui/ingame_help.menu
UI menu load time = 790 milli seconds
Sys_LoadDll(/usr/local/games/wolfenstein-spdemo/demomain/cgamei386.so)...
Sys_LoadDll(cgame) found **vmMain** at  0x4b1a61e8
Sys_LoadDll(cgame) succeeded!
LOADING... collision map
trying levelshots/cutscene1.TGA...
LOADING... sounds

.........................
Initializing Sound Scripts
...loading 'sound/scripts/cutscene1.sounds'
...loading 'sound/scripts/cutscene6.sounds'
...loading 'sound/scripts/cutscene9.sounds'
...loading 'sound/scripts/cutscene11.sounds'
...loading 'sound/scripts/cutscene14.sounds'
...loading 'sound/scripts/cutscene19.sounds'
...loading 'sound/scripts/escape1.sounds'
...loading 'sound/scripts/escape2.sounds'
...loading 'sound/scripts/tram.sounds'
...loading 'sound/scripts/village1.sounds'
...loading 'sound/scripts/crypt1.sounds'
...loading 'sound/scripts/crypt2.sounds'
...loading 'sound/scripts/church.sounds'
...loading 'sound/scripts/boss1.sounds'
...loading 'sound/scripts/forest.sounds'
...loading 'sound/scripts/rocket.sounds'
...loading 'sound/scripts/assault.sounds'
...loading 'sound/scripts/sfm.sounds'
...loading 'sound/scripts/factory.sounds'
...loading 'sound/scripts/trainyard.sounds'
...loading 'sound/scripts/swf.sounds'
...loading 'sound/scripts/norway.sounds'
...loading 'sound/scripts/xlabs.sounds'
...loading 'sound/scripts/boss2.sounds'
...loading 'sound/scripts/dam.sounds'
...loading 'sound/scripts/village2.sounds'
...loading 'sound/scripts/chateau.sounds'
...loading 'sound/scripts/dark.sounds'
...loading 'sound/scripts/castle.sounds'
...loading 'sound/scripts/end.sounds'
...loading 'sound/scripts/ai.sounds'
...loading 'sound/scripts/general.sounds'
...loading 'sound/scripts/combat.sounds'
...loading 'sound/scripts/movers.sounds'
done.
LOADING... graphics
LOADING... maps/cutscene1.bsp
trying full_rt.TGA...
trying full_bk.TGA...
trying full_lf.TGA...
trying full_ft.TGA...
trying full_up.TGA...
trying full_dn.TGA...
stitched 0 LoD cracks
...loaded 2413 faces, 25 meshes, 147 trisurfs, 17 flares
LOADING... game media
LOADING...  - textures
r_rmse of 0.000000 has saved 720kb
r_rmse of 0.000000 has saved 768kb
r_rmse of 0.000000 has saved 780kb
LOADING...  - models
trying models/weapons2/rocketl/panzerfast1a.TGA...
r_rmse of 0.000000 has saved 828kb
r_rmse of 0.000000 has saved 840kb
LOADING...  - weapons
LOADING...  - items
LOADING...  - inline models
LOADING...  - server models
LOADING...  - particles
r_rmse of 0.000000 has saved 852kb
trying ui/assets/sizecursor.TGA...
trying ui/assets/selectcursor.TGA...
LOADING...  - game media done
LOADING... flamechunks
LOADING... clients
LOADING... WolfPlayer
trying fonts/bigFont.TGA...
UI menu load time = 43 milli seconds
CL_InitCGame:  6.40 seconds
198 msec to draw all images
Com_TouchMemory: 0 msec
sv_maxclients will be changed upon restarting.
AAS shutdown.
------ Server Initialization ------
Server: escape1
RE_Shutdown( 0 )
Hunk_Clear: reset the hunk ok
----- FS_Startup -----
Current search path:
/root/.wolf-spdemo/main
/usr/local/games/wolfenstein-spdemo/main
./wolfsp.x86/main

----------------------
4948 files in pk3 files

Running in restricted demo mode.

----- FS_Startup -----
Current search path:
/root/.wolf-spdemo/demomain
/usr/local/games/wolfenstein-spdemo/demomain/pak0.pk3 (2474 files)
/usr/local/games/wolfenstein-spdemo/demomain
./wolfsp.x86/demomain

----------------------
7422 files in pk3 files
Sys_LoadDll(/usr/local/games/wolfenstein-spdemo/demomain/qagamei386.so)...
Sys_LoadDll(qagame) found **vmMain** at  0x498da2ec
Sys_LoadDll(qagame) succeeded!
------- BotLib Initialization -------
------------ Map Loading ------------
trying to load maps/escape1_b0.aas
loaded maps/escape1_b0.aas
trying to load maps/escape1_b1.aas
loaded maps/escape1_b1.aas
-------------------------------------
AAS initialized.
AAS initialized.
-----------------------------------
RE_Shutdown( 0 )
----- R_Init -----

GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce4 MX 440/AGP/SSE/3DNOW!
GL_VERSION: 1.5.3 NVIDIA 76.64
GL_EXTENSIONS: GL_ARB_imaging GL_ARB_multitexture GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_paletted_texture GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shared_texture_palette GL_EXT_stencil_wrap GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_vertex_array GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_square GL_NV_fence GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_packed_depth_stencil GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_register_combiners GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex_program GL_NV_vertex_program1_1 GL_SGIS_generate_mipmap GL_SGIS_multitexture GL_SGIS_texture_lod GL_SUN_slice_accum
GL_MAX_TEXTURE_SIZE: 2048
GL_MAX_ACTIVE_TEXTURES_ARB: 2

PIXELFORMAT: color(32-bits) Z(24-bit) stencil(0-bits)
MODE: 3, 640 x 480 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
CPU:
rendering primitives: single glDrawElements
texturemode: GL_LINEAR_MIPMAP_NEAREST
picmip: 1
picmip2: 2
texture bits: 32
multitexture: enabled
compiled vertex arrays: enabled
texenv add: disabled
compressed textures: enabled
ATI truform: disabled
NV distance fog: disabled
Initializing Shaders
...loading 'scripts/ai.shader'
...loading 'scripts/alpha.shader'
...loading 'scripts/blacksmokeanim.shader'
...loading 'scripts/blacksmokeanimb.shader'
...loading 'scripts/characters.shader'
...loading 'scripts/clipboard.shader'
...loading 'scripts/common.shader'
...loading 'scripts/cursorhints.shader'
...loading 'scripts/decals.shader'
...loading 'scripts/eerie.shader'
...loading 'scripts/expblue.shader'
...loading 'scripts/explode1.shader'
...loading 'scripts/fijets.shader'
...loading 'scripts/firest.shader'
...loading 'scripts/flamethrower.shader'
...loading 'scripts/funnel.shader'
...loading 'scripts/gfx.shader'
...loading 'scripts/heat.shader'
...loading 'scripts/lights.shader'
...loading 'scripts/liquid.shader'
...loading 'scripts/maxx.shader'
...loading 'scripts/menu.shader'
...loading 'scripts/metal.shader'
...loading 'scripts/models.shader'
...loading 'scripts/netest.shader'
...loading 'scripts/oldwolf.shader'
...loading 'scripts/organics.shader'
...loading 'scripts/particle.shader'
...loading 'scripts/q3view.shader'
...loading 'scripts/sfx.shader'
...loading 'scripts/signs.shader'
...loading 'scripts/skin.shader'
...loading 'scripts/sky.shader'
...loading 'scripts/solo.shader'
...loading 'scripts/surfaces.shader'
...loading 'scripts/terrain.shader'
...loading 'scripts/test.shader'
...loading 'scripts/twiltb.shader'
...loading 'scripts/twiltb2.shader'
...loading 'scripts/ui.shader'
...loading 'scripts/ui_hud.shader'
...loading 'scripts/ui_notebook.shader'
...loading 'scripts/ui_wolf.shader'
...loading 'scripts/viewflames.shader'
...loading 'scripts/walls.shader'
...loading 'scripts/z_light.shader'
----- finished R_Init -----
Sys_LoadDll(/usr/local/games/wolfenstein-spdemo/demomain/uii386.so)...
Sys_LoadDll(ui) found **vmMain** at  0x49f6c778
Sys_LoadDll(ui) succeeded!
Parsing menu file:ui/main.menu
r_rmse of 0.000000 has saved 864kb
Parsing menu file:ui/setup.menu
Parsing menu file:ui/controls.menu
Parsing menu file:ui/cdkey.menu
Parsing menu file:ui/system.menu
Parsing menu file:ui/options.menu
Parsing menu file:ui/credit.menu
r_rmse of 0.000000 has saved 1056kb
r_rmse of 0.000000 has saved 1104kb
r_rmse of 0.000000 has saved 1116kb
Parsing menu file:ui/connect.menu
Parsing menu file:ui/quit.menu
Parsing menu file:ui/vid_restart.menu
Parsing menu file:ui/snd_restart.menu
Parsing menu file:ui/rec_restart.menu
Parsing menu file:ui/default.menu
Parsing menu file:ui/error.menu
Parsing menu file:ui/serverinfo.menu
Parsing menu file:ui/quitcredit.menu
Parsing menu file:ui/resetscore.menu
Parsing menu file:ui/buy_pop.menu
Parsing menu file:ui/multiplayer_pop.menu
Parsing menu file:ui/play.menu
Parsing menu file:ui/load.menu
Parsing menu file:ui/briefing.menu
UI menu load time = 1453 milli seconds
Parsing menu file:ui/ingame.menu
Parsing menu file:ui/ingame_controls.menu
Parsing menu file:ui/ingame_options.menu
Parsing menu file:ui/ingame_system.menu
Parsing menu file:ui/ingame_leave.menu
Parsing menu file:ui/ingame_player.menu
Parsing menu file:ui/ingame_load.menu
Parsing menu file:ui/ingame_save.menu
Parsing menu file:ui/in_vid_restart.menu
Parsing menu file:ui/in_snd_restart.menu
Parsing menu file:ui/in_rec_restart.menu
Parsing menu file:ui/notebook.menu
Parsing menu file:ui/clipboard.menu
Parsing menu file:ui/bookz.menu
Parsing menu file:ui/bookv.menu
Parsing menu file:ui/bookp.menu
Parsing menu file:ui/pregame.menu
Parsing menu file:ui/test.menu
Parsing menu file:ui/ingame_help.menu
UI menu load time = 881 milli seconds
Sys_LoadDll(/usr/local/games/wolfenstein-spdemo/demomain/cgamei386.so)...
Sys_LoadDll(cgame) found **vmMain** at  0x4acd81e8
Sys_LoadDll(cgame) succeeded!
LOADING... collision map
LOADING... sounds

.........................
Initializing Sound Scripts
...loading 'sound/scripts/cutscene1.sounds'
...loading 'sound/scripts/cutscene6.sounds'
...loading 'sound/scripts/cutscene9.sounds'
...loading 'sound/scripts/cutscene11.sounds'
...loading 'sound/scripts/cutscene14.sounds'
...loading 'sound/scripts/cutscene19.sounds'
...loading 'sound/scripts/escape1.sounds'
...loading 'sound/scripts/escape2.sounds'
...loading 'sound/scripts/tram.sounds'
...loading 'sound/scripts/village1.sounds'
...loading 'sound/scripts/crypt1.sounds'
...loading 'sound/scripts/crypt2.sounds'
...loading 'sound/scripts/church.sounds'
...loading 'sound/scripts/boss1.sounds'
...loading 'sound/scripts/forest.sounds'
...loading 'sound/scripts/rocket.sounds'
...loading 'sound/scripts/assault.sounds'
...loading 'sound/scripts/sfm.sounds'
...loading 'sound/scripts/factory.sounds'
...loading 'sound/scripts/trainyard.sounds'
...loading 'sound/scripts/swf.sounds'
...loading 'sound/scripts/norway.sounds'
...loading 'sound/scripts/xlabs.sounds'
...loading 'sound/scripts/boss2.sounds'
...loading 'sound/scripts/dam.sounds'
...loading 'sound/scripts/village2.sounds'
...loading 'sound/scripts/chateau.sounds'
...loading 'sound/scripts/dark.sounds'
...loading 'sound/scripts/castle.sounds'
...loading 'sound/scripts/end.sounds'
...loading 'sound/scripts/ai.sounds'
...loading 'sound/scripts/general.sounds'
...loading 'sound/scripts/combat.sounds'
...loading 'sound/scripts/movers.sounds'
done.
LOADING... graphics
LOADING... maps/escape1.bsp
trying full_rt.TGA...
trying full_bk.TGA...
trying full_lf.TGA...
trying full_ft.TGA...
trying full_up.TGA...
trying full_dn.TGA...
stitched 12 LoD cracks
...loaded 14663 faces, 284 meshes, 367 trisurfs, 7 flares
LOADING... game media
LOADING...  - textures
r_rmse of 0.000000 has saved 1308kb
r_rmse of 0.000000 has saved 1356kb
r_rmse of 0.000000 has saved 1368kb
LOADING...  - models
trying models/weapons2/rocketl/panzerfast1a.TGA...
r_rmse of 0.000000 has saved 1416kb
r_rmse of 0.000000 has saved 1428kb
LOADING...  - weapons
LOADING...  - items
trying icons/iconh_breadandmeat.TGA...
trying icons/binocs.TGA...
LOADING...  - inline models
LOADING...  - server models
LOADING...  - particles
r_rmse of 0.000000 has saved 1440kb
trying ui/assets/sizecursor.TGA...
trying ui/assets/selectcursor.TGA...
LOADING...  - game media done
LOADING... flamechunks
LOADING... clients
LOADING... WolfPlayer
trying fonts/bigFont.TGA...
UI menu load time = 31 milli seconds
CL_InitCGame:  7.43 seconds
25 msec to draw all images
Com_TouchMemory: 0 msec
S_StartStreamingSound: No free streaming tracks
S_StartStreamingSound: No free streaming tracks
S_StartStreamingSound: No free streaming tracks
S_StartStreamingSound: No free streaming tracks
S_StartStreamingSound: No free streaming tracks
S_StartStreamingSound: No free streaming tracks
Received signal 11, exiting...
Shutdown tty console
debian:/home/mat# w

 Dodam że gra w tym momencie się wyłączyła
Po wydaniu polecenia z konta root:
debian:/home/mat# echo "wolfsp.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
bash: /proc/asound/card0/pcm0p/oss: Nie ma takiego pliku ani katalogu
debian:/home/mat#

Jak widąc czegoś brakuje pytanie tylko czego?
Bardzo proszę o pomoc?


CrimeDog

  • Gość
debian 3.1 i dzwięk w grach
« Odpowiedź #8 dnia: 2005-06-13, 13:54:23 »
2005-06-11 19:00:31 gbudny napisał:

 >  Dodam że gra w tym momencie się wyłączyła
 > Po wydaniu polecenia z konta root:
 > debian:/home/mat# echo "wolfsp.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
 > bash: /proc/asound/card0/pcm0p/oss: Nie ma takiego pliku ani katalogu
 > debian:/home/mat#
 >
 > Jak widąc czegoś brakuje pytanie tylko czego?
 > Bardzo proszę o pomoc?

Spróbuj komendy jak:
artsdsp -m et
(dla Enemy territorry, jeżeli masz KDE)
Arts jest systemem dźwiękowym w KDE, ta komenda przechwyci wszystkie wywołania do karty dźwiękowej. Niestety obciąża to procesor i dzwięk jest z pewnym opóźnieniem (można to wyregulować w Centrum Sterowania zmniejszając bufer w systemie dźwiękowym, ale wtedy jeszcze bardziej obciąża procesor i czasem się tnie – trzeba wybierać).

Plik o którym mówisz pojawi się, ale dopiero po pierwszym uruchomieniu gry.
Potrzebujesz właściwie dwóch komend:

echo "et.x86 0 0 direct" >> /proc/asound/card0/pcm0p/oss
echo "et.x86 0 0 disable" >> /proc/asound/card0/pcm0c/oss

U mnie to działa, ale w tym czasie żaden program nie może korzystać z karty dźwiękowej (chyba że masz kartę dźwiękowo z Hardware-mixing, kiedy to wreszcie będzie zrobione porządnie??), czyli TeamSpeak albo Xmms w tle odpadają (nawet jak masz skonfigurowane Dmix):-(

xamil

  • Gość
debian 3.1 i dzwięk w grach
« Odpowiedź #9 dnia: 2005-08-10, 19:28:00 »
2005-06-13 13:54:23 CrimeDog napisał:
 > Spróbuj komendy jak:
 > artsdsp -m et
 > (dla Enemy territorry, jeżeli masz KDE)
 > Arts jest systemem dźwiękowym w KDE, ta komenda przechwyci wszystkie wywołania do karty
 > dźwiękowej. Niestety obciąża to procesor i dzwięk jest z pewnym opóźnieniem (można to
 > wyregulować w Centrum Sterowania zmniejszając bufer w systemie dźwiękowym, ale wtedy jeszcze
 > bardziej obciąża procesor i czasem się tnie – trzeba wybierać).
 >
 > Plik o którym mówisz pojawi się, ale dopiero po pierwszym uruchomieniu gry.
 > Potrzebujesz właściwie dwóch komend:
 >
 > echo "et.x86 0 0 direct" >> /proc/asound/card0/pcm0p/oss
 > echo "et.x86 0 0 disable" >> /proc/asound/card0/pcm0c/oss
 >
 > U mnie to działa, ale w tym czasie żaden program nie może korzystać z karty dźwiękowej (chyba
 > że masz kartę dźwiękowo z Hardware-mixing, kiedy to wreszcie będzie zrobione porządnie??),
 > czyli TeamSpeak albo Xmms w tle odpadają (nawet jak masz skonfigurowane Dmix):-(
 >

Właśnie moje pytanie brzmi o chodzi, że moja karta ma "8 chanells"?? Wiem, że to pytanie nie do końca tu no ale też mam problem z dźwiękiem w et;) Ogólnie jakiś czas temu zakupiłem płyte główną z wbudowaną karta dźwiękową która miała właśnie taki bajer. Sczerze powiedziawszy kompletnie nie zwróciłem na to uwagi przy zakupie zwróciłem jednak uwage kiedy odpaliłem xmms'a, kadu, mplayera i jeszcze jakąś gierke i dźwięk się miksował:] (Odrazu pokochałem swoją nową karte dźwiękową:]) A trzeba zaznaczyć, że korzystały one z alsy lub arts i wcześniej nie było szans aby chodziły razem (tzn. aby dźwięk się miksował) no bo wiadomo jeden blokował drugiemu dostęp. Z tego co rozumiem to te dwie komendy powyżej nakazują et właśnie słać dzwięk bezpośrednio do karty która sama to miksuje. Nie rozumiem jednak kompletnie o co w tym chodzi czyli jak np. ustwić aby wszystkie aplikacje odnosiły się bezpośrednio do /dev/dsp a nie tak jak et któremu trzeba najpierw kazać sie tak zachować? Czy jest wogóle to możliwe aby narzucić z góry aby wszystkie aplikacje odnosiły się bezpośrednio do /dev/dsp?)??

Płyta:
Microstar K8T Neo2-F
http://www.apollo.pl/do_cmd_win.php?menu=store&name=k8t%20neo2&search=1&cmd=show_detail&id=12377

Ogólnie sorki jeśli coś pokręciłem ale kompletnie nie znam sie na dźwięku... zainteresowałem sie tym dopiero po zakupie nowej płyty z wbudowaną kartą dźwiękową posiadającą taki bajer:]

Z góry dzięki za odpowiedź.