Nowe posty

Autor Wątek: aMule problem z Temp  (Przeczytany 3801 razy)

Offline Monika

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
aMule problem z Temp
« dnia: 2007-06-14, 22:01:54 »
elo ludziska mam big problem z aMulem kiedy chce go wlaczyc wyswietla mi sie komunikat : FATAL ERROR Bad permissions on Temp directory!
i co ja mam z tym fantem zrobic????
ps jestem poczatkujacym uzytkownikiem mandrivy 2006

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 18
    • Zobacz profil
aMule problem z Temp
« Odpowiedź #1 dnia: 2007-06-14, 22:07:53 »
to może znaczyć iż emule nie ma uprawnień do katalogu Temp, ale nie koniecznie ;>

jak zmienić uprawnienia?
man chmod



2007-06-14 22:01:54 monia_stn napisał:

> elo ludziska mam big problem z aMulem kiedy chce go wlaczyc wyswietla mi sie komunikat : FATAL
 > ERROR Bad permissions on Temp directory!
 > i co ja mam z tym fantem zrobic????
 > ps jestem poczatkujacym uzytkownikiem mandrivy 2006

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 277
    • Zobacz profil
aMule problem z Temp
« Odpowiedź #2 dnia: 2007-06-14, 23:04:23 »
2007-06-14 22:01:54 monia_stn napisał:

 > i co ja mam z tym fantem zrobic????
 
Ale czy aMule tak się zachowywał już po pierwszym uruchomieniu, czy poprzednio Ci jednak działał? Jeśli po pierwszym, to może po prostu skasuj w home katalog .amule (jeśli będą problemy, to jako root), uruchom aMule jeszcze raz i zobacz co się będzie działo.

Jeśli aMule poprzednio działał, to może przypomnij sobie, co ostatnio z nim robiłeś. Zresztą odpal np. Krusadera, sprawdź czy w .amule w ogóle istnieje katalog Temp, czy w amule.conf jest linijka:

TempDir=/home/(twojnick)/.aMule/Temp

oraz we "Właściwościach" czy jesteś właścicielem katalogu Temp.

Tyle mi przychodzi do głowy. Aha, w Krusaderze "ctrl ." wyświetla/chowa ukryte pliki (z kropką na początku).

Offline Monika

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
aMule problem z Temp
« Odpowiedź #3 dnia: 2007-06-20, 18:53:49 »
2007-06-14 23:04:23 Brix napisał:

 > Jeśli aMule poprzednio działał, to może przypomnij sobie, co ostatnio z nim robiłeś. Zresztą
 > odpal np. Krusadera, sprawdź czy w .amule w ogóle istnieje katalog Temp, czy w amule.conf jest
 > linijka:
 >
 > TempDir=/home/(twojnick)/.aMule/Temp
 >
 > oraz we "Właściwościach" czy jesteś właścicielem katalogu Temp.
 >
 > Tyle mi przychodzi do głowy. Aha, w Krusaderze "ctrl ." wyświetla/chowa ukryte pliki
 > (z kropką na początku).

poprzednio mi dzialal bez problemow i nic z nim nie mieszalam nie zmienialam zadnych ustawien poprostu jak go wlacze to jakies pol godziny chodzi i nagle sam sie wylacza i jak chce go ponownie wlaczyc to wywala mi komunikat ktory napisalam wczesniej

posprawdzalam to co pisales wyzej i wszystko sie zgadza
wiec nie wiem co moze byc spieprzone:/
buuu:/:/:/

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 277
    • Zobacz profil
aMule problem z Temp
« Odpowiedź #4 dnia: 2007-06-21, 22:52:15 »
AMule nie jest demonem stabilności i bezbłędnego kodu, wersja działająca na M2006 w ogóle lubi czasem nagle kończyć pracę (w wersji 2.1.3 miałem natomiast jak na razie przeboje z ipfilter.dat :) )

A aMule instalowałaś przez urpmi/rpmdrake czy ręcznie? I jaka to jest wersja? Niestety, nie pamiętam teraz jaka wersja na M2006 jest w repozytorium. A skoro jednak aMule działa Ci po starcie/restarcie systemu, możesz od razu odpalić go z konsoli, a gdy "się skończy", powinien wyświetlić jakiś komunikat o błędzie.

Proponowałbym sprawdzić, czy w aMule jednak nie schrzaniły się ustawienia. Albo stwórz nowego użytkownika, zaloguj się na niego i odpal tam aMule, albo (chyba lepiej) zmień nazwę .aMule na odrobinkę inną i też odpal ten program. Starych ustawień i plików nie stracisz (o ile nie skasujesz katalogu .aMule), to tylko dla testów. Jeżeli masz oficjalną wersję muła z repozytorium i dalej będzie się dziwnie zachowywał mimo domyślnych ustawień, to dopiero trzeba się będzie zacząć martwić...

Offline ultr

  • Users
  • Guru
  • *****
  • Wiadomości: 1186
    • Zobacz profil
aMule problem z Temp
« Odpowiedź #5 dnia: 2007-06-21, 23:09:09 »
Pewnie to nie to, ale sprawdź ile masz miejsca na dysku z Tempem. Może w trakcie pracy się kończy i dlatego program się wywala.