Nowe posty

Autor Wątek: Pomocy-modem  (Przeczytany 3547 razy)


  • Gość
« dnia: 2007-02-08, 15:55:52 »
Mam SoftV92 Data Fax Modem. Pisałem już na tym forum o moim proplemie. Chodziło o to, ze nie moge znalezc pelnej wersji sterow pod LINUKSA. Na stronie darmowe pozwalaja na predkosc 14,4 kbps. Lecz znalazłem chyb zozwiazanie problemu tylko po angielsku, czesc rozmumie , ale moglby mi ktos wytlumaczyc, jak to zrbic po krotce. tzn. jaki plik edytowac i co w nim zmienic itp prosze

Oto tekst
The modem is integrated in the sound card, Soft V92 Data Fax Modem with Smart CP, and it's obviously a softmodem. The scanModem utility downloaded from reports this:

Though not displayed, an embedded soft modem may reside in this Audio card:
0000:00:1b.0 0403: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
Support is in an active developement stage. There is always an audio codec(s)
+ (optionally) modem. ALSA HDA setup is likely automatic, but can be maually done with:
su - root
modprobe snd-hda-intel
Information on the chips should map into /proc/asound/ folders.

The following command shows:

cat /proc/asound/card0/codec#1

Codec: Generic 14f1 ID 2bfa
Address: 1
Vendor Id: 0x14f12bfa
Subsystem Id: 0x0
Revision Id: 0x90000

As reported by the people of the linmodems mailing list, the Id shows it has a Conexant codec, which, for the moment, it is not supported alas. This modem is now supported by Linuxant,, the bad news is that you have to pay for this driver (unless you want to stick with 14k and no fax), but it's worthwhile, since it works pretty good.

I had few problems in installing this driver (and later to apply the bought license), here's how I solved the problems.

First of all I downloaded the driver sources (at the moment of writing, the file is hsfmodem-, uncompressed them, and run make and make install (as root). Actually I had first started the installation with the script, but I soon quit (and some think that this might be the sources of the problems I then experienced).

The first problem I experienced is that the installation did not create the expected symbolic link, 0-HDA-14f12bfa:20030003-1(I guess this name depends on the specific modem so it is likely to be different from laptop to laptop), in the directory /etc/hsfmodem/nvm/dynamic, and so I created manually and made it point to ../hsfhda, since that is the chipset of the modem. So this is the situation now:

ll /etc/hsfmodem/nvm/dynamic/
total 0
lrwxrwxrwx 1 root root 9 Apr 10 14:13 0-HDA-14f12bfa:20030003-1 -> ../hsfhda

The modem was working (but limited in speed) and so I proceeded in buying the license (see the instruction in the linuxant site), but when I applied the license it reported an error saying that it couldn't change the license status (it was complaining about some modules that could not be unloaded). I tried to reboot but the problem was still there so I modified the file /etc/modules.conf, and removed (commented) the following lines:

### update-modules: start processing /etc/modutils/hsf
alias /dev/ttySHSF[0-9]* /dev/ttySHSF
alias /dev/modem /dev/ttySHSF
alias char-major-241 /dev/ttySHSF
alias /dev/cuaHSF[0-9]* /dev/ttySHSF
alias char-major-244 /dev/ttySHSF
options hsfserial serialmajor=241 calloutmajor=244
alias char-major-245 hsfosspec
alias /dev/hsfdiag hsfosspec
alias /dev/hsfdiag* /dev/hsfdiag
alias char-major-246 /dev/hsfdiag
options hsfosspec dcpmajor=245 diagmajor=246
probeall /dev/ttySHSF hsfpcibasic2 hsfmc97ich hsfmc97via hsfmc97ali hsfmc97ati h
sfmc97sis hsfusbcd2 snd_hda_intel

### update-modules: end processing /etc/modutils/hsf

I then rebooted and successfully applied the license. After this I added the above lines to /etc/modules.conf again.

The modem now works great!  "



  • Gość
« Odpowiedź #1 dnia: 2007-02-08, 19:13:45 »
Autor opisu zakupił jednak licencję.
Opisuje swoje przygody z instalacją wersji darmowej ORAZ problemy z aktywacją zakupionej licencji.

Tobie zdaje się chodziło o rozwiązanie darmowe, więc nie trudzę się dalej z tłumaczeniem co i jak tam jest napisane


  • Gość
« Odpowiedź #2 dnia: 2007-02-10, 17:06:02 »
Dzkeji za odpozwiedz. Bede musiał szuka innego rozwiązania =( pozdro


  • Gość
« Odpowiedź #3 dnia: 2007-02-13, 16:43:00 »
2007-02-08 19:13:45 toranaga napisał:

> Autor opisu zakupił jednak licencję.
 > Opisuje swoje przygody z instalacją wersji darmowej ORAZ problemy z aktywacją zakupionej
 > licencji.
 > Tobie zdaje się chodziło o rozwiązanie darmowe, więc nie trudzę się dalej z tłumaczeniem co i
 > jak tam jest napisane

a co z tym tekstem:

It's a Conexant 56k ACLink Modem and located on PCI 0:8:0, man lspci for more info.

Note from Germán Sanchis Trilles: The winmodem works perfectly using the hsf (softmodem) driver from linuxant. You can find this driver in [ drivers/ hsf/ index.php]. Since I use debian and neither my distribution nor me feel too confident with rpms, I haven't tried the rpm package, I installed it with the tar.gz package. Read the README file for instructions about how to install the driver, they are quite clear. After the installation, the modem should be accessible at /dev/ttySHSF0 or at /dev/modem, the latter one being a symbolic link of the former one.

Note from Philip Van Hoof: I have tested the RPM package hsfmodem-6.03.00lnxt03091800free-1.i386.rpm and verify that this package works. It also works on a patched kernel (see below at ACPI support). You can find this file here: [ drivers/ hsf/ free/ downloads.php].

Output of hsfconfig --info:

Config for modem unit 0: /dev/ttySHSF0
Device instance: 0-PCI-10b9:5457-103c:0850
HW revision : CXT29
HW profile name: hsfmc97ali
Current region : BELGIUM (T.35 code: 000F)

The /dev/modem alias (symlink) points to /dev/ttySHSF0

Note from Lamarque Souza: Use this key regenerator to make the linuxant driver work at full speed in 2.6 kernels:

chmod 755

You can get the License owner and Registration ID with

hsfconfig --info

The key generated should enable full modem functionality (including full speed and fax). I have not tested the modem as fax so do not ask me it really works. If the key generator does not work (it does not work with the latest driver, hsfmodem-7.18.00full.tar.gz) use the hack below. This hack does not enable fax functionality.

Note from Lamarque: I use version 7.18 of the driver. I do not have hsfmodem-6.03.00lnxt04082400full.tar.gz or a key generator for driver version 7.x. Please do not ask me for any of them. Use the hack if you want to user driver version 7.x.

To hack the driver just use hexedit to replace the 74 number to 75 at offset 0x248cd of hsfmodem-6.03.00lnxt04051300full/modules/imported/hsfengine-i386.O or /usr/lib/hsfmodem/modules/imported/hsfengine-i386.O (if the driver is already installed):

hexedit hsfmodem-6.03.00lnxt04051300full/modules/imported/hsfengine-i386.O

Press ENTER, type 248cd, press ENTER, type 75, press ENTER, press Ctrl+X,
type Y, press ENTER.

The offset 0x248cd will be different if you use a driver other than hsfmodem-6.03.00lnxt04051300full.tar.gz. The offset of driver hsfmodem-6.03.00lnxt04082400full.tar.gz is 0x2488D. The offset of the latest driver (hsfmodem-7.18.00full.tar.gz) is 0x2659D.

I had a memory leak in my notebook caused by an infinite loop in modprobe (in modules.dep hsfserial depends on hsfmc97ali and vice-versa). The memory leak seems to be solved in version 7.18. To prevent the memory leak edit hsfmodem-6.03.00lnxt04051300full/scripts/hsfconfig or /usr/sbin/hsfconfig (if the driver is already installed), change the lines below from:

echo "probeall /dev/ttySHSF hsfpcibasic2 hsfmc97ich hsfmc97via hsfmc97ali"
echo "probeall hsfserial hsfpcibasic2 hsfmc97ich hsfmc97via hsfmc97ali"


echo "probeall /dev/ttySHSF hsfpcibasic2 hsfmc97ali"


cd hsfmodem-6.03.00lnxt04051300full
make install

And also this:

Quote:In the same forum where I found this hack there is also a post of a patch to enable full speed driver with kernel 2.6. I have not tested it since mine is already in full speed.

Note from Milton Paiva Neto: To get the modem working at maximum speed, download the file modem/ dell-hsflinmodem-5.03.27.tar.gz in a tmp directory :Note from jt :This site no longer works.Why steal in linux

#tar -zxvf dell-hsflinmodem-5.03.27.tar.gz

will be created three directories(dell,etc,usr), type i

# cd usr/src/hsflinmodem
# tar -zxvf hsflinmodem-5.03.27lnxtbeta03041600.tar.gz

Change to the created directory

# cd hsflinmodem-5.03.27lnxtbeta03041600

If you have any previous version of this modem driver you will need to remove the old driver, to remove type

# rpm -el hsflinmodem or make uninstall

now that you have uninstalled the driver, install the new one

# make install

The driver will be installed, you will get the message telling that the modem were installed, now type

# hsfconfig

Type 'yes' for automatic detection: yes
Type the name of your country (if exist in the list):BRAZIL
Type the path of your kernel source (depends on your kernelversion): /lib/modules/2.4.20-8custom/build
Note from Philip Van Hoof: To know what path you need, try echo "/lib/modules/`uname -r`/build"
ps. I recompiled my kernel for ACPI and NTFS support using the instructions on this site.

Congratulations your modem has been configured, enjoy it at 56k!

Feel free to contribute additional information or mail me in case of problems (see below).

Note from Peter Scott:

Fedora core == 1
I had to edit the serial_core.c file inorder to get hsfconfig to be able to compile the driver corectly. to do this:

edit the file
and change line 1073 from
if ((tty->count == 1) && (state->count != 1)) {
if (((tty->count.counter) == 1) && (state->count != 1)) {

then run make install followed by /usr/sbin/hsfconfig

Note From Ow(Ow.Mun.Heng_at_nospam_wdc_com)

RH9 + Kernel 2.4.23+cpufreq_patch) Tried compiling it.. This one can be compiled as is.. (i think, I'm lazy to re-compile it) After a few tries.. I vi the modules/makefile and just uncommented line 41

1. Remove the following if your OS already has the new serial core
2. (expected to be merged one day in linux 2.5)

serial_hsf.o: CFLAGS += -DCNXTSERIAL_INCLUDE_CORE <---uncommented

1. The following is a workaround as the previous line causes certain
2. versions of GNU make to crash with the message:
3. "make: expand.c:489: allocated_variable_append: Assertion

`current_variable_set_list->next != 0' failed."

1. CFLAGS-serial_hsf = -DCNXTSERIAL_INCLUDE_CORE <--- commented out

1. serial_hsf.o: serial_core.c serial_core.h <----commented out

Again.. I iterate.. It might work without _any_ changes at all..