Nowe posty

Autor Wątek: dhcp ???  (Przeczytany 7730 razy)

Offline Rafał D*******

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 18
    • Zobacz profil
dhcp ???
« dnia: 2005-07-19, 19:20:00 »
Mam problem z t? znan? i niby bezproblemow? sieciówk?. Po zainstalowaniu slacka przy automatycznej konfiguracji nie wykrywa mi po??czenia sieciowego.
Po restarcie proobowalem bawic sie w rc.modules, i nic.
Po wpisaniu lsmod, nie wyskakuje mi modul siecioowki, a
ao wpisaniu ifconfig eth0 up stwierdza ze eth0 nie istnieje.

Pierwszy raz spotykam sie z takim czyms jesli chodzi o realtek\\'i pod slackiem. Zaznaczam ze jestem kompletnym niewbie i nie mialem sporo do czynienia wczesniej z Linuxem ;)

Offline Marcin Miśkiewicz

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 20
    • Zobacz profil
dhcp ???
« Odpowiedź #1 dnia: 2005-07-19, 19:41:35 »
mi w slacku 10.0 te? nie ?adowa? sam modu?u do 8139...
pocz?tkowo wklepywa?em z palca modprobe 8139too, a potem wkompilowa?em w kernel

Offline Tomcio Paluch

  • Users
  • Guru
  • *****
  • Wiadomości: 676
    • Zobacz profil
dhcp ???
« Odpowiedź #2 dnia: 2005-07-20, 10:19:08 »
A czy system w ogole wykrywa karte sieciowa ?
cat /proc/pci | grep Ethernet

Czy jest wsparcie dla tego typu karty wlaczone w kernelu ?

Offline Rafał D*******

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 18
    • Zobacz profil
dhcp ???
« Odpowiedź #3 dnia: 2005-07-21, 17:42:45 »
Poradzilem sobie juz z ta karta...wlozylem CD ktoore dostalem z karta w poszukiwaniu jakiegos helpa. Znalazlem plik 8139too.c w katalogu linux :)
Skompilowalem ten plik, potem juz robilem krok po kroku to co w ReadMe, nastepnie insmod, ifconfig, reboot i dziala :)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 10
    • Zobacz profil
dhcp ???
« Odpowiedź #4 dnia: 2005-07-19, 14:29:49 »
Witam robie dhcp i nie daje rady problem wyglada tak:
System red hat
pierwsza sieciówka eth0 ma adres 192.168.1.68 maska 255.255.0.0 brama 192.168.1.1
to jest sieciówka ktora dostaje sygna? internetowy.
A na drugiej sieciówce ma by? serwer który bedzie przydziela? adresy komputerom z sieci i dawa? im internet
Robie ca?? konfiguracje w dhcpd.conf
subnet 192.168.0.1 netmask 255.255.255.0  {
range 192.168.0.100 192.168.0.199;
default-lease-time 86400;
option subnet-mask 255.255.255.0;
option broadcast-address 192.168.1.255;
}
i zawsze wywala mi jakis b??d np subnet or mask bad combination
co musze miec wbite w configu eth1 ?
czy musze co? dopisac do tablicy "route -n"
Bardzo prosze o pomoc
THX z góry

Offline bojleros bojleros

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 190
    • Zobacz profil
dhcp ???
« Odpowiedź #5 dnia: 2005-07-19, 14:43:39 »
2005-07-19 14:29:49 gotriel napisa?:


 > pierwsza sieciówka eth0 ma adres 192.168.1.68 maska 255.255.0.0 brama 192.168.1.1

 > subnet 192.168.0.1 netmask 255.255.255.0  {
 > range 192.168.0.100 192.168.0.199;
 > default-lease-time 86400;
 > option subnet-mask 255.255.255.0;
 > option broadcast-address 192.168.1.255;
 > }


w sieci prywatnej ( tej której neta udost?pniasz ) musisz mie? inny zakres adresów ip niz w tej gdzie masz bramke.

sie? od strony bramki ma mask? 255.255.0.0 co oznacza ze z jej punktu widzenia adresy 192.168.*.* s? widoczne.
sytuacja taka jest niedopuszczalna

zmien swoj? klase podsieci na A lub B i nie zapomnij startowa? dhcpd z parametrem eth1 a wszystko bedzie dzia?a?o dobrze



Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 10
    • Zobacz profil
dhcp ???
« Odpowiedź #6 dnia: 2005-07-19, 16:21:29 »
2005-07-19 14:43:39 bojleros napisa?:

> 2005-07-19 14:29:49 gotriel napisa?:
 >
 >
 >  > pierwsza sieciówka eth0 ma adres 192.168.1.68 maska 255.255.0.0 brama 192.168.1.1
 >
 >  > subnet 192.168.0.1 netmask 255.255.255.0  {
 >  > range 192.168.0.100 192.168.0.199;
 >  > default-lease-time 86400;
 >  > option subnet-mask 255.255.255.0;
 >  > option broadcast-address 192.168.1.255;
 >  > }
 >
 >
 > w sieci prywatnej ( tej której neta udost?pniasz ) musisz mie? inny zakres adresów ip niz w tej
 > gdzie masz bramke.
 >
 > sie? od strony bramki ma mask? 255.255.0.0 co oznacza ze z jej punktu widzenia adresy
 > 192.168.*.* s? widoczne.
 > sytuacja taka jest niedopuszczalna
 >
 > zmien swoj? klase podsieci na A lub B i nie zapomnij startowa? dhcpd z parametrem eth1 a
 > wszystko bedzie dzia?a?o dobrze
 >
 >
 >
sorry tam jest b??d na eth0 maska jest 255.255.255.0
czy moge na tej drugiej sieciowce miec adresy 192.168.0.x i maske 255.255.255.0 ?
jakim poleceniem uruchomic te dhcp z parametrem eth1 ?
jakie ustawienia musze miec w ifcfg-eth1 ?


Offline Marcin Miśkiewicz

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 20
    • Zobacz profil
dhcp ???
« Odpowiedź #7 dnia: 2005-07-19, 17:31:55 »
subnet to ogólnie sie?!!! czyli musisz da? 192.168.0.0!!!
a eth1 musisz i tak z r?ki ustawi? na 192.168.0.1/255.255.255.0

Offline bojleros bojleros

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 190
    • Zobacz profil
dhcp ???
« Odpowiedź #8 dnia: 2005-07-19, 18:50:34 »
2005-07-19 17:31:55 Mamut napisa?:

> subnet to ogólnie sie?!!! czyli musisz da? 192.168.0.0!!!
 > a eth1 musisz i tak z r?ki ustawi? na 192.168.0.1/255.255.255.0

niestety to jest b?edne poniewaz na eth0 jest maska 255.255.0.0 co oznacza ze ta sie? to w istocie adresy192.168.*.* co daje konflikt

2005-07-19 16:21:29 gotriel napisa?:

 > czy moge na tej drugiej sieciowce miec adresy 192.168.0.x i maske 255.255.255.0 ?

odpowiedz j/w

 > jakim poleceniem uruchomic te dhcp z parametrem eth1
poprostu:

dhcpd eth1
 
 > jakie ustawienia musze miec w ifcfg-eth1 ?
nie uzywa?em redhata wiec nie moge udzieli? 100% odpowiedzi na to pytanie , dawno temu by? linuxconf ale nie wiem jak jest teraz ,
mia?em kiedy? na próbe gentoo i skrypty wydajemi sie wyglada?y tam podobnie
mozesz szuka? pliku z ustawieniami w /etc/conf.d/ nazwa bedzie podobna do nazwy sktyptu który pali ten interfejs a potem go zrestartowa? przez ten w?asnie skrypt

proponuje zeby? na eth1 mia? taki zakres ip 10.1.1.0/24 to da ci pewno?c ze bedziesz mia? rózne sieci na interfejsach i bedziesz móg? w?aczy? maskarad? , oczywi?cie dostosuj do tego dhcpd.conf

proponuje zeby? poczyta? troche o protokole ip , to nie s? trudne rzeczy i ustrzerzesz sie tak banalnych problemów

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 10
    • Zobacz profil
dhcp ???
« Odpowiedź #9 dnia: 2005-07-20, 10:44:27 »
2005-07-19 18:50:34 bojleros napisa?:

> 2005-07-19 17:31:55 Mamut napisa?:
 >
 > > subnet to ogólnie sie?!!! czyli musisz da? 192.168.0.0!!!
 >  > a eth1 musisz i tak z r?ki ustawi? na 192.168.0.1/255.255.255.0
 >
 > niestety to jest b?edne poniewaz na eth0 jest maska 255.255.0.0 co oznacza ze ta sie? to w
 > istocie adresy192.168.*.* co daje konflikt
 >
 > 2005-07-19 16:21:29 gotriel napisa?:
 >
 >  > czy moge na tej drugiej sieciowce miec adresy 192.168.0.x i maske 255.255.255.0 ?
 >
 > odpowiedz j/w
 >
 >  > jakim poleceniem uruchomic te dhcp z parametrem eth1
 > poprostu:
 >
 > dhcpd eth1
 >  
 >  > jakie ustawienia musze miec w ifcfg-eth1 ?
 > nie uzywa?em redhata wiec nie moge udzieli? 100% odpowiedzi na to pytanie , dawno temu by?
 > linuxconf ale nie wiem jak jest teraz ,
 > mia?em kiedy? na próbe gentoo i skrypty wydajemi sie wyglada?y tam podobnie
 > mozesz szuka? pliku z ustawieniami w /etc/conf.d/ nazwa bedzie podobna do nazwy sktyptu który
 > pali ten interfejs a potem go zrestartowa? przez ten w?asnie skrypt
 >
 > proponuje zeby? na eth1 mia? taki zakres ip 10.1.1.0/24 to da ci pewno?c ze bedziesz mia? rózne
 > sieci na interfejsach i bedziesz móg? w?aczy? maskarad? , oczywi?cie dostosuj do tego
 > dhcpd.conf
 >
 > proponuje zeby? poczyta? troche o protokole ip , to nie s? trudne rzeczy i ustrzerzesz sie tak
 > banalnych problemów
 >
Po pierwsze chcia?em podzi?kowa? za wszelak? pomoc udzielon? przez kolegów.

No a teraz dalej walka z dhcp
wiec tak na eth0 mam :
IP:192.168.1.68
Maska 255.255.255.0
itd.
w eth1 mam:
IP 192.168.0.1
maska 255.255.255.0
BOOTPROTO:(i tu nie wiem)mam narazie static

w konfiguracji dhcpd.conf
mam tak:
subnet 192.168.0.0
netmask 255.255.255.0 {
range 192.168.0.100 192.168.0.199;

no i teraz wpisuje dhcpd eth1 i wyskakuje co? takiego :

"You must add a ddns-update-style statement to /etc/dhcpd.conf.
To get the same behaviour as in 3.0b2pl11 and previous version add a line that says ddns-update-style ad-hoc;
Please read the dhcpd.conf manual page for more information.

ja juz rozk?adam r?ce ju? poprostu nie moge .

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
dhcp ???
« Odpowiedź #10 dnia: 2005-07-20, 10:59:48 »
 > "You must add a ddns-update-style statement to /etc/dhcpd.conf.
 > To get the same behaviour as in 3.0b2pl11 and previous version add a line that says
 > ddns-update-style ad-hoc;
 > Please read the dhcpd.conf manual page for more information.

wez w reke slownik angielsko - polski i sobie to przetlumacz...

Offline Tomcio Paluch

  • Users
  • Guru
  • *****
  • Wiadomości: 676
    • Zobacz profil
dhcp ???
« Odpowiedź #11 dnia: 2005-07-20, 11:57:52 »
dodac do /etc/dhcpd.conf linie brzmiaca jak nastepuje: ddns-update-style ad-hoc

Widze, ze z angielskim jestesmy na bakier.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 10
    • Zobacz profil
dhcp ???
« Odpowiedź #12 dnia: 2005-07-20, 12:49:05 »
2005-07-20 11:57:52 Xax79 napisa?:

> dodac do /etc/dhcpd.conf linie brzmiaca jak nastepuje: ddns-update-style ad-hoc
 >
 > Widze, ze z angielskim jestesmy na bakier.

nie z angielskim jest ok

wiec tak zrobi?em wcze?niej doda?em to

ddns-update-style ad-hoc;

i tak to samo wyskakuje

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
dhcp ???
« Odpowiedź #13 dnia: 2005-07-20, 13:34:05 »
no a reszte komunikatu doczytales ??



Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 10
    • Zobacz profil
dhcp ???
« Odpowiedź #14 dnia: 2005-07-20, 13:55:37 »
2005-07-20 13:34:05 chmooreck napisa?:

> no a reszte komunikatu doczytales ??
 >
 >
 >
ja juz sie pogubi?em w tym wszystkim doda?em t? komende teraz mi pokazuje expecting netmask cho? nic nie rusza?em

ddns-update-style ad-hoc;
option subnet-mask 255.255.255.0;  
default-lease-time 21600;  
max-lease-time 86400;  
subnet 192.168.0.0


netmask 255.255.255.0 {
range 192.168.0.200 192.168.0.250;
}


ifcfg eth1 recznie zrobi?em tak

BOOTPROTO=static
IPADRESS=192.168.0.1
NETMASK=255.255.255.0


poprostu na moj rozum powinno dzia?a? a niechce.Magia lub poprostu mam pecha sorry ?e tyle robie problemu ale ja sie dopiero ucz?