Nowe posty

Autor Wątek: fstab - montowanie partycji NTFS  (Przeczytany 2853 razy)

Offline Rafał Lewandowski

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 154
    • Zobacz profil
fstab - montowanie partycji NTFS
« dnia: 2005-07-19, 13:03:32 »
witajcie
mam apacha2, php-4.3.3, odpalam stron? i pokazuje mi si? komunikat.
\\"Fatal error: Call to undefined function: imagecreatefromjpeg() in /home/kampa/public_html/includes/functions.php on line 298\\"
doczyta?em si? ?? chodzi tutaj o biblioteke gd  - i j? zainstalowa?em w wersji gd-2.0.33 .
Jednak ci?gle jest ten sam konuikat - jak to sprawdzi? czy jest dobrze zainstalowane - przy instalacji nie by?o b??dów. libpng i libjpeg te? mam. ???

Offline Maciej Majewski

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 10
    • Zobacz profil
fstab - montowanie partycji NTFS
« Odpowiedź #1 dnia: 2005-08-20, 16:40:34 »
sprawdz czy w konfiguracji PHP  (/etc/php.ini) masz zaladowany modul GD

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 14
    • Zobacz profil
fstab - montowanie partycji NTFS
« Odpowiedź #2 dnia: 2005-08-20, 17:04:24 »
2005-07-19 13:03:32 zajacraf napisał:

> witajcie
 > mam apacha2, php-4.3.3, odpalam stron? i pokazuje mi si? komunikat.
 > \\"Fatal error: Call to undefined function: imagecreatefromjpeg() in
 > /home/kampa/public_html/includes/functions.php on line 298\\"
 > doczyta?em si? ?? chodzi tutaj o biblioteke gd  - i j? zainstalowa?em w wersji gd-2.0.33 .
 > Jednak ci?gle jest ten sam konuikat - jak to sprawdzi? czy jest dobrze zainstalowane - przy
 > instalacji nie by?o b??dów. libpng i libjpeg te? mam. ???

wykonaj w skrypcie
phpinfo();

i sprawdz czy w sekcji gd masz
JPEG Support: enabled

Offline Michal B

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 22
    • Zobacz profil
fstab - montowanie partycji NTFS
« Odpowiedź #3 dnia: 2005-07-19, 09:43:49 »
Witam,

Mam pytanie. Jaki powinien by? prawid?owy wpis do fstab, ?eby montowa? partycje NTFS? Próbowa?em ró?nych opcji, ale nic z tego narazie nie wychodzi.
Ostatnio da?em wpis nast?puj?cy:

/dev/hda5 /mnt/Dysk_F ntfs defaults,ro 0 0

My?la?em pocz?tkowo, ?e j?dro nie obs?uguje systemu plików NTFS, ale polecenie mount wydane "r?cznie" dzia?a bez zarzutu. No i narazie nie mam pomys?u, co tam innego wpisa?.
Sprawa dotyczy systemu Debian GNU/Linux 3.1,
kernel 2.6.8-2-k7

Pozdrawiam, Micha?

Offline Grzegorz Świtkowski

  • Users
  • Guru
  • *****
  • Wiadomości: 516
    • Zobacz profil
fstab - montowanie partycji NTFS
« Odpowiedź #4 dnia: 2005-07-19, 09:48:18 »
> /dev/hda5 /mnt/Dysk_F ntfs defaults,ro 0 0

A nie jest tak, ze rw w defaults gryzie sie z ro?

Offline Michal B

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 22
    • Zobacz profil
fstab - montowanie partycji NTFS
« Odpowiedź #5 dnia: 2005-07-19, 09:53:46 »
hmmm ... nie wiem, próbowa?em u szwagra na PLD Linux i tam montowa?o przy taki ustawieniu defaults,ro - wszystko by?o ok ...

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 29
    • Zobacz profil
fstab - montowanie partycji NTFS
« Odpowiedź #6 dnia: 2005-07-19, 11:40:34 »
Sprawd?:

/dev/hda1 /mnt/windows ntfs ro,umask=0222 0 0

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 29
    • Zobacz profil
fstab - montowanie partycji NTFS
« Odpowiedź #7 dnia: 2005-07-19, 11:41:34 »
> /dev/hda1 /mnt/windows ntfs ro,umask=0222 0 0

Znaczy poprawka:

/dev/hda5 /mnt/Dysk_F ntfs ro,umask=0222 0 0

Offline Michal B

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 22
    • Zobacz profil
fstab - montowanie partycji NTFS
« Odpowiedź #8 dnia: 2005-07-19, 12:14:21 »
Oki, sprawdz? wieczorem, jak wróc? do domu, dzi?ki :)

Offline Michal B

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 22
    • Zobacz profil
fstab - montowanie partycji NTFS
« Odpowiedź #9 dnia: 2005-07-20, 20:43:12 »
 > /dev/hda5 /mnt/Dysk_F ntfs ro,umask=0222 0 0

niestety ten wpis równie? nie dzia? :(
Próbowa?em te? stosowa? inn? kolejno?? wpisów w fstab, ale to te? bezskutecznie ...

Offline Marcin Kubat

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 45
    • Zobacz profil
fstab - montowanie partycji NTFS
« Odpowiedź #10 dnia: 2006-03-25, 00:19:18 »
Czy komuś się udało poprawie ustawić fstab?
(zmontowane ale brak dostępu z konta user)
Jeśli tak to proszę w imieniu wielu o  odpowiedź.

Offline Tomasz Jezierczuk

  • Users
  • Guru
  • *****
  • Wiadomości: 852
    • Zobacz profil
fstab - montowanie partycji NTFS
« Odpowiedź #11 dnia: 2006-03-25, 00:36:39 »
2006-03-25 00:19:18 szpok napisał:

 > Jeśli tak to proszę w imieniu wielu o  odpowiedź.

zastanow sie jak sie zachowa katalog w ktorym jest zamontowany ntfs potraktowany umask=0222, bedziesz mial odpowiedz.

Offline Marcin Kubat

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 45
    • Zobacz profil
fstab - montowanie partycji NTFS
« Odpowiedź #12 dnia: 2006-03-25, 23:40:47 »
 > zastanow sie jak sie zachowa katalog w ktorym jest zamontowany ntfs potraktowany umask=0222,
 > bedziesz mial odpowiedz.

nie mam pojęcia :/
gdybym wiedział nie prosiłbym o pomoc w rozwiazaniu problemu.

Offline Tomasz Jezierczuk

  • Users
  • Guru
  • *****
  • Wiadomości: 852
    • Zobacz profil
fstab - montowanie partycji NTFS
« Odpowiedź #13 dnia: 2006-03-25, 23:59:29 »
2006-03-25 23:40:47 szpok napisał:

 > nie mam pojęcia :/
 > gdybym wiedział nie prosiłbym o pomoc w rozwiazaniu problemu.

Widze ze nawet o umask nie poczytales... niewazne...
Przede wszystkim zakladam ze kernel zbudowany masz ze wsparciem (jako takim) dla ntfs

Najpierw sprawdz czy podmontuje recznie i czy wejdziesz jako user. Zwroc uwage na gid! powinna tam sie znalezc nazwa grupy w jakiej jest user ktory chce zamontowac. powinno wystarczyc
Samo mount oczywiscie jako root!
mount -t ntfs /dev/hda1 /mnt/windows -o umask=000,gid=nazwa_grupy

Poczytaj.... ten temat milion razy przewijal sie przez forum...

Offline Tomasz Jezierczuk

  • Users
  • Guru
  • *****
  • Wiadomości: 852
    • Zobacz profil
fstab - montowanie partycji NTFS
« Odpowiedź #14 dnia: 2006-03-26, 00:04:30 »
2006-03-25 23:59:29 jezior napisał:

 > mount -t ntfs /dev/hda1 /mnt/windows -o umask=000,gid=nazwa_grupy
.
jesli przejdzie i user bedzie mogl czytac pliki to:

/dev/hda1 /mnt/windows ntfs umask=000,ro,gid=grupa_usera 0 0

itd itp....