Nowe posty

Autor Wątek: Debian  (Przeczytany 7837 razy)

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 155
    • Zobacz profil
Debian
« dnia: 2007-01-02, 18:57:52 »
Zainstalowałem sobie debiana net installer. Przy uruchamianiu pisze błąd z x serwera:
fatal (nie pamiętam co:D) error
no screens found.
i wywala mi do konsoli.
I tam pisało też, że x serwer nie jest skonfigurowany, jak to zrobić? mam dostęp tylko do konsoli.
Zaraz mnie pewnie zbesztacie za ten temat:D...
PS. brałem xorg -configure ale błąd wywalało. moja arch. debiana to amd64.

Offline Maciej Rutecki

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2107
    • Zobacz profil
Debian
« Odpowiedź #1 dnia: 2007-01-02, 21:51:12 »
2007-01-02 18:57:52 tatar111 napisał:

> Zainstalowałem sobie debiana net installer. Przy uruchamianiu pisze błąd z x serwera:
 > fatal (nie pamiętam co:D) error
 > no screens found.
 > i wywala mi do konsoli.
 > I tam pisało też, że x serwer nie jest skonfigurowany, jak to zrobić? mam dostęp tylko do
 > konsoli.
 > Zaraz mnie pewnie zbesztacie za ten temat:D...
 > PS. brałem xorg -configure ale błąd wywalało. moja arch. debiana to amd64.

Pokaż xorg.conf i jaka karta?

--
Maciek

Offline Szymek W

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 350
    • Zobacz profil
Debian
« Odpowiedź #2 dnia: 2007-01-02, 22:13:38 »
2007-01-02 18:57:52 tatar111 napisał:

> Zainstalowałem sobie debiana net installer. Przy uruchamianiu pisze błąd z x serwera:
 > fatal (nie pamiętam co:D) error
 > no screens found.
 > i wywala mi do konsoli.
 > I tam pisało też, że x serwer nie jest skonfigurowany, jak to zrobić? mam dostęp tylko do
 > konsoli.
 > Zaraz mnie pewnie zbesztacie za ten temat:D...
 > PS. brałem xorg -configure ale błąd wywalało. moja arch. debiana to amd64.

#apt-get install mc
#mc

wyedytuj plik /etc/xorg.conf i zmien Driver w sekcji karty graficznej na vesa
zapisz plik

#startx

Offline Damian Labuda

  • Global Moderator
  • Guru
  • *****
  • Wiadomości: 705
    • Zobacz profil
Debian
« Odpowiedź #3 dnia: 2007-01-02, 22:40:10 »
http://debian.linux.pl/viewtopic.php?t=492

Jeżeli masz nowszego Debianka niż sarge to zamiast xfree zainstaluj xorg. Konfiguracja jest prawie identyczna.

I nie xorg-configure tylko: dpkg-reconfigure xserver-xorg




Pozdrawiam!

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 155
    • Zobacz profil
Debian
« Odpowiedź #4 dnia: 2007-01-03, 15:28:42 »
> http://debian.linux.pl/viewtopic.php?t=492
 >
 > Jeżeli masz nowszego Debianka niż sarge to zamiast xfree zainstaluj xorg. Konfiguracja jest
 > prawie identyczna.
 >
 > I nie xorg-configure tylko: dpkg-reconfigure xserver-xorg
Robiłem, zrobiłem całą konfigurację i nic, nie działa. Mam ubuntu live cd i to samo, no screens found.

Offline Damian Labuda

  • Global Moderator
  • Guru
  • *****
  • Wiadomości: 705
    • Zobacz profil
Debian
« Odpowiedź #5 dnia: 2007-01-03, 17:39:42 »
> Robiłem, zrobiłem całą konfigurację i nic, nie działa. Mam ubuntu live cd i to samo, no screens
 > found.

Na 99% przed tym "no screen found" coś jeszcze pisze. Więc podaj co tam pisze, to coś może doradzę, bo w wróżkę bawić się nie będę...

Offline Dominik Przyborowski

  • Users
  • Guru
  • *****
  • Wiadomości: 747
    • Zobacz profil
Debian
« Odpowiedź #6 dnia: 2007-01-03, 21:48:24 »
dpkg-reconfigure xserver nie pomoże jesli konfiguracji nie dokonywał za pomoca dpkg.
Robisz tak (jesli masz xfree to zmień xorg na xfree86, a xorg.conf na XF86Config):

#md5sum /etc/X11/xorg.conf > /var/lib/x11/xorg.conf.md5sum
#dpkg-reconfigure xserver-xorg

I skonfiguruj to po ludzku. Jak będa nadal problemy to ustaw moduł karty na vese i oczywiście napisz jaka to karta.